ํƒœ๊ทธ ๋ณด๊ด€๋ฌผ: Router

[Router] EIGRP

Enhanced Interior Gateway Routing Protocol

Cisco์—์„œ ๋งŒ๋“  EIGRP.
๊ทธ๋Œ€๋กœ ํ•ด์„ํ•˜๋ฉด, ํ–ฅ์ƒ๋œ ๋‚ด๋ถ€ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์ด๋‹ค. ๊ธฐ์กด IGRP์—์„œ ์—…๊ทธ๋ ˆ์ด๋“œ๋œ ๋ฒ„์ „(?)์ด๋ผ๊ณ  ์ƒ๊ฐํ•˜์ž. ๊ทธ๋Ÿผ EIGRP์— ๋Œ€ํ•ด ์•Œ์•„๋ณด๋„๋ก ํ•œ๋‹ค.

1. EIGRP ๊ธฐ๋ณธ ๊ฐœ๋…
2. EIGRP ๋™์ž‘ ๊ณผ์ •
3. EIGRP ํŒจํ‚ท ์ข…๋ฅ˜
4. EIGRP ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ๊ณผ ๋ณด์•ˆ
5. EIGRP ๋ถ€ํ•˜ ๋ถ„์‚ฐ


1. EIGRP ๊ธฐ๋ณธ ๊ฐœ๋…

– Cisco์—์„œ ๋งŒ๋“  ๊ฑฐ๋ฆฌ ๋ฒกํ„ฐ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์ด๋‹ค.
– IPv4 ํ”„๋ ˆ์ž„ ๋‚ด IP Protocol ํ•„๋“œ ๋ฒˆํ˜ธ 88์„ ์‚ฌ์šฉํ•œ๋‹ค.(ํฌํŠธ ๋ฒˆํ˜ธ ์•„๋‹˜.)
– Multicast 224.0.0.10์„ ์‚ฌ์šฉํ•œ๋‹ค.
– EIGRP์˜ ์‹ ๋ขฐ์„ฑ ํš๋“ ๊ณผ์ •์€ TCP 3way-handshake์™€ ๋น„์Šทํ•˜๋‹ค. EIGRP์™€ ๊ด€๋ จ๋œ ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›๋Š” ๊ณผ์ •์—์„œ ์‹ ๋ขฐ์„ฑ์„ ํš๋“ํ•œ๋‹ค.

[์žฅ์ ]
– ‘Update Cost’๋ฅผ ์ง€์›ํ•œ๋‹ค. ์ฆ‰, ๋ฉ”ํŠธ๋ฆญ์ด ๋‹ค๋ฅธ ๋‹ค์ˆ˜ ๊ฐœ์˜ ๊ฒฝ๋กœ๋ฅผ ๋™์‹œ์— ์‚ฌ์šฉํ•  ์ˆ˜์žˆ๋‹ค.
– ์„ค์ •์ด ๊ฐ„๋‹จํ•˜๋‹ค.

[๋‹จ์ ]
– Cisco ๋ผ์šฐํ„ฐ์—์„œ๋งŒ ๋™์ž‘ํ•œ๋‹ค.
– ๋Œ€๊ทœ๋ชจ ๋„คํŠธ์›Œํฌ์—์„œ ์šด์šฉ ์‹œ “SIA ํ˜„์ƒ”์ด ๋ฐœ์ƒํ•œ๋‹ค.

[๋ฉ”ํŠธ๋ฆญ]
– Bandwidth, Delay, Reliability, Load, MTU ๋ฐ Hop Count๋ฅผ ํŠน์ • ๊ณต์‹์— ๋Œ€์ž…ํ•˜์—ฌ ๊ณ„์‚ฐํ•œ๋‹ค. ์ด ๊ฐ’์„ ๋น„๊ตํ•˜์—ฌ ๊ฒฝ๋กœ์˜ ์šฐ์„  ์ˆœ์œ„๋ฅผ ๊ฒฐ์ •ํ•œ๋‹ค.
– ํŠน์ • ๊ณต์‹์— K ์ƒ์ˆ˜ 5๊ฐœ๊ฐ€ ๋“ค์–ด๊ฐ€ ์žˆ๊ณ , ์ˆœ์„œ๋Œ€๋กœ ‘1 0 1 0 0’์˜ ๊ธฐ๋ณธ ๊ฐ’์„ ๊ฐ€์ง€๊ณ  ์žˆ๋‹ค.

EIGRP ์„ค์ •

Router(config)# router eigrp <AS>
Router(config-router)# eigrp router-id <IP>
Router(config-router)# network <IP> <WILDCARD>

1: EIGRP๋ฅผ ์‚ฌ์šฉํ•˜๋Š” ๋ผ์šฐํ„ฐ๋Š” ๋™์ผํ•œ AS ๋ฒˆํ˜ธ๋ฅผ ๊ฐ–๊ณ  ์žˆ์–ด์•ผ ํ•œ๋‹ค.
2: ๋ณ„๋„๋กœ ์„ค์ •ํ•˜์ง€ ์•Š๋Š”๋‹ค๋ฉด, (1) ๊ฐ€์žฅ ๋†’์€ ๋ฃจํ”„๋ฐฑ IP (2) ๋ฌผ๋ฆฌ ์ธํ„ฐํŽ˜์ด์Šค ์ค‘ ๊ฐ€์žฅ ๋†’์€ IP๋กœ ์ž๋™ ํ• ๋‹น๋œ๋‹ค.


2. EIGRP ๋™์ž‘ ๊ณผ์ •

(1) Neighbor ๊ด€๊ณ„ ์ˆ˜๋ฆฝ
EIGRP ์„ค์ • ์ดํ›„ ์ธ์ •ํ•œ ๋ผ์šฐํ„ฐ์™€ Hello ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›๋Š”๋‹ค.
AS๋ฒˆํ˜ธ, K ์ƒ์ˆ˜ ๊ฐ’, EIRP ์•”ํ˜ธ ๊ฐ’ ๋“ฑ์ด ๋‹ค๋ฅด๋ฉด Neighbor๋ฅผ ์ˆ˜๋ฆฝํ•˜์ง€ ์•Š๋Š”๋‹ค.

(2) Neighbor Table ์ƒ์„ฑ
Neighbor ๊ด€๊ณ„ ์ˆ˜๋ฆฝ ํ›„ Neighbor Table์— ์ธ์ ‘ํ•œ ๋ผ์šฐํ„ฐ ์ •๋ณด๋ฅผ ์ €์žฅํ•œ๋‹ค. ์ฃผ๊ธฐ์ ์œผ๋กœ Hello ํŒจํ‚ท์„ ๋ณด๋‚ด์„œ Neighbor๋ฅผ ์œ ์ง€ํ•œ๋‹ค.

(3) ๋ผ์šฐํŒ… ์ •๋ณด ๊ตํ™˜ ๋ฐ Topology Table ๊ตฌ์„ฑ
Neighbor๋ฅผ ๋งบ์€ ๋ผ์šฐํ„ฐ๋ผ๋ฆฌ Update ํŒจํ‚ท์„ ์ด์šฉํ•ด ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๊ตํ™˜ํ•œ๋‹ค. ์ด Update ํŒจํ‚ท๊ณผ EIGRP ๋กœ์ปฌ ์ •๋ณด๋ฅผ ํ•ฉ์ณ Topology Table์„ ๊ตฌ์„ฑํ•œ๋‹ค.

(4) ๋ผ์šฐํŒ… ๊ฒฝ๋กœ ๊ณ„์‚ฐ ๋ฐ Routing Table ์ €์žฅ
์ฒ˜์Œ Topology Table์— ๋“ฑ๋ก๋œ EIGRP ๊ฒฝ๋กœ๋Š” Active ์ƒํƒœ์ด๋‹ค.
Passive ์ƒํƒœ๊ฐ€ ๋˜๋ฉด Routing Table์— ํ•ด๋‹น ๊ฒฝ๋กœ๋ฅผ ์ €์žฅํ•  ์ˆ˜ ์žˆ๋‹ค.
(Active ์ƒํƒœ๋ž€, ํ•ด๋‹น ๊ฒฝ๋กœ๋ฅผ ์ตœ์  ๊ฒฝ๋กœ๋กœ ์‚ฌ์šฉํ•˜๊ธฐ ์œ„ํ•œ ๊ณ„์‚ฐ ๊ณผ์ •์ด ์ง„ํ–‰ ์ค‘์ธ ์ƒํƒœ์ด๋‹ค. ๊ณ„์‚ฐ์ด ๋๋‚˜๋ฉด Passive ์ƒํƒœ๋กœ ๋ฐ”๋€๋‹ค.)

โ€ป EIGRP ์šด์šฉ ์ค‘ ํ† ํด๋กœ์ง€ ๋ณ€๋™์‚ฌํ•ญ ๋ฐœ์ƒ

(ex. ๋กœ์ปฌ ์ •๋ณด๊ฐ€ ์‚ญ์ œ๋œ ๊ฒฝ์šฐ, ์ตœ์  ๊ฒฝ๋กœ์— ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ•œ ๊ฒฝ์šฐ)

(1) ๋ผ์šฐํŒ… ์ •๋ณด ์š”์ฒญ
Query ํŒจํ‚ท์„ ์ „์†กํ•˜์—ฌ, ๋ชฉ์ ์ง€๊นŒ์ง€์˜ ๋Œ€์ฒด ๊ฒฝ๋กœ๋‚˜ ๋ชฉ์ ์ง€๊นŒ์ง€์˜ ๋„๋‹ฌํ•˜๋Š”์ง€ ํ™•์ธ์„ ์š”์ฒญํ•œ๋‹ค.

(2) ๋ผ์šฐํŒ… ์ •๋ณด ์ˆ˜์‹ 
์ƒ๋Œ€ ๋ผ์šฐํ„ฐ๋กœ๋ถ€ํ„ฐ Reply ํŒจํ‚ท์„ ๋ฐ›๋Š”๋‹ค.


3. EIGRP ํŒจํ‚ท ์ข…๋ฅ˜

(1) ํŒจํ‚ท ์ข…๋ฅ˜

Hello ํŒจํ‚ท

– Neighbor๋ฅผ ๊ตฌ์„ฑํ•˜๊ณ  ์œ ์ง€ํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
– ๋ชฉ์ ์ง€ ์ฃผ์†Œ๋กœ Multicast 224.0.0.10 ์„ ์‚ฌ์šฉํ•œ๋‹ค.

Update ํŒจํ‚ท

– ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ „์†กํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
– NBMA ๋„คํŠธ์›Œํฌ์˜ ๊ฒฝ์šฐ ๋ชฉ์ ์ง€ ์ฃผ์†Œ๋กœ Neighbor IP,
BMA ๋„คํŠธ์›Œํฌ์˜ ๊ฒฝ์šฐ Multicast 224.0.0.10์„ ์‚ฌ์šฉํ•œ๋‹ค.
– Update ํŒจํ‚ท ์ „์†ก ํ›„ Ack๋ฅผ ๋ชป๋ฐ›์œผ๋ฉด ์ตœ๋Œ€ 16๋ฒˆ๊นŒ์ง€ ๋‹ค์‹œ ์ „์†กํ•œ๋‹ค. ๊ทธ๋ž˜๋„ ์‘๋‹ต์ด ์—†์œผ๋ฉด Neighbor ๊ด€๊ณ„๋ฅผ ๋Š๋Š”๋‹ค.

Query ํŒจํ‚ท

– ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์š”์ฒญํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
(๋กœ์ปฌ ์ •๋ณด๊ฐ€ ์‚ญ์ œ๋˜๊ฑฐ๋‚˜ ๋ฉ”ํŠธ๋ฆญ์ด ๋ณ€๊ฒฝ๋œ ๋•Œ, Topology Table์— ๋Œ€์ฒด ๊ฒฝ๋กœ๊ฐ€ ์—†์„ ๋•Œ)
– ๋ชฉ์ ์ง€๋Š” ์œ„์™€ ๊ฐ™๋‹ค.

Reply ํŒจํ‚ท

– Query(๋ผ์šฐํŒ… ์ •๋ณด ์š”์ฒญ)์— ์‘๋‹ตํ•  ๋•Œ ์‚ฌ์šฉ๋œ๋‹ค.
– Ack ํŒจํ‚ท๊ณผ ๋‹ค๋ฅธ ํŒจํ‚ท์ด๋‹ค.

Ack ํŒจํ‚ท

– Update, Query, Reply ํŒจํ‚ท ์ˆ˜์‹  ์‹œ ํ™•์ธํ–ˆ๋‹ค๊ณ  ์‘๋‹ตํ•˜๋Š” ํŒจํ‚ท์ด๋‹ค.

(2) ํŒจํ‚ท ํฌ๋งท

<Format : EIGRP Packet>

Version: EIGRP ๋ฒ„์ „, ํ˜„์žฌ EIGRP ๋ฒ„์ „์€ 2์ด๋‹ค.
Opcode: EIGRP ํŒจํ‚ท ์ข…๋ฅ˜๋ฅผ ์ง€์ •ํ•œ๋‹ค. Update (0x01), Query (0x03), Reply (0x04), Hello (0x05) ์ด๋‹ค. EIGRP Header ๋’ค์— ์˜ค๋Š” TLV๋ฅผ ๊ฒฐ์ •ํ•œ๋‹ค. Ack๋Š” 0์ด ์•„๋‹Œ ACK๋ฒˆํ˜ธ๋ฅผ ํฌํ•จํ•œ Hello ํŒจํ‚ท์ด๋‹ค.
Checksum: IP ํ—ค๋”๋ฅผ ์ œ์™ธํ•œ EIGRP ์ „์ฒด ํŒจํ‚ท์˜ ์ฒดํฌ์„ฌ์ด๋‹ค.
Flags: ์ฒซ๋ฒˆ์งธ LSB bit (0x00000001) – ์‹œ์ž‘ ๋น„ํŠธ, ์ƒˆ๋กœ์šด Neighbor ๊ด€๊ณ„๋ฅผ ์ˆ˜๋ฆฝํ•  ๋•Œ ๋ผ์šฐํŒ… ์—…๋ฐ์ดํŠธ์˜ ์ฒซ๋ฒˆ์งธ ์„ธํŠธ๋ฅผ ๋‚˜ํƒ€๋‚ธ๋‹ค.
๋‘๋ฒˆ์งธ LSB bit (0x00000002) – ์กฐ๊ฑด๋ถ€ ์ˆ˜์‹  ๋น„ํŠธ, RTP์—์„œ ์‚ฌ์šฉ๋œ๋‹ค.
*๋‹ค๋ฅธ ๋น„ํŠธ๋“ค์€ ์‚ฌ์šฉํ•˜์ง€ ์•Š๋Š”๋‹ค.
Sequence & ACK number: ์‹ ๋ขฐ์„ฑ์žˆ๋Š” EIGRP ๋ฉ”์„ธ์ง€ ๊ตํ™˜์„ ์œ„ํ•œ RTP์—์„œ ์‚ฌ์šฉํ•œ๋‹ค.
AS number: EIGRP AS ๋ฒˆํ˜ธ์ด๋‹ค.
TLV: 16bit์˜ Type ํ•„๋“œ, 16bit์˜ Length ํ•„๋“œ, TLB ์ข…๋ฅ˜์— ๋”ฐ๋ฅธ ๋‹ค์–‘ํ•œ ํ•„๋“œ ๊ฐœ์ˆ˜๋กœ ๊ตฌ์„ฑ๋˜์–ด ์žˆ๋‹ค. TLV ๊ฐ’์€ ์•„๋ž˜ ์‚ฌ์ง„ ์ฐธ๊ณ , ๋” ์ž์„ธํ•œ ์ •๋ณด๋Š” ์ด ์‚ฌ์ดํŠธ ์ฐธ๊ณ .

TLV Values,  (Written by Yap Chin Hoong, http://www.cisco.com)

4. EIGRP ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ๊ณผ ๋ณด์•ˆ

(1) ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ

EIGRP์—์„œ๋„ ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ ๊ธฐ๋Šฅ์„ ์ง€์›ํ•œ๋‹ค. ์ž๋™ ์ถ•์•ฝ์ด ๊ธฐ๋ณธ ๊ฐ’์ด๋ฏ€๋กœ ํ•ด๋‹น ๊ธฐ๋Šฅ์„ ์‚ฌ์šฉํ•˜์ง€ ์•Š์œผ๋ ค๋ฉด, ‘no auto-summary’๋ฅผ ํ•ด์•ผํ•œ๋‹ค.

์ถ•์•ฝ์„ ํ•˜๊ฒŒ ๋˜๋ฉด ์ถ•์•ฝ๋œ ๋„คํŠธ์›Œํฌ์˜ GW๊ฐ€ null 0์œผ๋กœ ๋œ๋‹ค. ๋ผ์šฐํŒ… ๋ฃจํ”„๋ฅผ ๋ฐฉ์ง€ ํ•˜๊ธฐ ์œ„ํ•จ์ด๋‹ค.

[Default Route ์ƒ์„ฑ]

Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>
Router(config)# router eigrp <AS>
Router(config-router)# redistribute static

[์ˆ˜๋™ ์ถ•์•ฝ]
์ถ•์•ฝ๋œ ์ •๋ณด๋ฅผ ๋‚ด๋ณด๋‚ด๊ณ ์ž ํ•˜๋Š” ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ์„ค์ •ํ•œ๋‹ค.

Router(config)# int <INTERFACE>
Router(config-if)# ip summary-address eigrp <AS> <SUMMARY_IP> <SUBNET>

* ์ถ•์•ฝํ•˜๋ฉด GW๊ฐ€ null 0์œผ๋กœ ์žกํžˆ๋Š” ์ด์œ 

R1์˜ ๋„คํŠธ์›Œํฌ ์ •๋ณด๋ฅผ ๋ฐ›์•„ ์ถ•์•ฝ ํ›„ R3์—๊ฒŒ ์ „ํŒŒ.

์ด ์ƒํ™ฉ์—์„œ R1์˜ 30.30.30.0/24 ๋„คํŠธ์›Œํฌ๊ฐ€ ๋‹ค์šด๋œ๋‹ค๋ฉด R2๊นŒ์ง€๋งŒ ํ†ต๋ณด๋œ๋‹ค. R3๋Š” ์ถ•์•ฝ๋˜์–ด์žˆ๊ณ , R2์—์„œ 30.0.0.0/8 ๋ชจ๋‘ ๋‹ค์šด๋˜์–ด์•ผ ํ†ต๋ณดํ•˜๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

๊ทธ ๋‹ค์Œ, R3๊ฐ€ 30.30.30.X๋กœ ๊ฐ€๋Š” ํŒจํ‚ท์„ ์ „๋‹ฌ ๋ฐ›์œผ๋ฉด ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ๋ณด๊ณ  R2๋กœ ๋ณด๋‚ธ๋‹ค. ํ•˜์ง€๋งŒ R2๋Š” 30.0.0.0/8์˜ ๊ฒŒ์ดํŠธ์›จ์ด๊ฐ€ null 0๊ณผ ๋งค์นญ๋œ ๊ฒƒ์„ ๋ณด๊ณ  ํ•ด๋‹น ํŒจํ‚ท์„ ํ๊ธฐํ•œ๋‹ค.

null 0์œผ๋กœ ์„ค์ •๋˜์ง€ ์•Š์•˜๋‹ค๋ฉด, R2์™€ R3๋Š” ์„œ๋กœ ๊ณ„์† ํŒจํ‚ท์„ ์ฃผ๊ณ ๋ฐ›์•˜์„ ๊ฒƒ์ด๋‹ค. ( = ๋ฃจํ•‘ )

(2) ๋„คํŠธ์›Œํฌ ๋ณด์•ˆ

EIGRP ๋„คํŠธ์›Œํฌ ์ƒ์—์„œ ๋ณด์•ˆ ์นจํ•ด๊ฐ€ ๋งŽ์€ ๊ณณ์€ PC์™€ ์—ฐ๊ฒฐ๋œ ๋ง, ์„œ๋ฒ„์™€ ์—ฐ๊ฒฐ๋˜๋Š” ๋„คํŠธ์›Œํฌ๋‹ค. ์ด๋Ÿฐ ๋„คํŠธ์›Œํฌ์—์„œ EIGRP ๋ณด์•ˆ์„ ์œ„ํ•ด ๋‘ ๊ฐ€์ง€ ๋ฐฉ๋ฒ•์„ ์ ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค. EIGRP ํŒจํ‚ท์„ ์ธ์ฆํ•˜๋Š” ๊ฒƒ๊ณผ ์•ก์„ธ์Šค ๋„คํŠธ์›Œํฌ๋Š” ์žฌ๋ถ„๋ฐฐ์‹œํ‚ค๋Š” ๊ฒƒ์ด๋‹ค.

[EIGRP ํŒจํ‚ท ์ธ์ฆ]
MD5, HMAC-SHA-256 ๋ฐฉ์‹์„ ํ†ตํ•ด ํŒจํ‚ท์˜ ๋ฌด๊ฒฐ์„ฑ์„ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

Router(config)# key chain <CHAIN_NAME>
Router(config-keychain)# key [0-2147483647]
Router(config-keychain-key)# key-string <WORD>
Router(config-keychain-key)# exit
Router(config-keychain)# exit
Router(config)#
Router(config)# int <INTERFACE>
Router(config-if)# ip authentication key-chain eigrp <AS> <CHAIN_NAME>
Router(config-if)# ip authentication mode eigrp <AS> [MD5|SHA]

1: ํ‚ค ์ฒด์ธ ์ด๋ฆ„์€ ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•˜์ง€ ์•Š์•„๋„ ๋œ๋‹ค.
2: ํ‚ค ๋ฒˆํ˜ธ๋Š” ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•ด์•ผ ํ•œ๋‹ค.
3: ์•”ํ˜ธ๋Š” ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•ด์•ผ ํ•œ๋‹ค.
7: eigrp ์ธ์ฆ ์„ค์ •์„ ์ ์šฉํ•  ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์ง„์ž…ํ•œ๋‹ค.
8-9: ์ธ์ฆ ์„ค์ •

[์•ก์„ธ์Šค ๋„คํŠธ์›Œํฌ ์žฌ๋ถ„๋ฐฐ]
PC๊ฐ€ ์—ฐ๊ฒฐ๋œ ์ข…๋‹จ ๋ถ€๋ถ„์€ EIGRP ํŒจํ‚ท์„ ๋ณด๋‚ผ ํ•„์š”๊ฐ€ ์—†๋‹ค. ์ด๋Ÿฐ ๋„คํŠธ์›Œํฌ๋กœ EIGRP ํŒจํ‚ท์„ ์ „์†กํ•˜์ง€ ์•Š๋„๋ก ํ•œ๋‹ค.

Router(config)# router eigrp <AS>
Router(config-router)# redistribute connected

์œ„์™€ ๋น„์Šทํ•œ ์„ค์ •์ด ์žˆ๋‹ค. Passive interface๋ฅผ ์„ค์ •ํ•˜์—ฌ, ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค๋กœ EIGRP Hello ํŒจํ‚ท์„ ์†ก์ˆ˜์‹ ํ•˜์ง€ ์•Š๋Š” ๊ฒƒ์ด๋‹ค.

Router(config)# router eigrp <AS>
Router(config-router)# passive-interface <INTERFACE>

5. EIGRP ๋ถ€ํ•˜๋ถ„์‚ฐ

EIGRP๋Š” ๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฐ’์„ ๊ฐ€์ง„ ๊ฒฝ๋กœ 32๊ฐœ๊นŒ์ง€ ๋ถ€ํ•˜ ๋ถ„์‚ฐ์„ ์ง€์›ํ•œ๋‹ค.

Equal Cost MultiPath ; ECMP

‘๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฒฝ๋กœ์— ๋Œ€ํ•œ ๋ถ€ํ•˜ ๋ถ„์‚ฐ’
๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฒฝ๋กœ๊ฐ€ ์—ฌ๋Ÿฌ ๊ฐœ๋ฉด, ๋ณ„๋„ ์„ค์ •์—†์ด ์ž๋™์œผ๋กœ ๋™์ž‘ํ•œ๋‹ค. ๊ธฐ๋ณธ๊ฐ’์€ ์ตœ๋Œ€ 4๊ฐœ๋กœ ์„ค์ •๋˜์–ด ์žˆ๋‹ค. ์ตœ๋Œ€ ๋ถ€ํ•˜๋ถ„์‚ฐ ๊ฒฝ๋กœ ์ง€์ •์€ ์•„๋ž˜์™€ ๊ฐ™์ด ํ•œ๋‹ค.

Router(config)# router eigrp <AS>
Router(config)# maximum-paths [1-32]

Unequal Cost MultiPath ; UCMP

‘๋ฉ”ํŠธ๋ฆญ ๊ฐ’์ด ์„œ๋กœ ๋‹ค๋ฅธ ๊ฒฝ๋กœ์— ๋Œ€ํ•œ ๋ถ€ํ•˜ ๋ถ„์‚ฐ’
UCMP๊ฐ€ ๋™์ž‘ํ•˜๊ธฐ ์œ„ํ•ด์„  2๊ฐ€์ง€ ์กฐ๊ฑด์„ ๋งŒ์กฑํ•ด์•ผ ํ•œ๋‹ค.
โ‘  Feasible Successor๋ฅผ ํ†ตํ•˜๋Š” ๊ฒฝ๋กœ
โ‘ก ‘Feasible  * variance’ ๋ณด๋‹ค ์ž‘์•„์•ผํ•œ๋‹ค.

[Router] RIP

Routing Information Protocol
์‚ฐ์—… ํ‘œ์ค€์œผ๋กœ ๊ฐœ๋ฐœ๋˜์—ˆ๋‹ค๊ฐ€ ์ดํ›„ ์ธํ„ฐ๋„ท ํ‘œ์ค€์œผ๋กœ ๋ฐœ์ „๋œ ํ”„๋กœํ† ์ฝœ.
Xerox(์ œ๋ก์Šค)์˜ PARC(ํŒ”๋กœ์•Œํ†  ์—ฐ๊ตฌ์†Œ)์—์„œ Ethernet ์œ„์— ์‚ฌ์šฉํ•  ๋” ๋†’์€ ๊ณ„์ธต์— ์†ํ•œ PUP(PARC Universal Protocol)์„ ๊ฐœ๋ฐœํ–ˆ๋‹ค.
๊ทธ๋ฆฌ๊ณ  PUP ๋ผ์šฐํŒ…์— ์‚ฌ์šฉํ•˜๊ธฐ ์œ„ํ•œ GWINFO(๊ฒŒ์ดํŠธ์›จ์ด ์ •๋ณด ํ”„๋กœํ† ์ฝœ)์„ ๋งŒ๋“ค์—ˆ๊ณ , ์ด๊ฒŒ RIP๊ฐ€ ๋˜์—ˆ๋‹ค.
RIP๋Š” BSD์—์„œ ์‚ฌ์šฉ๋˜๋ฉด์„œ ๋„๋ฆฌ ์“ฐ์ด๊ฒŒ ๋˜์—ˆ๋‹ค. 1988๋…„ IETF์—์„œ RFC 1058 “Routing Information Protocol”์„ ์ •์‹ ๋ช…์‹œํ•˜์˜€๋‹ค.

  1. RIP ํŠน์ง•
  2. RIP ํŒจํ‚ท ํฌ๋งท
  3. RIP ์„ค์ •
  4. RIP ๋ณด์•ˆ

1. RIP ํŠน์ง•

– RIPv1, RIPv2, IPv6์šฉ RIPng๊ฐ€ ์žˆ๋‹ค.
– RIPv1, v2๋Š” UDP 520๋ฒˆ, RIPng๋Š” UDP 521๋ฒˆ์„ ์‚ฌ์šฉํ•œ๋‹ค.
– ํ•œ ์žฅ๋น„๋กœ๋งŒ ์ „์†กํ•  ๋•Œ๋Š” Unicast ๋ฐฉ์‹์„ ์‚ฌ์šฉํ•œ๋‹ค. ์—ฌ๋Ÿฌ ์žฅ๋น„๋กœ ์ „์†กํ•  ๋•Œ, RIPv1๋Š” Broadcast, RIPv2์™€ RIPng๋Š” Multicast ๋ฐฉ์‹์„ ์‚ฌ์šฉํ•œ๋‹ค.
– ๋ฉ”ํŠธ๋ฆญ์œผ๋กœ Hop count ๋ฅผ ์‚ฌ์šฉํ•˜๋ฉฐ, ๋งํฌ ์†๋„๋ฅผ ๋ฐ˜์˜ํ•˜์ง€ ์•Š๋Š”๋‹ค. ๋ผ์šฐํ„ฐ ํ™‰ ์ˆ˜๊ฐ€ 16 ์ด์ƒ์ผ ๋•Œ, ๋„๋‹ฌํ•  ์ˆ˜ ์—†๋Š” ๋„คํŠธ์›Œํฌ๋ผ๊ณ  ํŒ๋‹จํ•œ๋‹ค.
– ํ† ํด๋กœ์ง€ ๋ณ€ํ™”์™€ ์ƒ๊ด€์—†์ด 30์ดˆ๋งˆ๋‹ค ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ” ์ „์ฒด๋ฅผ ์ธ์ ‘ ๋ผ์šฐํ„ฐ๋กœ ์ „์†กํ•˜๊ณ , ์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์ด ๊ธธ๋‹ค.

1-1. ๋ฉ”์„ธ์ง€ ์œ ํ˜•

(1) RIP Request : ํƒ€ ๋ผ์šฐํ„ฐ์˜ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ” ์ผ๋ถ€/์ „์ฒด๋ฅผ ์š”์ฒญํ•œ๋‹ค. ex) ๋ผ์šฐํ„ฐ๊ฐ€ ์ผœ์กŒ์„ ๋•Œ.
(2) RIP Respond : ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ” ์ผ๋ถ€/์ „์ฒด๋ฅผ ์ „์†กํ•œ๋‹ค. 30์ดˆ๋งˆ๋‹ค ์ „์†กํ•˜๊ฑฐ๋‚˜ Request ๋ฉ”์„ธ์ง€์— ๋Œ€ํ•œ ์‘๋‹ต์œผ๋กœ ์ „์†กํ•œ๋‹ค.

1-2. Timer

(1) ํŠน์ • ๋งํฌ๊ฐ€ ๋งŒ๋ฃŒ๋˜๋Š” ์ƒํ™ฉ์— ๋Œ€๋น„ํ•˜๊ธฐ ์œ„ํ•ด 180์ดˆ์˜ Timeout Timer๋ฅผ ๊ฐ–๋Š”๋‹ค. 180์ดˆ ์•ˆ์— ํ•ด๋‹น ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๋ฐ›์œผ๋ฉด Timer๋Š” ์ดˆ๊ธฐํ™” ๋˜๊ณ , ๊ทธ๋ ‡์ง€ ์•Š์œผ๋ฉด Metric์„ 16์œผ๋กœ ์˜ฌ๋ฆฐ ํ›„ ๋‹ค์Œ ๋‹จ๊ณ„๋กœ ๋„˜์–ด๊ฐ„๋‹ค.
(2) Garbage-Collection Timer๋ฅผ ๋™์ž‘์‹œ์ผœ 120์ดˆ ๋™์•ˆ ์‚ญ์ œ ๋Œ€๊ธฐ๋ฅผ ํ•œ๋‹ค. ์ด ๋•Œ, Respond ๋ฉ”์„ธ์ง€๋ฅผ ๋ณด๋‚ด๋”๋ผ๋„ ์‚ญ์ œ ๋Œ€๊ธฐ ์ค‘์ธ ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ํฌํ•จ์‹œ์ผœ ์ „์†กํ•œ๋‹ค. ๋งŒ์•ฝ ๋‹ค๋ฅธ ๋ผ์šฐํ„ฐ๋กœ ํ•ด๋‹น ๋ผ์šฐํŒ… ์ •๋ณด๊ฐ€ ๋“ค์–ด์˜ค๋ฉด, ์œ ํšจํ•œ ๋ผ์šฐํŒ… ์ •๋ณด๋กœ ๊ฐ„์ฃผํ•˜๊ณ  ์ฆ‰์‹œ Timer๋ฅผ ์ดˆ๊ธฐํ™” ์‹œํ‚จ๋‹ค.

*** ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์‚ญ์ œํ•˜๊ธฐ ์ „ Timeout Timer, Garbage-Collection Timer๋ฅผ ๊ฑฐ์ณ์•ผ ์‚ญ์ œ๋œ๋‹ค.


2. RIP ํŒจํ‚ท ํฌ๋งท

[ RIP ๋ฉ”์„ธ์ง€ ํฌ๋งท ]
– Command: RIP ๋ฉ”์„ธ์ง€ ์œ ํ˜• ์ง€์ •. 1 – RIP Request, 2 – RIP Respond
– Version: RIP ๋ฒ„์ „ ์ง€์ •
– 0: ์˜ˆ์•ฝ๋œ ํ•„๋“œ๋กœ 0์œผ๋กœ ํŒจ๋”ฉ
– RTE: ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๊ฐ–๊ณ  ์žˆ๋Š” ํ•„๋“œ. ์ตœ์†Œ 1๊ฐœ~ ์ตœ๋Œ€ 25๊ฐœ์˜ ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๊ฐ–๊ณ  ์žˆ๋‹ค.

[ RTE ํฌ๋งท ]
– Address Family Identifier: ์ฃผ์†Œ ์œ ํ˜• ์ง€์ •. IP์ฃผ์†Œ๋Š” 2๋กœ ์ง€์ •
– Router Tag: ๊ฒฝ๋กœ์— ๋Œ€ํ•œ ์ถ”๊ฐ€ ์ •๋ณด
– IP ์ฃผ์†Œ, Subnet Mask, Next Hop, Metric

๋งŒ์•ฝ, RIP ์ธ์ฆ์„ ์‚ฌ์šฉํ•˜๊ฒŒ๋˜๋ฉด,  ๋ผ์šฐํŒ… ์ •๋ณด์— ์ธ์ฆ ์ •๋ณด 1๊ฐœ๊ฐ€ ํฌํ•จ๋˜๊ธฐ ๋•Œ๋ฌธ์— ์ตœ๋Œ€ 24๊ฐœ๊นŒ์ง€ ๊ฐ–์„ ์ˆ˜ ์žˆ๋‹ค.


3. RIP ์„ค์ •

3-1. RIP ๊ธฐ๋ณธ ์„ค์ •

RIP ์„ค์ • ์‹œ ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ „์†กํ•˜๋Š” ์ธํ„ฐํŽ˜์ด์Šค๋Š” ๋ฐ˜๋“œ์‹œ ์„ค์ •์— ํฌํ•จ.

Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# network <NETWORK_ID>

3-2. RIP ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ

Default Route ๊ด‘๊ณ 
RIP๊ฐ€ ๋™์ž‘ํ•˜๋Š” ์ธ์ ‘ ๋ผ์šฐํ„ฐ๋กœ Default Route๋ฅผ ๊ด‘๊ณ ํ•œ๋‹ค.

# ๋ฐฉ๋ฒ• 1
Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>
Router(config)# router rip
Router(config-router)# default-information originate

# ๋ฐฉ๋ฒ• 2
Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>
Router(config)# router rip
Router(config-router)# redistribute static

RIP ์ž๋™ ์ถ•์•ฝ
์ถ•์•ฝ์„ ํ†ตํ•ด ๋„คํŠธ์›Œํฌ์˜ ์•ˆ์ •์„ฑ๊ณผ ์„ฑ๋Šฅ์„ ํ–ฅ์ƒ์‹œํ‚ฌ ์ˆ˜ ์žˆ๋‹ค. ์ž๋™ ์ถ•์•ฝ์€ ๊ธฐ๋ณธ์œผ๋กœ ์„ค์ •๋˜์–ด ์žˆ๋‹ค.
172.30.1.0/24๋ฅผ ์‚ฌ์šฉํ•˜๋Š” ๋„คํŠธ์›Œํฌ๋ฅผ ๊ด‘๊ณ ํ•  ๋•Œ,  ์ž๋™ ์ถ•์•ฝ์ด ๋˜์–ด์žˆ๋‹ค๋ฉด IP ํด๋ž˜์Šค์— ๋งž๊ฒŒ 172.30.0.0/16์œผ๋กœ ๊ด‘๊ณ ํ•œ๋‹ค.

# ์ž๋™ ์ถ•์•ฝ ํ•ด์ œ
Router(config)# router rip
Router(config-router)# no auto-summary

RIP ์ˆ˜๋™ ์ถ•์•ฝ
๊ด€๋ฆฌ์ž ์ž„์˜๋กœ ๋„คํŠธ์›Œํฌ๋ฅผ ์ถ•์•ฝํ•œ๋‹ค. ์ˆ˜๋™์œผ๋กœ ์ถ•์•ฝํ•  ๋•Œ, ์ฃผ ๋„คํŠธ์›Œํฌ ๋ฒ”์œ„ ๋‚ด์—์„œ๋งŒ ์ถ•์•ฝํ•  ์ˆ˜ ์žˆ๋‹ค. RIPv2๋กœ ์ž๋™ ์ถ•์•ฝ ํ•ด์ œ๋œ ์ƒํƒœ์—์„œ๋งŒ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค.
‘192.168.0.128/26’, ‘192.168.0.192/26’ 
—โ†’ ‘192.168.0.128/25’ ์ถ•์•ฝ ๊ฐ€๋Šฅ
‘192.168.0.0/24’, ‘192.168.1.0/24’
—โ†’ ‘192.168.0.0/23’ ์ถ•์•ฝ ๋ถˆ๊ฐ€

Router(config)# int <INTERFACE>
Router(config-if)# ip summary-address rip <NETWORK_ID> <SUBNET>

3-3. Offset List๋ฅผ ์ด์šฉํ•œ ๋ฉ”ํŠธ๋ฆญ ์กฐ์ •

Offset List๋ž€, EIGRP๋‚˜ RIP์™€ ๊ฐ™์€ ๊ฑฐ๋ฆฌ ๋ฒกํ„ฐ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์—์„œ ์‚ฌ์šฉํ•˜๋Š” ‘์†ก.์ˆ˜์‹  ๋ฉ”ํŠธ๋ฆญ์„ ์ฆ๊ฐ€์‹œํ‚ค๋Š” ๋ฉ”์ปค๋‹ˆ์ฆ˜’์ด๋‹ค.

์˜ˆ๋ฅผ ๋“ค์–ด, ์•„๋ž˜์™€ ๊ฐ™์€ ํ† ํด๋กœ์ง€๊ฐ€ ์žˆ๋‹ค๊ณ  ๊ฐ€์ •ํ•ด๋ณด์ž.

ํ† ํด๋กœ์ง€. OFFSET LIST

๊ฒฝ๋กœ A(R1โ†’R2โ†’R3) ์™€ B(R1โ†’R3)๋ฅผ ๋ถ€ํ•˜ ๋ถ„์‚ฐ ์‹œํ‚ค๊ธฐ ์œ„ํ•ด์„  Offset List๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค. A์˜ ๋ฉ”ํŠธ๋ฆญ์€ 2, B์˜ ๋ฉ”ํŠธ๋ฆญ์€ 1์ด๋ฏ€๋กœ B์˜ ๋ฉ”ํŠธ๋ฆญ์„ 1 ์˜ฌ๋ ค์ฃผ์–ด์•ผ ํ•œ๋‹ค.

R1(config)# ip access-list standard <ACL_NAME>
R1(config-std-nacl)# permit <NETWORK_ID> <WILDMASK>
R1(config-std-nacl)# exit
R1(config)# 
R1(config)# router rip
R1(config-router)# offset-list <ACL_NAME> in [0-16] <INTERFACE>
R1(config-router)# offset-list <ACL_NAME> out [0-16] <INTERFACE>

-----

R1(config)# ip access-list standard IP_LIST
R1(config-std-nacl)# permit 10.10.10.0 0.0.0.255
R1(config-std-nacl)# exit
R1(config)# 
R1(config)# router rip
R1(config-router)# offset-list IP_LIST in 1 fa0/1
R1(config-router)# offset-list IP_LIST out 1 fa0/1

1: ACL์„ ์ด์šฉํ•ด ๋ฉ”ํŠธ๋ฆญ์„ ์กฐ์ •ํ•  ๋„คํŠธ์›Œํฌ๋ฅผ ์ง€์ •ํ•œ๋‹ค.
6: in-๋ผ์šฐํŒ… ์ •๋ณด ์ˆ˜์‹  ์‹œ ๋ฉ”ํŠธ๋ฆญ ์ฆ๊ฐ€, out-๋ผ์šฐํŒ… ์ •๋ณด ์†ก์‹  ์‹œ ๋ฉ”ํŠธ๋ฆญ ์ฆ๊ฐ€, ๋ฉ”ํŠธ๋ฆญ ๊ฐ’์€ 0~16 ๊ฐ’์„ ์ง€์ •ํ•  ์ˆ˜ ์žˆ๋‹ค.


4. RIP ๋ณด์•ˆ

4-1. ๋ผ์šฐํŒ… ์ •๋ณด ์ธ์ฆ

๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ˆ˜์‹ ํ•  ๋•Œ, ์•”ํ˜ธ๊ฐ€ ์ผ์น˜ํ•  ๋•Œ๋งŒ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์— ์ €์žฅํ•œ๋‹ค. ์ง์ ‘ ์—ฐ๊ฒฐ๋œ ์žฅ๋น„๋ผ๋ฆฌ๋งŒ ์„ค์ •ํ•˜๋ฉด ๋œ๋‹ค. ์–‘์ชฝ ๋ผ์šฐํ„ฐ ๋ชจ๋‘ ์„ค์ •ํ•œ๋‹ค.

์„ค์ •

Router(config)# key chain <CHAIN_NAME>
Router(config-keychain)# key [0-2147483647]
Router(config-keychain-key)# key-string <WORD>
Router(config-keychain-key)# exit
Router(config-keychain)# exit
Router(config)# 
Router(config)# int <INTERFACE>
Router(config-if)# ip rip authentication key-chain <CHAIN_NAME>
Router(config-if)# ip rip authentication mode [md5|text]

4-2. ๋ผ์šฐํŒ… ์ •๋ณด ์ฐจ๋‹จ

ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์˜ค๋Š” ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ฐจ๋‹จํ•œ๋‹ค.

์„ค์ •

Router(config)# ip prefix-list <PREFIX_NAME> deny 0.0.0.0/0 le 32
Router(config)#
Router(config)# router rip
Router(config-router)# distribute-list prefix <PREFIX_NAME> in <INTERFACE>
Router(config-router)# distribute-list prefix <PREFIX_NAME> out <INTERFACE>

1: (1) ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ฐจ๋‹จํ•˜๊ธฐ ์œ„ํ•ด Prefix List๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค. Access List๋ฅผ ์‚ฌ์šฉํ•ด๋„ ๋œ๋‹ค. (2) ๋งŒ์ผ, ํŠน์ • ๊ด‘๊ณ ๋งŒ ๋ฐ›์œผ๋ ค๋ฉด deny๋Œ€์‹  permit์„ ์‚ฌ์šฉํ•œ๋‹ค. ‘deny 0.0.0.0/0 le 32’๋Š” ๋ชจ๋“  ๋„คํŠธ์›Œํฌ๋ฅผ ์ฐจ๋‹จํ•œ๋‹ค๋Š” ์˜๋ฏธ์ด๋‹ค. Prefix List์— ๋Œ€ํ•œ ๋‚ด์šฉ์€ ์ถ”ํ›„ ๋‹ค์‹œ ์ž์„ธํžˆ ํ™•์ธํ•ด๋ณด๋„๋ก ํ•œ๋‹ค.
4,5: in์€ ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์ˆ˜์‹ ํ•˜๋Š” ๊ฒƒ์— ๋Œ€ํ•œ ๋‚ด์šฉ, out์€ ์†ก์‹ ํ•˜๋Š” ๊ฒƒ์— ๋Œ€ํ•œ ๋‚ด์šฉ์„ ์˜๋ฏธํ•œ๋‹ค.

[Router] Static Routing

๋ผ์šฐํŒ…์„ ์ฒ˜์Œ ๋ฐฐ์šด๋‹ค๋ฉด, ํ•ญ์ƒ ๋จผ์ € ๋ฐฐ์šฐ๊ฒŒ ๋˜๋Š” Static Routing์ด๋‹ค. ์ฒ˜์Œ์—๋Š” Static Routing์— ๋ณ„๊ฑฐ ์žˆ๊ฒ ๋‚˜ ์‹ถ์—ˆ์ง€๋งŒ, ๋ถ€ํ•˜๋ถ„์‚ฐ(์ดํ•˜ LB)๋„ ๋˜๋‹ˆ ๋‹ค์‹œ ํ•œ๋ฒˆ ์งš๊ณ  ๋„˜์–ด๊ฐˆ ํ•„์š”๊ฐ€ ์žˆ๋‹ค.

1. Static Routing ํŠน์ง•
2. Static Routing ๋ถ€ํ•˜๋ถ„์‚ฐ


1. Static Routing

‘Static’, ๊ด€๋ฆฌ์ž๊ฐ€ ์ง์ ‘ ์ •์ (๊ณ ์ •๋œ) ๊ฒฝ๋กœ๋ฅผ ์„ค์ •ํ•œ๋‹ค.

Routing protocol๋กœ ์ธํ•œ ๋ถ€ํ•˜๊ฐ€ ๊ฑฐ์˜ ์—†๊ณ , ๊ด€๋ฆฌ์ž ์˜๋„๋Œ€๋กœ ์ •๋ฐ€ํ•˜๊ฒŒ ๋ผ์šฐํŒ…ํ•  ์ˆ˜ ์žˆ๋‹ค. ํ•˜์ง€๋งŒ ๋„คํŠธ์›Œํฌ์— ๋ณ€ํ™”๊ฐ€ ์ƒ๊ธธ ๊ฒฝ์šฐ ๊ด€๋ฆฌ์ž๊ฐ€ ์ผ์ผํžˆ ๋Œ€์‘ํ•ด์•ผํ•˜๋ฏ€๋กœ ๋‹จ์ ์ด ๋  ์ˆ˜ ์žˆ๊ณ , ๋”๋ถˆ์–ด ๋„คํŠธ์›Œํฌ์˜ ๊ทœ๋ชจ๊ฐ€ ์ปค์ง€๋ฉด ์—ญ์‹œ ์„ค์ •์ด๋‚˜ ๊ด€๋ฆฌ๊ฐ€ ์–ด๋ ต๊ฒŒ ๋œ๋‹ค.

์„ค์ •

# Static Routing
Router(config)# ip route <DESTINATION_NETWORK> <D_N_SUBNET> <NEXT_HOP_IP>

# Default Routing
Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>

* Default-gateway์™€ Default route์˜ ์ฐจ์ด?
Default-gateway๋Š” ๋ผ์šฐํŒ… ๊ธฐ๋Šฅ์ด ๋™์ž‘ํ•˜์ง€ ์•Š์„ ๋•Œ, (์˜ˆ๋ฅผ ๋“ค์–ด L2 ๊ธฐ๋Šฅ๋งŒ ์‚ฌ์šฉํ•˜๋Š” ์Šค์œ„์น˜) ์‚ฌ์šฉํ•œ๋‹ค.
Default route๋Š” ๋ผ์šฐํŒ… ๊ธฐ๋Šฅ๊ณผ ํ•จ๊ป˜ ๋™์ž‘ํ•œ๋‹ค.

Floating Static Routing
Static Route์˜ AD ๊ฐ’์„ ์ž„์˜๋กœ ๋†’๊ฒŒ ์„ค์ •ํ•˜์—ฌ ํŠน์ • ๊ฒฝ๋กœ๋กœ ํŒจํ‚ท์„ ์ „์†กํ•˜๋„๋ก ํ•œ๋‹ค. ๊ทธ๋Ÿฌ๋‹ค ํ•ด๋‹น ๊ฒฝ๋กœ์— ๋ฌธ์ œ๊ฐ€ ๋ฐœ์ƒํ•˜๋ฉด, ๋‹ค๋ฅธ ๊ฒฝ๋กœ๋กœ ์ž๋™ ์ „์†ก๋˜๋„๋ก ํ•œ๋‹ค.  AD๊ฐ’์„ ์„ค์ •ํ•˜๊ณ ์ž ํ•˜๋ฉด, ์–‘์ชฝ์—์„œ ์„ค์ •ํ•ด์•ผ ํ•œ๋‹ค.

Router(config)# ip route <DESTINATION_NETWORK> <D_N_SUBNET> <NEXT_HOP_IP> <AD_COST>

2. Static Routing ๋ถ€ํ•˜๋ถ„์‚ฐ

Static Routing์œผ๋กœ๋„ LB๋ฅผ ํ•  ์ˆ˜ ์žˆ๋‹ค.
์šฐ์„ , ๋ผ์šฐํ„ฐ์˜ ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ๋ชฉ์ ์ง€ ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์ „์†กํ•˜๋Š” Switching ๋ฐฉ์‹์— ๋”ฐ๋ผ ๋ผ์šฐํ„ฐ์—์„œ ํŒจํ‚ท ์†ก์‹  ๊ฒฝ๋กœ ์ง€์ • ๋ฐฉ์‹์ด ๋‹ฌ๋ผ์ง„๋‹ค.

๋ฐฉ์‹1: CEF

Cisco Express Forwarding
์‹œ์Šค์ฝ” ๋ผ์šฐํ„ฐ์—์„œ ๊ธฐ๋ณธ์ ์œผ๋กœ ์‚ฌ์šฉํ•˜๋Š” ๋ฐฉ์‹์ด๋‹ค. ์ฒ˜์Œ๋ถ€ํ„ฐ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ์บ์‹œ๋กœ ๋ณต์‚ฌํ•ด๋†“์œผ๋ฏ€๋กœ ์†๋„๊ฐ€ ๋น ๋ฅด๋‹ค. ๊ธฐ๋ณธ๊ฐ’์ด๊ธฐ ๋•Œ๋ฌธ์— ๋ณ„๋„ ์„ค์ •ํ•  ํ•„์š”๊ฐ€ ์—†๋‹ค.

๋ฐฉ์‹2: Process Switching

๊ฐ๊ฐ์˜ ํŒจํ‚ท์„ ์ „์†กํ•  ๋•Œ๋งˆ๋‹ค ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ํ™•์ธํ•œ ๋’ค Next Hop์„ ๊ฒฐ์ •ํ•˜์—ฌ ํŒจํ‚ท์„ ์ „์†กํ•œ๋‹ค. Switching ์†๋„๊ฐ€ ๋Š๋ฆฌ๊ณ , ํŒจํ‚ท ๋””๋ฒ„๊น…๊ณผ ๊ฐ™์ด ํŠน๋ณ„ํ•œ ๊ฒฝ์šฐ์—๋งŒ ์‚ฌ์šฉํ•œ๋‹ค.

Router(config)# int <INTERFACE>
Router(config-if)# no ip load-sharing per-packet
Router(config-if)# exit
Router(config)#
Router(config)# no ip cef

[Router] Routing ๊ธฐ๋ณธ ๊ฐœ๋…

  1. Router์˜ ๊ธฐ๋ณธ ๋‘ ๊ฐ€์ง€ ์—ญํ• 
  2. Routing ๊ธฐ๋ณธ ๊ฐœ๋…

1. Router์˜ ๊ธฐ๋ณธ ๋‘ ๊ฐ€์ง€ ์—ญํ• 

1) ๊ฒฝ๋กœ์„ค์ •

๊ฒฝ๋กœ ์„ค์ • ์‹œ์—๋Š” ์†Œ๊ทœ๋ชจ์— ์ ํ•ฉํ•œ Static Routing๊ณผ ์ค‘.๋Œ€๊ทœ๋ชจ์— ์ ํ•ฉํ•œ Dynamic Routing์ด ์žˆ๋‹ค.

2) ๊ฒฐ์ •๋œ ๊ฒฝ๋กœ๋ฅผ ๋”ฐ๋ผ ํŒจํ‚ท ์ „์†ก

ํŒจํ‚ท ์ „์†ก ๊ณผ์ •

2. Routing ๊ธฐ๋ณธ ๊ฐœ๋…

Loopback Interface

๊ฐ€์ƒ ์ธํ„ฐํŽ˜์ด์Šค.
๋ผ์šฐํ„ฐ๊ฐ€ ๋‹ค์šด๋˜๊ฑฐ๋‚˜ ๋„คํŠธ์›Œํฌ ๊ด€๋ฆฌ์ž๊ฐ€ ์ž„์˜๋กœ ๋‹ค์šด์‹œํ‚ค์ง€ ์•Š๋Š” ์ด์ƒ ๊ณ„์† ๋™์žฅํ•˜๋ฏ€๋กœ Routing์—์„œ Router-ID๋กœ ์‚ฌ์šฉ๋œ๋‹ค.

Split Horizon

๊ด‘๊ณ ๋ฅผ ์ˆ˜์‹ ํ•œ ์ธํ„ฐํŽ˜์ด์Šค๋กœ ๋™์ผํ•œ ๊ด‘๊ณ ๋ฅผ ์ „์†กํ•˜์ง€ ์•Š๋Š”๋‹ค.

R3์€ F0/1๋กœ ๊ด‘๊ณ ๋ฅผ ๋ฐ›์•˜๊ธฐ ๋•Œ๋ฌธ์— F0/1๋กœ ๋‹ค์‹œ ๊ด‘๊ณ ๋ฅผ ์ „์†กํ•˜์ง€ ์•Š๋Š”๋‹ค.

Auto-summary

์ฃผ ๋„คํŠธ์›Œํฌ ๊ฒฝ๊ณ„์—์„œ ์ฃผ ๋„คํŠธ์›Œํฌ๋งŒ ๊ด‘๊ณ ํ•œ๋‹ค.

– ์ฃผ ๋„คํŠธ์›Œํฌ: ์„œ๋ธŒ๋„คํŒ… ํ•˜์ง€ ์•Š์•˜์„ ๋•Œ์˜ ๋„คํŠธ์›Œํฌ
‘10.10.10.0/24’์˜ ์ฃผ ๋„คํŠธ์›Œํฌ๋Š” 10.0.0.0/8
‘172.30.10.0/25’์˜ ์ฃผ ๋„คํŠธ์›Œํฌ๋Š” 172.30.0.0/16

– ์ฃผ ๋„คํŠธ์›Œํฌ ๊ฒฝ๊ณ„: ์ฃผ ๋„คํŠธ์›Œํฌ์™€ ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ „์†กํ•˜๋Š” ์ธํ„ฐํŽ˜์ด์Šค์˜ ์ฃผ ๋„คํŠธ์›Œํฌ๊ฐ€ ๋‹ค๋ฅธ ์ง€์ 

Auto-summary ๊ทœ์น™์— ์˜ํ•ด ๋‚ด๋ถ€ ๋„คํŠธ์›Œํฌ๋Š” 192.168.0.0/24๋กœ ๊ด‘๊ณ ๋œ๋‹ค.

Longest Match Rule

๋ผ์šฐํŒ…ํ•  ๋•Œ, ๋ชฉ์ ์ง€ ์ฃผ์†Œ์™€ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์˜ ๋ชฉ์ ์ง€ ์ฃผ์†Œ๊ฐ€ ์ผ์น˜ํ•˜๋Š” ๋ถ€๋ถ„์ด ๊ฐ€์žฅ ๊ธด ๊ณณ์œผ๋กœ ์ „์†กํ•œ๋‹ค.

F0/2๋กœ ํŒจํ‚ท์„ ์ „์†กํ•œ๋‹ค.

3. Routing ์ข…๋ฅ˜

  • ๋ผ์šฐํŒ… ๊ด‘๊ณ  ์ข…๋ฅ˜์— ๋”ฐ๋ผ
    ๊ฑฐ๋ฆฌ ๋ฒกํ„ฐ ํ”„๋กœํ† ์ฝœ <—> ๋งํฌ ์ƒํƒœ ํ”„๋กœํ† ์ฝœ
  • ์„œ๋ธŒ๋„ท ๋งˆ์Šคํฌ ์ •๋ณด ์‚ฌ์šฉ ์—ฌ๋ถ€์— ๋”ฐ๋ผ
    ํด๋ž˜์Šคํ’€ ํ”„๋กœํ† ์ฝœ <—> ํด๋ž˜์Šค๋ฆฌ์Šค ํ”„๋กœํ† ์ฝœ
  • AS ์œ„์น˜์— ๋”ฐ๋ผ
    IGP <—> EGP