์นดํ…Œ๊ณ ๋ฆฌ ๋ณด๊ด€๋ฌผ: Network

[Router] Static Routing

๋ผ์šฐํŒ…์„ ์ฒ˜์Œ ๋ฐฐ์šด๋‹ค๋ฉด, ํ•ญ์ƒ ๋จผ์ € ๋ฐฐ์šฐ๊ฒŒ ๋˜๋Š” Static Routing์ด๋‹ค. ์ฒ˜์Œ์—๋Š” Static Routing์— ๋ณ„๊ฑฐ ์žˆ๊ฒ ๋‚˜ ์‹ถ์—ˆ์ง€๋งŒ, ๋ถ€ํ•˜๋ถ„์‚ฐ(์ดํ•˜ LB)๋„ ๋˜๋‹ˆ ๋‹ค์‹œ ํ•œ๋ฒˆ ์งš๊ณ  ๋„˜์–ด๊ฐˆ ํ•„์š”๊ฐ€ ์žˆ๋‹ค.

1. Static Routing ํŠน์ง•
2. Static Routing ๋ถ€ํ•˜๋ถ„์‚ฐ


1. Static Routing

‘Static’, ๊ด€๋ฆฌ์ž๊ฐ€ ์ง์ ‘ ์ •์ (๊ณ ์ •๋œ) ๊ฒฝ๋กœ๋ฅผ ์„ค์ •ํ•œ๋‹ค.

Routing protocol๋กœ ์ธํ•œ ๋ถ€ํ•˜๊ฐ€ ๊ฑฐ์˜ ์—†๊ณ , ๊ด€๋ฆฌ์ž ์˜๋„๋Œ€๋กœ ์ •๋ฐ€ํ•˜๊ฒŒ ๋ผ์šฐํŒ…ํ•  ์ˆ˜ ์žˆ๋‹ค. ํ•˜์ง€๋งŒ ๋„คํŠธ์›Œํฌ์— ๋ณ€ํ™”๊ฐ€ ์ƒ๊ธธ ๊ฒฝ์šฐ ๊ด€๋ฆฌ์ž๊ฐ€ ์ผ์ผํžˆ ๋Œ€์‘ํ•ด์•ผํ•˜๋ฏ€๋กœ ๋‹จ์ ์ด ๋  ์ˆ˜ ์žˆ๊ณ , ๋”๋ถˆ์–ด ๋„คํŠธ์›Œํฌ์˜ ๊ทœ๋ชจ๊ฐ€ ์ปค์ง€๋ฉด ์—ญ์‹œ ์„ค์ •์ด๋‚˜ ๊ด€๋ฆฌ๊ฐ€ ์–ด๋ ต๊ฒŒ ๋œ๋‹ค.

์„ค์ •

# Static Routing
Router(config)# ip route <DESTINATION_NETWORK> <D_N_SUBNET> <NEXT_HOP_IP>

# Default Routing
Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>

* Default-gateway์™€ Default route์˜ ์ฐจ์ด?
Default-gateway๋Š” ๋ผ์šฐํŒ… ๊ธฐ๋Šฅ์ด ๋™์ž‘ํ•˜์ง€ ์•Š์„ ๋•Œ, (์˜ˆ๋ฅผ ๋“ค์–ด L2 ๊ธฐ๋Šฅ๋งŒ ์‚ฌ์šฉํ•˜๋Š” ์Šค์œ„์น˜) ์‚ฌ์šฉํ•œ๋‹ค.
Default route๋Š” ๋ผ์šฐํŒ… ๊ธฐ๋Šฅ๊ณผ ํ•จ๊ป˜ ๋™์ž‘ํ•œ๋‹ค.

Floating Static Routing
Static Route์˜ AD ๊ฐ’์„ ์ž„์˜๋กœ ๋†’๊ฒŒ ์„ค์ •ํ•˜์—ฌ ํŠน์ • ๊ฒฝ๋กœ๋กœ ํŒจํ‚ท์„ ์ „์†กํ•˜๋„๋ก ํ•œ๋‹ค. ๊ทธ๋Ÿฌ๋‹ค ํ•ด๋‹น ๊ฒฝ๋กœ์— ๋ฌธ์ œ๊ฐ€ ๋ฐœ์ƒํ•˜๋ฉด, ๋‹ค๋ฅธ ๊ฒฝ๋กœ๋กœ ์ž๋™ ์ „์†ก๋˜๋„๋ก ํ•œ๋‹ค.  AD๊ฐ’์„ ์„ค์ •ํ•˜๊ณ ์ž ํ•˜๋ฉด, ์–‘์ชฝ์—์„œ ์„ค์ •ํ•ด์•ผ ํ•œ๋‹ค.

Router(config)# ip route <DESTINATION_NETWORK> <D_N_SUBNET> <NEXT_HOP_IP> <AD_COST>

2. Static Routing ๋ถ€ํ•˜๋ถ„์‚ฐ

Static Routing์œผ๋กœ๋„ LB๋ฅผ ํ•  ์ˆ˜ ์žˆ๋‹ค.
์šฐ์„ , ๋ผ์šฐํ„ฐ์˜ ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ๋ชฉ์ ์ง€ ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์ „์†กํ•˜๋Š” Switching ๋ฐฉ์‹์— ๋”ฐ๋ผ ๋ผ์šฐํ„ฐ์—์„œ ํŒจํ‚ท ์†ก์‹  ๊ฒฝ๋กœ ์ง€์ • ๋ฐฉ์‹์ด ๋‹ฌ๋ผ์ง„๋‹ค.

๋ฐฉ์‹1: CEF

Cisco Express Forwarding
์‹œ์Šค์ฝ” ๋ผ์šฐํ„ฐ์—์„œ ๊ธฐ๋ณธ์ ์œผ๋กœ ์‚ฌ์šฉํ•˜๋Š” ๋ฐฉ์‹์ด๋‹ค. ์ฒ˜์Œ๋ถ€ํ„ฐ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ์บ์‹œ๋กœ ๋ณต์‚ฌํ•ด๋†“์œผ๋ฏ€๋กœ ์†๋„๊ฐ€ ๋น ๋ฅด๋‹ค. ๊ธฐ๋ณธ๊ฐ’์ด๊ธฐ ๋•Œ๋ฌธ์— ๋ณ„๋„ ์„ค์ •ํ•  ํ•„์š”๊ฐ€ ์—†๋‹ค.

๋ฐฉ์‹2: Process Switching

๊ฐ๊ฐ์˜ ํŒจํ‚ท์„ ์ „์†กํ•  ๋•Œ๋งˆ๋‹ค ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ํ™•์ธํ•œ ๋’ค Next Hop์„ ๊ฒฐ์ •ํ•˜์—ฌ ํŒจํ‚ท์„ ์ „์†กํ•œ๋‹ค. Switching ์†๋„๊ฐ€ ๋Š๋ฆฌ๊ณ , ํŒจํ‚ท ๋””๋ฒ„๊น…๊ณผ ๊ฐ™์ด ํŠน๋ณ„ํ•œ ๊ฒฝ์šฐ์—๋งŒ ์‚ฌ์šฉํ•œ๋‹ค.

Router(config)# int <INTERFACE>
Router(config-if)# no ip load-sharing per-packet
Router(config-if)# exit
Router(config)#
Router(config)# no ip cef

[Router] Routing ๊ธฐ๋ณธ ๊ฐœ๋…

  1. Router์˜ ๊ธฐ๋ณธ ๋‘ ๊ฐ€์ง€ ์—ญํ• 
  2. Routing ๊ธฐ๋ณธ ๊ฐœ๋…

1. Router์˜ ๊ธฐ๋ณธ ๋‘ ๊ฐ€์ง€ ์—ญํ• 

1) ๊ฒฝ๋กœ์„ค์ •

๊ฒฝ๋กœ ์„ค์ • ์‹œ์—๋Š” ์†Œ๊ทœ๋ชจ์— ์ ํ•ฉํ•œ Static Routing๊ณผ ์ค‘.๋Œ€๊ทœ๋ชจ์— ์ ํ•ฉํ•œ Dynamic Routing์ด ์žˆ๋‹ค.

2) ๊ฒฐ์ •๋œ ๊ฒฝ๋กœ๋ฅผ ๋”ฐ๋ผ ํŒจํ‚ท ์ „์†ก

ํŒจํ‚ท ์ „์†ก ๊ณผ์ •

2. Routing ๊ธฐ๋ณธ ๊ฐœ๋…

Loopback Interface

๊ฐ€์ƒ ์ธํ„ฐํŽ˜์ด์Šค.
๋ผ์šฐํ„ฐ๊ฐ€ ๋‹ค์šด๋˜๊ฑฐ๋‚˜ ๋„คํŠธ์›Œํฌ ๊ด€๋ฆฌ์ž๊ฐ€ ์ž„์˜๋กœ ๋‹ค์šด์‹œํ‚ค์ง€ ์•Š๋Š” ์ด์ƒ ๊ณ„์† ๋™์žฅํ•˜๋ฏ€๋กœ Routing์—์„œ Router-ID๋กœ ์‚ฌ์šฉ๋œ๋‹ค.

Split Horizon

๊ด‘๊ณ ๋ฅผ ์ˆ˜์‹ ํ•œ ์ธํ„ฐํŽ˜์ด์Šค๋กœ ๋™์ผํ•œ ๊ด‘๊ณ ๋ฅผ ์ „์†กํ•˜์ง€ ์•Š๋Š”๋‹ค.

R3์€ F0/1๋กœ ๊ด‘๊ณ ๋ฅผ ๋ฐ›์•˜๊ธฐ ๋•Œ๋ฌธ์— F0/1๋กœ ๋‹ค์‹œ ๊ด‘๊ณ ๋ฅผ ์ „์†กํ•˜์ง€ ์•Š๋Š”๋‹ค.

Auto-summary

์ฃผ ๋„คํŠธ์›Œํฌ ๊ฒฝ๊ณ„์—์„œ ์ฃผ ๋„คํŠธ์›Œํฌ๋งŒ ๊ด‘๊ณ ํ•œ๋‹ค.

– ์ฃผ ๋„คํŠธ์›Œํฌ: ์„œ๋ธŒ๋„คํŒ… ํ•˜์ง€ ์•Š์•˜์„ ๋•Œ์˜ ๋„คํŠธ์›Œํฌ
‘10.10.10.0/24’์˜ ์ฃผ ๋„คํŠธ์›Œํฌ๋Š” 10.0.0.0/8
‘172.30.10.0/25’์˜ ์ฃผ ๋„คํŠธ์›Œํฌ๋Š” 172.30.0.0/16

– ์ฃผ ๋„คํŠธ์›Œํฌ ๊ฒฝ๊ณ„: ์ฃผ ๋„คํŠธ์›Œํฌ์™€ ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ „์†กํ•˜๋Š” ์ธํ„ฐํŽ˜์ด์Šค์˜ ์ฃผ ๋„คํŠธ์›Œํฌ๊ฐ€ ๋‹ค๋ฅธ ์ง€์ 

Auto-summary ๊ทœ์น™์— ์˜ํ•ด ๋‚ด๋ถ€ ๋„คํŠธ์›Œํฌ๋Š” 192.168.0.0/24๋กœ ๊ด‘๊ณ ๋œ๋‹ค.

Longest Match Rule

๋ผ์šฐํŒ…ํ•  ๋•Œ, ๋ชฉ์ ์ง€ ์ฃผ์†Œ์™€ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์˜ ๋ชฉ์ ์ง€ ์ฃผ์†Œ๊ฐ€ ์ผ์น˜ํ•˜๋Š” ๋ถ€๋ถ„์ด ๊ฐ€์žฅ ๊ธด ๊ณณ์œผ๋กœ ์ „์†กํ•œ๋‹ค.

F0/2๋กœ ํŒจํ‚ท์„ ์ „์†กํ•œ๋‹ค.

3. Routing ์ข…๋ฅ˜

  • ๋ผ์šฐํŒ… ๊ด‘๊ณ  ์ข…๋ฅ˜์— ๋”ฐ๋ผ
    ๊ฑฐ๋ฆฌ ๋ฒกํ„ฐ ํ”„๋กœํ† ์ฝœ <—> ๋งํฌ ์ƒํƒœ ํ”„๋กœํ† ์ฝœ
  • ์„œ๋ธŒ๋„ท ๋งˆ์Šคํฌ ์ •๋ณด ์‚ฌ์šฉ ์—ฌ๋ถ€์— ๋”ฐ๋ผ
    ํด๋ž˜์Šคํ’€ ํ”„๋กœํ† ์ฝœ <—> ํด๋ž˜์Šค๋ฆฌ์Šค ํ”„๋กœํ† ์ฝœ
  • AS ์œ„์น˜์— ๋”ฐ๋ผ
    IGP <—> EGP

[Switch] SPAN

Switch Port Analyzer

ํŠน์ • ํฌํŠธ๋ฅผ ํ†ตํ•ด ์ž…/์ถœ๋ ฅ๋˜๋Š” ํŠธ๋ž˜ํ”ฝ์„ ๋‹ค๋ฅธ ํฌํŠธ๋กœ ๋ณต์ œํ•˜์—ฌ ๋ถ„์„ํ•˜๋Š” ๊ธฐ๋Šฅ์ด๋‹ค. ํŠธ๋ž˜ํ”ฝ ๋ถ„์„ ๋˜๋Š” ์นจ์ž…๋ฐฉ์ง€์‹œ์Šคํ…œ(IPS)๋ฅผ ์œ„ํ•ด ์„ค์ •ํ•œ๋‹ค. ์—ฌ๋Ÿฌ ๊ฐœ์˜ ํฌํŠธ๋กœ ์ž…/์ถœ๋ ฅ๋˜๋Š” ํŠธ๋ž˜ํ”ฝ์„ ๋™์‹œ์— ๋ณต์ œํ•  ์ˆ˜ ์žˆ๊ณ , VLAN ํŠธ๋ž˜ํ”ฝ๋„ ๋ณต์ œํ•  ์ˆ˜ ์žˆ๋‹ค.

SPAN ํฌํŠธ ์ข…๋ฅ˜

SPAN Source Port : ๋ถ„์„ ๋Œ€์ƒ์ด ๋˜๋Š” ํฌํŠธ.
SPAN Destination Port : ๋ถ„์„์žฅ๋น„๊ฐ€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ, ์—ฌ๊ธฐ์— ์ ‘์†๋œ ์žฅ๋น„๋Š” ์ธํ„ฐ๋„ท์€ ๋ฌผ๋ก  Layer 2 ํ”„๋กœํ† ์ฝœ์ด ๋™์ž‘ํ•˜์ง€ ์•Š๋Š”๋‹ค. ์–ด๋–ค VLAN์— ์†Œ์†๋˜์–ด๋„ ์ƒ๊ด€ ์—†๋‹ค.

SPAN ์ง€์—ญ ์ข…๋ฅ˜

Local SPAN : SPAN Source ์™€ Destination์ด ๋™์ผํ•œ ์Šค์œ„์น˜ ์†Œ์†.
Remote SPAN : SPAN Source ์™€ Destination์ด ์„œ๋กœ ๋‹ค๋ฅธ ์Šค์œ„์น˜ ์†Œ์†.

SPAN ์„ค์ •

ํ† ํด๋กœ์ง€1. SPAN ์„ค์ •
Switch(config)# monitor session 1 source int fa0/3
Switch(config)# monitor session 1 destination int fa0/2

RSPAN ์„ค์ •

ํ† ํด๋กœ์ง€2. RSPAN ์„ค์ •

[ SPAN Source ์Šค์œ„์น˜ ์„ค์ • ]

SW1(config)# vlan 500
SW1(config-vlan)# remote-span
SW1(config-vlan)# exit
SW1(config)#
SW1(config)# monitor session 1 source int fa0/1
SW1(config)# monitor session 1 destination remote vlan 500

[ SPAN Destination ์Šค์œ„์น˜ ์„ค์ • ]

SW2(config)# vlan 500
SW2(config-vlan)# remote-span
SW2(config-vlan)# exit
SW2(config)#
SW2(config)# monitor session 1 source remote vlan 500
SW2(config)# monitor session 1 destination int fa0/20


[QoS] 3: Policing

Policing ์ด๋ž€, ํŠธ๋ž˜ํ”ฝ์˜ ์ตœ๋Œ€ ์†๋„๋ฅผ ์ œํ•œํ•˜๋Š” ๊ฒƒ์„ ๋งํ•œ๋‹ค. ๋Œ€์—ญํญ์— ์—ฌ์œ ๊ฐ€ ์žˆ์–ด๋„ ์ตœ๋Œ€ ์†๋„๋ฅผ ๋„˜๊ธฐ๋ฉด ํ•ด๋‹น ํŠธ๋ž˜ํ”ฝ์„ ํ๊ธฐํ•œ๋‹ค.

Input Policing: ํŒจํ‚ท ์ž…๋ ฅ(์ˆ˜์‹ ) ์‹œ ์ ์šฉํ•˜๋Š” Policing
Output Policing: ํŒจํ‚ท ์ถœ๋ ฅ(์†ก์‹ ) ์‹œ ์ ์šฉํ•˜๋Š” Policing, ์ง€์›ํ•˜์ง€ ์•Š๋Š” ์Šค์œ„์น˜๋„ ์žˆ๋‹ค๊ณ  ํ•œ๋‹ค.

1. Policing ์„ค์ •
2. DSCP ๋งˆํฌ๋‹ค์šด


1. Policing ์„ค์ •

ํ† ํด๋กœ์ง€1. Policing ์„ค์ •
Switch(config)# mls qos
Switch(config)#
Switch(config)# policy-map <POLICY_NAME>
Switch(config-pmap)# class [ <CLASS_MAP_NAME> | class-default ]
Switch(config-pmap-c)# police <LIMITED_BPS> <Bc>
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)#
Switch(config)# int <INTERFACE>
Switch(config-if)# service-policy input <POLICY_NAME>

5: ‘<CLASS_MAP_NAME>‘์€ class-map์„ ํ†ตํ•ด ์ง€์ •ํ•œ ํŠธ๋ž˜ํ”ฝ์— ์ ์šฉํ•˜๊ณ , ‘class-default‘๋Š” ๋ชจ๋“  ํŠธ๋ž˜ํ”ฝ์— ์ ์šฉํ•œ๋‹ค.
6: ex) police 1000000 31250
<LIMITED_BPS>‘์˜ ๋‹จ์œ„๋Š” bps์ด๋‹ค.
<Bc>’๋Š” ๋‹จ์œ„์‹œ๊ฐ„(Tc)์— ์ „์†กํ•  ์ˆ˜ ์žˆ๋Š” ์ตœ๋Œ€ ํŠธ๋ž˜ํ”ฝ ์–‘์ด๋‹ค. Byte ๋‹จ์œ„์ด๋ฉฐ, ์žฅ๋น„๋งˆ๋‹ค ์ตœ์†Œ/์ตœ๋Œ€ BC๊ฐ’์ด ๋‹ค๋ฅด๋‹ค.

Bc ์™€ Tc

– Bc : Burst Committed, ํŒจํ‚ท์„ ๋‹ด๋Š” ๋ฒ„ํ‚ท์ด๋ผ๊ณ  ์ƒ๊ฐํ•˜๋ฉด ๋œ๋‹ค.
– CIR : Committed Information Rate, ํด๋ฆฌ์‹ฑ ์†๋„.
– Tc : ๋‹จ์œ„์‹œ๊ฐ„, Bc๋ฅผ ๋‹ค ์ฑ„์šฐ๋Š” ์‹œ๊ฐ„

Bc = (CIR * Tc) / 8‘ ์ด๋ผ๋Š” ๊ณต์‹์— ๋”ฐ๋ผ ๋™์ž‘ํ•œ๋‹ค.
์ตœ๋Œ€ ํŠธ๋ž˜ํ”ฝ ์–‘(Bc)์ด ๋™์ผํ•˜๋‹ค๊ณ  ํ• ๋•Œ, ํด๋ฆฌ์‹ฑ ์†๋„(CIR)๊ฐ€ ์ปค์งˆ์ˆ˜๋ก ๋‹จ์œ„์‹œ๊ฐ„(Tc)๋Š” ์ž‘์•„์ง„๋‹ค.


2. DSCP ๋งˆํฌ๋‹ค์šด

Policing์—์„œ ์ตœ๋Œ€ ์†๋„๋ฅผ ์ดˆ๊ณผํ•˜๋Š” ํ”„๋ ˆ์ž„์€ ํ๊ธฐํ•œ๋‹ค๊ณ  ํ–ˆ๋‹ค. ํ•˜์ง€๋งŒ, ์ด๋Ÿฌํ•œ ํ”„๋ ˆ์ž„์„ ํ๊ธฐํ•˜๋Š” ๋Œ€์‹  ‘policed-dscp map’์„ ์ฐธ๊ณ ํ•˜์—ฌ DSCP ๊ฐ’์„ ๋ณ€๊ฒฝํ•˜๋Š” ๊ฒƒ์„ ‘DSCP ๋งˆํฌ๋‹ค์šด’์ด๋ผ๊ณ  ํ•œ๋‹ค.

์„ค์ •

Switch(config)# policy-map <POLICY_NAME>
Switch(config-pmap)# class [ <CLASS_MAP_NAME> | class-default ]
Switch(config-pmap-c)# police <LIMITED_BPS> <Bc> exceed-action policed-dscp transmit

policed-dscp map ํ™•์ธ

Switch# show mls qos maps policed-dscp

[QoS] 2: Trusting

QoS ํ๋ฆ„ ์ค‘ ํ”„๋ ˆ์ž„์„ ๋ถ„๋ฅ˜ํ•˜๊ณ  ํ‘œ์‹œํ•˜๋Š” ๊ฒƒ์„ Trusting์ด๋ผ๊ณ  ํ•œ๋‹ค. Trusting์„ ํ•  ์ˆ˜ ์žˆ๋Š” ๋ฐฉ๋ฒ•์€ ํฌ๊ฒŒ 2๊ฐ€์ง€์ด๋‹ค.

1. ‘trust๋ช…๋ น์–ด๋ฅผ ํ†ตํ•ด ํŠธ๋ž˜ํ”ฝ์„ ๋ถ„๋ฅ˜ํ•˜๊ณ , ํŠธ๋ž˜ํ”ฝ์˜ QoS๋ฅผ ํ‘œ์‹œํ•œ๋‹ค.

2. ์•ž์„œ ์‚ดํŽด๋ณธ QoS ์„ค์ •์˜ MQC ๋ช…๋ น์–ด ์ค‘ ‘class-map‘์„ ํ†ตํ•ด ํŠธ๋ž˜ํ”ฝ์„ ๋ถ„๋ฅ˜ํ•˜๊ณ , ‘policy-map‘์„ ํ†ตํ•ด ํŠธ๋ž˜ํ”ฝ์˜ QoS๋ฅผ ํ‘œ์‹œํ•œ๋‹ค.

  1. trust ๋ช…๋ น์–ด
  2. ์ธํ„ฐํŽ˜์ด์Šค์—์„œ trusting
  3. policy-map์„ ์ด์šฉํ•œ trusting

1. trust ๋ช…๋ น์–ด

์ˆ˜์‹ ๋œ ํ”„๋ ˆ์ž„์˜ QoS ๊ฐ’ ์ค‘ ์–ด๋–ค ๊ฐ’์„ ๊ธฐ์ค€์œผ๋กœ ํ• ์ง€ ๊ฒฐ์ •ํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค. QoS ๊ฐ’ ์—†์ด QoS๋ฅผ ์„ค์ •ํ•œ๋‹ค๋ฉด, ‘trust๋ช…๋ น์–ด๋ฅผ ์‚ฌ์šฉํ•  ํ•„์š”๊ฐ€ ์—†๋‹ค.
trust๋ช…๋ น์–ด๋Š” ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ์‚ฌ์šฉํ•˜๊ฑฐ๋‚˜ MQC์˜ ‘policy-map‘์—์„œ ์‚ฌ์šฉํ•œ๋‹ค.

– ‘trust‘๋Š” ๊ธฐ๋ณธ์ ์œผ๋กœ ๋ฏธ์‚ฌ์šฉ ์ƒํƒœ๋‹ค.
– ‘trust‘๋ฅผ ๋ฏธ์‚ฌ์šฉํ•ด๋„ ์ˆ˜์‹ ํ•œ ํ”„๋ ˆ์ž„์˜ ์šฐ์„ ์ˆœ์œ„ ๊ฐ’์€ ๊ทธ๋Œ€๋กœ ์œ ์ง€ํ•œ๋‹ค.
– ๋‹จ, QoS๋ฅผ ํ™œ์„ฑํ™”ํ•˜๊ณ  ๋ณ„๋„ ์„ค์ •์„ ํ•˜์ง€ ์•Š๋Š”๋‹ค๋ฉด, ์šฐ์„ ์ˆœ์œ„ ๊ฐ’์€ 0์œผ๋กœ ์ดˆ๊ธฐํ™”๋˜๋‹ˆ ์ฃผ์˜ํ•ด์•ผ ํ•œ๋‹ค.


2. ์ธํ„ฐํŽ˜์ด์Šค์—์„œ trusting

Switch(config)# mls qos
Switch(config)#
Switch(config)# int <INTERFACE>
Switch(config-if)# mls qos [ cos | device | dscp | ip-precedence | <cr> ]

2: qos๋ฅผ ํ™œ์„ฑํ™”ํ•œ๋‹ค.
5: cos, dscp, ip-precedence -> QoS ์šฐ์„ ์ˆœ์œ„์˜ ์ข…๋ฅ˜๋ฅผ ์ง€์ •.
device -> Cisco IP ์ „ํ™”๊ธฐ๊ฐ€ ์„ค์น˜๋œ ๊ฒฝ์šฐ ์‚ฌ์šฉํ•œ๋‹ค.
๋ณ„๋„ ์ข…๋ฅ˜๋ฅผ ์ง€์ •ํ•˜์ง€ ์•Š์œผ๋ฉด, dscp๋กœ ๊ฐ„์ฃผํ•œ๋‹ค.

[ QoS ์šฐ์„ ์ˆœ์œ„๋ฅผ CoS๊ฐ’ ๊ธฐ์ค€, CoS๊ฐ’์ด ์—†๋‹ค๋ฉด 2๋กœ ์ง€์ • ]

Switch(config-if)# mls qos trust cos
Switch(config-if)# mls qos cos 2

[ ์ˆ˜์‹  ํ”„๋ ˆ์ž„์˜ coS ๊ฐ’์„ ๋ฌด์‹œ, ๋ฌด์กฐ๊ฑด 1๋กœ ์ง€์ • ]

Switch(config-if)# mls qos cos 1
Switch(config-if)# mls qos cos override

3. Policy-map์„ ์ด์šฉํ•œ trusting

์ธํ„ฐํŽ˜์ด์Šค์—์„œ trusting์„ ํ•˜๋ฉด, ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค๋ฅผ ํ†ต๊ณผํ•˜๋Š” ํŠธ๋ž˜ํ”ฝ ์ „์ฒด์— ์ ์šฉ๋œ๋‹ค. ๊ทธ๋Ÿฌ๋‚˜ Policy-map์„ ์ด์šฉํ•ด trusting์„ ํ•œ๋‹ค๋ฉด, ‘class-map‘์œผ๋กœ ์ง€์ •๋œ ํŠธ๋ž˜ํ”ฝ์—๋งŒ ์ ์šฉ๋œ๋‹ค. ๋‹ค์‹œ ๋งํ•ด, Policy-map์„ ํ†ตํ•ด ๋” ์ •๊ตํ•œ trusting์„ ํ•  ์ˆ˜ ์žˆ๋‹ค๋Š” ๊ฒƒ์ด๋‹ค.

๋งŒ์ผ, ์ธํ„ฐํŽ˜์ด์Šค์™€ Policy-map ๋ชจ๋‘ trusting์„ ์ ์šฉํ•˜๋ฉด Policy-map์˜ trusting์ด ์šฐ์„ ํ•œ๋‹ค.

trusting ์„ค์ •

ACL ์„ค์ • โ†’ class-map ์„ค์ • โ†’ policy-map ์„ค์ • โ†’ policy-map ์ ์šฉ

Switch(config)# ip access-list extended <ACL_NAME>
Switch(config-ext-nacl)# permit ip <SOURCE_IP> <DESTINATION_IP>
Switch(config-ext-nacl)# exit
Switch(config)#
Switch(config)# class-map <CLASS_MAP_NAME>
Switch(config-cmap)# match access-group name <ACL_NAME>
Switch(config-cmap)# exit
Switch(config)#
Switch(config)# policy-map <POLICY_NAME>
Switch(config-pmap)# class <CLASS_MAP_NAME>
Switch(config-pmap-c)# trust [ cos | dscp | ip-precedence | <cr> ]
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)#
Switch(config)# int <INTERFACE>
Switch(config-if)# service-policy input <POLICY_NAME>

[QoS] 1: ๊ฐœ๋…

Quality of Service

์ˆ˜ ๋งŽ์€ ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›๋Š” ์ƒํ™ฉ์—์„œ ๋‹ค๋ฅธ ํŒจํ‚ท ๋ณด๋‹ค ๋จผ์ € ์ฒ˜๋ฆฌํ•ด์•ผํ•˜๋Š” ์ค‘์š”ํ•œ ํŒจํ‚ท์ด ์žˆ๊ธฐ ๋งˆ๋ จ์ด๋‹ค. ๊ทธ๋Ÿฐ ํŒจํ‚ท์„ ์œ„ํ•œ ๊ฒƒ์ด ๋ฐ”๋กœ QoS์ด๋‹ค.
VoIP์ฒ˜๋Ÿผ ์‹ค์‹œ๊ฐ„์œผ๋กœ ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›์œผ๋ฉด์„œ ์ง€์—ฐ๋˜์ง€ ์•Š๋„๋ก, ๊ทธ๋ฆฌ๊ณ  ์ค‘์š”ํ•œ ํŠธ๋ž˜ํ”ฝ์˜ ๋Œ€์—ญํญ์„ ๋ณด์žฅํ•˜๊ณ  ํŠน์ • ํŠธ๋ž˜ํ”ฝ์„ ์ œํ•œํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค.

Qos ์ž‘์—…์€ 6๊ฐ€์ง€๋กœ ๋ถ„๋ฅ˜ํ•  ์ˆ˜์žˆ๊ณ , 1~6๋ฒˆ ์ˆœ์„œ๋Œ€๋กœ ํ๋ฆ„์ด ์ง„ํ–‰๋œ๋‹ค.

  1. Classification (ํŠธ๋ž˜ํ”ฝ ๋ถ„๋ฅ˜)
  2. Policing (ํด๋ฆฌ์‹ฑ)
  3. Marking (์šฐ์„ ์ˆœ์œ„ ํ‘œ์‹œ)
  4. Congestion Avoidance (ํ˜ผ์žก ํšŒํ”ผ)
  5. Queueing (ํ์ž‰)
  6. Scheduling (์Šค์ผ€์ค„๋ง)
  7. Switch QoS ์„ค์ •
QoS ๊ฐ„๋žต ํ๋ฆ„

1. Classification – ํŠธ๋ž˜ํ”ฝ ๋ถ„๋ฅ˜

QoS ์ •์ฑ…์„ ์„ค์ •ํ•˜๊ธฐ ์•ž์„œ ๋จผ์ € QoS๋ฅผ ์ ์šฉํ•  ํŒจํ‚ท์„ ๊ตฌ๋ถ„ํ•œ๋‹ค.

์˜ˆ๋ฅผ ๋“ค๋ฉด,
(1) ํŠน์ • IP์—์„œ ์˜จ ํŒจํ‚ท
(2) ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ์˜จ ํŒจํ‚ท
(3) ํŠน์ • ์šฐ์„ ์ˆœ์œ„(IP Precedence/DSCP/CoS)๋ฅผ ๊ฐ€์ง„ ํŒจํ‚ท

์ด๋ ‡๊ฒŒ ๋ง์ด๋‹ค.


2. Policing – ํด๋ฆฌ์‹ฑ

์‚ฌ์šฉ ๊ฐ€๋Šฅํ•œ ์†๋„๋ฅผ ์ œํ•œํ•œ๋‹ค. ํ†ต์‹ ์‚ฌ์—…์ž๊ฐ€ ๋งŽ์ด ์‚ฌ์šฉํ•œ๋‹ค๊ณ  ํ•œ๋‹ค.
100Mbps๋กœ Policingํ•œ๋‹ค = ์ตœ๋Œ€ ์†๋„๊ฐ€ 100Mbps๊นŒ์ง€ ๋‚˜์˜จ๋‹ค.


3. Marking – ์šฐ์„ ์ˆœ์œ„ ํ‘œ์‹œ

ํ”„๋ ˆ์ž„์— ์šฐ์„  ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•˜๋Š” ๊ฒƒ์ด๋‹ค. ๋งŒ์ผ, ์šฐ์„ ์ˆœ์œ„๋ฅผ ์„ค์ •ํ•˜์ง€ ์•Š์•˜๋‹ค๋ฉด, ์‹ค์‹œ๊ฐ„ ์ฒ˜๋ฆฌ๊ฐ€ ํ•„์š”ํ•œ ํŒจํ‚ท์ด ์ง€์—ฐ๋  ์ˆ˜ ์žˆ๋‹ค.
ํ”„๋กœํ† ์ฝœ์— ๋”ฐ๋ผ ์ง€์ •/์ง€์ • ๋ถˆ๊ฐ€ํ•˜๋‹ค.

3-1. Ethernet ํ”„๋ ˆ์ž„๊ณผ 802.1Q ํ”„๋ ˆ์ž„

Ethernet ํ”„๋ ˆ์ž„์—๋Š” ์šฐ์„ ์ˆ˜์œ„๋ฅผ ํ‘œ์‹œํ•  ํ•„๋“œ๊ฐ€ ์—†๋‹ค.
์ฆ‰, ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์—†๋‹ค.

802.1Q ํ”„๋ ˆ์ž„์˜ Tag ํ•„๋“œ์— CoS(Priority) ํ•ญ๋ชฉ์ด ์žˆ๋‹ค.
์šฐ์„ ์ˆ˜์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์žˆ๋‹ค.
์ฆ‰, Trunking ํฌํŠธ๋ฅผ ํ†ตํ•ด ์†ก์ˆ˜์‹ ๋˜๋Š” ํŠธ๋ž˜ํ”ฝ์€ ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์žˆ๋‹ค.

3-2. IP ํ—ค๋”

์ถœ์ฒ˜: What 8-bit field exists in IP packet for QoS?, ITExamAnswers, https://itexamanswers.net/question/what-8-bit-field-exists-in-ip-packet-for-qos

IP ํ—ค๋”์—์„œ IP Precedence ํ˜น์€ DSCP๋ฅผ ์ด์šฉํ•ด ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์žˆ๋‹ค.
IP Precedence : ๊ฐ’ 0~7, ๊ฐ’์ด ํด์ˆ˜๋ก ์šฐ์„ ์ˆœ์œ„๊ฐ€ ๋†’์•„์ง„๋‹ค.
DSCP : ๊ฐ’ 0~63, ๊ฐ’์˜ ํฌ๊ธฐ์˜ ๋”ฐ๋ฅธ ์˜๋ฏธ๋Š” ์—†๋‹ค. ๋ณดํ†ต VoIP์— DSCP ๊ฐ’ 46์„ ๋ถ€์—ฌํ•œ๋‹ค. 46์„ EF(Expected Forwarding)์ด๋ผ๊ณ  ํ•œ๋‹ค.
* DSCP ๊ฐ’ ์ฐธ๊ณ  : Cisco Configuration Guides

3-3. Marking ์‚ฌ์šฉ ์˜ˆ์‹œ

ํ† ํด๋กœ์ง€1. Marking ์‚ฌ์šฉ ์˜ˆ์‹œ

โ‘  โ‘ก : 802.1Q TAG์˜ CoS ํ•„๋“œ๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.
โ‘ข : Serial์€ Ethernet ๋ฐฉ์‹์ด ์•„๋‹Œ RS232C, RS422A, RS485 ๋ฐฉ์‹์„ ์‚ฌ์šฉํ•œ๋‹ค. ๊ทธ๋ž˜์„œ IPํ—ค๋”์˜ IP Precedence๋‚˜ DSCP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.
โ‘ฃ : Access ํฌํŠธ๋Š” ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์—†์–ด์„œ IPํ—ค๋”์˜ IP Precedence๋‚˜ DSCP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.
โ‘ค : 802.1Q TAG์˜ CoS ํ•„๋“œ๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.


4. Congestion Avoidance -ํ˜ผ์žก ํšŒํ”ผ

ํ”„๋ ˆ์ž„์„ ์ž„์‹œ ์ €์žฅํ•  ํ๊ฐ€ ๊ฐ€๋“ ์ฐจ ์žˆ๋Š” ์ƒํƒœ๋ฅผ ํ˜ผ์žก์ด๋ผ๊ณ  ํ‘œํ˜„ํ•œ ๊ฒƒ ๊ฐ™๋‹ค. ํ๊ฐ€ ๊ฐ€๋“ ์ฐจ์žˆ๋Š” ์ƒํƒœ์—์„œ ํ”„๋ ˆ์ž„์„ ํ๊ธฐํ•˜๋Š” ๊ฒƒ์„ ํ˜ผ์žก ํšŒํ”ผ๋ผ๊ณ  ํ•œ๋‹ค. ํ˜ผ์žก ํšŒํ”ผ๋Š” ํฌ๊ฒŒ 3๊ฐ€์ง€ ๋ฐฉ๋ฒ•์ด ์žˆ๋‹ค.

TailDrop, WTD, WRED

4-1. TailDrop

๊ฐ„๋‹จํ•˜๋‹ค. ํ๊ฐ€ ๊ฐ€๋“ ์ฐผ์„ ๋•Œ, ์ดํ›„์— ๋„์ฐฉํ•˜๋Š” ํŒจํ‚ท๋“ค์„ ๋ชจ์กฐ๋ฆฌ ํ๊ธฐํ•˜๋Š” ๋ฐฉ๋ฒ•์ด๋‹ค.

4-2. WTD

Weighted Tail Drop

CoS / DSCP ๊ฐ’์— ๋”ฐ๋ผ Taildrop์ด ์ผ์–ด๋‚˜๋Š” ์ž„๊ณ„์น˜(Threshold๋ผ๊ณ ๋„ ํ•จ)๋ฅผ ๋‹ค๋ฅด๊ฒŒ ํ•˜์—ฌ ํ๊ธฐํ•˜๋Š” ๋ฐฉ๋ฒ•์ด๋‹ค. UDP๊ฐ€ ๋งŽ์€ ํ™˜๊ฒฝ์—์„œ ์‚ฌ์šฉํ•˜๋ฉด ํ˜ผ์žก ์ œ์–ด์— ์œ ๋ฆฌํ•˜๋‹ค๊ณ  ํ•œ๋‹ค.

4-3. WRED

Weighted Random Early Detection

WRED๋ฅผ ์„ค๋ช…ํ•˜๊ธฐ ์•ž์„œ ๋จผ์ € ‘Global TCP Synchronization’์— ๋Œ€ํ•ด ์•Œ์•„๋ณด๋„๋ก ํ•˜์ž.


* Global TCP Synchronization์ด๋ž€?
TCP์™€ ๊ฐ™์ด ์‹ ๋ขฐ์„ฑ์ด ํ•„์š”ํ•œ ํ†ต์‹ ์€ ํŒจํ‚ท 1๊ฐœ๋ฅผ ๋ณด๋‚ด๊ณ  Ack๋ฅผ ๋ฐ›์•„์•ผ ๋‹ค์Œ ํŒจํ‚ท์„ ๋ณด๋‚ธ๋‹ค. ํ•˜์ง€๋งŒ ๊ณ„์† ์ด๋ ‡๊ฒŒ ํ†ต์‹ ํ•˜๋ฉด ๋‹น์—ฐํžˆ ํ†ต์‹ ์†๋„๋Š” ๋Š๋ ค์งˆ ๊ฒƒ์ด๋‹ค.
์ด ๋ฌธ์ œ๋ฅผ ํ•ด๊ฒฐํ•˜๊ณ ์ž ์ƒ๋Œ€ Ack์—†์ด ํ•œ๋ฒˆ์— ๋ณด๋‚ผ ์ˆ˜ ์žˆ๋Š” ํŒจํ‚ท ์ˆ˜๋ฅผ ์ง€์ •ํ•˜๋Š” ‘Window Size’๋ผ๋Š” ๊ฐœ๋…์„ ๋„์ž…ํ–ˆ๋‹ค. ์—๋Ÿฌ๊ฐ€ ์—†๋‹ค๋ฉด Window Size๊ฐ€ ํฐ ๊ฒƒ์ด ์œ ๋ฆฌํ•  ๊ฑฐ๊ณ , ์—๋Ÿฌ๊ฐ€ ๋นˆ๋ฒˆํ•˜๋‹ค๋ฉด Window Size๊ฐ€ ์ž‘์€ ๊ฒƒ์ด ์œ ๋ฆฌํ•  ๊ฒƒ์ด๋‹ค.
ํ•œ ๋ฒˆ์— 1500๊ฐœ TCP ํŒจํ‚ท์„ ๋ณด๋ƒˆ๋Š”๋ฐ ๊ทธ ์ค‘ ์ƒ๋Œ€๊ฐ€ 500๊ฐœ๋ฅผ ๋ชป๋ฐ›์€ ์ƒํ™ฉ์ด ์žˆ๋‹ค๊ณ  ๊ฐ€์ •ํ•ด๋ณด์ž. ์—๋Ÿฌ๊ฐ€ ๋ฐœ์ƒํ•œ ์ƒํ™ฉ์ธ๋ฐ, ์ด๋Ÿด ๋•Œ๋Š” Window Size๋ฅผ ์ค„์—ฌ์„œ ํŒจํ‚ท์„ ๋ณด๋‚ธ๋‹ค. ํ•œ๋ฒˆ์— ๋ณด๋‚ด๋Š” ํŒจํ‚ท๋Ÿ‰์ด ์ ์–ด์ง€๋‹ˆ ํ†ต์‹  ์†๋„๋„ ๋‚ฎ์•„์งˆ ๊ฒƒ์ด๋‹ค. ์ด ์ƒํ™ฉ์—์„œ ๋งŒ์•ฝ PC๊ฐ€ ์—ฌ๋Ÿฌ ๋Œ€ ์žˆ๋‹ค๋ฉด..? ์—ฌ๋Ÿฌ ๋Œ€์˜ PC๊ฐ€ ์ƒ๋Œ€์—๊ฒŒ ์ง€๊ธˆ ์—๋Ÿฌ๋‚ฌ์œผ๋‹ˆ ์žฌ์ „์†ก ์š”์ฒญ์„ ํ•  ๊ฒƒ์ด๋‹ค. ์ด๋ฏธ ์—๋Ÿฌ๊ฐ€ ๋ฐœ์ƒํ•œ ์ƒํ™ฉ์ด๋ฏ€๋กœ ์ƒ๋Œ€๊ฐ€ Window Size๋ฅผ ์ค„์—ฌ์„œ ์žฌ์ „์†กํ•œ๋‹ค. ๊ฒฐ๊ณผ์ ์œผ๋กœ ์ „์ฒด ํŒจํ‚ท ์ˆ˜๊ฐ€ ์ค„์–ด๋“ค๊ณ  ๋งํฌ ์‚ฌ์šฉ๋ฅ ๋„ ๋‚ฎ์•„์งˆ ๊ฒƒ์ด๋‹ค.
์ด๋ ‡๊ฒŒ ๋™์‹œ์— TCP Window Size ๋ฐ”๊พธ๋Š” ๊ฒƒ์„ ‘Global TCP synchronization’์ด๋ผ๊ณ  ํ•œ๋‹ค.


WRED๋Š” Global TCP Synchronization์„ ๋ฐฉ์ง€ํ•˜๊ธฐ ์œ„ํ•ด TailDrop(์ „์ฒด ์—๋Ÿฌ)๊ฐ€ ๋ฐœ์ƒํ•˜๊ธฐ ์ „ ์ž„์˜์˜ ํŒจํ‚ท์„ ํ๊ธฐํ•œ๋‹ค. ๊ทธ๋ ‡๊ฒŒ ๋˜๋ฉด ํŠน์ • ์žฅ๋น„์—์„œ๋งŒ ์—๋Ÿฌ๊ฐ€ ๋ฐœ์ƒํ•œ๋‹ค๊ณ  ์ธ์‹ํ•˜๊ณ  Window Size๋ฅผ ์ค„์ธ๋‹ค.

์ฆ‰, ๋Œ€์˜๋ฅผ ์œ„ํ•ด ์ผ๋ถ€๋ฅผ ํฌ์ƒํ•œ๋‹ค๊ณ  ์ƒ๊ฐํ•˜๋ฉด ๋  ๊ฒƒ ๊ฐ™๋‹ค.


5. Queueing – ํ์ž‰

ํ”„๋ ˆ์ž„์„ ์ „์†กํ•˜๊ธฐ ์ „ ์ž„์‹œ๋กœ ๋ณด๊ด€ํ•˜๋Š” ์žฅ์†Œ๋ฅผ Queue๋ผ๊ณ  ํ•œ๋‹ค.
๊ทธ๋ฆฌ๊ณ  ์ด Queue๋ฅผ ์ฒ˜๋ฆฌํ•˜๋Š” ๊ฒƒ์„ Queueing์ด๋ผ๊ณ  ํ•œ๋‹ค.

ํ†ต์‹ ์žฅ๋น„๋Š” ์ž…๋ ฅํ/์ถœ๋ ฅํ๋ฅผ ๊ฐ–๊ณ  ์žˆ๋‹ค. (์žฅ๋น„๋งˆ๋‹ค ํ์˜ ๊ฐœ์ˆ˜๊ฐ€ ๋‹ค๋ฅด๋‹ค.)
– ์ž…๋ ฅํ: ํ”„๋ ˆ์ž„ ์ˆ˜์‹  ํ›„ ์ฒ˜๋ฆฌํ•˜๊ธฐ ์ „ ๋ณด๊ด€ํ•˜๋Š” ํ
– ์ถœ๋ ฅํ: ์ฒ˜๋ฆฌ ํ›„ ์™ธ๋ถ€๋กœ ์ „์†กํ•˜๊ธฐ ์ „ ๋ณด๊ด€ํ•˜๋Š” ํ
ํ ์ „์†ก ๋ฐฉ๋ฒ•์— ๋”ฐ๋ผ ํ‘œ์ค€ํ/์šฐ์„ ํ๋กœ ๋‚˜๋ˆˆ๋‹ค. ์šฐ์„ ํ์— ์ €์žฅ๋œ ํ”„๋ ˆ์ž„์ด ๋” ๋จผ์ € ์ „์†ก๋œ๋‹ค.


6. Scheduling – ์Šค์ผ€์ค„๋ง

Queue์— ์ €์žฅ๋œ ํ”„๋ ˆ์ž„์„ ์™ธ๋ถ€๋กœ ์ „์†กํ•œ๋‹ค.
Scheduling ๋ฐฉ์‹์€ ํฌ๊ฒŒ 3๊ฐ€์ง€๋กœ ๋‚˜๋‰œ๋‹ค.

WRR, DWRR, Strict-priority queueing

6-1. WRR

Weighted Round Robin

์ •ํ•ด์ง„ ๋น„์œจ๋Œ€๋กœ ์ฐจ๋ก€์ฐจ๋ก€ ๋Œ์•„๊ฐ€๋ฉฐ ํ”„๋ ˆ์ž„์„ ์ „์†กํ•œ๋‹ค.

6-2. DWRR

Deficit Weighted Round Robin

์ˆœ์„œ(์ฐจ๋ก€)๊ฐ€ ๋˜์–ด๋„ ์ „์†กํ•  ํ”„๋ ˆ์ž„ ํฌ๊ธฐ๋ณด๋‹ค deficit counter ์ž‘์œผ๋ฉด, ํ”„๋ ˆ์ž„์„ ์ „์†กํ•˜์ง€ ์•Š๊ณ  deficit counter๋ฅผ ์ฆ๊ฐ€์‹œํ‚จ ๋’ค ๋‹ค์Œ ์ฐจ๋ก€์— ์ „์†กํ•œ๋‹ค.

6-3. Strict-priority Queueing

์ตœ์šฐ์„  ํ์ž‰

์šฐ์„ ํ์— ์ €์žฅ๋œ ํ”„๋ ˆ์ž„์„ ๋จผ์ € ์ „์†กํ•œ๋‹ค.
๋ณดํ†ต VoIP ํ”„๋ ˆ์ž„์„ ์ตœ์šฐ์„ ํ์ž‰ํ•œ๋‹ค.


7. Switch QoS ์„ค์ •

QoS ์„ค์ •์€ MQC ๊ด€๋ จ ๋ช…๋ น์–ด์™€ mls qos ๊ด€๋ จ ๋ช…๋ น์–ด๊ฐ€ ์žˆ๋‹ค.

7-1. MQC ๊ด€๋ จ ๋ช…๋ น์–ด

Modular QoS CLI

์Šค์œ„์น˜๋‚˜ ๋ผ์šฐํ„ฐ์—์„œ ์‚ฌ์šฉ๋˜๋Š” QoS ๋ช…๋ น์–ด ์ฒด๊ณ„์ด๋‹ค. ์Šค์œ„์น˜์—์„œ๋Š” ์ฃผ๋กœ Marking์ด๋‚˜ Policing์„ ์œ„ํ•ด ์‚ฌ์šฉํ•œ๋‹ค.

– ์„ค์ •4๋‹จ๊ณ„
(1) class-map : QoS ์ž‘์—… ๋Œ€์ƒ ๋ถ„๋ฅ˜
(2) policy-map : QoS ์ •์ฑ… ํ‘œ์‹œ
(3) service-policy : policy-map ์ ์šฉ
(4) show policy-map interface <INTERFACE> : QoS ๋™์ž‘ ํ™•์ธ

7-2. mls qos ๊ด€๋ จ ๋ช…๋ น์–ด

Queue ๋ณ„ ๋Œ€์—ญํญ ๋น„์œจ, ๊ธธ์ด, ๋งคํ•‘ ๋“ฑ Queue์™€ ๊ด€๋ จ๋œ ์„ค์ •์ด๋‹ค.

DHCP 2: ๋ณด์•ˆ

DHCP์™€ ๊ด€๋ จ๋œ ๋ณด์•ˆ์— ๋Œ€ํ•ด์„œ ์•Œ์•„๋ณด๋„๋ก ํ•˜์ž.

1. DHCP Snooping
2. IP Source Guard
3. Dynamic ARP Inspection


1. DHCP Snooping

์ผ๋ฐ˜์ ์œผ๋กœ DHCP์™€ ๊ด€๋ จ๋œ ๊ณต๊ฒฉ์œผ๋กœ
โ‘  ๊ณต๊ฒฉ์ž๊ฐ€ DHCP ์„œ๋ฒ„ ํ–‰์„ธ ๋ฐ ํด๋ผ์ด์–ธํŠธ๋“ค์ด ๊ณต๊ฒฉ์ž์™€ ํ†ต์‹ ํ•˜๋Š” ๊ฒƒ โ‘ก ๊ณต๊ฒฉ์ž๊ฐ€ ํ• ๋‹นํ•  ์ˆ˜ ์žˆ๋Š” IP๋ฅผ ๋ชจ๋‘ ๋ฐ›์•„๊ฐ€์„œ ๋‹ค๋ฅธ ํด๋ผ์ด์–ธํŠธ๋“ค์ด IPํ• ๋‹น์„ ๋ฐ›์ง€ ๋ชปํ•˜๊ฒŒ ํ•˜๋Š” ๊ฒƒ
์ด ๋‘ ๊ฐ€์ง€๊ฐ€ ์žˆ๋‹ค. 

์ด๋Ÿฐ ์œ ํ˜•์˜ ๊ณต๊ฒฉ์„ ๋ฐฉ์ง€ํ•˜๋Š” ๊ธฐ์ˆ ์ด DHCP Snooping์ด๋‹ค.

1-1. DHCP Snooping ๋™์ž‘ ๋ฐฉ์‹

DHCP ์„œ๋ฒ„ ํ˜น์€ DHCP ๋ฆด๋ ˆ์ด ์„œ๋ฒ„๊ฐ€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ๋ฅผ ‘Trusted’๋กœ ์ง€์ •ํ•˜๊ณ , ํด๋ผ์ด์–ธํŠธ๊ฐ€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ๋ฅผ ‘Untrusted’๋กœ ์ง€์ •ํ•œ๋‹ค.

Trusted ํฌํŠธ์—์„œ ์ˆ˜์‹ ํ•œ DHCP ๋ฉ”์„ธ์ง€๋Š” ๋ณ„๋„๋กœ ํ™•์ธ์„ ํ•˜์ง€ ์•Š๊ณ ,
Untrusted ํฌํŠธ์—์„œ ์ˆ˜์‹ ํ•œ DHCP ์„œ๋ฒ„์˜ ๋ฉ”์„ธ์ง€, DHCP ๋ฆด๋ ˆ์ด ์„œ๋ฒ„์˜ ๋ฉ”์„ธ์ง€๋Š” ์ฐจ๋‹จํ•œ๋‹ค.
๋˜ํ•œ, Ethernet ํ”„๋ ˆ์ž„์˜ MAC ์ฃผ์†Œ์™€ DHCP ๋ฉ”์„ธ์ง€์˜ Client Hardware ์ฃผ์†Œ๊ฐ€ ๋‹ค๋ฅด๋ฉด ์ฐจ๋‹จํ•œ๋‹ค.

1-2. DHCP Snooping ๋™์ž‘ ๊ณผ์ •

ํ† ํด๋กœ์ง€1. DHCP Snooping

– DHCP ์„œ๋ฒ„์™€ ์—ฐ๊ฒฐ๋œ F0/3 : Trusted Port
– ์ด์™ธ ๋‚˜๋จธ์ง€ ์ธํ„ฐํŽ˜์ด์Šค : Untrusted Port

1-3. DHCP Snooping ์„ค์ •

Switch(config)# ip dhcp snooping
Switch(config)# ip dhcp snooping <INTERFACE>
Switch(config)# 
Switch(config)# int <interface>
Switch(config-if)# ip dhcp snooping trust

# DHCP Snooping Binding Table ํ™•์ธ
Switch# show ip dhcp snooping binding

2. IP Source Guard

๊ณต๊ฒฉ์ž๊ฐ€ Source IP๋ฅผ ์†์—ฌ ํ†ต์‹ ํ•˜๋Š” ๊ฒƒ์„ ์ฐจ๋‹จํ•œ๋‹ค. L2 ์žฅ๋น„์—์„œ ์‚ฌ์šฉํ•œ๋‹ค. DHCP Snooping๊ณผ ๋™์‹œ์— ์‚ฌ์šฉํ•œ๋‹ค.

* IP Spoofing = ๋‚จ์˜ IP๋ฅผ ์ž์‹ ์˜ ๊ฒƒ์ฒ˜๋Ÿผ ์†์ด๋Š” ํ–‰์œ„.

ํ† ํด๋กœ์ง€2. IP Spoofing ๋™์ž‘ ๋ฐฉ์‹

2-1. IP Source Guard ๋™์ž‘ ๋ฐฉ์‹

โ‘  ๊ณต๊ฒฉ์ž๊ฐ€ PING ํŒจํ‚ท์„ ์Šค์œ„์น˜๋กœ ์ „์†กํ•œ๋‹ค.

โ‘ก ํŒจํ‚ท์„ ๋ฐ›์€ PC๋Š” ๋ชฉํ‘œ ๋Œ€์ƒ์œผ๋กœ ์‘๋‹ตํ•œ๋‹ค.

ํ•˜์ง€๋งŒ IP Source Guard๋ฅผ ์‚ฌ์šฉํ•˜๋ฉด,  โ‘  ์ดํ›„ ์Šค์œ„์น˜๊ฐ€ DHCP Binding Table์™€ ๋น„๊ตํ•œ๋‹ค.(IP Source Binding์œผ๋กœ ๋น„๊ตํ•  ์ˆ˜๋„ ์žˆ๋‹ค.) 
๋น„๊ต ํ›„ ์ˆ˜์‹ ํ•œ ํ”„๋ ˆ์ž„์˜ ์ถœ๋ฐœ์ง€ IP๊ฐ€ ๋‹ค๋ฅด๋‹ค๋ฉด, ํ•ด๋‹น ํŒจํ‚ท์„ ์ฐจ๋‹จํ•œ๋‹ค.

2-2. IP Source Guard ์„ค์ •

[์„ค์ •]
๊ธฐ๋ณธ์œผ๋กœ DHCP Snooping ์„ค์ •์ด ๋˜์–ด ์žˆ์–ด์•ผ ํ•œ๋‹ค.

Switch(config)# int <interface>
Switch(config-if)# ip verify source

#IP Source Binding Table
Switch# show ip verify source

[IP Source Binding ์„ค์ •]

Switch(config)# ip source binding <MAC> <VLAN> <IP> <INTERFACE>

3. Dynamic ARP Inspection ; DAI

ARP Spoofing์„ ์ฐจ๋‹จํ•˜๊ธฐ ์œ„ํ•ด DAI๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.

3-1.  ARP Spoofing์ด๋ž€?

๊ณต๊ฒฉ์ž๊ฐ€ ARP ํŒจํ‚ท์„ ๋ณด๋‚ผ ๋•Œ, ์ž์‹ ์˜ MAC ์ฃผ์†Œ๋ฅผ GW๋‚˜ Server ๋“ฑ์˜ MAC ์ฃผ์†Œ๋กœ ์†์—ฌ์„œ ๋ณด๋‚ธ๋‹ค. ๊ทธ๋ฆฌ๊ณ  GW๋กœ๋Š” ์ž์‹ ์ด Host, Server๋ผ๊ณ  ๊ด‘๊ณ ํ•œ๋‹ค.  ์ด๋ ‡๊ฒŒ ๋˜๋ฉด ๊ฒฐ๊ตญ ๋ชจ๋“  ๋ฐ์ดํ„ฐ๋Š” ๊ณต๊ฒฉ์ž๋ฅผ ๊ฑฐ์น˜๊ฒŒ ๋  ๊ฒƒ์ด๋‹ค.

ํŠนํžˆ๋‚˜, ARP๋Š” ๊ฐ€์žฅ ๋งˆ์ง€๋ง‰์— ๋“ค์–ด์˜จ ์ •๋ณด๋ฅผ ์‚ฌ์šฉํ•˜๊ธฐ ๋•Œ๋ฌธ์— ์ฃผ๊ธฐ์ ์œผ๋กœ ์ด๋Ÿฐ ์‹์œผ๋กœ ARP ๊ด‘๊ณ ๋ฅผ ํ•œ๋‹ค๋ฉด ๋‚ด๋ถ€ ํ˜ธ์ŠคํŠธ๋“ค์€ ๊ณต๊ฒฉ์ž์˜ MAC์ฃผ์†Œ๊ฐ€ GW๋‚˜ ์„œ๋ฒ„์˜ MAC ์ฃผ์†Œ์ธ ์ค„ ์•Œ๊ฒŒ ๋˜๋ฏ€๋กœ ์œ„ํ—˜ํ•˜๋‹ค.

์ด๋Ÿฐ ํŒจํ‚ท์„ ์ฐจ๋‹จํ•˜๊ธฐ ์œ„ํ•ด DAI๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.


3-2. Dynamic ARP Inspection ๋™์ž‘ ๋ฐฉ์‹

DAI๊ฐ€ ๋™์ž‘ํ•˜๋ฉด ๋ชจ๋“  ARP ์š”์ฒญ/์‘๋‹ต ํŒจํ‚ท์„ ๊ฒ€์‚ฌํ•˜๊ฒŒ ๋œ๋‹ค.
์Šค์œ„์น˜๊ฐ€ ์ˆ˜์‹ ํ•œ ARP ํ”„๋ ˆ์ž„๊ณผ DHCP Binding Table ๋˜๋Š” ARP ACL์ด ์ผ์น˜ํ•ด์•ผ ํ”„๋ ˆ์ž„์„ ์ „์†กํ•œ๋‹ค.

3-3. Dynamic ARP Inspection ์„ค์ •

[์„ค์ •]
DAI๊ฐ€ ๋™์ž‘ํ•˜๊ธฐ ์œ„ํ•ด์„  DHCP Snooping์ด ๋™์ž‘ํ•ด์•ผ ํ•œ๋‹ค.

Switch(config)# ip dhcp snooping
Switch(config)# ip dhcp snooping <VLAN>
Switch(config)# ip arp inspection <VLAN>
Switch(config)# 
Switch(config)# int <INTERFACE>
Switch(config-if)# ip dhcp snooping trust
Switch(config-if)# ip arp inspection trust

[ARP ACL ์„ค์ •]

Switch(config)# arp access-list <NAME>
Switch(config-arp-nacl)# permit ip <SOURCE> mac <DESTINATION>
Switch(config-arp-nacl)# exit
Switch(config)# 
Switch(config)# ip arp inspection filter <NAME> <VLAN>

DHCP 1: ๊ฐœ๋…

Dynamic Host Configuration Protocol

๋™์  ํ˜ธ์ŠคํŠธ ์„ค์ • ํ”„๋กœํ† ์ฝœ.
๋ง ๊ทธ๋Œ€๋กœ ๋™์ ์œผ๋กœ ํ˜ธ์ŠคํŠธ IP๋ฅผ ๋ถ€์—ฌํ•˜๊ณ  ๊ด€๋ฆฌํ•˜๋Š” ํ”„๋กœํ† ์ฝœ.

1. DHCP ๋™์ž‘๊ณผ์ •
2. DHCP Relay Agent


1. DHCP ๋™์ž‘๊ณผ์ •

โ‘  PC๋Š” DHCP ์„œ๋ฒ„๋ฅผ ์ฐพ๊ธฐ ์œ„ํ•ด DHCP DISCOVER ๋ฉ”์„ธ์ง€๋ฅผ Broadcastํ•œ๋‹ค.
– ์ถœ๋ฐœ์ง€: 0.0.0.0
– ๋ชฉ์ ์ง€: 255.255.255.255 / udp 67
– ๋ณธ์ธ์˜ MAC์ฃผ์†Œ๋ฅผ ํฌํ•จํ•˜์—ฌ ๋ณด๋‚ธ๋‹ค. 

โ‘ก DHCP ์„œ๋ฒ„๋Š” IP๋ฅผ ์ œ์•ˆํ•˜๊ธฐ ์œ„ํ•ด DHCP OFFER ๋ฉ”์„ธ์ง€๋ฅผ Broadcastํ•œ๋‹ค.
– ์ถœ๋ฐœ์ง€: DHCP ์„œ๋ฒ„์˜ IP
– ๋ชฉ์ ์ง€: 255.255.255.255
– ํด๋ผ์ด์–ธํŠธ์—์„œ ์‚ฌ์šฉํ•  IP, Subnet, GW, DNS, IP ์ž„๋Œ€ ์‹œ๊ฐ„, ๊ทธ๋ฆฌ๊ณ  ํด๋ผ์ด์–ธํŠธ์˜ MAC์„ ํฌํ•จํ•˜์—ฌ ๋ณด๋‚ธ๋‹ค.

โ‘ข PC๋Š” OFFER ๋ฉ”์„ธ์ง€๋กœ ๋ฐ›์€ ์ •๋ณด๋ฅผ ์‚ฌ์šฉํ•˜๊ธฐ ์œ„ํ•ด DHCP REQUEST ๋ฉ”์„ธ์ง€๋ฅผ Broadcastํ•œ๋‹ค.
– ์ถœ๋ฐœ์ง€: 0.0.0.0
– ๋ชฉ์ ์ง€: 255.255.255.255
– ์„œ๋ฒ„ IP๋ฅผ ์•Œ์•„๋„ Broadcast๋กœ ๋ณด๋‚ด๋Š” ์ด์œ ๋Š” ๋‹ค๋ฅธ DHCP์„œ๋ฒ„์—๊ฒŒ ์•Œ๋ฆฌ๊ธฐ ์œ„ํ•จ์ด๋‹ค.

โ‘ฃ ์„œ๋ฒ„๊ฐ€ ํด๋ผ์ด์–ธํŠธ์˜ ์š”์ฒญ์„ ์ˆ˜๋ฝํ•˜๊ธฐ ์œ„ํ•ด DHCP ACK๋ฅผ Broadcastํ•œ๋‹ค.
– ์ถœ๋ฐœ์ง€: DHCP ์„œ๋ฒ„์˜ IP
– ๋ชฉ์ ์ง€: 255.255.255.255


2. DHCP Relay Agent

DHCP ์„œ๋ฒ„๊ฐ€ ํ•ญ์ƒ ๊ฐ™์€ ๋ง์— ์†ํ•ด์žˆ์œผ๋ฆฌ๋ž€ ๋ณด์žฅ์€ ์—†๋‹ค.
์„œ๋กœ ๋‹ค๋ฅธ ๋ง์ด๋ผ๋ฉด L3์žฅ๋น„์—์„œ Relay Agent๋ฅผ ์„ค์ •ํ•ด์•ผํ•œ๋‹ค.

[ DHCP ์„œ๋ฒ„๊ฐ€ 1๋Œ€์ธ ๊ฒฝ์šฐ]

Router(config)# service dhcp
Router(config)# int <INTERFACE_CONNECTD_BY_CLIENT>
Router(config-if)# ip helper-address <DHCP_SERVER_IP>
๏ปฟ

[ DHCP ์„œ๋ฒ„๊ฐ€ ์—ฌ๋Ÿฌ๋Œ€์ธ ๊ฒฝ์šฐ ]

#์ˆ˜๋™์œผ๋กœ ์„œ๋ฒ„ ์ง€์ •
Router(config)# int <INTERFACE_CONNECTD_BY_CLIENT>
Router(config-if)# ip helper-address <DHCP_SERVER_IP_1>
Router(config-if)# ip helper-address <DHCP_SERVER_IP_2>

#์ž๋™์œผ๋กœ ์„œ๋ฒ„ ์ง€์ •
Router(config)# ip helper-address <DHCP_BROADCAST_IP>
Router(config)# int <INTERFACE_CONNECTD_BY_CLIENT>
Router(config-if)# ip directed-broadcast

[Switch] VLAN Hopping Attack

์„œ๋กœ ๋‹ค๋ฅธ VLAN์˜ ํ˜ธ์ŠคํŠธ๋“ค๋ผ๋ฆฌ ํ†ต์‹ ํ•˜๋ ค๋ฉด, L3 ์žฅ๋น„๋ฅผ ๊ฑฐ์ณ์„œ ํ†ต์‹ ํ•ด์•ผํ•œ๋‹ค. ๊ทธ๋Ÿฌ๋‚˜, ๋‹ค๋ฅธ VLAN์— ์†ํ•œ ๋Œ€์ƒ์„ ๊ณต๊ฒฉํ•  ๋•Œ, L3 ์žฅ๋น„๋ฅผ ๊ฑฐ์น˜์ง€ ์•Š๊ณ  ๊ณต๊ฒฉํ•˜๋Š” ๊ฒƒ์„ VLAN Hopping Attack์ด๋ผ๊ณ  ํ•œ๋‹ค.

์•„๋ž˜ ํ† ํด๋กœ์ง€๋ฅผ ๋ณด๊ณ  ์–ด๋–ป๊ฒŒ Hopping Attack์ด ์ง„ํ–‰๋˜๋Š”์ง€ ๋ณด์ž.

ํ† ํด๋กœ์ง€ 1. VLAN Hopping Attack

[ํ˜„์žฌ ํ† ํด๋กœ์ง€ ๊ตฌ์„ฑ ์ƒํƒœ]
(1) ํ˜„์žฌ ๊ด€๋ฆฌ์ž๊ฐ€ PC์™€ ์—ฐ๊ฒฐ๋œ SW2์˜ ํฌํŠธ๋ฅผ ์„ค์ •ํ•  ๋•Œ,
‘switchport access vlan 20’๋งŒ ์„ค์ •ํ•œ ์ƒํ™ฉ.
(2) ‘switchport mode access’๋ฅผ ๋ˆ„๋ฝํ–ˆ๊ณ , native vlan ๋„ 1์ธ ์ƒํ™ฉ์ด๋‹ค.

์ด ์ƒํƒœ๋ผ๋ฉด ๊ณต๊ฒฉ์ž๋Š” DTP ํ”„๋ ˆ์ž„์„ ์ด์šฉํ•ด SW2-๊ณต๊ฒฉ์ž PC์˜ mode๋ฅผ Trunk๋กœ ๋ณ€๊ฒฝํ•  ์ˆ˜ ์žˆ๊ฒŒ ๋œ๋‹ค.


โ‘  TrunkํฌํŠธ๋กœ ๋ณ€๊ฒฝํ•˜๊ณ , Data๋ฅผ ๋ณด๋‚ธ๋‹ค.

SW2—–๊ณต๊ฒฉ์ž์˜ Port mode๊ฐ€ Trunk๋กœ ๋ณ€๊ฒฝ๋˜๊ณ ,

๊ณต๊ฒฉ์ž๋Š” SW2๋กœ ํŒจํ‚ท์„ ๋ณด๋‚ธ๋‹ค.
( Vlan 1 Tag | Vlan 10 Tag | ๊ณต๊ฒฉ Data )

SW2์˜ Native VLAN์ด 1 ์ด๋ฏ€๋กœ
VLAN 1 TAG๋ฅผ ์ œ๊ฑฐ ํ›„ SW1๋กœ ์ „๋‹ฌํ•œ๋‹ค.

โ‘ก VLAN 1 TAG๋ฅผ ์ œ๊ฑฐ ํ›„ SW1๋กœ ๋ฐ์ดํ„ฐ๋ฅผ ์ „์†กํ•œ๋‹ค.

SW1์€ ํŒจํ‚ท์˜ VLAN 10 TAG๋ฅผ ๋ณด๊ณ , VLAN 10์— ์†ํ•œ PC1์—๊ฒŒ ํŒจํ‚ท์„ ์ „๋‹ฌํ•œ๋‹ค.
์ด๋ ‡๊ฒŒ ๊ณต๊ฒฉ์ž์˜ ํŒจํ‚ท์€ ๋ฌดํƒˆํžˆ PC1๋กœ ์ „์†ก๋˜์—ˆ๋‹ค.

๊ทธ๋ ‡๋‹ค๋ฉด, ์ด๋Ÿฐ ๊ณต๊ฒฉ์„ ๋ง‰์„ ์ˆ˜ ์žˆ๋Š” ๋ฐฉ๋ฒ•์€ ๋ฌด์—‡์ผ๊นŒ?
๋‹น์—ฐํ•˜๊ฒŒ๋„ ์ด๋ฏธ ๋ฐฉ๋ฒ•์€ ๋‚˜์™€์žˆ๋‹ค.

โ‘ Trunking์„ ์‚ฌ์šฉํ•˜์ง€ ์•Š๋Š” ํฌํŠธ๋Š” ๋ฐ˜๋“œ์‹œ Access๋กœ ์„ค์ •ํ•ด์ฃผ๊ณ ,
โ‘กNative VLAN์€ ๋ฐ˜๋“œ์‹œ ๋‹ค๋ฅธ ๋ฒˆํ˜ธ๋กœ ๋ณ€๊ฒฝํ•˜๋Š” ๊ฒƒ์ด๋‹ค.

[Switch] ํฌํŠธ ํŠธ๋ž˜ํ”ฝ ์ œ์–ด

์Šค์œ„์น˜ ๋ณด์•ˆ ์ค‘ ํŠธ๋ž˜ํ”ฝ์˜ ์ถœ๋ฐœ์ง€๋ฅผ ๋ณด๊ณ  ์ฐจ๋‹จํ•˜๋Š” ๋ฐฉ๋ฒ•๋งŒ ์žˆ๋Š” ๊ฒƒ์ด ์•„๋‹ˆ๋‹ค. ํŠธ๋ž˜ํ”ฝ์˜ ์ข…๋ฅ˜, ํŠธ๋ž˜ํ”ฝ์˜ ์–‘์— ๋”ฐ๋ผ ์ฐจ๋‹จํ•˜๋Š” ๋ฐฉ๋ฒ•๋„ ์žˆ๋‹ค. ๋ฐ”๋กœ ํฌํŠธ ํŠธ๋ž˜ํ”ฝ์„ ์ œ์–ดํ•˜๋Š” ๊ฒƒ์ด๋‹ค. ํฌํŠธ ํŠธ๋ž˜ํ”ฝ์— ๋Œ€ํ•ด ์•Œ์•„๋ณด์ž.

  1. Storm Control
  2. Protected Port
  3. Port Blocking

ํ† ํด๋กœ์ง€1. ํฌํŠธ ํŠธ๋ž˜ํ”ฝ ์ œ์–ด

1. Storm Control (๊ณผ๋‹ค ํŠธ๋ž˜ํ”ฝ ์ œ์–ด)

์Šค์œ„์น˜์˜ ํฌํŠธ๋กœ Unicast / Multicast / Broadcast ํŠธ๋ž˜ํ”ฝ์ด 1์ดˆ ๋™์•ˆ ์‚ฌ์šฉ์ž๊ฐ€ ์„ค์ •ํ•œ ์ˆ˜์ค€ ์ด์ƒ์œผ๋กœ ๋งŽ์ด ์ˆ˜์‹ ๋˜์—ˆ์„ ๋•Œ, ํ•ด๋‹น ํŠธ๋ž˜ํ”ฝ์„ ๋ชจ๋‘ ์ฐจ๋‹จํ•œ๋‹ค.

์„ค์ •

์˜ˆ๋ฅผ ๋“ค์–ด, SW2์˜ F0/3์—์„œ Broadcast ํŒจํ‚ท์ด ๋Œ€์—ญํญ์˜ 25% ์ด์ƒ์„ ์ฐจ์ง€ํ•  ๊ฒฝ์šฐ ์ฐจ๋‹จํ•˜๋Š” ๊ฒƒ์„ ์„ค์ •ํ•ด๋ณด์ž.

SW2(config)# int fa0/3
SW2(config-if)# storm-control broadcast level 25

3: broadcast ๋Œ€์‹  unicast, multicast๋กœ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค. level 25๋Š” ๋Œ€์—ญํญ์˜ 25%๋ฅผ ์˜๋ฏธํ•˜๋ฏ€๋กœ ์ ์ ˆํ•œ ๊ฐ’์œผ๋กœ ๋ณ€๊ฒฝํ•˜์—ฌ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค.


2. Protected Port (๋ฐฉ์–ด ํฌํŠธ)

ํ•˜๋‚˜์˜ ์Šค์œ„์น˜์—์„œ Protected Port๋กœ ์„ค์ •๋œ ํฌํŠธ๋ผ๋ฆฌ Unicast / Multicast / Broadcast๋ฅผ ์ฐจ๋‹จํ•œ๋‹ค. ์„œ๋กœ ๋‹ค๋ฅธ ์Šค์œ„์น˜์˜ Protected Port๋ผ๋ฆฌ๋Š” ์ •์ƒ์ ์œผ๋กœ ํŠธ๋ž˜ํ”ฝ์„ ์ฃผ๊ณ  ๋ฐ›๋Š”๋‹ค.
(๋‹จ, ๋ชฉ์ ์ง€๊ฐ€ ์—†๋Š” ํ”„๋ ˆ์ž„์€ Flooding ๋œ๋‹ค.)
Protected Port๋กœ ์„ค์ •๋˜์ง€ ์•Š์€ ํฌํŠธ์™€๋Š” ์ •์ƒ์ ์œผ๋กœ ํŠธ๋ž˜ํ”ฝ์„ ์ฃผ๊ณ  ๋ฐ›์„ ์ˆ˜ ์žˆ๋‹ค.

์„ค์ •

SW2์˜ F0/2, F0/3์„ Protected Port๋กœ ์„ค์ •ํ•ด๋ณด์ž.

SW2(config)# int ran fa0/2 - 3
SW2(config-if)# switchport protected

์ด์ œ PC1๊ณผ PC2๋ฅผ PING ํ…Œ์ŠคํŠธํ•ด๋ณด๋ฉด ์‘๋‹ต์ด ์—†๋Š” ๊ฒƒ์„ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.
PC1 – PC3, PC2 – PC3 ๊ฐ„์˜ PING์€ ์ •์ƒ์ ์œผ๋กœ ๋‚˜๊ฐ„๋‹ค.


3. Port Blocking (ํฌํŠธ ์ฐจ๋‹จ)

์Šค์œ„์น˜๊ฐ€ ์ˆ˜์‹ ํ•œ ํ”„๋ ˆ์ž„์˜ ๋ชฉ์ ์ง€๊ฐ€ MAC Table์— ์—†๋‹ค๋ฉด, Flooding ๋˜๋Š” ๊ฒƒ์„ ์ฐจ๋‹จํ•œ๋‹ค. Unicast / Multicast ํŒจํ‚ท์—๋งŒ ์ ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค.

์„ค์ •

SW2์˜ F0/4์— ๋ชฉ์ ์ง€๊ฐ€ ์—†๋Š” Multicast ํ”„๋ ˆ์ž„์„ ์ฐจ๋‹จํ•˜๋„๋ก ์„ค์ •ํ•ด๋ณด์ž.

SW2(config)# int fa0/4
SW2(config-if)# switchport block multicast

3: multicast ๋Œ€์‹  unicast๋ฅผ ์‚ฌ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค.