musketo์˜ ๋ชจ๋“  ๊ธ€

์—ญ์ˆœ ์ฃผ์†Œ ๊ฒฐ์ •, ๊ทธ๋ฆฌ๊ณ  RARP

Reverse Address Resolution Protocol, RFC 903

ARP์™€๋Š” ๋ฐ˜๋Œ€๋กœ 2๊ณ„์ธต ์ฃผ์†Œ๋ฅผ ์ด์šฉํ•ด 3๊ณ„์ธต ์ฃผ์†Œ๋ฅผ ์–ป๋Š” ๋ฐฉ๋ฒ•์ด๋‹ค.

๊ทธ ๋ง์ธ ์ฆ‰์Šจ, ์ฒ˜์Œ์—” IP์ฃผ์†Œ ์—†์ด MAC์ฃผ์†Œ๋กœ๋งŒ ํ†ต์‹ ์„ ํ•œ๋‹ค๋Š”๊ฑด๋ฐ.. TCP/IP ํ†ต์‹ ์— ํ•„์š”ํ•œ IP์ฃผ์†Œ๋ฅผ ์–ป๊ธฐ ์œ„ํ•ด TCP/IP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค๋Š” ๋ชจ์ˆœ์ด ์ƒ๊ธด๋‹ค.

ํ•˜์ง€๋งŒ IP์ฃผ์†Œ๋ฅผ ๋ชจ๋ฅด๋Š” ๊ฒฝ์šฐ์—๋„ ๋กœ์ปฌ ํ†ต์‹ ์ด ๋ฐœ์ƒ๋˜๋„๋ก ๋ธŒ๋กœ๋“œ์บ์ŠคํŠธ๋ฅผ ์ด์šฉํ•˜๋ฉด ๊ฐ€๋Šฅํ•œ ์ผ์ด๊ณ , ์ด๊ฒƒ์„ ‘๋ถ€ํŠธ์ŠคํŠธ๋ž˜ํ•‘’์ด๋ผ๊ณ  ํ•œ๋‹ค.

์ผ๋ฐ˜์ ์œผ๋กœ ๋Œ€๋ถ€๋ถ„ ์žฅ๋น„์—๋Š” ์ž์‹ ์˜ ๋‚ด๋ถ€ ์–ด๋”˜๊ฐ€์— IP์ฃผ์†Œ๋ฅผ ์ €์žฅํ•ด๋†“๋Š”๋‹ค. ํ•˜์ง€๋งŒ ๋ช‡ ๋ช‡ ์žฅ๋น„๋“ค์€ IP์ฃผ์†Œ๋ฅผ ์ €์žฅํ•˜๊ณ  ์ฝ์–ด์˜ค๋Š” ์ˆ˜๋‹จ์ด ์•„์˜ˆ ์—†๊ธฐ๋„ ํ•˜๋‹ค. ์ด๋Ÿฐ ์žฅ๋น„๋“ค์€ ์ž์‹ ์˜ MAC์ฃผ์†Œ๋งŒ ์•Œ๊ณ , IP์ฃผ์†Œ๋ฅผ ๋ชจ๋ฅด๋Š” ์ƒํƒœ๊ฐ€ ๋œ๋‹ค.

๊ธฐ๋ณธ ๋™์ž‘

โ‘  ํŠน์ • ์žฅ๋น„์—์„œ ์ž์‹ ์˜ MAC์ฃผ์†Œ๊ฐ€ ๋‹ด๊ธด ๋ฉ”์‹œ์ง€๋ฅผ ๋ธŒ๋กœ๋“œ์บ์ŠคํŠธ

โ‘ก RARP์„œ๋ฒ„๊ฐ€ ํŠน์ • ์žฅ๋น„์—์„œ ์š”์ฒญํ•œ IP์ฃผ์†Œ๋ฅผ ํ™•์ธ ํ›„ ์œ ๋‹ˆ์บ์ŠคํŠธ

์ƒ์„ธ ๋™์ž‘

RARP Request & Reply

โ‘  ํŠน์ • ์žฅ๋น„๊ฐ€ RARP Request ๋ฉ”์‹œ์ง€ ์ƒ์„ฑ
(OPCODE ํ•„๋“œ: 3, SHA/THA ํ•„๋“œ: ์žฅ๋น„ ์ž์‹ ์˜ MAC์ฃผ์†Œ)

โ‘ก ํŠน์ • ์žฅ๋น„๊ฐ€ RARP Request ๋ฉ”์‹œ์ง€ ๋ธŒ๋กœ๋“œ์บ์ŠคํŠธ

โ‘ข ๋กœ์ปฌ ์žฅ๋น„๊ฐ€ RARP Request ๋ฉ”์‹œ์ง€ ์ฒ˜๋ฆฌ
(RARP ์„œ๋ฒ„๊ฐ€ ์•„๋‹Œ ์žฅ๋น„๋Š” ์ด ๋ฉ”์‹œ์ง€๋ฅผ ๋ฌด์‹œ)

โ‘ฃ RARP ์„œ๋ฒ„๊ฐ€ RARP Reply ๋ฉ”์‹œ์ง€ ์ƒ์„ฑ
(OPCODE ํ•„๋“œ: 4, SHA/SPA ํ•„๋“œ: RARP์„œ๋ฒ„ MAC๊ณผ IP, THA/TPA: ์š”์ฒญ ์žฅ๋น„์˜ MAC๊ณผ IP)

โ‘ค RARP ์„œ๋ฒ„๊ฐ€ RARP Reply ๋ฉ”์‹œ์ง€๋ฅผ ์œ ๋‹ˆ์บ์ŠคํŠธ

โ‘ฅ ํŠน์ • ์žฅ๋น„๊ฐ€ RARP Reply ๋ฉ”์‹œ์ง€๋ฅผ ์ฒ˜๋ฆฌ
(IP ํ™•์ธ)

RARP์˜ ๋ฌธ์ œ์ 

  • RARP ์„œ๋ฒ„์˜ MAC-IP ํ…Œ์ด๋ธ”์€ ์ˆ˜๋™์œผ๋กœ ์ง์ ‘ ์ž…๋ ฅํ•ด์•ผ ํ•œ๋‹ค.
  • RARP ์„œ๋ฒ„๋Š” ํ˜ธ์ŠคํŠธ์—๊ฒŒ ์˜ค์ง IP๋งŒ ์ œ๊ณตํ•œ๋‹ค. ์ด์™ธ ์„œ๋ธŒ๋„ท๋งˆ์Šคํฌ, ๊ฒŒ์ดํŠธ์›จ์ด ์ •๋ณด๋ฅผ ์ œ๊ณตํ•˜์ง€ ์•Š๋Š”๋‹ค.
  • RARP๋ฅผ ๋™์ž‘์‹œํ‚ค๋ ค๋ฉด ๊ฐ ๋„คํŠธ์›Œํฌ๋งˆ๋‹ค RARP ์„œ๋ฒ„๊ฐ€ ์šด์šฉ๋˜์–ด์•ผ ํ•œ๋‹ค.

์ฃผ์†Œ ๊ฒฐ์ •, ๊ทธ๋ฆฌ๊ณ  ARP

๋จผ์ €, OSI 7๊ณ„์ธต์—์„œ ์ฃผ์†Œ๋ฅผ ์ง€์ •ํ•˜๋Š” ๊ณ„์ธต์„ ๋– ์˜ฌ๋ ค๋ณด์ž.
MAC ์ฃผ์†Œ๋ฅผ ์‚ฌ์šฉํ•˜๋Š” DataLink ๊ณ„์ธต (2๊ณ„์ธต)๊ณผ IP ์ฃผ์†Œ๋ฅผ ์‚ฌ์šฉํ•˜๋Š” Network ๊ณ„์ธต (3๊ณ„์ธต)์ด ๋– ์˜ค๋ฅผ ๊ฒƒ์ด๋‹ค.
๊ทธ๋Ÿฐ๋ฐ ์ฃผ์†Œ๋ฅผ ์ง€์ •ํ•˜๋Š” ๊ณ„์ธต์€ ์™œ ํ•œ ๊ณ„์ธต์ด ์•„๋‹Œ ๋‘ ๊ณ„์ธต์ผ๊นŒ?
๋‘ ๊ณ„์ธต์—์„œ ์“ฐ์ด๋Š” ์ฃผ์†Œ์˜ ๋ชฉ์ ๊ณผ ์œ ํ˜•์ด ์„œ๋กœ ๋‹ค๋ฅด๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

์šฐ๋ฆฌ๊ฐ€ ํ†ต์‹ ํ•œ๋‹ค๊ณ  ์–˜๊ธฐํ•  ๋•Œ, ๊ฐœ๋…์ ์œผ๋ก  IP์ฃผ์†Œ(3๊ณ„์ธต)์œผ๋กœ ํ†ต์‹ ํ•œ๋‹ค๊ณ  ํ•˜์ง€๋งŒ, ์‹ค์ œ๋ก  MAC์ฃผ์†Œ(2๊ณ„์ธต)์œผ๋กœ ํ†ต์‹ ์œผ๋กœ ์ˆ˜ํ–‰ํ•œ๋‹ค.
๊ทธ๋ž˜์„œ 3๊ณ„์ธต์— ๋Œ€์‘ํ•˜๋Š” 2๊ณ„์ธต ์ฃผ์†Œ๋ฅผ ๋งคํ•‘ ์‹œ์ผœ์ค˜์•ผํ•˜๋Š”๋ฐ ์ด๊ฒƒ์„ ‘์ฃผ์†Œ๊ฒฐ์ •’์ด๋ผ๊ณ  ํ•œ๋‹ค.

  1. ์ฃผ์†Œ ๊ฒฐ์ • ๋ฐฉ๋ฒ•
  2. ARP
    ๊ธฐ๋ณธ๋™์ž‘
    ์ƒ์„ธ๋™์ž‘
    ARP ๋ฉ”์‹œ์ง€ ํฌ๋งท
    ARP ์บ์‹ฑ
    ํ”„๋ก์‹œ ARP
  3. ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ํ†ต์‹ ์—์„œ์˜ ARP
  4. IPv6์—์„œ์˜ ์ฃผ์†Œ ๊ฒฐ์ •

1. ์ฃผ์†Œ ๊ฒฐ์ • ๋ฐฉ๋ฒ•

(1) ์ง์ ‘ ๋งคํ•‘

– 3๊ณ„์ธต IP ์ฃผ์†Œ <–> 2๊ณ„์ธต MAC ์ฃผ์†Œ๋ฅผ ์ง์ ‘ ๋งคํ•‘ํ•˜๋Š” ๋ฐฉ๋ฒ•์ด๋‹ค.
– 1 ๋Œ€ 1๋กœ ๊ณ ์ •ํ•˜๋ฏ€๋กœ ์œ ์—ฐํ•˜์ง€ ์•Š๋‹ค.
– 3๊ณ„์ธต ์ฃผ์†Œ๊ฐ€ 2๊ณ„์ธต ์ฃผ์†Œ๋ณด๋‹ค ๊ธธ์–ด์•ผ ํ•จ, IP์ฃผ์†Œ 32bit, MAC์ฃผ์†Œ 48bit๋กœ ์‚ฌ์‹ค ์ƒ ์‚ฌ์šฉํ•  ์ˆ˜ ์—†๋‹ค.

(2) ๋™์  ์ฃผ์†Œ ๊ฒฐ์ •

– IP์ฃผ์†Œ๋ฅผ ์•ˆ๋‹ค๋ฉด, ๋‘ ์ฃผ์†Œ์˜ ์œ ํ˜•์ด ๋‹ค๋ฅด๋”๋ผ๋„ MAC์ฃผ์†Œ๋ฅผ ์ฐพ์•„๋‚ผ ์ˆ˜ ์žˆ๋Š” ํ”„๋กœํ† ์ฝœ์„ ์‚ฌ์šฉํ•œ๋‹ค. ์ผ๋ฐ˜์ ์œผ๋กœ ARP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.
– ์ง€์†์ ์ธ ์ฃผ์†Œ ์ž‘์—…์€ ์„ฑ๋Šฅ์— ์˜ํ–ฅ์„ ์ฃผ๋ฏ€๋กœ ์บ์‹ฑ์„ ์‚ฌ์šฉํ•œ๋‹ค. ํ•˜์ง€๋งŒ ์บ์‹ฑ์„ ์‚ฌ์šฉํ•˜๋ฉด ๋ณต์žก๋„๊ฐ€ ์ฆ๊ฐ€ํ•˜๊ณ  ์‹œ๊ฐ„์ด ์ง€๋‚ ์ˆ˜๋ก ์บ์‹ฑ ์ •๋ณด์˜ ์œ ํšจ์„ฑ์ด ๋‚ฎ์•„์ง„๋‹ค.


2. ARP

Address Resolution Protocol , RFC 826

ARP ๊ธฐ๋ณธ๋™์ž‘

โ‘  ์š”์ฒญ
์ฃผ์†Œ ๊ฒฐ์ •์ด ํ•„์š”ํ•œ ์žฅ๋น„์˜ IP ์ฃผ์†Œ๋ฅผ ๋ธŒ๋กœ๋“œ์บ์ŠคํŠธ ๋ฉ”์‹œ์ง€๋กœ ์ „์†ก.
(= MAC์„ ์•Œ๊ณ  ์‹ถ์€ ์žฅ๋น„์˜ IP ๋ฅผ ๋ธŒ๋กœ๋“œ์บ์ŠคํŠธ)

โ‘ก ์‘๋‹ต
ํ•ด๋‹น ์žฅ๋น„๊ฐ€ ์ž์‹ ์˜ MAC์ฃผ์†Œ๋ฅผ ์†ก์‹ ์ž์—๊ฒŒ ์œ ๋‹ˆ์บ์ŠคํŠธ ๋ฉ”์‹œ์ง€๋กœ ์ „์†ก.
(= ํ•ด๋‹น IP๋ฅผ ๊ฐ€์ง„ ์žฅ๋น„๊ฐ€ ์ž์‹ ์˜ MAC์„ ์š”์ฒญ์ž์—๊ฒŒ ์œ ๋‹ˆ์บ์ŠคํŠธ)

ARP ์ƒ์„ธ๋™์ž‘

ARP Request & Reply

โ‘  ์ถœ๋ฐœ์ง€ ์žฅ๋น„์—์„œ ARP ์บ์‹œ ํ™•์ธ
(์บ์‹œ ์ •๋ณด๊ฐ€ ์žˆ์œผ๋ฉด ARP ์บ์‹œ๋ฅผ ํ•œ ๋ฒˆ ๊ฐฑ์‹ , ARP ์š”์ฒญ์€ ๋”ฐ๋กœ ์•ˆํ•จ.)

โ‘ก ์ถœ๋ฐœ์ง€ ์žฅ๋น„์—์„œ ARP Request ๋ฉ”์‹œ์ง€ ์ƒ์„ฑ (SHA,SPA,TPA ํ•„๋“œ๊ฐ’ o)

โ‘ข ์ถœ๋ฐœ์ง€ ์žฅ๋น„์—์„œ ARP Request ๋ฉ”์‹œ์ง€๋ฅผ ๋ธŒ๋กœ๋“œ์บ์ŠคํŠธ

โ‘ฃ ๋กœ์ปฌ ๋„คํŠธ์›Œํฌ์— ์žˆ๋Š” ๊ฐ ์žฅ๋น„์—์„œ ์ƒ๊ธฐ ARP Request ๋ฉ”์‹œ์ง€ ์ฒ˜๋ฆฌ
(์ž์‹ ๊ณผ ๊ด€๋ จ ์—†๋Š” ์ •๋ณด๋Š” ๋ฌด์‹œ, ๊ด€๋ จ ์žˆ๋‹ค๋ฉด โ‘ค๋กœ ์ด๋™)

โ‘ค ๋ชฉ์ ์ง€ ์žฅ๋น„์—์„œ ARP Reply ๋ฉ”์‹œ์ง€ ์ƒ์„ฑ ๋ฐ ARP ์บ์‹œ ๊ฐฑ์‹ 

โ‘ฅ ๋ชฉ์ ์ง€ ์žฅ๋น„์—์„œ ARP Reply ๋ฉ”์‹œ์ง€๋ฅผ ์•„๊นŒ ์š”์ฒญํ•œ ์žฅ๋น„๋กœ ์œ ๋‹ˆ์บ์ŠคํŠธ

โ‘ฆ ์ถœ๋ฐœ์ง€ ์žฅ๋น„์—์„œ ARP Reply ๋ฉ”์‹œ์ง€ ์ฒ˜๋ฆฌ ํ›„ ARP ์บ์‹œ ๊ฐฑ์‹ 

ARP ๋ฉ”์‹œ์ง€ ํฌ๋งท

HRD: ํ•˜๋“œ์›จ์–ด ์œ ํ˜•๊ณผ ์ฃผ์†Œ ์ง€์ • ๋ฐฉ์‹, ์ด๋”๋„ท – 1 / IEEE 802 – 6 / ์ด์™ธ
PRO: ์ด ๋ฉ”์‹œ์ง€์—์„œ ์‚ฌ์šฉํ•˜๋Š” 3๊ณ„์ธต ์ฃผ์†Œ ์œ ํ˜• ์ง€์ •, IPv4 ๋ฐฉ์‹์€ 2048.
HLN: 2๊ณ„์ธต ์ฃผ์†Œ ๊ธธ์ด๋ฅผ ๋ฐ”์ดํŠธ ๋‹จ์œ„๋กœ ํ‘œ์‹œ. ์ผ๋ฐ˜์ ์œผ๋กœ 6.
PLN: 3๊ณ„์ธต ์ฃผ์†Œ ๊ธธ์ด๋ฅผ ๋ฐ”์ดํŠธ ๋‹จ์œ„๋กœ ํ‘œ์‹œ. ์ผ๋ฐ˜์ ์œผ๋กœ 4.
OP: ์ด ๋ฉ”์‹œ์ง€์˜ ๋™์ž‘ ์œ ํ˜• ์ง€์ •, ARP ์š”์ฒญ – 1 / ARP ์‘๋‹ต – 2 / ์ด์™ธ
SHA: ์†ก์‹ ์ž์˜ 2๊ณ„์ธต ์ฃผ์†Œ
SPA: ์†ก์‹ ์ž์˜ 3๊ณ„์ธต ์ฃผ์†Œ
THA: ์ˆ˜์‹ ์ž์˜ 2๊ณ„์ธต ์ฃผ์†Œ
TPA: ์ˆ˜์‹ ์ž์˜ 3๊ณ„์ธต ์ฃผ์†Œ

ARP ์บ์‹ฑ

ARP ๋ฉ”์„ธ์ง€๊ฐ€ ํฌ์ง„ ์•Š์ง€๋งŒ, ๋ชจ๋“  ์žฅ๋น„์—์„œ ARP ๋ฉ”์„ธ์ง€๋ฅผ ๋ณด๋‚ธ๋‹ค๋ฉด ๋„คํŠธ์›Œํฌ์— ๋ถ€ํ•˜๊ฐ€ ๊ฑธ๋ฆด ์ˆ˜ ์žˆ๋‹ค. ๊ทธ๋ž˜์„œ ์ผ๋ฐ˜์ ์œผ๋กœ ‘์บ์‹ฑ’ ๋ฐฉ๋ฒ•์„ ์‚ฌ์šฉํ•œ๋‹ค.

ARP ์บ์‹œ ์•ˆ์—๋Š” MAC์ฃผ์†Œ์™€ IP์ฃผ์†Œ ์ง‘ํ•ฉ์„ ํฌํ•จํ•˜๋Š” ํ…Œ์ด๋ธ”์ด ์žˆ๋‹ค.

ARP ์บ์‹œ ํ…Œ์ด๋ธ”์— ์บ์‹œ ํ•ญ๋ชฉ์„ ์ถ”๊ฐ€ํ•˜๋Š” ๋ฐฉ๋ฒ•์€ ์ •์  ARP ์บ์‹œ ํ•ญ๋ชฉ(์ˆ˜๋™์œผ๋กœ ์ถ”๊ฐ€ํ•˜๋Š” ๋ฐฉ๋ฒ•)๊ณผ ๋™์  ARP ์บ์‹œ ํ•ญ๋ชฉ(์ด์ „์— ์„ฑ๊ณตํ•œ ARP ๊ฒฐ๊ณผ๋ฅผ SW๊ฐ€ ์ž๋™ ์ถ”๊ฐ€ํ•˜๋Š” ๋ฐฉ๋ฒ•)์ด ์žˆ๋‹ค.

  • ์ •์  ARP ์บ์‹œ ํ•ญ๋ชฉ: ๋งŒ๋ฃŒ ๊ธฐ๊ฐ„ ์—†์Œ, ํŠน์ • ์žฅ๋น„์™€ ์ •๊ธฐ์ ์œผ๋กœ ํ†ต์‹ ์ด ํ•„์š”ํ•œ ๊ฒฝ์šฐ์— ์‚ฌ์šฉ.
  • ๋™์  ARP ์บ์‹œ ํ•ญ๋ชฉ: ์ผ๋ฐ˜์ ์ธ ์œ ํšจ๊ธฐ๊ฐ„์€ 10~20๋ถ„, ARP ์š”์ฒญ ํ•  ๋•Œ์™€ ๋ฐ›์„ ๋•Œ ์ถ”๊ฐ€.

ํ”„๋ก์‹œ ARP

ARP Proxy Operation, TCP/IP Guide, P.222

Datalink ๊ณ„์ธต ๊ด€์ ์—์„œ ์„œ๋กœ ๋‹ค๋ฅธ ๋„คํŠธ์›Œํฌ์ง€๋งŒ, Network ๊ณ„์ธต ๊ด€์ ์—์„œ ๋™์ผํ•œ IP๋Œ€์—ญ์ด๋‚˜ ์„œ๋ธŒ๋„คํŠธ์›Œํฌ์— ์กด์žฌํ•˜๋Š” ๊ฒฝ์šฐ ์‚ฌ์šฉํ•œ๋‹ค.
ํ”„๋ก์‹œ ARP๋ฅผ ์‚ฌ์šฉํ•˜๊ฒŒ ๋˜๋ฉด, ๋กœ์ปฌ ๋„คํŠธ์›Œํฌ ์‚ฌ์ด์— ์œ„์น˜ํ•œ ๋ผ์šฐํ„ฐ๊ฐ€ ARP ๋ธŒ๋กœ๋“œ์บ์ŠคํŠธ ์š”์ฒญ์— ์‘๋‹ตํ•˜๊ฒŒ ๋œ๋‹ค.
ํ•˜์ง€๋งŒ ํ”„๋ก์‹ฑ์œผ๋กœ ์ธํ•ด ๋„คํŠธ์›Œํฌ๊ฐ€ ๋ณต์žกํ•ด์ง€๊ณ , ๋ผ์šฐํ„ฐ๊ฐ€ ๋‹ค๋ฅธ ์žฅ๋น„์ธ ์ฒ™ ๊ฐ€์žฅํ•˜๋Š” ๊ฒƒ์ด๋ฏ€๋กœ ์ž ์žฌ์  ๋ณด์•ˆ ์œ„ํ˜‘๋„ ์กด์žฌํ•œ๋‹ค.


3. ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ํ†ต์‹ ์—์„œ์˜ ARP

์ผ๋ฐ˜์ ์ธ ARP ๋™์ž‘ ๋ฐฉ์‹์ฒ˜๋Ÿผ IP ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ๋ฐ์ดํ„ฐ๊ทธ๋žจ์„ ๊ฐ ์œ ๋‹ˆ์บ์ŠคํŠธ ์ „์†ก์œผ๋กœ ๋ณ€ํ™˜ ํ›„ ARP ๊ฐœ๋ณ„๋กœ ๋™์ž‘ํ•˜๋„๋ก ํ•  ์ˆ˜ ์žˆ์œผ๋‚˜, ๋„ˆ๋ฌด ๋น„ํšจ์œจ์ ์ด๋‹ค. ๊ทธ๋ž˜์„œ IP ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ๊ทธ๋ฃน๊ณผ Datalink ๊ณ„์ธต ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ๊ทธ๋ฃน ๊ฐ„ ๋งคํ•‘์„ ์ง์ ‘ ์ •์˜ํ•œ๋‹ค.

Mapping of multicast IP addresses to IEEE 802 multicast MAC addresses, TCP/IP Guide, P.224

์ด ๋•Œ, ๋ฉ€ํ‹ฐ์บ์ŠคํŒ…์šฉ MAC์ฃผ์†Œ๋ฅผ ์ง€์ •ํ•  ๋•Œ์—๋Š” ‘IEEE 802 ์ฃผ์†Œ ์ง€์ • ๋ฐฉ๋ฒ•’์„ ์‚ฌ์šฉํ•œ๋‹ค. 0~24bit๋Š” IANA์—์„œ ์ง€์ •ํ•œ ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ OUI๋ฅผ ์‚ฌ์šฉํ•˜๊ณ , 25๋ฒˆ์งธ bit๋Š” 0, ๋‚˜๋จธ์ง€ 23bit(26~48๋ฒˆ์งธ)๋Š” IP ์ฃผ์†Œ์˜ ํ•˜์œ„ 23bit๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.


4. IPv6์—์„œ์˜ ์ฃผ์†Œ ๊ฒฐ์ •

IPv6์—์„œ ์ฃผ์†Œ๋ฅผ ๊ฒฐ์ •ํ•  ๋•Œ, ARP๊ฐ€ ์•„๋‹Œ ์ฃผ๋ณ€ ND ํ”„๋กœํ† ์ฝœ(์ฃผ๋ณ€ ํƒ์ƒ‰ ํ”„๋กœํ† ์ฝœ)์„ ์‚ฌ์šฉํ•œ๋‹ค.
Neighbor Discovery์˜ ์•ฝ์ž๋กœ ์—ฌ๊ธฐ์„œ Neighbor๋Š” ๋‹จ์ˆœํžˆ LAN ์•ˆ์— ์žˆ๋Š” ์žฅ๋น„๋ฅผ ์ผ์ปซ๋Š”๋‹ค.
๋™์  ์ฃผ์†Œ ๊ฒฐ์ • ๋ฐฉ์‹์ด๋ฉฐ, IPv6-MAC์ฃผ์†Œ ์Œ์œผ๋กœ ๋œ ์บ์‹œ ํ…Œ์ด๋ธ”์„ ์‚ฌ์šฉํ•œ๋‹ค.

๋™์ž‘๋ฐฉ์‹

โ‘  ์ถœ๋ฐœ์ง€ ์žฅ๋น„์—์„œ ND ์ฃผ๋ณ€ ์ •๋ณด ์š”์ฒญ ๋ฉ”์„ธ์ง€ ์ „์†ก

โ‘ก ํ•˜์œ„ Datalink ๊ณ„์ธต ํ”„๋กœํ† ์ฝœ์ด ๋ฉ€ํ‹ฐ์บ์ŠคํŒ…์„ ์ง€์›ํ•˜๋ฉด, ๋ชฉ์ ์ง€ ์žฅ๋น„์˜ ์š”์ฒญ ๋…ธ๋“œ ์ฃผ์†Œ๋กœ ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ์ „์†ก
(*์š”์ฒญ ๋…ธ๋“œ ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ์ฃผ์†Œ: ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ๊ฐ€๋Šฅ ๋„คํŠธ์›Œํฌ์— ์žˆ๋Š” ์žฅ๋น„๊ฐ€ ์œ ๋‹ˆ์บ์ŠคํŠธ ์ฃผ์†Œ๋กœ๋ถ€ํ„ฐ ํŠน์ˆ˜ํ•œ ๋งคํ•‘์„ ํ†ตํ•ด ๋งŒ๋“  ์ฃผ์†Œ)

โ‘ข ๋ชฉ์ ์ง€ ์žฅ๋น„๋Š” ์ฃผ๋ณ€ ์ •๋ณด ์š”์ฒญ์„ ๋ฐ›์€ ๋’ค ์ถœ๋ฐœ์ง€ ์žฅ๋น„์—๊ฒŒ ์ฃผ๋ณ€ ์ •๋ณด ๊ด‘๊ณ ๋กœ ์‘๋‹ต

[MPLS] MPLS VPN ๊ตฌ์ถ•ํ•˜๊ธฐ

* EVE-NG๋ฅผ ์‚ฌ์šฉํ•˜์—ฌ ์ž‘์„ฑ๋˜์—ˆ์Šต๋‹ˆ๋‹ค.
ํ˜น EVE-NG Lab ํŒŒ์ผ์ด ํ•„์š”ํ•˜์‹  ๋ถ„์€ ๋Œ“๊ธ€ ๋‚จ๊ฒจ์ฃผ์„ธ์š”.

  1. ๊ธฐ๋ณธ ํ† ํด๋กœ์ง€ ๊ตฌ์„ฑ
  2. MPLS VPN ์„œ๋น„์Šค๋ง ์„ค์ •
    MPLS ๋ผ์šฐํ„ฐ ๊ฐ„ LDP ์„ค์ •
    PE ๋ผ์šฐํ„ฐ ๊ฐ„ MBGP ์„ค์ •
  3. MPLS VPN ๊ณ ๊ฐ๋ง ์„ค์ •
    Company A ์„ค์ •
    Company B ์„ค์ •

1. ๊ธฐ๋ณธ ํ† ํด๋กœ์ง€ ๊ตฌ์„ฑ

  • ๊ฐ ๋„คํŠธ์›Œํฌ์˜ ๋งˆ์ง€๋ง‰ ์˜ฅํ…Ÿ์€ ๋ผ์šฐํ„ฐ ๋ฒˆํ˜ธ๋กœ ์ง€์ •ํ•œ๋‹ค.
    ex) R1: 1.1.12.1, 10.1.15.1, 10.1.17.1
    R4: 1.1.34.4, 10.1.46.4, 10.1.48.4

2. MPLS VPN ์„œ๋น„์Šค๋ง ์„ค์ •

(1) MPLS ๋ผ์šฐํ„ฐ ๊ฐ„ LDP ์„ค์ •

R1(config)# mpls label protocol ldp
R1(config)# mpls ldp router-id lo0
R1(config)# int fa0/0
R1(config-if)# mpls ip

R2(config)# mpls label protocol ldp
R2(config)# mpls ldp router-id lo0
R2(config)# int fa0/0
R2(config-if)# mpls ip
R2(config-if)# int fa1/0
R2(config-if)# mpls ip

R3(config)# mpls label protocol ldp
R3(config)# mpls ldp router-id lo 0
R3(config)# int fa1/0
R3(config-if)# mpls ip
R3(config-if)# int fa2/0
R3(config-if)# mpls ip
R3(config-if)#

R4(config)# mpls label protocol ldp
R4(config)# mpls ldp router-id lo 0
R4(config)# int fa2/0
R4(config-if)# mpls ip

1: MPLS ๋ผ๋ฒจ ๋ฐ”์ธ๋”ฉ ์ •๋ณด ์ „์†ก ํ”„๋กœํ† ์ฝœ์„ ์ง€์ •ํ•œ๋‹ค.
LDP, TDP๋ฅผ ์ง€์ •ํ•  ์ˆ˜ ์žˆ๋‹ค. LDP๊ฐ€ ๋””ํดํŠธ ๊ฐ’์ด๋‹ค.
2: LDP Router-id๋กœ ์‚ฌ์šฉํ•  ์ธํ„ฐํŽ˜์ด์Šค๋ฅผ ์ง€์ •ํ•œ๋‹ค.
router-id๋ฅผ ๋”ฐ๋กœ ์ง€์ •ํ•˜์ง€ ์•Š์„ ๊ฒฝ์šฐ ‘๋ฃจํ”„๋ฐฑ ์ธํ„ฐํŽ˜์ด์Šค IP’ (๋†’์€->๋‚ฎ์€) -> ‘๋ฌผ๋ฆฌ ์ธํ„ฐํŽ˜์ด์Šค IP’ ์ˆœ์œผ๋กœ ์ง€์ •๋œ๋‹ค.
3,4: MPLS๊ฐ€ ๋™์ž‘ํ•  ์ธํ„ฐํŽ˜์ด์Šค๋กœ ๋“ค์–ด๊ฐ€์„œ MPLS๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค๊ณ  ์ง€์ •ํ•œ๋‹ค. PE-CE ๊ตฌ๊ฐ„์—์„œ๋Š” ์ ์šฉํ•˜์ง€ ์•Š๋Š”๋‹ค.

LDP ์„ค์ • ํ™•์ธ

LDP Neighbor๋ฅผ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.
LIB ์ •๋ณด๋ฅผ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

– ๋„คํŠธ์›Œํฌ ๋ณ„๋กœ ๊ฐ LSR์ด ๋ถ€์—ฌํ•œ ๋ผ๋ฒจ๊ฐ’์„ ๋ชจ๋‘ ์ €์žฅํ•œ ๊ฒƒ์„ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

LFIB ์ •๋ณด๋ฅผ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

(2) PE ๋ผ์šฐํ„ฐ ๊ฐ„ MBGP ์„ค์ •

R1(config)# router bgp 1
R1(config-router)# bgp router-id 1.1.1.1
R1(config-router)# neighbor 1.1.4.4 remote-as 1
R1(config-router)# neighbor 1.1.4.4 update-source lo0
R1(config-router)# address-family vpnv4
R1(config-router-af)# neighbor 1.1.4.4 activate
R1(config-router-af)# neighbor 1.1.4.4 send-community extended

R4(config)# router bgp 1
R4(config-router)# bgp router-id 1.1.4.4
R4(config-router)# neighbor 1.1.1.1 remote-as 1
R4(config-router)# neighbor 1.1.1.1 update-source lo0
R4(config-router)# address-family vpnv4
R4(config-router-af)# neighbor 1.1.1.1 activate
R4(config-router-af)# neighbor 1.1.1.1 send-community both

5: MBGP ์„ค์ •๋ชจ๋“œ๋กœ ์ง„์ž…ํ•œ๋‹ค. MPLS VPN์„ ์‚ฌ์šฉํ•˜๊ธฐ ์œ„ํ•ด์„  vpnv4 ์˜ต์…˜์„ ์ž…๋ ฅํ•ด์•ผ ํ•œ๋‹ค.
6: ๋„ค์ด๋ฒ„๋ฅผ ํ™œ์„ฑํ™”ํ•œ๋‹ค.
7: MPLS VPN์—์„œ ์‚ฌ์šฉ๋˜๋Š” RT ๋“ฑ๊ณผ ๊ฐ™์€ BGP ํ™•์žฅ ์ปค๋ฎค๋‹ˆํ‹ฐ๋ฅผ ์ „์†กํ•  ์ˆ˜ ์žˆ๋„๋ก ์„ค์ •ํ•œ๋‹ค.
๋งŒ์•ฝ, MPLS VPN ์™ธ BGP์—์„œ ํ‘œ์ค€ ์ปค๋ฎค๋‹ˆํ‹ฐ๋ฅผ ์‚ฌ์šฉํ•ด ์ •์ฑ… ์„ค์ •ํ•ด์•ผ ํ•œ๋‹ค๋ฉด, 15๋ฒˆ์งธ ์ค„์ฒ˜๋Ÿผ both ์˜ต์…˜์„ ์‚ฌ์šฉํ•œ๋‹ค.

BGP ํ™•์ธ

3. MPLS VPN ๊ณ ๊ฐ๋ง ์„ค์ •

(1) Company A ์„ค์ •

R1 (PE) <-> R5 (CE) ๊ตฌ๊ฐ„

< VRF ์„ค์ • > 
R1(config)# ip vrf A_company
R1(config-vrf)# rd 1:100
R1(config-vrf)# route-target export 1:101
R1(config-vrf)# route-target import 1:102
R1(config-vrf)# exit
R1(config)#
R1(config)# int fa1/0
R1(config-if)# ip vrf forwarding A_company
R1(config-if)# ip addr 10.1.15.1 255.255.255.0
R1(config-if)#
R1(config-if)# exit

< Static Routing ์„ค์ • >
R1(config)#
R1(config)# ip route vrf A_company 10.1.1.0 255.255.255.0 10.1.15.5

< BGP ์„ค์ • >
R1(config)#
R1(config)# router bgp 1
R1(config-router)# address-family ipv4 vrf A_company
R1(config-router-af)# redistribute static
R1(config-router-af)# redistribute connected
R1(config-router-af)# exit
R1(config-router)# exit
R1(config)#

< R5 Static Default Routing ์„ค์ • >
R5(config)# ip route 0.0.0.0 0.0.0.0 10.1.15.1

2: A_company๋ผ๋Š” VRF์˜ ์„ค์ •๋ชจ๋“œ๋กœ ์ง„์ž…ํ•œ๋‹ค.
3: RD ๊ฐ’์„ ์ง€์ •ํ•œ๋‹ค.
4: A_company์— ์†Œ์†๋œ ๋„คํŠธ์›Œํฌ(CE ๋ผ์šฐํ„ฐ์˜ ๋„คํŠธ์›Œํฌ)์— ๋Œ€ํ•œ RT ๊ฐ’์„ ์ง€์ •ํ•œ๋‹ค.
5: ์ธ์ ‘ CE๋ผ์šฐํ„ฐ๋กœ ๊ด‘๊ณ ํ•  ๋•Œ ์‚ฌ์šฉํ•˜๋Š” RT๊ฐ’์„ ์ง€์ •ํ•œ๋‹ค.
์ฆ‰, RT๊ฐ’์ด 1:102์ธ ๋„คํŠธ์›Œํฌ์™€ ํ†ต์‹ ์ด ๋˜๋„๋ก ํ•œ๋‹ค.
9: ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค์— ๋จผ์ € ์„ค์ •ํ•œ VRF๋ฅผ ์ ์šฉํ•œ๋‹ค.
10: IP์ฃผ์†Œ๋ฅผ ์ง€์ •ํ•œ๋‹ค. ์ด๋•Œ, ๊ธฐ์กด์— ์„ค์ •๋œ IP๋Š” ์‚ญ์ œ๋˜๊ณ  ๋‹ค์‹œ IP์ฃผ์†Œ๋ฅผ ์ ์šฉํ•˜๊ฒŒ ๋œ๋‹ค.
16: R1์—์„œ R5 ๋‚ด๋ถ€๋ง์œผ๋กœ ์ •์  ๊ฒฝ๋กœ๋ฅผ ์„ค์ •ํ•œ๋‹ค.
21: MBGP๋ฅผ ์ด์šฉํ•ด VRF A_company์˜ ๋„คํŠธ์›Œํฌ๊ฐ€ ์ƒ๋Œ€ PE ๋ผ์šฐํ„ฐ๋กœ ์ „๋‹ฌ๋˜๋„๋ก ํ•œ๋‹ค.
22: Static Routing๊ณผ BGP๋ฅผ ์žฌ๋ถ„๋ฐฐํ•œ๋‹ค.
23: PE-CE๊ตฌ๊ฐ„์˜ ๋„คํŠธ์›Œํฌ๋ฅผ MBGP์— ํฌํ•จ์‹œํ‚จ๋‹ค. ์ด ๋ช…๋ น์–ด๋ฅผ ์‚ฌ์šฉํ•˜์ง€ ์•Š์œผ๋ฉด, R1์—์„œ R6๋กœ ์ ‘๊ทผํ•  ๋•Œ source๊ฐ€ R1์ž„์„ ๋ฐํ˜€์•ผ ํ•œ๋‹ค. ์˜ˆ๋ฅผ ๋“ค์–ด ping ํ…Œ์ŠคํŠธ๋ฅผ ์ง„ํ–‰ํ•œ๋‹ค๋ฉด, ‘ping 10.1.2.2 source 10.1.1.1’์„ ์ณ์•ผ ํ•œ๋‹ค. ํ•˜์ง€๋งŒ, ์ด ๋ช…๋ น์–ด๋ฅผ ์‚ฌ์šฉํ•˜๋ฏ€๋กœ ‘ping 10.1.2.2’๋งŒ ์น˜๋ฉด ๋œ๋‹ค.
29: R5์—์„œ Default Static Routing์„ ์„ค์ •ํ•œ๋‹ค.

R4 (PE) <-> R6 (CE) ๊ตฌ๊ฐ„

< VRF ์„ค์ • > 
R4(config)# ip vrf A_company
R4(config-vrf)# rd 1:100
R4(config-vrf)# route-target export 1:102
R4(config-vrf)# route-target import 1:101
R4(config-vrf)# exit
R4(config)# int fa1/0
R4(config-if)# ip vrf forwarding A_company
R4(config-if)# ip addr 10.1.46.4 255.255.255.0
R4(config-if)# exit

< Static Routing ์„ค์ • >
R4(config)#
R4(config)# ip route vrf A_company 10.1.2.0 255.255.255.0 10.1.46.6

< BGP ์„ค์ • >
R4(config)#
R4(config)# router bgp 1
R4(config-router)# address-family ipv4 vrf A_company
R4(config-router-af)# redistribute static
R4(config-router-af)# redistribute connected
R4(config-router-af)# exit
R4(config-router)# exit

< R6 Static Default Routing ์„ค์ • >
R6(config)# ip route 0.0.0.0 0.0.0.0 10.1.46.4

๊ณ ๊ฐ๋ง ์„ค์ • ํ™•์ธ

R1 (PE) -> R5 (CE) Ping Test

VRF ์„ค์ • ํ›„ R1์—์„œ R5๋กœ ping์€ ์•ˆ๋œ๋‹ค. R1 ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์—๋Š” VRF A_company์™€ ๊ด€๋ จ๋œ ๋„คํŠธ์›Œํฌ ์ •๋ณด๊ฐ€ ์—†๊ณ , VRF๋ณ„ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”๋กœ ๋ณ€๊ฒฝ๋˜๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค. ๊ทธ๋ž˜์„œ pingํ•  ๋•Œ์—๋Š” VRF A_company๋ฅผ ๋ช…์‹œํ•ด์•ผ ํ•œ๋‹ค.

R1์˜ (๊ธ€๋กœ๋ฒŒ) ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”
R1์˜ VRF ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”

์•ž์„œ ์–ธ๊ธ‰ํ•œ ๊ฒƒ์ฒ˜๋Ÿผ CE ๋„คํŠธ์›Œํฌ ์ •๋ณด๋Š” VRF ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์— ์žˆ๋Š” ๊ฒƒ์„ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

์ •์ƒ์ ์œผ๋กœ Ping Test๊ฐ€ ์„ฑ๊ณตํ•˜๋Š” ๊ฒƒ์„ ๋ณผ ์ˆ˜ ์žˆ๋‹ค.

(2) Company B ์„ค์ •

< R1 - R7 ๊ตฌ์„ฑ >
R1(config)# ip vrf B_company
R1(config-vrf)# rd 1:200
R1(config-vrf)# route-target export 1:201
R1(config-vrf)# route-target import 1:202
R1(config-vrf)# exit
R1(config)#
R1(config)# int fa3/0
R1(config-if)# ip vrf forwarding B_company
R1(config-if)# ip addr 10.1.17.1 255.255.255.0
R1(config-if)# exit
R1(config-if)#
R1(config)# ip route vrf B_company 10.1.1.0 255.255.255.0 10.1.17.7
R1(config)#
R1(config)# router bgp 1
R1(config-router)# address-family ipv4 vrf B_company
R1(config-router-af)# redistribute static
R1(config-router-af)# redistribute connected
R1(config-router-af)# exit
R1(config-router)# exit
R1(config)#

R7(config)# ip route 0.0.0.0 0.0.0.0 10.1.17.1

< R4 - R8 ๊ตฌ์„ฑ > 
R4(config)# ip vrf B_company
R4(config-vrf)# rd 1:200
R4(config-vrf)# route-target export 1:202
R4(config-vrf)# route-target import 1:201
R4(config-vrf)# exit
R4(config)# int fa3/0
R4(config-if)# ip vrf forwarding B_company
R4(config-if)# ip addr 10.1.48.4 255.255.255.0
R4(config-if)# exit
R4(config)#
R4(config)# ip route vrf B_company 10.1.2.0 255.255.255.0 10.1.48.8
R4(config)# router bgp 1
R4(config-router)#address-family ipv4 vrf B_company
R4(config-router-af)#redistribute static
R4(config-router-af)#redistribute connected
R4(config-router-af)#exit
R4(config-router)#exit

R8(config)#ip route 0.0.0.0 0.0.0.0 10.1.48.4

[MPLS] MPLS VPN ๊ฐœ์š”

‘[MPLS] MPLS ๊ฐœ์š”’์—์„œ ์–ธ๊ธ‰ํ•œ ๋ฐ”์™€ ๊ฐ™์ด ๋Œ€๊ทœ๋ชจ VPN์„ ์‰ฝ๊ฒŒ ๊ตฌ์„ฑํ•  ์ˆ˜ ์žˆ์–ด ํ†ต์‹  ์‚ฌ์—…์ž๊ฐ€ ์„ ํ˜ธํ•œ๋‹ค.

  1. ํŠน์ง•
  2. MPLS VPN์„ ๊ตฌ์„ฑํ•˜๋Š” ๋ผ์šฐํ„ฐ ์ข…๋ฅ˜
  3. VRF
  4. RD
  5. RT

1. ํŠน์ง•

(1) ํ†ต์‹ ์‚ฌ ๋‚ด๋ถ€์—์„œ ์‚ฌ์ „ ์„ค์ •๋œ ๊ฒฝ๋กœ๋ผ๋ฆฌ๋งŒ ํŠธ๋ž˜ํ”ฝ ์ „์†ก์ด ํ—ˆ์šฉ๋˜์–ด์„œ VPN ๋‚ด๋ถ€-์™ธ๋ถ€ ํŠธ๋ž˜ํ”ฝ์ด ์™„์ „ํžˆ ๋ถ„๋ฆฌ๋œ๋‹ค. ๋น„๊ต์  ์•ˆ์ „ํ•œ ๋ง ๊ตฌ์„ฑ์ด ๊ฐ€๋Šฅํ•œ ๊ฒƒ์ด๋‹ค.
(2) ์ธ์ฆ ๋ฐ ์•”ํ˜ธํ™” ๊ธฐ๋Šฅ์„ ์ œ๊ณตํ•˜์ง€ ์•Š์œผ๋ฏ€๋กœ IPSec VPN๊ฐ™์€ ๊ฒƒ์„ ๊ฐ™์ด ์“ฐ๋Š”๊ฒŒ ์ข‹๋‹ค.

2. MPLS VPN์„ ๊ตฌ์„ฑํ•˜๋Š” ๋ผ์šฐํ„ฐ ์ข…๋ฅ˜

์ด ์ด๋ฏธ์ง€๋Š” ๋Œ€์ฒด ์†์„ฑ์ด ๋น„์–ด์žˆ์Šต๋‹ˆ๋‹ค. ๊ทธ ํŒŒ์ผ ์ด๋ฆ„์€ image-1024x279.png์ž…๋‹ˆ๋‹ค

Customer Edge ๋ผ์šฐํ„ฐ
MPLS๋ง๊ณผ ์ง์ ‘ ์—ฐ๊ฒฐ๋˜๋Š” ๊ณ ๊ฐ ๋ผ์šฐํ„ฐ, MPLS ๊ด€๋ จ ์„ค์ •์€ ์—†๋‹ค.
Provider Edge ๋ผ์šฐํ„ฐ
๊ณ ๊ฐ ๋ผ์šฐํ„ฐ์™€ ์ง์ ‘ ์—ฐ๊ฒฐ๋˜๋Š” MPLS ๋ผ์šฐํ„ฐ.
Global Routing Table, VRF Routing Table์„ ๊ฐ–๊ณ  ์žˆ๋‹ค.
Provider ๋ผ์šฐํ„ฐ
๊ณ ๊ฐ ๋ผ์šฐํ„ฐ์™€ ์ง์ ‘ ์—ฐ๊ฒฐ๋˜์ง€ ์•Š๋Š” MPLS ๋ผ์šฐํ„ฐ.

* Global Routing Table: MPLS ๋ง ๋‚ด๋ถ€์˜ ๋ผ์šฐํŒ…์„ ์œ„ํ•ด ์‚ฌ์šฉ๋˜๋Š” ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”.
* VRF Routing Table: PE ๋ผ์šฐํ„ฐ์— ์—ฐ๊ฒฐ๋œ ๊ฐ ๊ณ ๊ฐ์— ๋Œ€ํ•œ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”, VRF ์ด๋ฆ„์€ ๋Œ€์†Œ๋ฌธ์ž ๊ตฌ๋ณ„ํ•˜๊ณ  ํ•ด๋‹น ๋ผ์šฐํ„ฐ์—์„œ๋งŒ ์˜๋ฏธ๋ฅผ ๊ฐ–๋Š”๋‹ค.

3. VRF ; Virtual Routing/Forwarding

– ๊ฐ VPN(๊ณ ๊ฐ) ๋ณ„ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”
– CEF ํ…Œ์ด๋ธ”
– PE ๋ผ์šฐํ„ฐ ๊ด€๋ จ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ
์ด 3๊ฐ€์ง€์˜ ์ง‘ํ•ฉ์ด๋‹ค. ํ•˜๋‚˜์˜ ๊ณ ๊ฐ์€ ํ•˜๋‚˜์˜ VRF๋ฅผ ๊ฐ–๋Š”๋‹ค.

4. RD; Router Distinguisher

์„œ๋กœ ๋‹ค๋ฅธ VPN ๊ณ ๊ฐ๋“ค์ด ์˜๋„์น˜ ์•Š๊ฒŒ ๋™์ผ IP๋Œ€์—ญ์„ ์‚ฌ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค. ํ•˜์ง€๋งŒ IP๊ฐ€ ๋™์ผํ•˜๋‹ค๋ฉด, ๋ผ์šฐํ„ฐ ์ž…์žฅ์—์„  ์–ด๋””๋กœ ์ „์†กํ•ด์•ผ ํ•˜๋Š”์ง€ ์•Œ ์ˆ˜ ์—†๋‹ค. ์ด ๋•Œ, RD๋ผ๋Š” ๊ตฌ๋ถ„์ž๋ฅผ ํ†ตํ•ด ์„œ๋กœ ๋‹ค๋ฅธ VPN ๊ณ ๊ฐ์„ ๊ตฌ๋ถ„ํ•œ๋‹ค.
์ฆ‰, MBGP๋‚ด์—์„œ ๊ฒฝ๋กœ๋ฅผ ๊ตฌ๋ถ„ํ•˜๋Š” ๊ฒƒ์ด๋‹ค.

RD ํ˜•์‹
์ฃผ๋กœ AS:NN ํ˜•ํƒœ๋ฅผ ๋งŽ์ด ์‚ฌ์šฉํ•œ๋‹ค. (IP:NN ํ˜•ํƒœ๋„ ์žˆ๋‹ค.)
AS๋Š” ISP์˜ AS๋ฒˆํ˜ธ, NN์€ ISP๊ฐ€ ๊ณ ๊ฐ ๋ณ„๋กœ ๋ถ€์—ฌํ•˜๋Š” ๊ณ ์œ ๋ฒˆํ˜ธ์ด๋‹ค.

vpnv4 prefix
IPv4 ์ •๋ณด์™€ RD์˜ ์กฐํ•ฉ.
ex) ํ”„๋ฆฌํ”ฝ์Šค 10.10.10.0/25, RD 10:100
=> 10:100:10.10.10.0.25

5. RT; Route Target

ํŠน์ • ๊ฒฝ๋กœ์ •๋ณด๋ฅผ ์–ด๋Š VRF๋กœ ์ „๋‹ฌํ• ์ง€ ๊ฒฐ์ •ํ•˜๋Š” ๊ฒƒ.
๋•Œ๋ก , ๋‹ค๋ฅธ VPN(๊ณ ๊ฐ) ๊ฐ„ ํ†ต์‹ ์ด ํ•„์š”ํ•œ ๊ฒฝ์šฐ๊ฐ€ ์žˆ๋Š”๋ฐ ์ด๋•Œ RT๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.

* ํ•˜๋‚˜์˜ ๊ณ ๊ฐ์ด ํ•˜๋‚˜์˜ VRF๋ฅผ ๊ฐ–์œผ๋ฏ€๋กœ ‘์–ด๋Š VPN(๊ณ ๊ฐ)์œผ๋กœ ์ „๋‹ฌํ• ์ง€ ๊ฒฐ์ •ํ•˜๋Š” ๊ฒƒ’์ด๋ผ๊ณ  ์ƒ๊ฐํ•ด๋„ ๋ฌด๋ฐฉํ•˜๋‹ค.

* RD๊ฐ’๊ณผ RT๊ฐ’์ด ๋™์ผํ•ด๋„ ์ƒ๊ด€์—†๋‹ค. ์„œ๋กœ ๋ณ„๊ฐœ์˜ ๋ณ€์ˆ˜๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

Import
– PE๋ผ์šฐํ„ฐ๊ฐ€ ์ธ์ ‘ CE๋ผ์šฐํ„ฐ๋กœ ํŠน์ • RT๊ฐ’์„ ๊ด‘๊ณ ํ•˜๋Š” ๊ฒƒ์„ ๋งํ•œ๋‹ค.
– CE๋ผ์šฐํ„ฐ๋กœ ๋„คํŠธ์›Œํฌ๋ฅผ ๊ด‘๊ณ ํ•  ๋•Œ, PE๋ผ์šฐํ„ฐ๋Š” Importํ•œ๋‹ค.

Export
– PE๋ผ์šฐํ„ฐ๊ฐ€ CE๋ผ์šฐํ„ฐ ๋„คํŠธ์›Œํฌ์˜ RT๊ฐ’์„ ์ง€์ •ํ•˜๋Š” ๊ฒƒ์„ ๋งํ•œ๋‹ค.
– CE๋ผ์šฐํ„ฐ๋กœ๋ถ€ํ„ฐ ๋„คํŠธ์›Œํฌ๋ฅผ ๊ด‘๊ณ ๋ฐ›์„ ๋•Œ, PE๋ผ์šฐํ„ฐ๋Š” Exportํ•œ๋‹ค.

[MPLS] MPLS ๊ฐœ์š”

Multiprotocol Label Switching

IPv4/IPv6 ํŒจํ‚ท์ด๋‚˜ L2 ํ”„๋ ˆ์ž„์— ๋ผ๋ฒจ์„ ์ฒจ๋ถ€ํ•˜๋Š” ๊ธฐ์ˆ ์„ ๋งํ•œ๋‹ค.
๊ฐ LSR๋“ค์ด MPLS ํŒจํ‚ท์„ ์ˆ˜์‹ ํ•˜๋ฉด ๋ผ๋ฒจ์„ ์ฐธ๊ณ ํ•˜์—ฌ ํ•ด๋‹น ํŒจํ‚ท์„ ์Šค์œ„์นญํ•˜๋Š” ๊ฒƒ์ด๋‹ค.

*LSR ; Lasbel Switch Router – MPLS๊ฐ€ ๋™์ž‘ํ•˜๋Š” ๋ผ์šฐํ„ฐ/์Šค์œ„์น˜

  1. ์‚ฌ์šฉ ์ด์œ 
  2. ํ—ค๋”
  3. FEC
  4. ๋ผ๋ฒจ ๋ฐ”์ธ๋”ฉ
  5. MPLS ๋™์ž‘๋ชจ๋“œ
  6. MPLS ํŒจํ‚ท ์ „์†ก๊ณผ์ •

1. ์‚ฌ์šฉ ์ด์œ 

(1) MPLS VPN ๊ตฌ์„ฑ
๋Œ€๊ทœ๋ชจ VPN์„ ์‰ฝ๊ฒŒ ๊ตฌ์„ฑํ•  ์ˆ˜ ์žˆ์–ด์„œ ํ†ต์‹  ์‚ฌ์—…์ž๊ฐ€ ์„ ํ˜ธํ•œ๋‹ค.
(์ž์„ธํ•œ ๋‚ด์šฉ์€ ๋‹ค์Œ ๊ฒŒ์‹œ๊ธ€์—์„œ ๋‹ค๋ฃจ๋„๋ก ํ•œ๋‹ค.)


(2) ํŠธ๋ž˜ํ”ฝ ์—”์ง€๋‹ˆ์–ด๋ง; Traffic Engineering
ํŠน์ • ํŠธ๋ž˜ํ”ฝ์— ๋Œ€ํ•ด ๋Œ€์—ญํญ์„ ๋ณด์žฅ(์ฆ‰, QoS ๋ณด์žฅ)ํ•˜๊ณ , IGP๊ฐ€ ์‚ฌ์šฉํ•˜์ง€ ์•Š๋Š” ๋งํฌ๊นŒ์ง€ ์‚ฌ์šฉํ•  ์ˆ˜ ์žˆ์œผ๋ฏ€๋กœ ๋„คํŠธ์›Œํฌ ์ž์›์„ ํšจ์œจ์ ์œผ๋กœ ์‚ฌ์šฉํ•œ๋‹ค.
FRR(Fast Reroute) ๊ธฐ๋Šฅ์„ ํ†ตํ•ด ์žฅ์•  ๋ฐœ์ƒ ์‹œ ๋Œ€์ฒด ๊ฒฝ๋กœ๋กœ ์šฐํšŒ์‹œ์ผœ ํŒจํ‚ท ์†์‹ค์„ ์ตœ์†Œํ™”ํ•œ๋‹ค.

2. ํ—ค๋”

Label: ๋ผ๋ฒจ์„ ํ‘œ์‹œํ•˜๋Š” ๊ฐ’์ด๋‹ค. 0~1,048,575 ์‚ฌ์ด ๊ฐ’์„ ์‚ฌ์šฉํ•œ๋‹ค. 0~15๋Š” ํŠน๋ณ„ ์šฉ๋„๋กœ ์‚ฌ์šฉ๋˜๊ณ , ์ผ๋ฐ˜์ ์œผ๋กœ 16~100,000 ๊ฐ’์„ ์‹ค์ œ ์‚ฌ์šฉํ•œ๋‹ค.
EXP(Experimental): QoS ๊ฐ’์„ ํ‘œ์‹œํ•œ๋‹ค. 0~7 ์‚ฌ์ด ๊ฐ’์„ ์‚ฌ์šฉํ•œ๋‹ค.
BoS: ๊ฐ’์ด 1์ธ ๊ฒฝ์šฐ ๋งˆ์ง€๋ง‰ ๋ผ๋ฒจ, 0์ธ ๊ฒฝ์šฐ ํ˜„์žฌ ๋ผ๋ฒจ ๋‹ค์Œ ๋˜ ๋‹ค๋ฅธ ๋ผ๋ฒจ์ด ์žˆ์Œ์„ ์˜๋ฏธํ•œ๋‹ค. ์—ฌ๊ธฐ์„œ ‘๋ผ๋ฒจ’์€ ๊ฐ™์€ ๋ผ๋ฒจ์˜ ํŒจํ‚ท์ด๊ฑฐ๋‚˜ ๋‹ค๋ฅธ ๋ผ๋ฒจ๊ฐ’์ด๊ฑฐ๋‚˜ ๋‘˜ ์ค‘ ํ•˜๋‚˜์ด๋‹ค.
TTL: ํŒจํ‚ท ๋ฃจํ”„๋ฅผ ๋ฐฉ์ง€ํ•˜๊ธฐ ์œ„ํ•œ Time To Live ๊ฐ’์ด๋‹ค.

* Label ๋ฒ”์œ„์— ๋”ฐ๋ฅธ ์šฉ๋„ – IANA ์ฐธ๊ณ 

3. FEC (Forwarding Equivalence Class)

๋™์ผํ•œ MPLS ๊ฒฝ๋กœ๋ฅผ ์ด์šฉํ•ด ์ „์†ก๋˜๋Š” ํŒจํ‚ท์˜ ๊ทธ๋ฃน.

๋ˆ„๊ฐ€ FEC๋ฅผ ์ง€์ •ํ• ๊นŒ?

ํŒจํ‚ท์„ ์ฒ˜์Œ ์ˆ˜์‹ ํ•œ Ingress LSR์—์„œ ํ•ด๋‹น ํŒจํ‚ท์˜ ์†Œ์† FEC๋ฅผ ์ง€์ •.
๋™์ผ FEC์— ์†ํ•œ ํŒจํ‚ท์€ ๋ผ๋ฒจ๊ฐ’๋„ ๋™์ผ.

์–ด๋–ค ๊ธฐ์ค€์œผ๋กœ FEC๋ฅผ ์ง€์ •ํ• ๊นŒ?

– ๋ชฉ์ ์ง€ ๋„คํŠธ์›Œํฌ๊ฐ€ ๋™์ผํ•œ ํŒจํ‚ท
– ๋™์ผ ๊ทธ๋ฃน์— ์†ํ•œ ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ํŒจํ‚ท
– BGP Next Hop ๋ผ์šฐํ„ฐ๊ฐ€ ๋™์ผํ•œ ํŒจํ‚ท

4. ๋ผ๋ฒจ ๋ฐ”์ธ๋”ฉ

FEC๋ณ„๋กœ ๋ผ๋ฒจ์„ ๋ถ€์—ฌํ•œ๋‹ค.
๋ผ๋ฒจ๊ฐ’์€ ์ธ์ ‘ํ•œ ๋‘ LSR ์‚ฌ์ด์—์„œ๋งŒ ์˜๋ฏธ ์žˆ๋‹ค. ์˜ˆ๋ฅผ ๋“ค์–ด, R1 – R2 – R3 ๊ตฌ์„ฑ์—์„œ R1-R2 ๊ฐ„ ์‚ฌ์šฉํ•˜๋Š” ๋ผ๋ฒจ๊ฐ’์€ R3์™€ ๊ด€๋ จ ์—†๋Š” ๊ฒƒ์ด๋‹ค.

๋ผ๋ฒจ ๋ฐ”์ธ๋”ฉ ์ •๋ณด ์ „์†ก ํ”„๋กœํ† ์ฝœ

– Tag Distribution Protocol(TDP)
– Label Distribution Protocol(LDP)
– Resource Reservation Protocol(RSVP)
– BGP

(1) MPLS VPN์—์„œ LDP/TDP๊ฐ€ router-id ๋ณ„ ๋ผ๋ฒจ๊ฐ’ ์ „์†ก.
(2) ์ด ํ›„ PE๋ผ์šฐํ„ฐ ๊ฐ„ BGP๋ฅผ ์ด์šฉํ•ด ๋ชฉ์ ์ง€ ๋„คํŠธ์›Œํฌ ๋ณ„ ๋ผ๋ฒจ๊ฐ’ ๊ตํ™˜.
(3) MPLS TE์—์„  RSVP๋ฅผ ์ด์šฉํ•ด ๋ผ๋ฒจ๊ฐ’ ๊ตํ™˜.

LIB / LFIB

Label Information Base / Label Forwarding Information Base

์•„๋ž˜ 2๊ฐœ์˜ ๋ฐ”์ธ๋”ฉ์„ LIB๋ผ๊ณ  ํ•œ๋‹ค.

๋กœ์ปฌ ๋ฐ”์ธ๋”ฉ: ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์— ์žˆ๋Š” ๊ฐ IGP ๋„คํŠธ์›Œํฌ ๋ณ„๋กœ ๋ผ๋ฒจ ๋ถ€์—ฌ.
๋ฆฌ๋ชจํŠธ ๋ฐ”์ธ๋”ฉ: ์ธ์ ‘ LSR์—๊ฒŒ ๊ด‘๊ณ  ๋ฐ›์€ ๋ผ๋ฒจ.

ํŠน์ • FEC์— ๋Œ€ํ•ด ์œ ์ผํ•œ ๋ผ๋ฒจ๊ฐ’์„ ๋ถ€์—ฌํ•˜๊ฑฐ๋‚˜ ์ธํ„ฐํŽ˜์ด์Šค ๋ณ„๋กœ ์œ ์ผํ•œ ๋ผ๋ฒจ๊ฐ’์„ ๋ถ€์—ฌํ•œ๋‹ค.
์—ฌ๋Ÿฌ ์ธ์ ‘ LSR์ด ์žˆ๋‹ค๋ฉด, ํ•˜๋‚˜์˜ ๋ชฉ์ ์ง€ ๋„คํŠธ์›Œํฌ์— ๋Œ€ํ•ด ์—ฌ๋Ÿฌ ๋ฆฌ๋ชจํŠธ ๋ฐ”์ธ๋”ฉ์„ ๊ฐ–๊ฒŒ ๋œ๋‹ค. ํ•˜์ง€๋งŒ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์— ์˜ํ•ด ํ•˜๋‚˜๋งŒ ์„ ์ •๋˜์–ด ์‚ฌ์šฉํ•œ๋‹ค. ๊ทธ๋ ‡๊ฒŒ ํ•ด์„œ ๊ฒฐ์ •๋œ ๋กœ์ปฌ ๋ฐ”์ธ๋”ฉ๊ณผ ๋ฆฌ๋ชจํŠธ ๋ฐ”์ธ๋”ฉ์— ์‚ฌ์šฉ๋˜๋Š” ๋ผ๋ฒจ์„ LFIB์— ์ €์žฅํ•œ๋‹ค.

5. MPLS ๋™์ž‘๋ชจ๋“œ

๋ผ๋ฒจ ๋ฐ”์ธ๋”ฉ ๋ถ„๋ฐฐ ๋ฐฉ์‹

Downstream-On-Demand(DoD) ๋ฐฉ์‹
๊ฐ LSR์ด ๋„ฅ์ŠคํŠธ ํ™‰ ๋ผ์šฐํ„ฐ(DoD๋ผ์šฐํ„ฐ)์—๊ฒŒ ํŠน์ • FEC์— ๋Œ€ํ•œ ๋ฐ”์ธ๋”ฉ์„ ์š”์ฒญํ•œ ๋’ค ์˜ค์ง ํ•˜๋‚˜์˜ ๋ฐ”์ธ๋”ฉ์„ ๋ถ€์—ฌ ๋ฐ›๋Š”๋‹ค.
Unsolicited Downstream(UD) ๋ฐฉ์‹
๊ฐ LSR์ด ๋…์ž์ ์œผ๋กœ FEC๋ฅผ ๋ถ€์—ฌํ•˜๊ณ , ์ด๋ฅผ ์ธ์ ‘ LSR์—๊ฒŒ ๊ด‘๊ณ ํ•œ๋‹ค.

๋ผ๋ฒจ ์ €์žฅ ๋ชจ๋“œ

Liberal Label Retention(LLR) ๋ชจ๋“œ
๋ชจ๋“  ๋„ค์ด๋ฒ„๋กœ๋ถ€ํ„ฐ ์ˆ˜์‹ ํ•œ ๋ฐ”์ธ๋”ฉ ์ •๋ณด๋ฅผ ๋ชจ๋‘ LIB์— ์ €์žฅํ•œ๋‹ค.
Conservative Label Retention(CLR) ๋ชจ๋“œ
์ตœ์  ๊ฒฝ๋กœ ์ƒ์˜ ๋„ฅ์ŠคํŠธ ํ™‰ LSR๋กœ๋ถ€ํ„ฐ ์ˆ˜์‹ ํ•œ ๋ฐ”์ธ๋”ฉ ์ •๋ณด๋งŒ LIB์— ์ €์žฅํ•œ๋‹ค.

๋กœ์ปฌ ๋ฐ”์ธ๋”ฉ ์ƒ์„ฑ ๋ฐฉ์‹

๋…๋ฆฝ์  LSP ์ œ์–ด ๋ชจ๋“œ
๊ฐ LSR์ด FEC๋ฅผ ์ธ์‹ํ•  ๋•Œ (๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์— ํŠน์ • ๋„คํŠธ์›Œํฌ๊ฐ€ ์˜ฌ๋ผ์˜ฌ ๋•Œ), ๋กœ์ปฌ ๋ฐ”์ธ๋”ฉ์„ ์ƒ์„ฑํ•œ๋‹ค.
์ˆœ์ฐจ์  LSP ์ œ์–ด ๋ชจ๋“œ
๋„ฅ์ŠคํŠธ ํ™‰ LSR๋กœ๋ถ€ํ„ฐ ๋ผ๋ฒจ ์ •๋ณด๋ฅผ ์ˆ˜์‹ ํ•˜๊ฑฐ๋‚˜ ํŠน์ • LSR์ด ํŠน์ • FEC์— ๋Œ€ํ•œ ์ถœ๋ ฅ(Egrees) LSR์ผ ๋•Œ, ๋กœ์ปฌ ๋ฐ”์ธ๋”ฉ์„ ์ƒ์„ฑํ•œ๋‹ค.

6. MPLS ํŒจํ‚ท ์ „์†ก๊ณผ์ •

MPLS ๋™์ž‘ ์‹œ ๊ฐ LSR๋“ค์€ ์ž์‹ ์˜ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์— ์žˆ๋Š” ๋„คํŠธ์›Œํฌ์— ๋Œ€ํ•ด ๋ผ๋ฒจ์„ ๋ถ€์—ฌํ•œ๋‹ค. ๊ทธ๋ฆฌ๊ณ  ์ด ๋ผ๋ฒจ๋“ค์„ ์ธ์ ‘ LSR๋กœ ์ „์†กํ•œ๋‹ค.
๋‹จ, ์ตœ์ข… ๋ชฉ์ ์ง€๊ฐ€ ์ž์‹ ์ธ ๋„คํŠธ์›Œํฌ๋Š” ๋ผ๋ฒจ์„ ๋ถ€์—ฌํ•˜์ง€ ์•Š๋Š”๋‹ค.

(1) MPLS ๋ผ๋ฒจ ํ• ๋‹น ๊ณผ์ •

#1

#1. R4 ์ž…์žฅ์—์„œ IP๊ฐ€ ‘5.1.3.1’์ธ ํŒจํ‚ท์˜ ์ตœ์ข… ๋ชฉ์ ์ง€๋Š” ์ž์‹ ์ด๋ฏ€๋กœ ๋ผ๋ฒจ์„ ๋ถ€์—ฌ ํ•˜์ง€ ์•Š์€ ์ฑ„ R3๋กœ ๋ฐ”์ธ๋”ฉ ์ •๋ณด๋ฅผ ์ „์†กํ•œ๋‹ค.

#2

#2. R3๋Š” ๋ชฉ์ ์ง€ ‘5.1.3.1’์ธ ํŒจํ‚ท์— ๋ผ๋ฒจ๊ฐ’ 30์„ ๋ถ€์—ฌํ•˜๊ณ , ์ž์‹ ์—๊ฒŒ ์ „์†กํ•˜๋ผ๋Š” ๋ฐ”์ธ๋”ฉ ์ •๋ณด๋ฅผ R2์—๊ฒŒ ์ „์†กํ•œ๋‹ค.
์ด ๋•Œ, R3 ์ž…์žฅ์—์„œ ๋ผ๋ฒจ๊ฐ’ 30์€ ๋กœ์ปฌ ๋ฐ”์ธ๋”ฉ ์ •๋ณด์ด๋‹ค.

#3

#3. R2๋Š” ๋ชฉ์ ์ง€ ‘5.1.3.1’์ธ ํŒจํ‚ท์— ๋ผ๋ฒจ๊ฐ’ 20์„ ๋ถ€์—ฌํ•˜๊ณ , ์ž์‹ ์—๊ฒŒ ์ „์†กํ•˜๋Š” ๋ฐ”์ธ๋”ฉ ์ •๋ณด๋ฅผ R1์—๊ฒŒ ์ „์†กํ•œ๋‹ค.
์ด ๋•Œ, R2 ์ž…์žฅ์—์„œ ๋ผ๋ฒจ๊ฐ’ 20์€ ๋กœ์ปฌ ๋ฐ”์ธ๋”ฉ, ๋ผ๋ฒจ๊ฐ’ 30์€ ๋ฆฌ๋ชจํŠธ ๋ฐ”์ธ๋”ฉ ์ •๋ณด์ด๋‹ค.

์œ„์™€ ๊ฐ™์€ ๊ณผ์ •์„ ๊ฑฐ์น˜๋ฉด์„œ ๊ฐ LSR์€ ํŠน์ • ๋„คํŠธ์›Œํฌ์— ๋Œ€ํ•œ LIB ๋ฐ LFIB๋ฅผ ๋งŒ๋“ค๊ณ , MPLS ํŒจํ‚ท ์ „์†ก์„ ์œ„ํ•œ ์ค€๋น„๋ฅผ ํ•œ๋‹ค.

* ๋ผ๋ฒจ ๋ฐ”์ธ๋”ฉ ๋ถ„๋ฐฐ ๋ฐฉ์‹: UD ๋ผ๋ฒจ ๋ถ„๋ฐฐ ๋ฐฉ์‹
* ๋กœ์ปฌ ๋ฐ”์ธ๋”ฉ ์ƒ์„ฑ ๋ชจ๋“œ: ์ˆœ์ฐจ์  LSP ์ œ์–ด ๋ชจ๋“œ

(2) MPLS ํŒจํ‚ท ์ „์†ก๊ณผ์ •

#1

#1. R1์€ 5.1.3.1๋กœ ํŒจํ‚ท์„ ๋ณด๋‚ด๊ธฐ ์œ„ํ•ด ๋ผ๋ฒจ๊ฐ’ 20์„ ๋ถ€์—ฌํ•œ ๋’ค R2์—๊ฒŒ ์ „์†กํ•œ๋‹ค.
์ฒ˜์Œ ๋ผ๋ฒจ์„ ๋ถ€์—ฌํ•˜๋Š” ๋™์ž‘์„ PUSH ๋˜๋Š” IMPOSITION ์ด๋ผ๊ณ  ํ•œ๋‹ค.

#2

#2. R2๋Š” ๋ผ๋ฒจ 20์„ ํ™•์ธํ•˜๊ณ  ์ธ์ ‘ LSR(R3)๊ฐ€ ์š”์ฒญํ•œ ๋ฆฌ๋ชจํŠธ ๋ผ๋ฒจ๊ฐ’ 30์œผ๋กœ ๋ณ€๊ฒฝํ•œ ๋’ค R3๋กœ ์ „์†กํ•œ๋‹ค.
์ด ๋•Œ, ๋ผ๋ฒจ๊ฐ’์„ ๋ณ€๊ฒฝํ•˜๋Š” ๋™์ž‘์„ SWAP ์ด๋ผ๊ณ  ํ•œ๋‹ค.

#3

#3. R3๋Š” ๋ผ๋ฒจ 30์„ ํ™•์ธํ•˜๊ณ  ์ธ์ ‘ LSR(R4)๊ฐ€ ์š”์ฒญํ•œ ๋Œ€๋กœ ๋ผ๋ฒจ์„ ์ œ๊ฑฐํ•œ ๋’ค R4๋กœ ์ „์†กํ•œ๋‹ค.
์ด ๋•Œ, ๋ผ๋ฒจ๊ฐ’์„ ์ œ๊ฑฐํ•˜๋Š” ๋™์ž‘์„ POP ์ด๋ผ๊ณ  ํ•œ๋‹ค.

* Penultimate Hop Popping (PHP)
MPLS ๋ผ๋ฒจ์ด ์ตœ์ข… LSR ์ง์ „ ๋ผ์šฐํ„ฐ์—์„œ ์ œ๊ฑฐ๋˜๋Š” ๊ฒƒ์„ ์ผ์ปซ๋Š”๋‹ค.
์ตœ์ข… LSR์ด MPLS ๋ผ๋ฒจ๊ณผ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ์ฐธ์กฐํ•˜๋Š” ์ด์ค‘ ๋™์ž‘์„ ๋ฐฉ์ง€ํ•˜๊ธฐ ์œ„ํ•ด PHP๋ฅผ ๋™์ž‘์‹œํ‚จ๋‹ค. ์ด๋ ‡๊ฒŒ ํ•˜๊ฒŒ ๋˜๋ฉด ์ตœ์ข… LSR์€ ๋ผ๋ฒจ ์ฐธ์กฐ ํ•„์š” ์—†์ด ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”๋งŒ ์ฐธ์กฐํ•œ๋‹ค.

[Router] EIGRP: SIA ๋ฐฉ์ง€

Stuck In Active
EIGRP ๋ผ์šฐํ„ฐ๊ฐ€ ์ธ์ ‘ Neighbor๋กœ๋ถ€ํ„ฐ Query์— ๋Œ€ํ•œ Reply๋ฅผ ๋ฐ›์ง€ ๋ชปํ•œ ์ƒํƒœ๋ฅผ Active ์ƒํƒœ๋ผ๊ณ  ํ•˜๋Š”๋ฐ, ์ด ์ƒํƒœ๊ฐ€ ์ง€์†๋˜๋Š” ํ˜„์ƒ์„ ๋งŒํ•œ๋‹ค.
์ตœ๋Œ€ 180์ดˆ ๋™์•ˆ Reply ์ˆ˜์‹ ๋˜๊ธฐ๋ฅผ ๊ธฐ๋‹ค๋ฆฌ๋‹ค๊ฐ€ 180์ดˆ๊ฐ€ ์ง€๋‚˜๋ฉด Reply๋ฅผ ๋ณด๋‚ด์ง€ ์•Š์€ ๋ผ์šฐํ„ฐ์™€ Neighbor ๊ด€๊ณ„๋ฅผ ํ•ด์ง€ํ•œ๋‹ค.

์ž, ์•„๋ž˜์™€ ๊ฐ™์€ ํ† ํด๋กœ์ง€๋ฅผ ๋ณด๋„๋ก ํ•˜์ž.

R1 โ†’ R4๋กœ  Query๋ฅผ ๋ณด๋ƒˆ์ง€๋งŒ,  R4๋Š” Reply๋ฅผ ๋ณด๋‚ด์ง€ ์•Š๋Š” ์ƒํƒœ.

์ด ๊ฒฝ์šฐ์—” R1, R2, R3 ๋ชจ๋‘ R4์˜ Reply๋ฅผ ๊ธฐ๋‹ค๋ฆฐ๋‹ค. ์ด๋Ÿฐ ๊ณผ์ •์ด ์—ฌ๋Ÿฌ ๋ฒˆ ๋ฐ˜๋ณต๋˜๋ฉด ๋„คํŠธ์›Œํฌ๊ฐ€ ๋ถˆ์•ˆ์ •ํ•ด์ง„๋‹ค.

R4 ์ž…์žฅ์—์„œ Reply๋ฅผ ๋ณด๋‚ด์ง€ ๋ชปํ•˜๋Š” ์ด์œ ๋Š” ‘R3 – R4 ๊ฐ„ ๋งํฌ’์˜ ํŠธ๋ž˜ํ”ฝ์ด ๊ณผ๋‹คํ•˜๊ฑฐ๋‚˜ ์ž˜๋ชป ์„ค์ •ํ•œ ๊ฒƒ ๋“ฑ๋“ฑ ๋ผ์šฐํ„ฐ์— ๋ถ€ํ•˜๊ฐ€ ๊ฑธ๋ ค ๋ณด๋‚ด์ง€ ๋ชปํ•œ๋‹ค๊ณ  ๋ณผ ์ˆ˜ ์žˆ๋‹ค.

SIA ๋ฐฉ์ง€ ๋Œ€์ฑ…

1. SIA ํƒ€์ด๋จธ ์กฐ์ •

SIA ํ˜„์ƒ์— ์˜ํ•ด Neighbor๊ฐ€ ํ•ด์ง€๋˜๋Š” ๊ฒƒ์„ ๋ฐฉ์ง€ ํ•œ๋‹ค. Reply Hold ์‹œ๊ฐ„์„ ๋Š˜๋ ค์„œ Neighbor ๊ด€๊ณ„ ์ง€์† ์‹œ๊ฐ„์„ ์ฆ๊ฐ€์‹œํ‚ค๋Š” ๊ฒƒ์ด๋‹ค.

ํ•˜์ง€๋งŒ ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ•  ๊ฒฝ์šฐ ๋„คํŠธ์›Œํฌ์˜ ๋Œ€์ฒด ๊ฒฝ๋กœ๊ฐ€ ์žˆ์–ด๋„ Reply Hold ์‹œ๊ฐ„์ด ๊ธธ์–ด์กŒ๊ธฐ ๋•Œ๋ฌธ์— ๋Œ€์ฒด ๊ฒฝ๋กœ๋ฅผ ๋ผ์šฐํŒ…์— ์ €์žฅ์‹œํ‚ค๋Š” ์‹œ๊ฐ„๋„ ๋Š˜์–ด๋‚œ๋‹ค. (=์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์ด ๊ธธ์–ด์ง„๋‹ค.)

[์„ค์ •]

Router(config)# router eigrp <AS>
Router(config-router)# timers active-time [1-65535]

2. Query Scoping

Query ํŒจํ‚ท์ด ์ ๋‹นํ•œ ์„ ์—์„œ ๋ฉˆ์ถ”๋„๋ก ํ•˜๋Š” ๊ฒƒ์„ ๋งํ•œ๋‹ค. Query ํŒจํ‚ท์„ ๋ฐ›์€ ๊ฒƒ๊ณผ ๋™์ผ ๋„คํŠธ์›Œํฌ๊ฐ€ Topology table์— ์กด์žฌํ•˜์ง€ ์•Š์œผ๋ฉด ํŒจํ‚ท์„ ์ „ํŒŒํ•˜์ง€ ์•Š๋Š”๋‹ค.

2-1. ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ์— ์˜ํ•œ Query Scoping

R2์—์„œ ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ์„ ํ†ตํ•ด R3๋กœ 10.0.0.0/16 ์ •๋ณด๋ฅผ ์ „์†กํ–ˆ๋‹ค.
์ดํ›„ R1์ด R3๋กœ 10.0.0.0/24์— ๋Œ€ํ•œ EIGRP Query๋ฅผ ๋ณด๋‚ด๋ฉด R3๊ฐ€ ํ•ด๋‹น Query๋ฅผ ๋ฌด์‹œํ•œ๋‹ค.

[์„ค์ •]

Router(config)# int <INTERFACE>
Router(config-if)# ip summary-address eigrp <AS> <SUMMARY_IP> <SUBNETMASK>

2-2. ์žฌ๋ถ„๋ฐฐ์— ์˜ํ•œ Query Scoping
EIGRP๋ฅผ ์‚ฌ์šฉํ•˜์ง€ ์•Š๊ณ  ๋‹ค๋ฅธ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์„ ์‚ฌ์šฉํ•œ๋‹ค. EIGRP Query ํŒจํ‚ท์€ EIGRP ๋ผ์šฐํ„ฐ๋ผ๋ฆฌ๋งŒ ์ฃผ๊ณ ๋ฐ›๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

2-3. Stub์— ์˜ํ•œ Query Scoping
Stub ๋ผ์šฐํ„ฐ๋กœ๋Š” EIGRP Query๋ฅผ ๋ณด๋‚ด์ง€ ์•Š๋Š”๋‹ค.  ๋‚˜๋จธ์ง€ Update, Ack, Reply๋Š” ๋ณด๋‚ธ๋‹ค. Stub ๋ผ์šฐํ„ฐ๋Š” ์ง์ ‘ ์ ‘์†๋œ ๋„คํŠธ์›Œํฌ์™€ ์ถ•์•ฝ๋œ ๋„คํŠธ์›Œํฌ ์ •๋ณด๋งŒ neighbor๋กœ ์ „์†กํ•œ๋‹ค.

[์„ค์ •]

Router(config)# router eigrp <AS>
Router(config-router)# eigrp stub

[Router] EIGRP: DUAL Algorithm

Diffusing Update Algorithm

EIGRP๋Š” DUAL ์•Œ๊ณ ๋ฆฌ์ฆ˜์— ์˜ํ•ด ๋ผ์šฐํŒ…์„ ๊ณ„์‚ฐํ•œ๋‹ค.

1. ์šฉ์–ด
2. ์„ ์ถœํ•˜๊ธฐ


1. ์šฉ์–ด

Topology Table์ธ์ ‘ ๋ผ์šฐํ„ฐ๋กœ๋ถ€ํ„ฐ ์ˆ˜์‹ ํ•œ ๋„คํŠธ์›Œํฌ์™€ ํ•ด๋‹น ๋„คํŠธ์›Œํฌ์˜ ๋ฉ”ํŠธ๋ฆญ์„ ์ €์žฅํ•œ ํ…Œ์ด๋ธ”
Feasible Distanceํ˜„์žฌ ๋ผ์šฐํ„ฐ์—์„œ ๋ชฉ์ ์ง€ ๋„ทํŠธ์›Œํฌ๊นŒ์ง€ ์ตœ์  ๊ฒฝ๋กœ์˜ ๋ฉ”ํŠธ๋ฆญ
Successor์ตœ์  ๊ฒฝ๋กœ ์ƒ์—์„œ์˜ ๋„ฅ์ŠคํŠธ ํ™‰ ๋ผ์šฐํ„ฐ
Reported Distance
(Advertised Distance)
๋„ฅ์ŠคํŠธ ํ™‰ ๋ผ์šฐํ„ฐ์—์„œ ๋ชฉ์ ์ง€๊นŒ์ง€์˜ ๋ฉ”ํŠธ๋ฆญ
Feasible SuccessorSuccessor๊ฐ€ ์•„๋‹Œ ๋ผ์šฐํ„ฐ ์ค‘ FD > RD๋ฅผ ๋งŒ์กฑํ•˜๋Š” ๋„ฅ์ŠคํŠธ ํ™‰ ๋ผ์šฐํ„ฐ

2. ์„ ์ถœํ•˜๊ธฐ

R3 ๊ธฐ์ค€์œผ๋กœ 30.30.30.0/24 ๋„คํŠธ์›Œํฌ๋กœ ๊ฐ€๋Š” ๊ฒฝ๋กœ๊ฐ€ ์žˆ๋‹ค๊ณ  ์ƒ๊ฐํ•ด๋ณด์ž.

Q1. Feasible Distance์™€ Successor๋Š”?
FD: R3 โ†’ R2 โ†’ R1 ์ด๋ฏ€๋กœ 110
Successor: R2

Q2. Reported Distance๋Š”?
R2 โ†’ R1์ด๋ฏ€๋กœ 100์ด๋‹ค.

Q3. Feasible Successor๋Š”?
R4

[๋ผ์šฐํ„ฐ์—์„œ ์กฐํšŒํ•˜๊ธฐ]

# Feasible Successor๋‚˜ Successor ํ™•์ธ
Router# show ip eigrp topology 

# FD, RD, FS, S ํ™•์ธ
Router# show ip eigrp topology all-links
Router# show ip eigrp topology detail-links

[Router] EIGRP

Enhanced Interior Gateway Routing Protocol

Cisco์—์„œ ๋งŒ๋“  EIGRP.
๊ทธ๋Œ€๋กœ ํ•ด์„ํ•˜๋ฉด, ํ–ฅ์ƒ๋œ ๋‚ด๋ถ€ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์ด๋‹ค. ๊ธฐ์กด IGRP์—์„œ ์—…๊ทธ๋ ˆ์ด๋“œ๋œ ๋ฒ„์ „(?)์ด๋ผ๊ณ  ์ƒ๊ฐํ•˜์ž. ๊ทธ๋Ÿผ EIGRP์— ๋Œ€ํ•ด ์•Œ์•„๋ณด๋„๋ก ํ•œ๋‹ค.

1. EIGRP ๊ธฐ๋ณธ ๊ฐœ๋…
2. EIGRP ๋™์ž‘ ๊ณผ์ •
3. EIGRP ํŒจํ‚ท ์ข…๋ฅ˜
4. EIGRP ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ๊ณผ ๋ณด์•ˆ
5. EIGRP ๋ถ€ํ•˜ ๋ถ„์‚ฐ


1. EIGRP ๊ธฐ๋ณธ ๊ฐœ๋…

– Cisco์—์„œ ๋งŒ๋“  ๊ฑฐ๋ฆฌ ๋ฒกํ„ฐ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์ด๋‹ค.
– IPv4 ํ”„๋ ˆ์ž„ ๋‚ด IP Protocol ํ•„๋“œ ๋ฒˆํ˜ธ 88์„ ์‚ฌ์šฉํ•œ๋‹ค.(ํฌํŠธ ๋ฒˆํ˜ธ ์•„๋‹˜.)
– Multicast 224.0.0.10์„ ์‚ฌ์šฉํ•œ๋‹ค.
– EIGRP์˜ ์‹ ๋ขฐ์„ฑ ํš๋“ ๊ณผ์ •์€ TCP 3way-handshake์™€ ๋น„์Šทํ•˜๋‹ค. EIGRP์™€ ๊ด€๋ จ๋œ ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›๋Š” ๊ณผ์ •์—์„œ ์‹ ๋ขฐ์„ฑ์„ ํš๋“ํ•œ๋‹ค.

[์žฅ์ ]
– ‘Update Cost’๋ฅผ ์ง€์›ํ•œ๋‹ค. ์ฆ‰, ๋ฉ”ํŠธ๋ฆญ์ด ๋‹ค๋ฅธ ๋‹ค์ˆ˜ ๊ฐœ์˜ ๊ฒฝ๋กœ๋ฅผ ๋™์‹œ์— ์‚ฌ์šฉํ•  ์ˆ˜์žˆ๋‹ค.
– ์„ค์ •์ด ๊ฐ„๋‹จํ•˜๋‹ค.

[๋‹จ์ ]
– Cisco ๋ผ์šฐํ„ฐ์—์„œ๋งŒ ๋™์ž‘ํ•œ๋‹ค.
– ๋Œ€๊ทœ๋ชจ ๋„คํŠธ์›Œํฌ์—์„œ ์šด์šฉ ์‹œ “SIA ํ˜„์ƒ”์ด ๋ฐœ์ƒํ•œ๋‹ค.

[๋ฉ”ํŠธ๋ฆญ]
– Bandwidth, Delay, Reliability, Load, MTU ๋ฐ Hop Count๋ฅผ ํŠน์ • ๊ณต์‹์— ๋Œ€์ž…ํ•˜์—ฌ ๊ณ„์‚ฐํ•œ๋‹ค. ์ด ๊ฐ’์„ ๋น„๊ตํ•˜์—ฌ ๊ฒฝ๋กœ์˜ ์šฐ์„  ์ˆœ์œ„๋ฅผ ๊ฒฐ์ •ํ•œ๋‹ค.
– ํŠน์ • ๊ณต์‹์— K ์ƒ์ˆ˜ 5๊ฐœ๊ฐ€ ๋“ค์–ด๊ฐ€ ์žˆ๊ณ , ์ˆœ์„œ๋Œ€๋กœ ‘1 0 1 0 0’์˜ ๊ธฐ๋ณธ ๊ฐ’์„ ๊ฐ€์ง€๊ณ  ์žˆ๋‹ค.

EIGRP ์„ค์ •

Router(config)# router eigrp <AS>
Router(config-router)# eigrp router-id <IP>
Router(config-router)# network <IP> <WILDCARD>

1: EIGRP๋ฅผ ์‚ฌ์šฉํ•˜๋Š” ๋ผ์šฐํ„ฐ๋Š” ๋™์ผํ•œ AS ๋ฒˆํ˜ธ๋ฅผ ๊ฐ–๊ณ  ์žˆ์–ด์•ผ ํ•œ๋‹ค.
2: ๋ณ„๋„๋กœ ์„ค์ •ํ•˜์ง€ ์•Š๋Š”๋‹ค๋ฉด, (1) ๊ฐ€์žฅ ๋†’์€ ๋ฃจํ”„๋ฐฑ IP (2) ๋ฌผ๋ฆฌ ์ธํ„ฐํŽ˜์ด์Šค ์ค‘ ๊ฐ€์žฅ ๋†’์€ IP๋กœ ์ž๋™ ํ• ๋‹น๋œ๋‹ค.


2. EIGRP ๋™์ž‘ ๊ณผ์ •

(1) Neighbor ๊ด€๊ณ„ ์ˆ˜๋ฆฝ
EIGRP ์„ค์ • ์ดํ›„ ์ธ์ •ํ•œ ๋ผ์šฐํ„ฐ์™€ Hello ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›๋Š”๋‹ค.
AS๋ฒˆํ˜ธ, K ์ƒ์ˆ˜ ๊ฐ’, EIRP ์•”ํ˜ธ ๊ฐ’ ๋“ฑ์ด ๋‹ค๋ฅด๋ฉด Neighbor๋ฅผ ์ˆ˜๋ฆฝํ•˜์ง€ ์•Š๋Š”๋‹ค.

(2) Neighbor Table ์ƒ์„ฑ
Neighbor ๊ด€๊ณ„ ์ˆ˜๋ฆฝ ํ›„ Neighbor Table์— ์ธ์ ‘ํ•œ ๋ผ์šฐํ„ฐ ์ •๋ณด๋ฅผ ์ €์žฅํ•œ๋‹ค. ์ฃผ๊ธฐ์ ์œผ๋กœ Hello ํŒจํ‚ท์„ ๋ณด๋‚ด์„œ Neighbor๋ฅผ ์œ ์ง€ํ•œ๋‹ค.

(3) ๋ผ์šฐํŒ… ์ •๋ณด ๊ตํ™˜ ๋ฐ Topology Table ๊ตฌ์„ฑ
Neighbor๋ฅผ ๋งบ์€ ๋ผ์šฐํ„ฐ๋ผ๋ฆฌ Update ํŒจํ‚ท์„ ์ด์šฉํ•ด ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๊ตํ™˜ํ•œ๋‹ค. ์ด Update ํŒจํ‚ท๊ณผ EIGRP ๋กœ์ปฌ ์ •๋ณด๋ฅผ ํ•ฉ์ณ Topology Table์„ ๊ตฌ์„ฑํ•œ๋‹ค.

(4) ๋ผ์šฐํŒ… ๊ฒฝ๋กœ ๊ณ„์‚ฐ ๋ฐ Routing Table ์ €์žฅ
์ฒ˜์Œ Topology Table์— ๋“ฑ๋ก๋œ EIGRP ๊ฒฝ๋กœ๋Š” Active ์ƒํƒœ์ด๋‹ค.
Passive ์ƒํƒœ๊ฐ€ ๋˜๋ฉด Routing Table์— ํ•ด๋‹น ๊ฒฝ๋กœ๋ฅผ ์ €์žฅํ•  ์ˆ˜ ์žˆ๋‹ค.
(Active ์ƒํƒœ๋ž€, ํ•ด๋‹น ๊ฒฝ๋กœ๋ฅผ ์ตœ์  ๊ฒฝ๋กœ๋กœ ์‚ฌ์šฉํ•˜๊ธฐ ์œ„ํ•œ ๊ณ„์‚ฐ ๊ณผ์ •์ด ์ง„ํ–‰ ์ค‘์ธ ์ƒํƒœ์ด๋‹ค. ๊ณ„์‚ฐ์ด ๋๋‚˜๋ฉด Passive ์ƒํƒœ๋กœ ๋ฐ”๋€๋‹ค.)

โ€ป EIGRP ์šด์šฉ ์ค‘ ํ† ํด๋กœ์ง€ ๋ณ€๋™์‚ฌํ•ญ ๋ฐœ์ƒ

(ex. ๋กœ์ปฌ ์ •๋ณด๊ฐ€ ์‚ญ์ œ๋œ ๊ฒฝ์šฐ, ์ตœ์  ๊ฒฝ๋กœ์— ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ•œ ๊ฒฝ์šฐ)

(1) ๋ผ์šฐํŒ… ์ •๋ณด ์š”์ฒญ
Query ํŒจํ‚ท์„ ์ „์†กํ•˜์—ฌ, ๋ชฉ์ ์ง€๊นŒ์ง€์˜ ๋Œ€์ฒด ๊ฒฝ๋กœ๋‚˜ ๋ชฉ์ ์ง€๊นŒ์ง€์˜ ๋„๋‹ฌํ•˜๋Š”์ง€ ํ™•์ธ์„ ์š”์ฒญํ•œ๋‹ค.

(2) ๋ผ์šฐํŒ… ์ •๋ณด ์ˆ˜์‹ 
์ƒ๋Œ€ ๋ผ์šฐํ„ฐ๋กœ๋ถ€ํ„ฐ Reply ํŒจํ‚ท์„ ๋ฐ›๋Š”๋‹ค.


3. EIGRP ํŒจํ‚ท ์ข…๋ฅ˜

(1) ํŒจํ‚ท ์ข…๋ฅ˜

Hello ํŒจํ‚ท

– Neighbor๋ฅผ ๊ตฌ์„ฑํ•˜๊ณ  ์œ ์ง€ํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
– ๋ชฉ์ ์ง€ ์ฃผ์†Œ๋กœ Multicast 224.0.0.10 ์„ ์‚ฌ์šฉํ•œ๋‹ค.

Update ํŒจํ‚ท

– ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ „์†กํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
– NBMA ๋„คํŠธ์›Œํฌ์˜ ๊ฒฝ์šฐ ๋ชฉ์ ์ง€ ์ฃผ์†Œ๋กœ Neighbor IP,
BMA ๋„คํŠธ์›Œํฌ์˜ ๊ฒฝ์šฐ Multicast 224.0.0.10์„ ์‚ฌ์šฉํ•œ๋‹ค.
– Update ํŒจํ‚ท ์ „์†ก ํ›„ Ack๋ฅผ ๋ชป๋ฐ›์œผ๋ฉด ์ตœ๋Œ€ 16๋ฒˆ๊นŒ์ง€ ๋‹ค์‹œ ์ „์†กํ•œ๋‹ค. ๊ทธ๋ž˜๋„ ์‘๋‹ต์ด ์—†์œผ๋ฉด Neighbor ๊ด€๊ณ„๋ฅผ ๋Š๋Š”๋‹ค.

Query ํŒจํ‚ท

– ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์š”์ฒญํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
(๋กœ์ปฌ ์ •๋ณด๊ฐ€ ์‚ญ์ œ๋˜๊ฑฐ๋‚˜ ๋ฉ”ํŠธ๋ฆญ์ด ๋ณ€๊ฒฝ๋œ ๋•Œ, Topology Table์— ๋Œ€์ฒด ๊ฒฝ๋กœ๊ฐ€ ์—†์„ ๋•Œ)
– ๋ชฉ์ ์ง€๋Š” ์œ„์™€ ๊ฐ™๋‹ค.

Reply ํŒจํ‚ท

– Query(๋ผ์šฐํŒ… ์ •๋ณด ์š”์ฒญ)์— ์‘๋‹ตํ•  ๋•Œ ์‚ฌ์šฉ๋œ๋‹ค.
– Ack ํŒจํ‚ท๊ณผ ๋‹ค๋ฅธ ํŒจํ‚ท์ด๋‹ค.

Ack ํŒจํ‚ท

– Update, Query, Reply ํŒจํ‚ท ์ˆ˜์‹  ์‹œ ํ™•์ธํ–ˆ๋‹ค๊ณ  ์‘๋‹ตํ•˜๋Š” ํŒจํ‚ท์ด๋‹ค.

(2) ํŒจํ‚ท ํฌ๋งท

<Format : EIGRP Packet>

Version: EIGRP ๋ฒ„์ „, ํ˜„์žฌ EIGRP ๋ฒ„์ „์€ 2์ด๋‹ค.
Opcode: EIGRP ํŒจํ‚ท ์ข…๋ฅ˜๋ฅผ ์ง€์ •ํ•œ๋‹ค. Update (0x01), Query (0x03), Reply (0x04), Hello (0x05) ์ด๋‹ค. EIGRP Header ๋’ค์— ์˜ค๋Š” TLV๋ฅผ ๊ฒฐ์ •ํ•œ๋‹ค. Ack๋Š” 0์ด ์•„๋‹Œ ACK๋ฒˆํ˜ธ๋ฅผ ํฌํ•จํ•œ Hello ํŒจํ‚ท์ด๋‹ค.
Checksum: IP ํ—ค๋”๋ฅผ ์ œ์™ธํ•œ EIGRP ์ „์ฒด ํŒจํ‚ท์˜ ์ฒดํฌ์„ฌ์ด๋‹ค.
Flags: ์ฒซ๋ฒˆ์งธ LSB bit (0x00000001) – ์‹œ์ž‘ ๋น„ํŠธ, ์ƒˆ๋กœ์šด Neighbor ๊ด€๊ณ„๋ฅผ ์ˆ˜๋ฆฝํ•  ๋•Œ ๋ผ์šฐํŒ… ์—…๋ฐ์ดํŠธ์˜ ์ฒซ๋ฒˆ์งธ ์„ธํŠธ๋ฅผ ๋‚˜ํƒ€๋‚ธ๋‹ค.
๋‘๋ฒˆ์งธ LSB bit (0x00000002) – ์กฐ๊ฑด๋ถ€ ์ˆ˜์‹  ๋น„ํŠธ, RTP์—์„œ ์‚ฌ์šฉ๋œ๋‹ค.
*๋‹ค๋ฅธ ๋น„ํŠธ๋“ค์€ ์‚ฌ์šฉํ•˜์ง€ ์•Š๋Š”๋‹ค.
Sequence & ACK number: ์‹ ๋ขฐ์„ฑ์žˆ๋Š” EIGRP ๋ฉ”์„ธ์ง€ ๊ตํ™˜์„ ์œ„ํ•œ RTP์—์„œ ์‚ฌ์šฉํ•œ๋‹ค.
AS number: EIGRP AS ๋ฒˆํ˜ธ์ด๋‹ค.
TLV: 16bit์˜ Type ํ•„๋“œ, 16bit์˜ Length ํ•„๋“œ, TLB ์ข…๋ฅ˜์— ๋”ฐ๋ฅธ ๋‹ค์–‘ํ•œ ํ•„๋“œ ๊ฐœ์ˆ˜๋กœ ๊ตฌ์„ฑ๋˜์–ด ์žˆ๋‹ค. TLV ๊ฐ’์€ ์•„๋ž˜ ์‚ฌ์ง„ ์ฐธ๊ณ , ๋” ์ž์„ธํ•œ ์ •๋ณด๋Š” ์ด ์‚ฌ์ดํŠธ ์ฐธ๊ณ .

TLV Values,  (Written by Yap Chin Hoong, http://www.cisco.com)

4. EIGRP ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ๊ณผ ๋ณด์•ˆ

(1) ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ

EIGRP์—์„œ๋„ ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ ๊ธฐ๋Šฅ์„ ์ง€์›ํ•œ๋‹ค. ์ž๋™ ์ถ•์•ฝ์ด ๊ธฐ๋ณธ ๊ฐ’์ด๋ฏ€๋กœ ํ•ด๋‹น ๊ธฐ๋Šฅ์„ ์‚ฌ์šฉํ•˜์ง€ ์•Š์œผ๋ ค๋ฉด, ‘no auto-summary’๋ฅผ ํ•ด์•ผํ•œ๋‹ค.

์ถ•์•ฝ์„ ํ•˜๊ฒŒ ๋˜๋ฉด ์ถ•์•ฝ๋œ ๋„คํŠธ์›Œํฌ์˜ GW๊ฐ€ null 0์œผ๋กœ ๋œ๋‹ค. ๋ผ์šฐํŒ… ๋ฃจํ”„๋ฅผ ๋ฐฉ์ง€ ํ•˜๊ธฐ ์œ„ํ•จ์ด๋‹ค.

[Default Route ์ƒ์„ฑ]

Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>
Router(config)# router eigrp <AS>
Router(config-router)# redistribute static

[์ˆ˜๋™ ์ถ•์•ฝ]
์ถ•์•ฝ๋œ ์ •๋ณด๋ฅผ ๋‚ด๋ณด๋‚ด๊ณ ์ž ํ•˜๋Š” ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ์„ค์ •ํ•œ๋‹ค.

Router(config)# int <INTERFACE>
Router(config-if)# ip summary-address eigrp <AS> <SUMMARY_IP> <SUBNET>

* ์ถ•์•ฝํ•˜๋ฉด GW๊ฐ€ null 0์œผ๋กœ ์žกํžˆ๋Š” ์ด์œ 

R1์˜ ๋„คํŠธ์›Œํฌ ์ •๋ณด๋ฅผ ๋ฐ›์•„ ์ถ•์•ฝ ํ›„ R3์—๊ฒŒ ์ „ํŒŒ.

์ด ์ƒํ™ฉ์—์„œ R1์˜ 30.30.30.0/24 ๋„คํŠธ์›Œํฌ๊ฐ€ ๋‹ค์šด๋œ๋‹ค๋ฉด R2๊นŒ์ง€๋งŒ ํ†ต๋ณด๋œ๋‹ค. R3๋Š” ์ถ•์•ฝ๋˜์–ด์žˆ๊ณ , R2์—์„œ 30.0.0.0/8 ๋ชจ๋‘ ๋‹ค์šด๋˜์–ด์•ผ ํ†ต๋ณดํ•˜๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

๊ทธ ๋‹ค์Œ, R3๊ฐ€ 30.30.30.X๋กœ ๊ฐ€๋Š” ํŒจํ‚ท์„ ์ „๋‹ฌ ๋ฐ›์œผ๋ฉด ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ๋ณด๊ณ  R2๋กœ ๋ณด๋‚ธ๋‹ค. ํ•˜์ง€๋งŒ R2๋Š” 30.0.0.0/8์˜ ๊ฒŒ์ดํŠธ์›จ์ด๊ฐ€ null 0๊ณผ ๋งค์นญ๋œ ๊ฒƒ์„ ๋ณด๊ณ  ํ•ด๋‹น ํŒจํ‚ท์„ ํ๊ธฐํ•œ๋‹ค.

null 0์œผ๋กœ ์„ค์ •๋˜์ง€ ์•Š์•˜๋‹ค๋ฉด, R2์™€ R3๋Š” ์„œ๋กœ ๊ณ„์† ํŒจํ‚ท์„ ์ฃผ๊ณ ๋ฐ›์•˜์„ ๊ฒƒ์ด๋‹ค. ( = ๋ฃจํ•‘ )

(2) ๋„คํŠธ์›Œํฌ ๋ณด์•ˆ

EIGRP ๋„คํŠธ์›Œํฌ ์ƒ์—์„œ ๋ณด์•ˆ ์นจํ•ด๊ฐ€ ๋งŽ์€ ๊ณณ์€ PC์™€ ์—ฐ๊ฒฐ๋œ ๋ง, ์„œ๋ฒ„์™€ ์—ฐ๊ฒฐ๋˜๋Š” ๋„คํŠธ์›Œํฌ๋‹ค. ์ด๋Ÿฐ ๋„คํŠธ์›Œํฌ์—์„œ EIGRP ๋ณด์•ˆ์„ ์œ„ํ•ด ๋‘ ๊ฐ€์ง€ ๋ฐฉ๋ฒ•์„ ์ ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค. EIGRP ํŒจํ‚ท์„ ์ธ์ฆํ•˜๋Š” ๊ฒƒ๊ณผ ์•ก์„ธ์Šค ๋„คํŠธ์›Œํฌ๋Š” ์žฌ๋ถ„๋ฐฐ์‹œํ‚ค๋Š” ๊ฒƒ์ด๋‹ค.

[EIGRP ํŒจํ‚ท ์ธ์ฆ]
MD5, HMAC-SHA-256 ๋ฐฉ์‹์„ ํ†ตํ•ด ํŒจํ‚ท์˜ ๋ฌด๊ฒฐ์„ฑ์„ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

Router(config)# key chain <CHAIN_NAME>
Router(config-keychain)# key [0-2147483647]
Router(config-keychain-key)# key-string <WORD>
Router(config-keychain-key)# exit
Router(config-keychain)# exit
Router(config)#
Router(config)# int <INTERFACE>
Router(config-if)# ip authentication key-chain eigrp <AS> <CHAIN_NAME>
Router(config-if)# ip authentication mode eigrp <AS> [MD5|SHA]

1: ํ‚ค ์ฒด์ธ ์ด๋ฆ„์€ ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•˜์ง€ ์•Š์•„๋„ ๋œ๋‹ค.
2: ํ‚ค ๋ฒˆํ˜ธ๋Š” ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•ด์•ผ ํ•œ๋‹ค.
3: ์•”ํ˜ธ๋Š” ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•ด์•ผ ํ•œ๋‹ค.
7: eigrp ์ธ์ฆ ์„ค์ •์„ ์ ์šฉํ•  ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์ง„์ž…ํ•œ๋‹ค.
8-9: ์ธ์ฆ ์„ค์ •

[์•ก์„ธ์Šค ๋„คํŠธ์›Œํฌ ์žฌ๋ถ„๋ฐฐ]
PC๊ฐ€ ์—ฐ๊ฒฐ๋œ ์ข…๋‹จ ๋ถ€๋ถ„์€ EIGRP ํŒจํ‚ท์„ ๋ณด๋‚ผ ํ•„์š”๊ฐ€ ์—†๋‹ค. ์ด๋Ÿฐ ๋„คํŠธ์›Œํฌ๋กœ EIGRP ํŒจํ‚ท์„ ์ „์†กํ•˜์ง€ ์•Š๋„๋ก ํ•œ๋‹ค.

Router(config)# router eigrp <AS>
Router(config-router)# redistribute connected

์œ„์™€ ๋น„์Šทํ•œ ์„ค์ •์ด ์žˆ๋‹ค. Passive interface๋ฅผ ์„ค์ •ํ•˜์—ฌ, ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค๋กœ EIGRP Hello ํŒจํ‚ท์„ ์†ก์ˆ˜์‹ ํ•˜์ง€ ์•Š๋Š” ๊ฒƒ์ด๋‹ค.

Router(config)# router eigrp <AS>
Router(config-router)# passive-interface <INTERFACE>

5. EIGRP ๋ถ€ํ•˜๋ถ„์‚ฐ

EIGRP๋Š” ๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฐ’์„ ๊ฐ€์ง„ ๊ฒฝ๋กœ 32๊ฐœ๊นŒ์ง€ ๋ถ€ํ•˜ ๋ถ„์‚ฐ์„ ์ง€์›ํ•œ๋‹ค.

Equal Cost MultiPath ; ECMP

‘๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฒฝ๋กœ์— ๋Œ€ํ•œ ๋ถ€ํ•˜ ๋ถ„์‚ฐ’
๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฒฝ๋กœ๊ฐ€ ์—ฌ๋Ÿฌ ๊ฐœ๋ฉด, ๋ณ„๋„ ์„ค์ •์—†์ด ์ž๋™์œผ๋กœ ๋™์ž‘ํ•œ๋‹ค. ๊ธฐ๋ณธ๊ฐ’์€ ์ตœ๋Œ€ 4๊ฐœ๋กœ ์„ค์ •๋˜์–ด ์žˆ๋‹ค. ์ตœ๋Œ€ ๋ถ€ํ•˜๋ถ„์‚ฐ ๊ฒฝ๋กœ ์ง€์ •์€ ์•„๋ž˜์™€ ๊ฐ™์ด ํ•œ๋‹ค.

Router(config)# router eigrp <AS>
Router(config)# maximum-paths [1-32]

Unequal Cost MultiPath ; UCMP

‘๋ฉ”ํŠธ๋ฆญ ๊ฐ’์ด ์„œ๋กœ ๋‹ค๋ฅธ ๊ฒฝ๋กœ์— ๋Œ€ํ•œ ๋ถ€ํ•˜ ๋ถ„์‚ฐ’
UCMP๊ฐ€ ๋™์ž‘ํ•˜๊ธฐ ์œ„ํ•ด์„  2๊ฐ€์ง€ ์กฐ๊ฑด์„ ๋งŒ์กฑํ•ด์•ผ ํ•œ๋‹ค.
โ‘  Feasible Successor๋ฅผ ํ†ตํ•˜๋Š” ๊ฒฝ๋กœ
โ‘ก ‘Feasible  * variance’ ๋ณด๋‹ค ์ž‘์•„์•ผํ•œ๋‹ค.

[Router] RIP

Routing Information Protocol
์‚ฐ์—… ํ‘œ์ค€์œผ๋กœ ๊ฐœ๋ฐœ๋˜์—ˆ๋‹ค๊ฐ€ ์ดํ›„ ์ธํ„ฐ๋„ท ํ‘œ์ค€์œผ๋กœ ๋ฐœ์ „๋œ ํ”„๋กœํ† ์ฝœ.
Xerox(์ œ๋ก์Šค)์˜ PARC(ํŒ”๋กœ์•Œํ†  ์—ฐ๊ตฌ์†Œ)์—์„œ Ethernet ์œ„์— ์‚ฌ์šฉํ•  ๋” ๋†’์€ ๊ณ„์ธต์— ์†ํ•œ PUP(PARC Universal Protocol)์„ ๊ฐœ๋ฐœํ–ˆ๋‹ค.
๊ทธ๋ฆฌ๊ณ  PUP ๋ผ์šฐํŒ…์— ์‚ฌ์šฉํ•˜๊ธฐ ์œ„ํ•œ GWINFO(๊ฒŒ์ดํŠธ์›จ์ด ์ •๋ณด ํ”„๋กœํ† ์ฝœ)์„ ๋งŒ๋“ค์—ˆ๊ณ , ์ด๊ฒŒ RIP๊ฐ€ ๋˜์—ˆ๋‹ค.
RIP๋Š” BSD์—์„œ ์‚ฌ์šฉ๋˜๋ฉด์„œ ๋„๋ฆฌ ์“ฐ์ด๊ฒŒ ๋˜์—ˆ๋‹ค. 1988๋…„ IETF์—์„œ RFC 1058 “Routing Information Protocol”์„ ์ •์‹ ๋ช…์‹œํ•˜์˜€๋‹ค.

  1. RIP ํŠน์ง•
  2. RIP ํŒจํ‚ท ํฌ๋งท
  3. RIP ์„ค์ •
  4. RIP ๋ณด์•ˆ

1. RIP ํŠน์ง•

– RIPv1, RIPv2, IPv6์šฉ RIPng๊ฐ€ ์žˆ๋‹ค.
– RIPv1, v2๋Š” UDP 520๋ฒˆ, RIPng๋Š” UDP 521๋ฒˆ์„ ์‚ฌ์šฉํ•œ๋‹ค.
– ํ•œ ์žฅ๋น„๋กœ๋งŒ ์ „์†กํ•  ๋•Œ๋Š” Unicast ๋ฐฉ์‹์„ ์‚ฌ์šฉํ•œ๋‹ค. ์—ฌ๋Ÿฌ ์žฅ๋น„๋กœ ์ „์†กํ•  ๋•Œ, RIPv1๋Š” Broadcast, RIPv2์™€ RIPng๋Š” Multicast ๋ฐฉ์‹์„ ์‚ฌ์šฉํ•œ๋‹ค.
– ๋ฉ”ํŠธ๋ฆญ์œผ๋กœ Hop count ๋ฅผ ์‚ฌ์šฉํ•˜๋ฉฐ, ๋งํฌ ์†๋„๋ฅผ ๋ฐ˜์˜ํ•˜์ง€ ์•Š๋Š”๋‹ค. ๋ผ์šฐํ„ฐ ํ™‰ ์ˆ˜๊ฐ€ 16 ์ด์ƒ์ผ ๋•Œ, ๋„๋‹ฌํ•  ์ˆ˜ ์—†๋Š” ๋„คํŠธ์›Œํฌ๋ผ๊ณ  ํŒ๋‹จํ•œ๋‹ค.
– ํ† ํด๋กœ์ง€ ๋ณ€ํ™”์™€ ์ƒ๊ด€์—†์ด 30์ดˆ๋งˆ๋‹ค ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ” ์ „์ฒด๋ฅผ ์ธ์ ‘ ๋ผ์šฐํ„ฐ๋กœ ์ „์†กํ•˜๊ณ , ์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์ด ๊ธธ๋‹ค.

1-1. ๋ฉ”์„ธ์ง€ ์œ ํ˜•

(1) RIP Request : ํƒ€ ๋ผ์šฐํ„ฐ์˜ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ” ์ผ๋ถ€/์ „์ฒด๋ฅผ ์š”์ฒญํ•œ๋‹ค. ex) ๋ผ์šฐํ„ฐ๊ฐ€ ์ผœ์กŒ์„ ๋•Œ.
(2) RIP Respond : ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ” ์ผ๋ถ€/์ „์ฒด๋ฅผ ์ „์†กํ•œ๋‹ค. 30์ดˆ๋งˆ๋‹ค ์ „์†กํ•˜๊ฑฐ๋‚˜ Request ๋ฉ”์„ธ์ง€์— ๋Œ€ํ•œ ์‘๋‹ต์œผ๋กœ ์ „์†กํ•œ๋‹ค.

1-2. Timer

(1) ํŠน์ • ๋งํฌ๊ฐ€ ๋งŒ๋ฃŒ๋˜๋Š” ์ƒํ™ฉ์— ๋Œ€๋น„ํ•˜๊ธฐ ์œ„ํ•ด 180์ดˆ์˜ Timeout Timer๋ฅผ ๊ฐ–๋Š”๋‹ค. 180์ดˆ ์•ˆ์— ํ•ด๋‹น ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๋ฐ›์œผ๋ฉด Timer๋Š” ์ดˆ๊ธฐํ™” ๋˜๊ณ , ๊ทธ๋ ‡์ง€ ์•Š์œผ๋ฉด Metric์„ 16์œผ๋กœ ์˜ฌ๋ฆฐ ํ›„ ๋‹ค์Œ ๋‹จ๊ณ„๋กœ ๋„˜์–ด๊ฐ„๋‹ค.
(2) Garbage-Collection Timer๋ฅผ ๋™์ž‘์‹œ์ผœ 120์ดˆ ๋™์•ˆ ์‚ญ์ œ ๋Œ€๊ธฐ๋ฅผ ํ•œ๋‹ค. ์ด ๋•Œ, Respond ๋ฉ”์„ธ์ง€๋ฅผ ๋ณด๋‚ด๋”๋ผ๋„ ์‚ญ์ œ ๋Œ€๊ธฐ ์ค‘์ธ ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ํฌํ•จ์‹œ์ผœ ์ „์†กํ•œ๋‹ค. ๋งŒ์•ฝ ๋‹ค๋ฅธ ๋ผ์šฐํ„ฐ๋กœ ํ•ด๋‹น ๋ผ์šฐํŒ… ์ •๋ณด๊ฐ€ ๋“ค์–ด์˜ค๋ฉด, ์œ ํšจํ•œ ๋ผ์šฐํŒ… ์ •๋ณด๋กœ ๊ฐ„์ฃผํ•˜๊ณ  ์ฆ‰์‹œ Timer๋ฅผ ์ดˆ๊ธฐํ™” ์‹œํ‚จ๋‹ค.

*** ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์‚ญ์ œํ•˜๊ธฐ ์ „ Timeout Timer, Garbage-Collection Timer๋ฅผ ๊ฑฐ์ณ์•ผ ์‚ญ์ œ๋œ๋‹ค.


2. RIP ํŒจํ‚ท ํฌ๋งท

[ RIP ๋ฉ”์„ธ์ง€ ํฌ๋งท ]
– Command: RIP ๋ฉ”์„ธ์ง€ ์œ ํ˜• ์ง€์ •. 1 – RIP Request, 2 – RIP Respond
– Version: RIP ๋ฒ„์ „ ์ง€์ •
– 0: ์˜ˆ์•ฝ๋œ ํ•„๋“œ๋กœ 0์œผ๋กœ ํŒจ๋”ฉ
– RTE: ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๊ฐ–๊ณ  ์žˆ๋Š” ํ•„๋“œ. ์ตœ์†Œ 1๊ฐœ~ ์ตœ๋Œ€ 25๊ฐœ์˜ ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๊ฐ–๊ณ  ์žˆ๋‹ค.

[ RTE ํฌ๋งท ]
– Address Family Identifier: ์ฃผ์†Œ ์œ ํ˜• ์ง€์ •. IP์ฃผ์†Œ๋Š” 2๋กœ ์ง€์ •
– Router Tag: ๊ฒฝ๋กœ์— ๋Œ€ํ•œ ์ถ”๊ฐ€ ์ •๋ณด
– IP ์ฃผ์†Œ, Subnet Mask, Next Hop, Metric

๋งŒ์•ฝ, RIP ์ธ์ฆ์„ ์‚ฌ์šฉํ•˜๊ฒŒ๋˜๋ฉด,  ๋ผ์šฐํŒ… ์ •๋ณด์— ์ธ์ฆ ์ •๋ณด 1๊ฐœ๊ฐ€ ํฌํ•จ๋˜๊ธฐ ๋•Œ๋ฌธ์— ์ตœ๋Œ€ 24๊ฐœ๊นŒ์ง€ ๊ฐ–์„ ์ˆ˜ ์žˆ๋‹ค.


3. RIP ์„ค์ •

3-1. RIP ๊ธฐ๋ณธ ์„ค์ •

RIP ์„ค์ • ์‹œ ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ „์†กํ•˜๋Š” ์ธํ„ฐํŽ˜์ด์Šค๋Š” ๋ฐ˜๋“œ์‹œ ์„ค์ •์— ํฌํ•จ.

Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# network <NETWORK_ID>

3-2. RIP ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ

Default Route ๊ด‘๊ณ 
RIP๊ฐ€ ๋™์ž‘ํ•˜๋Š” ์ธ์ ‘ ๋ผ์šฐํ„ฐ๋กœ Default Route๋ฅผ ๊ด‘๊ณ ํ•œ๋‹ค.

# ๋ฐฉ๋ฒ• 1
Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>
Router(config)# router rip
Router(config-router)# default-information originate

# ๋ฐฉ๋ฒ• 2
Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>
Router(config)# router rip
Router(config-router)# redistribute static

RIP ์ž๋™ ์ถ•์•ฝ
์ถ•์•ฝ์„ ํ†ตํ•ด ๋„คํŠธ์›Œํฌ์˜ ์•ˆ์ •์„ฑ๊ณผ ์„ฑ๋Šฅ์„ ํ–ฅ์ƒ์‹œํ‚ฌ ์ˆ˜ ์žˆ๋‹ค. ์ž๋™ ์ถ•์•ฝ์€ ๊ธฐ๋ณธ์œผ๋กœ ์„ค์ •๋˜์–ด ์žˆ๋‹ค.
172.30.1.0/24๋ฅผ ์‚ฌ์šฉํ•˜๋Š” ๋„คํŠธ์›Œํฌ๋ฅผ ๊ด‘๊ณ ํ•  ๋•Œ,  ์ž๋™ ์ถ•์•ฝ์ด ๋˜์–ด์žˆ๋‹ค๋ฉด IP ํด๋ž˜์Šค์— ๋งž๊ฒŒ 172.30.0.0/16์œผ๋กœ ๊ด‘๊ณ ํ•œ๋‹ค.

# ์ž๋™ ์ถ•์•ฝ ํ•ด์ œ
Router(config)# router rip
Router(config-router)# no auto-summary

RIP ์ˆ˜๋™ ์ถ•์•ฝ
๊ด€๋ฆฌ์ž ์ž„์˜๋กœ ๋„คํŠธ์›Œํฌ๋ฅผ ์ถ•์•ฝํ•œ๋‹ค. ์ˆ˜๋™์œผ๋กœ ์ถ•์•ฝํ•  ๋•Œ, ์ฃผ ๋„คํŠธ์›Œํฌ ๋ฒ”์œ„ ๋‚ด์—์„œ๋งŒ ์ถ•์•ฝํ•  ์ˆ˜ ์žˆ๋‹ค. RIPv2๋กœ ์ž๋™ ์ถ•์•ฝ ํ•ด์ œ๋œ ์ƒํƒœ์—์„œ๋งŒ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค.
‘192.168.0.128/26’, ‘192.168.0.192/26’ 
—โ†’ ‘192.168.0.128/25’ ์ถ•์•ฝ ๊ฐ€๋Šฅ
‘192.168.0.0/24’, ‘192.168.1.0/24’
—โ†’ ‘192.168.0.0/23’ ์ถ•์•ฝ ๋ถˆ๊ฐ€

Router(config)# int <INTERFACE>
Router(config-if)# ip summary-address rip <NETWORK_ID> <SUBNET>

3-3. Offset List๋ฅผ ์ด์šฉํ•œ ๋ฉ”ํŠธ๋ฆญ ์กฐ์ •

Offset List๋ž€, EIGRP๋‚˜ RIP์™€ ๊ฐ™์€ ๊ฑฐ๋ฆฌ ๋ฒกํ„ฐ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์—์„œ ์‚ฌ์šฉํ•˜๋Š” ‘์†ก.์ˆ˜์‹  ๋ฉ”ํŠธ๋ฆญ์„ ์ฆ๊ฐ€์‹œํ‚ค๋Š” ๋ฉ”์ปค๋‹ˆ์ฆ˜’์ด๋‹ค.

์˜ˆ๋ฅผ ๋“ค์–ด, ์•„๋ž˜์™€ ๊ฐ™์€ ํ† ํด๋กœ์ง€๊ฐ€ ์žˆ๋‹ค๊ณ  ๊ฐ€์ •ํ•ด๋ณด์ž.

ํ† ํด๋กœ์ง€. OFFSET LIST

๊ฒฝ๋กœ A(R1โ†’R2โ†’R3) ์™€ B(R1โ†’R3)๋ฅผ ๋ถ€ํ•˜ ๋ถ„์‚ฐ ์‹œํ‚ค๊ธฐ ์œ„ํ•ด์„  Offset List๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค. A์˜ ๋ฉ”ํŠธ๋ฆญ์€ 2, B์˜ ๋ฉ”ํŠธ๋ฆญ์€ 1์ด๋ฏ€๋กœ B์˜ ๋ฉ”ํŠธ๋ฆญ์„ 1 ์˜ฌ๋ ค์ฃผ์–ด์•ผ ํ•œ๋‹ค.

R1(config)# ip access-list standard <ACL_NAME>
R1(config-std-nacl)# permit <NETWORK_ID> <WILDMASK>
R1(config-std-nacl)# exit
R1(config)# 
R1(config)# router rip
R1(config-router)# offset-list <ACL_NAME> in [0-16] <INTERFACE>
R1(config-router)# offset-list <ACL_NAME> out [0-16] <INTERFACE>

-----

R1(config)# ip access-list standard IP_LIST
R1(config-std-nacl)# permit 10.10.10.0 0.0.0.255
R1(config-std-nacl)# exit
R1(config)# 
R1(config)# router rip
R1(config-router)# offset-list IP_LIST in 1 fa0/1
R1(config-router)# offset-list IP_LIST out 1 fa0/1

1: ACL์„ ์ด์šฉํ•ด ๋ฉ”ํŠธ๋ฆญ์„ ์กฐ์ •ํ•  ๋„คํŠธ์›Œํฌ๋ฅผ ์ง€์ •ํ•œ๋‹ค.
6: in-๋ผ์šฐํŒ… ์ •๋ณด ์ˆ˜์‹  ์‹œ ๋ฉ”ํŠธ๋ฆญ ์ฆ๊ฐ€, out-๋ผ์šฐํŒ… ์ •๋ณด ์†ก์‹  ์‹œ ๋ฉ”ํŠธ๋ฆญ ์ฆ๊ฐ€, ๋ฉ”ํŠธ๋ฆญ ๊ฐ’์€ 0~16 ๊ฐ’์„ ์ง€์ •ํ•  ์ˆ˜ ์žˆ๋‹ค.


4. RIP ๋ณด์•ˆ

4-1. ๋ผ์šฐํŒ… ์ •๋ณด ์ธ์ฆ

๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ˆ˜์‹ ํ•  ๋•Œ, ์•”ํ˜ธ๊ฐ€ ์ผ์น˜ํ•  ๋•Œ๋งŒ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์— ์ €์žฅํ•œ๋‹ค. ์ง์ ‘ ์—ฐ๊ฒฐ๋œ ์žฅ๋น„๋ผ๋ฆฌ๋งŒ ์„ค์ •ํ•˜๋ฉด ๋œ๋‹ค. ์–‘์ชฝ ๋ผ์šฐํ„ฐ ๋ชจ๋‘ ์„ค์ •ํ•œ๋‹ค.

์„ค์ •

Router(config)# key chain <CHAIN_NAME>
Router(config-keychain)# key [0-2147483647]
Router(config-keychain-key)# key-string <WORD>
Router(config-keychain-key)# exit
Router(config-keychain)# exit
Router(config)# 
Router(config)# int <INTERFACE>
Router(config-if)# ip rip authentication key-chain <CHAIN_NAME>
Router(config-if)# ip rip authentication mode [md5|text]

4-2. ๋ผ์šฐํŒ… ์ •๋ณด ์ฐจ๋‹จ

ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์˜ค๋Š” ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ฐจ๋‹จํ•œ๋‹ค.

์„ค์ •

Router(config)# ip prefix-list <PREFIX_NAME> deny 0.0.0.0/0 le 32
Router(config)#
Router(config)# router rip
Router(config-router)# distribute-list prefix <PREFIX_NAME> in <INTERFACE>
Router(config-router)# distribute-list prefix <PREFIX_NAME> out <INTERFACE>

1: (1) ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ฐจ๋‹จํ•˜๊ธฐ ์œ„ํ•ด Prefix List๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค. Access List๋ฅผ ์‚ฌ์šฉํ•ด๋„ ๋œ๋‹ค. (2) ๋งŒ์ผ, ํŠน์ • ๊ด‘๊ณ ๋งŒ ๋ฐ›์œผ๋ ค๋ฉด deny๋Œ€์‹  permit์„ ์‚ฌ์šฉํ•œ๋‹ค. ‘deny 0.0.0.0/0 le 32’๋Š” ๋ชจ๋“  ๋„คํŠธ์›Œํฌ๋ฅผ ์ฐจ๋‹จํ•œ๋‹ค๋Š” ์˜๋ฏธ์ด๋‹ค. Prefix List์— ๋Œ€ํ•œ ๋‚ด์šฉ์€ ์ถ”ํ›„ ๋‹ค์‹œ ์ž์„ธํžˆ ํ™•์ธํ•ด๋ณด๋„๋ก ํ•œ๋‹ค.
4,5: in์€ ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์ˆ˜์‹ ํ•˜๋Š” ๊ฒƒ์— ๋Œ€ํ•œ ๋‚ด์šฉ, out์€ ์†ก์‹ ํ•˜๋Š” ๊ฒƒ์— ๋Œ€ํ•œ ๋‚ด์šฉ์„ ์˜๋ฏธํ•œ๋‹ค.

[Router] Static Routing

๋ผ์šฐํŒ…์„ ์ฒ˜์Œ ๋ฐฐ์šด๋‹ค๋ฉด, ํ•ญ์ƒ ๋จผ์ € ๋ฐฐ์šฐ๊ฒŒ ๋˜๋Š” Static Routing์ด๋‹ค. ์ฒ˜์Œ์—๋Š” Static Routing์— ๋ณ„๊ฑฐ ์žˆ๊ฒ ๋‚˜ ์‹ถ์—ˆ์ง€๋งŒ, ๋ถ€ํ•˜๋ถ„์‚ฐ(์ดํ•˜ LB)๋„ ๋˜๋‹ˆ ๋‹ค์‹œ ํ•œ๋ฒˆ ์งš๊ณ  ๋„˜์–ด๊ฐˆ ํ•„์š”๊ฐ€ ์žˆ๋‹ค.

1. Static Routing ํŠน์ง•
2. Static Routing ๋ถ€ํ•˜๋ถ„์‚ฐ


1. Static Routing

‘Static’, ๊ด€๋ฆฌ์ž๊ฐ€ ์ง์ ‘ ์ •์ (๊ณ ์ •๋œ) ๊ฒฝ๋กœ๋ฅผ ์„ค์ •ํ•œ๋‹ค.

Routing protocol๋กœ ์ธํ•œ ๋ถ€ํ•˜๊ฐ€ ๊ฑฐ์˜ ์—†๊ณ , ๊ด€๋ฆฌ์ž ์˜๋„๋Œ€๋กœ ์ •๋ฐ€ํ•˜๊ฒŒ ๋ผ์šฐํŒ…ํ•  ์ˆ˜ ์žˆ๋‹ค. ํ•˜์ง€๋งŒ ๋„คํŠธ์›Œํฌ์— ๋ณ€ํ™”๊ฐ€ ์ƒ๊ธธ ๊ฒฝ์šฐ ๊ด€๋ฆฌ์ž๊ฐ€ ์ผ์ผํžˆ ๋Œ€์‘ํ•ด์•ผํ•˜๋ฏ€๋กœ ๋‹จ์ ์ด ๋  ์ˆ˜ ์žˆ๊ณ , ๋”๋ถˆ์–ด ๋„คํŠธ์›Œํฌ์˜ ๊ทœ๋ชจ๊ฐ€ ์ปค์ง€๋ฉด ์—ญ์‹œ ์„ค์ •์ด๋‚˜ ๊ด€๋ฆฌ๊ฐ€ ์–ด๋ ต๊ฒŒ ๋œ๋‹ค.

์„ค์ •

# Static Routing
Router(config)# ip route <DESTINATION_NETWORK> <D_N_SUBNET> <NEXT_HOP_IP>

# Default Routing
Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>

* Default-gateway์™€ Default route์˜ ์ฐจ์ด?
Default-gateway๋Š” ๋ผ์šฐํŒ… ๊ธฐ๋Šฅ์ด ๋™์ž‘ํ•˜์ง€ ์•Š์„ ๋•Œ, (์˜ˆ๋ฅผ ๋“ค์–ด L2 ๊ธฐ๋Šฅ๋งŒ ์‚ฌ์šฉํ•˜๋Š” ์Šค์œ„์น˜) ์‚ฌ์šฉํ•œ๋‹ค.
Default route๋Š” ๋ผ์šฐํŒ… ๊ธฐ๋Šฅ๊ณผ ํ•จ๊ป˜ ๋™์ž‘ํ•œ๋‹ค.

Floating Static Routing
Static Route์˜ AD ๊ฐ’์„ ์ž„์˜๋กœ ๋†’๊ฒŒ ์„ค์ •ํ•˜์—ฌ ํŠน์ • ๊ฒฝ๋กœ๋กœ ํŒจํ‚ท์„ ์ „์†กํ•˜๋„๋ก ํ•œ๋‹ค. ๊ทธ๋Ÿฌ๋‹ค ํ•ด๋‹น ๊ฒฝ๋กœ์— ๋ฌธ์ œ๊ฐ€ ๋ฐœ์ƒํ•˜๋ฉด, ๋‹ค๋ฅธ ๊ฒฝ๋กœ๋กœ ์ž๋™ ์ „์†ก๋˜๋„๋ก ํ•œ๋‹ค.  AD๊ฐ’์„ ์„ค์ •ํ•˜๊ณ ์ž ํ•˜๋ฉด, ์–‘์ชฝ์—์„œ ์„ค์ •ํ•ด์•ผ ํ•œ๋‹ค.

Router(config)# ip route <DESTINATION_NETWORK> <D_N_SUBNET> <NEXT_HOP_IP> <AD_COST>

2. Static Routing ๋ถ€ํ•˜๋ถ„์‚ฐ

Static Routing์œผ๋กœ๋„ LB๋ฅผ ํ•  ์ˆ˜ ์žˆ๋‹ค.
์šฐ์„ , ๋ผ์šฐํ„ฐ์˜ ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ๋ชฉ์ ์ง€ ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์ „์†กํ•˜๋Š” Switching ๋ฐฉ์‹์— ๋”ฐ๋ผ ๋ผ์šฐํ„ฐ์—์„œ ํŒจํ‚ท ์†ก์‹  ๊ฒฝ๋กœ ์ง€์ • ๋ฐฉ์‹์ด ๋‹ฌ๋ผ์ง„๋‹ค.

๋ฐฉ์‹1: CEF

Cisco Express Forwarding
์‹œ์Šค์ฝ” ๋ผ์šฐํ„ฐ์—์„œ ๊ธฐ๋ณธ์ ์œผ๋กœ ์‚ฌ์šฉํ•˜๋Š” ๋ฐฉ์‹์ด๋‹ค. ์ฒ˜์Œ๋ถ€ํ„ฐ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ์บ์‹œ๋กœ ๋ณต์‚ฌํ•ด๋†“์œผ๋ฏ€๋กœ ์†๋„๊ฐ€ ๋น ๋ฅด๋‹ค. ๊ธฐ๋ณธ๊ฐ’์ด๊ธฐ ๋•Œ๋ฌธ์— ๋ณ„๋„ ์„ค์ •ํ•  ํ•„์š”๊ฐ€ ์—†๋‹ค.

๋ฐฉ์‹2: Process Switching

๊ฐ๊ฐ์˜ ํŒจํ‚ท์„ ์ „์†กํ•  ๋•Œ๋งˆ๋‹ค ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ํ™•์ธํ•œ ๋’ค Next Hop์„ ๊ฒฐ์ •ํ•˜์—ฌ ํŒจํ‚ท์„ ์ „์†กํ•œ๋‹ค. Switching ์†๋„๊ฐ€ ๋Š๋ฆฌ๊ณ , ํŒจํ‚ท ๋””๋ฒ„๊น…๊ณผ ๊ฐ™์ด ํŠน๋ณ„ํ•œ ๊ฒฝ์šฐ์—๋งŒ ์‚ฌ์šฉํ•œ๋‹ค.

Router(config)# int <INTERFACE>
Router(config-if)# no ip load-sharing per-packet
Router(config-if)# exit
Router(config)#
Router(config)# no ip cef