[Router] EIGRP: SIA ๋ฐฉ์ง€

Stuck In Active
EIGRP ๋ผ์šฐํ„ฐ๊ฐ€ ์ธ์ ‘ Neighbor๋กœ๋ถ€ํ„ฐ Query์— ๋Œ€ํ•œ Reply๋ฅผ ๋ฐ›์ง€ ๋ชปํ•œ ์ƒํƒœ๋ฅผ Active ์ƒํƒœ๋ผ๊ณ  ํ•˜๋Š”๋ฐ, ์ด ์ƒํƒœ๊ฐ€ ์ง€์†๋˜๋Š” ํ˜„์ƒ์„ ๋งŒํ•œ๋‹ค.
์ตœ๋Œ€ 180์ดˆ ๋™์•ˆ Reply ์ˆ˜์‹ ๋˜๊ธฐ๋ฅผ ๊ธฐ๋‹ค๋ฆฌ๋‹ค๊ฐ€ 180์ดˆ๊ฐ€ ์ง€๋‚˜๋ฉด Reply๋ฅผ ๋ณด๋‚ด์ง€ ์•Š์€ ๋ผ์šฐํ„ฐ์™€ Neighbor ๊ด€๊ณ„๋ฅผ ํ•ด์ง€ํ•œ๋‹ค.

์ž, ์•„๋ž˜์™€ ๊ฐ™์€ ํ† ํด๋กœ์ง€๋ฅผ ๋ณด๋„๋ก ํ•˜์ž.

R1 โ†’ R4๋กœ  Query๋ฅผ ๋ณด๋ƒˆ์ง€๋งŒ,  R4๋Š” Reply๋ฅผ ๋ณด๋‚ด์ง€ ์•Š๋Š” ์ƒํƒœ.

์ด ๊ฒฝ์šฐ์—” R1, R2, R3 ๋ชจ๋‘ R4์˜ Reply๋ฅผ ๊ธฐ๋‹ค๋ฆฐ๋‹ค. ์ด๋Ÿฐ ๊ณผ์ •์ด ์—ฌ๋Ÿฌ ๋ฒˆ ๋ฐ˜๋ณต๋˜๋ฉด ๋„คํŠธ์›Œํฌ๊ฐ€ ๋ถˆ์•ˆ์ •ํ•ด์ง„๋‹ค.

R4 ์ž…์žฅ์—์„œ Reply๋ฅผ ๋ณด๋‚ด์ง€ ๋ชปํ•˜๋Š” ์ด์œ ๋Š” ‘R3 – R4 ๊ฐ„ ๋งํฌ’์˜ ํŠธ๋ž˜ํ”ฝ์ด ๊ณผ๋‹คํ•˜๊ฑฐ๋‚˜ ์ž˜๋ชป ์„ค์ •ํ•œ ๊ฒƒ ๋“ฑ๋“ฑ ๋ผ์šฐํ„ฐ์— ๋ถ€ํ•˜๊ฐ€ ๊ฑธ๋ ค ๋ณด๋‚ด์ง€ ๋ชปํ•œ๋‹ค๊ณ  ๋ณผ ์ˆ˜ ์žˆ๋‹ค.

SIA ๋ฐฉ์ง€ ๋Œ€์ฑ…

1. SIA ํƒ€์ด๋จธ ์กฐ์ •

SIA ํ˜„์ƒ์— ์˜ํ•ด Neighbor๊ฐ€ ํ•ด์ง€๋˜๋Š” ๊ฒƒ์„ ๋ฐฉ์ง€ ํ•œ๋‹ค. Reply Hold ์‹œ๊ฐ„์„ ๋Š˜๋ ค์„œ Neighbor ๊ด€๊ณ„ ์ง€์† ์‹œ๊ฐ„์„ ์ฆ๊ฐ€์‹œํ‚ค๋Š” ๊ฒƒ์ด๋‹ค.

ํ•˜์ง€๋งŒ ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ•  ๊ฒฝ์šฐ ๋„คํŠธ์›Œํฌ์˜ ๋Œ€์ฒด ๊ฒฝ๋กœ๊ฐ€ ์žˆ์–ด๋„ Reply Hold ์‹œ๊ฐ„์ด ๊ธธ์–ด์กŒ๊ธฐ ๋•Œ๋ฌธ์— ๋Œ€์ฒด ๊ฒฝ๋กœ๋ฅผ ๋ผ์šฐํŒ…์— ์ €์žฅ์‹œํ‚ค๋Š” ์‹œ๊ฐ„๋„ ๋Š˜์–ด๋‚œ๋‹ค. (=์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์ด ๊ธธ์–ด์ง„๋‹ค.)

[์„ค์ •]

Router(config)# router eigrp <AS>
Router(config-router)# timers active-time [1-65535]

2. Query Scoping

Query ํŒจํ‚ท์ด ์ ๋‹นํ•œ ์„ ์—์„œ ๋ฉˆ์ถ”๋„๋ก ํ•˜๋Š” ๊ฒƒ์„ ๋งํ•œ๋‹ค. Query ํŒจํ‚ท์„ ๋ฐ›์€ ๊ฒƒ๊ณผ ๋™์ผ ๋„คํŠธ์›Œํฌ๊ฐ€ Topology table์— ์กด์žฌํ•˜์ง€ ์•Š์œผ๋ฉด ํŒจํ‚ท์„ ์ „ํŒŒํ•˜์ง€ ์•Š๋Š”๋‹ค.

2-1. ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ์— ์˜ํ•œ Query Scoping

R2์—์„œ ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ์„ ํ†ตํ•ด R3๋กœ 10.0.0.0/16 ์ •๋ณด๋ฅผ ์ „์†กํ–ˆ๋‹ค.
์ดํ›„ R1์ด R3๋กœ 10.0.0.0/24์— ๋Œ€ํ•œ EIGRP Query๋ฅผ ๋ณด๋‚ด๋ฉด R3๊ฐ€ ํ•ด๋‹น Query๋ฅผ ๋ฌด์‹œํ•œ๋‹ค.

[์„ค์ •]

Router(config)# int <INTERFACE>
Router(config-if)# ip summary-address eigrp <AS> <SUMMARY_IP> <SUBNETMASK>

2-2. ์žฌ๋ถ„๋ฐฐ์— ์˜ํ•œ Query Scoping
EIGRP๋ฅผ ์‚ฌ์šฉํ•˜์ง€ ์•Š๊ณ  ๋‹ค๋ฅธ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์„ ์‚ฌ์šฉํ•œ๋‹ค. EIGRP Query ํŒจํ‚ท์€ EIGRP ๋ผ์šฐํ„ฐ๋ผ๋ฆฌ๋งŒ ์ฃผ๊ณ ๋ฐ›๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

2-3. Stub์— ์˜ํ•œ Query Scoping
Stub ๋ผ์šฐํ„ฐ๋กœ๋Š” EIGRP Query๋ฅผ ๋ณด๋‚ด์ง€ ์•Š๋Š”๋‹ค.  ๋‚˜๋จธ์ง€ Update, Ack, Reply๋Š” ๋ณด๋‚ธ๋‹ค. Stub ๋ผ์šฐํ„ฐ๋Š” ์ง์ ‘ ์ ‘์†๋œ ๋„คํŠธ์›Œํฌ์™€ ์ถ•์•ฝ๋œ ๋„คํŠธ์›Œํฌ ์ •๋ณด๋งŒ neighbor๋กœ ์ „์†กํ•œ๋‹ค.

[์„ค์ •]

Router(config)# router eigrp <AS>
Router(config-router)# eigrp stub

[Router] EIGRP: DUAL Algorithm

Diffusing Update Algorithm

EIGRP๋Š” DUAL ์•Œ๊ณ ๋ฆฌ์ฆ˜์— ์˜ํ•ด ๋ผ์šฐํŒ…์„ ๊ณ„์‚ฐํ•œ๋‹ค.

1. ์šฉ์–ด
2. ์„ ์ถœํ•˜๊ธฐ


1. ์šฉ์–ด

Topology Table์ธ์ ‘ ๋ผ์šฐํ„ฐ๋กœ๋ถ€ํ„ฐ ์ˆ˜์‹ ํ•œ ๋„คํŠธ์›Œํฌ์™€ ํ•ด๋‹น ๋„คํŠธ์›Œํฌ์˜ ๋ฉ”ํŠธ๋ฆญ์„ ์ €์žฅํ•œ ํ…Œ์ด๋ธ”
Feasible Distanceํ˜„์žฌ ๋ผ์šฐํ„ฐ์—์„œ ๋ชฉ์ ์ง€ ๋„ทํŠธ์›Œํฌ๊นŒ์ง€ ์ตœ์  ๊ฒฝ๋กœ์˜ ๋ฉ”ํŠธ๋ฆญ
Successor์ตœ์  ๊ฒฝ๋กœ ์ƒ์—์„œ์˜ ๋„ฅ์ŠคํŠธ ํ™‰ ๋ผ์šฐํ„ฐ
Reported Distance
(Advertised Distance)
๋„ฅ์ŠคํŠธ ํ™‰ ๋ผ์šฐํ„ฐ์—์„œ ๋ชฉ์ ์ง€๊นŒ์ง€์˜ ๋ฉ”ํŠธ๋ฆญ
Feasible SuccessorSuccessor๊ฐ€ ์•„๋‹Œ ๋ผ์šฐํ„ฐ ์ค‘ FD > RD๋ฅผ ๋งŒ์กฑํ•˜๋Š” ๋„ฅ์ŠคํŠธ ํ™‰ ๋ผ์šฐํ„ฐ

2. ์„ ์ถœํ•˜๊ธฐ

R3 ๊ธฐ์ค€์œผ๋กœ 30.30.30.0/24 ๋„คํŠธ์›Œํฌ๋กœ ๊ฐ€๋Š” ๊ฒฝ๋กœ๊ฐ€ ์žˆ๋‹ค๊ณ  ์ƒ๊ฐํ•ด๋ณด์ž.

Q1. Feasible Distance์™€ Successor๋Š”?
FD: R3 โ†’ R2 โ†’ R1 ์ด๋ฏ€๋กœ 110
Successor: R2

Q2. Reported Distance๋Š”?
R2 โ†’ R1์ด๋ฏ€๋กœ 100์ด๋‹ค.

Q3. Feasible Successor๋Š”?
R4

[๋ผ์šฐํ„ฐ์—์„œ ์กฐํšŒํ•˜๊ธฐ]

# Feasible Successor๋‚˜ Successor ํ™•์ธ
Router# show ip eigrp topology 

# FD, RD, FS, S ํ™•์ธ
Router# show ip eigrp topology all-links
Router# show ip eigrp topology detail-links

[Router] EIGRP

Enhanced Interior Gateway Routing Protocol

Cisco์—์„œ ๋งŒ๋“  EIGRP.
๊ทธ๋Œ€๋กœ ํ•ด์„ํ•˜๋ฉด, ํ–ฅ์ƒ๋œ ๋‚ด๋ถ€ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์ด๋‹ค. ๊ธฐ์กด IGRP์—์„œ ์—…๊ทธ๋ ˆ์ด๋“œ๋œ ๋ฒ„์ „(?)์ด๋ผ๊ณ  ์ƒ๊ฐํ•˜์ž. ๊ทธ๋Ÿผ EIGRP์— ๋Œ€ํ•ด ์•Œ์•„๋ณด๋„๋ก ํ•œ๋‹ค.

1. EIGRP ๊ธฐ๋ณธ ๊ฐœ๋…
2. EIGRP ๋™์ž‘ ๊ณผ์ •
3. EIGRP ํŒจํ‚ท ์ข…๋ฅ˜
4. EIGRP ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ๊ณผ ๋ณด์•ˆ
5. EIGRP ๋ถ€ํ•˜ ๋ถ„์‚ฐ


1. EIGRP ๊ธฐ๋ณธ ๊ฐœ๋…

– Cisco์—์„œ ๋งŒ๋“  ๊ฑฐ๋ฆฌ ๋ฒกํ„ฐ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์ด๋‹ค.
– IPv4 ํ”„๋ ˆ์ž„ ๋‚ด IP Protocol ํ•„๋“œ ๋ฒˆํ˜ธ 88์„ ์‚ฌ์šฉํ•œ๋‹ค.(ํฌํŠธ ๋ฒˆํ˜ธ ์•„๋‹˜.)
– Multicast 224.0.0.10์„ ์‚ฌ์šฉํ•œ๋‹ค.
– EIGRP์˜ ์‹ ๋ขฐ์„ฑ ํš๋“ ๊ณผ์ •์€ TCP 3way-handshake์™€ ๋น„์Šทํ•˜๋‹ค. EIGRP์™€ ๊ด€๋ จ๋œ ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›๋Š” ๊ณผ์ •์—์„œ ์‹ ๋ขฐ์„ฑ์„ ํš๋“ํ•œ๋‹ค.

[์žฅ์ ]
– ‘Update Cost’๋ฅผ ์ง€์›ํ•œ๋‹ค. ์ฆ‰, ๋ฉ”ํŠธ๋ฆญ์ด ๋‹ค๋ฅธ ๋‹ค์ˆ˜ ๊ฐœ์˜ ๊ฒฝ๋กœ๋ฅผ ๋™์‹œ์— ์‚ฌ์šฉํ•  ์ˆ˜์žˆ๋‹ค.
– ์„ค์ •์ด ๊ฐ„๋‹จํ•˜๋‹ค.

[๋‹จ์ ]
– Cisco ๋ผ์šฐํ„ฐ์—์„œ๋งŒ ๋™์ž‘ํ•œ๋‹ค.
– ๋Œ€๊ทœ๋ชจ ๋„คํŠธ์›Œํฌ์—์„œ ์šด์šฉ ์‹œ “SIA ํ˜„์ƒ”์ด ๋ฐœ์ƒํ•œ๋‹ค.

[๋ฉ”ํŠธ๋ฆญ]
– Bandwidth, Delay, Reliability, Load, MTU ๋ฐ Hop Count๋ฅผ ํŠน์ • ๊ณต์‹์— ๋Œ€์ž…ํ•˜์—ฌ ๊ณ„์‚ฐํ•œ๋‹ค. ์ด ๊ฐ’์„ ๋น„๊ตํ•˜์—ฌ ๊ฒฝ๋กœ์˜ ์šฐ์„  ์ˆœ์œ„๋ฅผ ๊ฒฐ์ •ํ•œ๋‹ค.
– ํŠน์ • ๊ณต์‹์— K ์ƒ์ˆ˜ 5๊ฐœ๊ฐ€ ๋“ค์–ด๊ฐ€ ์žˆ๊ณ , ์ˆœ์„œ๋Œ€๋กœ ‘1 0 1 0 0’์˜ ๊ธฐ๋ณธ ๊ฐ’์„ ๊ฐ€์ง€๊ณ  ์žˆ๋‹ค.

EIGRP ์„ค์ •

Router(config)# router eigrp <AS>
Router(config-router)# eigrp router-id <IP>
Router(config-router)# network <IP> <WILDCARD>

1: EIGRP๋ฅผ ์‚ฌ์šฉํ•˜๋Š” ๋ผ์šฐํ„ฐ๋Š” ๋™์ผํ•œ AS ๋ฒˆํ˜ธ๋ฅผ ๊ฐ–๊ณ  ์žˆ์–ด์•ผ ํ•œ๋‹ค.
2: ๋ณ„๋„๋กœ ์„ค์ •ํ•˜์ง€ ์•Š๋Š”๋‹ค๋ฉด, (1) ๊ฐ€์žฅ ๋†’์€ ๋ฃจํ”„๋ฐฑ IP (2) ๋ฌผ๋ฆฌ ์ธํ„ฐํŽ˜์ด์Šค ์ค‘ ๊ฐ€์žฅ ๋†’์€ IP๋กœ ์ž๋™ ํ• ๋‹น๋œ๋‹ค.


2. EIGRP ๋™์ž‘ ๊ณผ์ •

(1) Neighbor ๊ด€๊ณ„ ์ˆ˜๋ฆฝ
EIGRP ์„ค์ • ์ดํ›„ ์ธ์ •ํ•œ ๋ผ์šฐํ„ฐ์™€ Hello ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›๋Š”๋‹ค.
AS๋ฒˆํ˜ธ, K ์ƒ์ˆ˜ ๊ฐ’, EIRP ์•”ํ˜ธ ๊ฐ’ ๋“ฑ์ด ๋‹ค๋ฅด๋ฉด Neighbor๋ฅผ ์ˆ˜๋ฆฝํ•˜์ง€ ์•Š๋Š”๋‹ค.

(2) Neighbor Table ์ƒ์„ฑ
Neighbor ๊ด€๊ณ„ ์ˆ˜๋ฆฝ ํ›„ Neighbor Table์— ์ธ์ ‘ํ•œ ๋ผ์šฐํ„ฐ ์ •๋ณด๋ฅผ ์ €์žฅํ•œ๋‹ค. ์ฃผ๊ธฐ์ ์œผ๋กœ Hello ํŒจํ‚ท์„ ๋ณด๋‚ด์„œ Neighbor๋ฅผ ์œ ์ง€ํ•œ๋‹ค.

(3) ๋ผ์šฐํŒ… ์ •๋ณด ๊ตํ™˜ ๋ฐ Topology Table ๊ตฌ์„ฑ
Neighbor๋ฅผ ๋งบ์€ ๋ผ์šฐํ„ฐ๋ผ๋ฆฌ Update ํŒจํ‚ท์„ ์ด์šฉํ•ด ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ๊ตํ™˜ํ•œ๋‹ค. ์ด Update ํŒจํ‚ท๊ณผ EIGRP ๋กœ์ปฌ ์ •๋ณด๋ฅผ ํ•ฉ์ณ Topology Table์„ ๊ตฌ์„ฑํ•œ๋‹ค.

(4) ๋ผ์šฐํŒ… ๊ฒฝ๋กœ ๊ณ„์‚ฐ ๋ฐ Routing Table ์ €์žฅ
์ฒ˜์Œ Topology Table์— ๋“ฑ๋ก๋œ EIGRP ๊ฒฝ๋กœ๋Š” Active ์ƒํƒœ์ด๋‹ค.
Passive ์ƒํƒœ๊ฐ€ ๋˜๋ฉด Routing Table์— ํ•ด๋‹น ๊ฒฝ๋กœ๋ฅผ ์ €์žฅํ•  ์ˆ˜ ์žˆ๋‹ค.
(Active ์ƒํƒœ๋ž€, ํ•ด๋‹น ๊ฒฝ๋กœ๋ฅผ ์ตœ์  ๊ฒฝ๋กœ๋กœ ์‚ฌ์šฉํ•˜๊ธฐ ์œ„ํ•œ ๊ณ„์‚ฐ ๊ณผ์ •์ด ์ง„ํ–‰ ์ค‘์ธ ์ƒํƒœ์ด๋‹ค. ๊ณ„์‚ฐ์ด ๋๋‚˜๋ฉด Passive ์ƒํƒœ๋กœ ๋ฐ”๋€๋‹ค.)

โ€ป EIGRP ์šด์šฉ ์ค‘ ํ† ํด๋กœ์ง€ ๋ณ€๋™์‚ฌํ•ญ ๋ฐœ์ƒ

(ex. ๋กœ์ปฌ ์ •๋ณด๊ฐ€ ์‚ญ์ œ๋œ ๊ฒฝ์šฐ, ์ตœ์  ๊ฒฝ๋กœ์— ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ•œ ๊ฒฝ์šฐ)

(1) ๋ผ์šฐํŒ… ์ •๋ณด ์š”์ฒญ
Query ํŒจํ‚ท์„ ์ „์†กํ•˜์—ฌ, ๋ชฉ์ ์ง€๊นŒ์ง€์˜ ๋Œ€์ฒด ๊ฒฝ๋กœ๋‚˜ ๋ชฉ์ ์ง€๊นŒ์ง€์˜ ๋„๋‹ฌํ•˜๋Š”์ง€ ํ™•์ธ์„ ์š”์ฒญํ•œ๋‹ค.

(2) ๋ผ์šฐํŒ… ์ •๋ณด ์ˆ˜์‹ 
์ƒ๋Œ€ ๋ผ์šฐํ„ฐ๋กœ๋ถ€ํ„ฐ Reply ํŒจํ‚ท์„ ๋ฐ›๋Š”๋‹ค.


3. EIGRP ํŒจํ‚ท ์ข…๋ฅ˜

(1) ํŒจํ‚ท ์ข…๋ฅ˜

Hello ํŒจํ‚ท

– Neighbor๋ฅผ ๊ตฌ์„ฑํ•˜๊ณ  ์œ ์ง€ํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
– ๋ชฉ์ ์ง€ ์ฃผ์†Œ๋กœ Multicast 224.0.0.10 ์„ ์‚ฌ์šฉํ•œ๋‹ค.

Update ํŒจํ‚ท

– ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์ „์†กํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
– NBMA ๋„คํŠธ์›Œํฌ์˜ ๊ฒฝ์šฐ ๋ชฉ์ ์ง€ ์ฃผ์†Œ๋กœ Neighbor IP,
BMA ๋„คํŠธ์›Œํฌ์˜ ๊ฒฝ์šฐ Multicast 224.0.0.10์„ ์‚ฌ์šฉํ•œ๋‹ค.
– Update ํŒจํ‚ท ์ „์†ก ํ›„ Ack๋ฅผ ๋ชป๋ฐ›์œผ๋ฉด ์ตœ๋Œ€ 16๋ฒˆ๊นŒ์ง€ ๋‹ค์‹œ ์ „์†กํ•œ๋‹ค. ๊ทธ๋ž˜๋„ ์‘๋‹ต์ด ์—†์œผ๋ฉด Neighbor ๊ด€๊ณ„๋ฅผ ๋Š๋Š”๋‹ค.

Query ํŒจํ‚ท

– ๋ผ์šฐํŒ… ์ •๋ณด๋ฅผ ์š”์ฒญํ•˜๋Š”๋ฐ ์‚ฌ์šฉ๋œ๋‹ค.
(๋กœ์ปฌ ์ •๋ณด๊ฐ€ ์‚ญ์ œ๋˜๊ฑฐ๋‚˜ ๋ฉ”ํŠธ๋ฆญ์ด ๋ณ€๊ฒฝ๋œ ๋•Œ, Topology Table์— ๋Œ€์ฒด ๊ฒฝ๋กœ๊ฐ€ ์—†์„ ๋•Œ)
– ๋ชฉ์ ์ง€๋Š” ์œ„์™€ ๊ฐ™๋‹ค.

Reply ํŒจํ‚ท

– Query(๋ผ์šฐํŒ… ์ •๋ณด ์š”์ฒญ)์— ์‘๋‹ตํ•  ๋•Œ ์‚ฌ์šฉ๋œ๋‹ค.
– Ack ํŒจํ‚ท๊ณผ ๋‹ค๋ฅธ ํŒจํ‚ท์ด๋‹ค.

Ack ํŒจํ‚ท

– Update, Query, Reply ํŒจํ‚ท ์ˆ˜์‹  ์‹œ ํ™•์ธํ–ˆ๋‹ค๊ณ  ์‘๋‹ตํ•˜๋Š” ํŒจํ‚ท์ด๋‹ค.

(2) ํŒจํ‚ท ํฌ๋งท

<Format : EIGRP Packet>

Version: EIGRP ๋ฒ„์ „, ํ˜„์žฌ EIGRP ๋ฒ„์ „์€ 2์ด๋‹ค.
Opcode: EIGRP ํŒจํ‚ท ์ข…๋ฅ˜๋ฅผ ์ง€์ •ํ•œ๋‹ค. Update (0x01), Query (0x03), Reply (0x04), Hello (0x05) ์ด๋‹ค. EIGRP Header ๋’ค์— ์˜ค๋Š” TLV๋ฅผ ๊ฒฐ์ •ํ•œ๋‹ค. Ack๋Š” 0์ด ์•„๋‹Œ ACK๋ฒˆํ˜ธ๋ฅผ ํฌํ•จํ•œ Hello ํŒจํ‚ท์ด๋‹ค.
Checksum: IP ํ—ค๋”๋ฅผ ์ œ์™ธํ•œ EIGRP ์ „์ฒด ํŒจํ‚ท์˜ ์ฒดํฌ์„ฌ์ด๋‹ค.
Flags: ์ฒซ๋ฒˆ์งธ LSB bit (0x00000001) – ์‹œ์ž‘ ๋น„ํŠธ, ์ƒˆ๋กœ์šด Neighbor ๊ด€๊ณ„๋ฅผ ์ˆ˜๋ฆฝํ•  ๋•Œ ๋ผ์šฐํŒ… ์—…๋ฐ์ดํŠธ์˜ ์ฒซ๋ฒˆ์งธ ์„ธํŠธ๋ฅผ ๋‚˜ํƒ€๋‚ธ๋‹ค.
๋‘๋ฒˆ์งธ LSB bit (0x00000002) – ์กฐ๊ฑด๋ถ€ ์ˆ˜์‹  ๋น„ํŠธ, RTP์—์„œ ์‚ฌ์šฉ๋œ๋‹ค.
*๋‹ค๋ฅธ ๋น„ํŠธ๋“ค์€ ์‚ฌ์šฉํ•˜์ง€ ์•Š๋Š”๋‹ค.
Sequence & ACK number: ์‹ ๋ขฐ์„ฑ์žˆ๋Š” EIGRP ๋ฉ”์„ธ์ง€ ๊ตํ™˜์„ ์œ„ํ•œ RTP์—์„œ ์‚ฌ์šฉํ•œ๋‹ค.
AS number: EIGRP AS ๋ฒˆํ˜ธ์ด๋‹ค.
TLV: 16bit์˜ Type ํ•„๋“œ, 16bit์˜ Length ํ•„๋“œ, TLB ์ข…๋ฅ˜์— ๋”ฐ๋ฅธ ๋‹ค์–‘ํ•œ ํ•„๋“œ ๊ฐœ์ˆ˜๋กœ ๊ตฌ์„ฑ๋˜์–ด ์žˆ๋‹ค. TLV ๊ฐ’์€ ์•„๋ž˜ ์‚ฌ์ง„ ์ฐธ๊ณ , ๋” ์ž์„ธํ•œ ์ •๋ณด๋Š” ์ด ์‚ฌ์ดํŠธ ์ฐธ๊ณ .

TLV Values,  (Written by Yap Chin Hoong, http://www.cisco.com)

4. EIGRP ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ๊ณผ ๋ณด์•ˆ

(1) ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ

EIGRP์—์„œ๋„ ๋„คํŠธ์›Œํฌ ์ถ•์•ฝ ๊ธฐ๋Šฅ์„ ์ง€์›ํ•œ๋‹ค. ์ž๋™ ์ถ•์•ฝ์ด ๊ธฐ๋ณธ ๊ฐ’์ด๋ฏ€๋กœ ํ•ด๋‹น ๊ธฐ๋Šฅ์„ ์‚ฌ์šฉํ•˜์ง€ ์•Š์œผ๋ ค๋ฉด, ‘no auto-summary’๋ฅผ ํ•ด์•ผํ•œ๋‹ค.

์ถ•์•ฝ์„ ํ•˜๊ฒŒ ๋˜๋ฉด ์ถ•์•ฝ๋œ ๋„คํŠธ์›Œํฌ์˜ GW๊ฐ€ null 0์œผ๋กœ ๋œ๋‹ค. ๋ผ์šฐํŒ… ๋ฃจํ”„๋ฅผ ๋ฐฉ์ง€ ํ•˜๊ธฐ ์œ„ํ•จ์ด๋‹ค.

[Default Route ์ƒ์„ฑ]

Router(config)# ip route 0.0.0.0 0.0.0.0 <NEXT_HOP_IP>
Router(config)# router eigrp <AS>
Router(config-router)# redistribute static

[์ˆ˜๋™ ์ถ•์•ฝ]
์ถ•์•ฝ๋œ ์ •๋ณด๋ฅผ ๋‚ด๋ณด๋‚ด๊ณ ์ž ํ•˜๋Š” ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ์„ค์ •ํ•œ๋‹ค.

Router(config)# int <INTERFACE>
Router(config-if)# ip summary-address eigrp <AS> <SUMMARY_IP> <SUBNET>

* ์ถ•์•ฝํ•˜๋ฉด GW๊ฐ€ null 0์œผ๋กœ ์žกํžˆ๋Š” ์ด์œ 

R1์˜ ๋„คํŠธ์›Œํฌ ์ •๋ณด๋ฅผ ๋ฐ›์•„ ์ถ•์•ฝ ํ›„ R3์—๊ฒŒ ์ „ํŒŒ.

์ด ์ƒํ™ฉ์—์„œ R1์˜ 30.30.30.0/24 ๋„คํŠธ์›Œํฌ๊ฐ€ ๋‹ค์šด๋œ๋‹ค๋ฉด R2๊นŒ์ง€๋งŒ ํ†ต๋ณด๋œ๋‹ค. R3๋Š” ์ถ•์•ฝ๋˜์–ด์žˆ๊ณ , R2์—์„œ 30.0.0.0/8 ๋ชจ๋‘ ๋‹ค์šด๋˜์–ด์•ผ ํ†ต๋ณดํ•˜๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

๊ทธ ๋‹ค์Œ, R3๊ฐ€ 30.30.30.X๋กœ ๊ฐ€๋Š” ํŒจํ‚ท์„ ์ „๋‹ฌ ๋ฐ›์œผ๋ฉด ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์„ ๋ณด๊ณ  R2๋กœ ๋ณด๋‚ธ๋‹ค. ํ•˜์ง€๋งŒ R2๋Š” 30.0.0.0/8์˜ ๊ฒŒ์ดํŠธ์›จ์ด๊ฐ€ null 0๊ณผ ๋งค์นญ๋œ ๊ฒƒ์„ ๋ณด๊ณ  ํ•ด๋‹น ํŒจํ‚ท์„ ํ๊ธฐํ•œ๋‹ค.

null 0์œผ๋กœ ์„ค์ •๋˜์ง€ ์•Š์•˜๋‹ค๋ฉด, R2์™€ R3๋Š” ์„œ๋กœ ๊ณ„์† ํŒจํ‚ท์„ ์ฃผ๊ณ ๋ฐ›์•˜์„ ๊ฒƒ์ด๋‹ค. ( = ๋ฃจํ•‘ )

(2) ๋„คํŠธ์›Œํฌ ๋ณด์•ˆ

EIGRP ๋„คํŠธ์›Œํฌ ์ƒ์—์„œ ๋ณด์•ˆ ์นจํ•ด๊ฐ€ ๋งŽ์€ ๊ณณ์€ PC์™€ ์—ฐ๊ฒฐ๋œ ๋ง, ์„œ๋ฒ„์™€ ์—ฐ๊ฒฐ๋˜๋Š” ๋„คํŠธ์›Œํฌ๋‹ค. ์ด๋Ÿฐ ๋„คํŠธ์›Œํฌ์—์„œ EIGRP ๋ณด์•ˆ์„ ์œ„ํ•ด ๋‘ ๊ฐ€์ง€ ๋ฐฉ๋ฒ•์„ ์ ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค. EIGRP ํŒจํ‚ท์„ ์ธ์ฆํ•˜๋Š” ๊ฒƒ๊ณผ ์•ก์„ธ์Šค ๋„คํŠธ์›Œํฌ๋Š” ์žฌ๋ถ„๋ฐฐ์‹œํ‚ค๋Š” ๊ฒƒ์ด๋‹ค.

[EIGRP ํŒจํ‚ท ์ธ์ฆ]
MD5, HMAC-SHA-256 ๋ฐฉ์‹์„ ํ†ตํ•ด ํŒจํ‚ท์˜ ๋ฌด๊ฒฐ์„ฑ์„ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

Router(config)# key chain <CHAIN_NAME>
Router(config-keychain)# key [0-2147483647]
Router(config-keychain-key)# key-string <WORD>
Router(config-keychain-key)# exit
Router(config-keychain)# exit
Router(config)#
Router(config)# int <INTERFACE>
Router(config-if)# ip authentication key-chain eigrp <AS> <CHAIN_NAME>
Router(config-if)# ip authentication mode eigrp <AS> [MD5|SHA]

1: ํ‚ค ์ฒด์ธ ์ด๋ฆ„์€ ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•˜์ง€ ์•Š์•„๋„ ๋œ๋‹ค.
2: ํ‚ค ๋ฒˆํ˜ธ๋Š” ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•ด์•ผ ํ•œ๋‹ค.
3: ์•”ํ˜ธ๋Š” ๋ผ์šฐํ„ฐ ๊ฐ„ ๋™์ผํ•ด์•ผ ํ•œ๋‹ค.
7: eigrp ์ธ์ฆ ์„ค์ •์„ ์ ์šฉํ•  ์ธํ„ฐํŽ˜์ด์Šค๋กœ ์ง„์ž…ํ•œ๋‹ค.
8-9: ์ธ์ฆ ์„ค์ •

[์•ก์„ธ์Šค ๋„คํŠธ์›Œํฌ ์žฌ๋ถ„๋ฐฐ]
PC๊ฐ€ ์—ฐ๊ฒฐ๋œ ์ข…๋‹จ ๋ถ€๋ถ„์€ EIGRP ํŒจํ‚ท์„ ๋ณด๋‚ผ ํ•„์š”๊ฐ€ ์—†๋‹ค. ์ด๋Ÿฐ ๋„คํŠธ์›Œํฌ๋กœ EIGRP ํŒจํ‚ท์„ ์ „์†กํ•˜์ง€ ์•Š๋„๋ก ํ•œ๋‹ค.

Router(config)# router eigrp <AS>
Router(config-router)# redistribute connected

์œ„์™€ ๋น„์Šทํ•œ ์„ค์ •์ด ์žˆ๋‹ค. Passive interface๋ฅผ ์„ค์ •ํ•˜์—ฌ, ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค๋กœ EIGRP Hello ํŒจํ‚ท์„ ์†ก์ˆ˜์‹ ํ•˜์ง€ ์•Š๋Š” ๊ฒƒ์ด๋‹ค.

Router(config)# router eigrp <AS>
Router(config-router)# passive-interface <INTERFACE>

5. EIGRP ๋ถ€ํ•˜๋ถ„์‚ฐ

EIGRP๋Š” ๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฐ’์„ ๊ฐ€์ง„ ๊ฒฝ๋กœ 32๊ฐœ๊นŒ์ง€ ๋ถ€ํ•˜ ๋ถ„์‚ฐ์„ ์ง€์›ํ•œ๋‹ค.

Equal Cost MultiPath ; ECMP

‘๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฒฝ๋กœ์— ๋Œ€ํ•œ ๋ถ€ํ•˜ ๋ถ„์‚ฐ’
๋™์ผ ๋ฉ”ํŠธ๋ฆญ ๊ฒฝ๋กœ๊ฐ€ ์—ฌ๋Ÿฌ ๊ฐœ๋ฉด, ๋ณ„๋„ ์„ค์ •์—†์ด ์ž๋™์œผ๋กœ ๋™์ž‘ํ•œ๋‹ค. ๊ธฐ๋ณธ๊ฐ’์€ ์ตœ๋Œ€ 4๊ฐœ๋กœ ์„ค์ •๋˜์–ด ์žˆ๋‹ค. ์ตœ๋Œ€ ๋ถ€ํ•˜๋ถ„์‚ฐ ๊ฒฝ๋กœ ์ง€์ •์€ ์•„๋ž˜์™€ ๊ฐ™์ด ํ•œ๋‹ค.

Router(config)# router eigrp <AS>
Router(config)# maximum-paths [1-32]

Unequal Cost MultiPath ; UCMP

‘๋ฉ”ํŠธ๋ฆญ ๊ฐ’์ด ์„œ๋กœ ๋‹ค๋ฅธ ๊ฒฝ๋กœ์— ๋Œ€ํ•œ ๋ถ€ํ•˜ ๋ถ„์‚ฐ’
UCMP๊ฐ€ ๋™์ž‘ํ•˜๊ธฐ ์œ„ํ•ด์„  2๊ฐ€์ง€ ์กฐ๊ฑด์„ ๋งŒ์กฑํ•ด์•ผ ํ•œ๋‹ค.
โ‘  Feasible Successor๋ฅผ ํ†ตํ•˜๋Š” ๊ฒฝ๋กœ
โ‘ก ‘Feasible  * variance’ ๋ณด๋‹ค ์ž‘์•„์•ผํ•œ๋‹ค.