[QoS] 1: ๊ฐœ๋…

Quality of Service

์ˆ˜ ๋งŽ์€ ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›๋Š” ์ƒํ™ฉ์—์„œ ๋‹ค๋ฅธ ํŒจํ‚ท ๋ณด๋‹ค ๋จผ์ € ์ฒ˜๋ฆฌํ•ด์•ผํ•˜๋Š” ์ค‘์š”ํ•œ ํŒจํ‚ท์ด ์žˆ๊ธฐ ๋งˆ๋ จ์ด๋‹ค. ๊ทธ๋Ÿฐ ํŒจํ‚ท์„ ์œ„ํ•œ ๊ฒƒ์ด ๋ฐ”๋กœ QoS์ด๋‹ค.
VoIP์ฒ˜๋Ÿผ ์‹ค์‹œ๊ฐ„์œผ๋กœ ํŒจํ‚ท์„ ์ฃผ๊ณ  ๋ฐ›์œผ๋ฉด์„œ ์ง€์—ฐ๋˜์ง€ ์•Š๋„๋ก, ๊ทธ๋ฆฌ๊ณ  ์ค‘์š”ํ•œ ํŠธ๋ž˜ํ”ฝ์˜ ๋Œ€์—ญํญ์„ ๋ณด์žฅํ•˜๊ณ  ํŠน์ • ํŠธ๋ž˜ํ”ฝ์„ ์ œํ•œํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค.

Qos ์ž‘์—…์€ 6๊ฐ€์ง€๋กœ ๋ถ„๋ฅ˜ํ•  ์ˆ˜์žˆ๊ณ , 1~6๋ฒˆ ์ˆœ์„œ๋Œ€๋กœ ํ๋ฆ„์ด ์ง„ํ–‰๋œ๋‹ค.

  1. Classification (ํŠธ๋ž˜ํ”ฝ ๋ถ„๋ฅ˜)
  2. Policing (ํด๋ฆฌ์‹ฑ)
  3. Marking (์šฐ์„ ์ˆœ์œ„ ํ‘œ์‹œ)
  4. Congestion Avoidance (ํ˜ผ์žก ํšŒํ”ผ)
  5. Queueing (ํ์ž‰)
  6. Scheduling (์Šค์ผ€์ค„๋ง)
  7. Switch QoS ์„ค์ •
QoS ๊ฐ„๋žต ํ๋ฆ„

1. Classification – ํŠธ๋ž˜ํ”ฝ ๋ถ„๋ฅ˜

QoS ์ •์ฑ…์„ ์„ค์ •ํ•˜๊ธฐ ์•ž์„œ ๋จผ์ € QoS๋ฅผ ์ ์šฉํ•  ํŒจํ‚ท์„ ๊ตฌ๋ถ„ํ•œ๋‹ค.

์˜ˆ๋ฅผ ๋“ค๋ฉด,
(1) ํŠน์ • IP์—์„œ ์˜จ ํŒจํ‚ท
(2) ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ์˜จ ํŒจํ‚ท
(3) ํŠน์ • ์šฐ์„ ์ˆœ์œ„(IP Precedence/DSCP/CoS)๋ฅผ ๊ฐ€์ง„ ํŒจํ‚ท

์ด๋ ‡๊ฒŒ ๋ง์ด๋‹ค.


2. Policing – ํด๋ฆฌ์‹ฑ

์‚ฌ์šฉ ๊ฐ€๋Šฅํ•œ ์†๋„๋ฅผ ์ œํ•œํ•œ๋‹ค. ํ†ต์‹ ์‚ฌ์—…์ž๊ฐ€ ๋งŽ์ด ์‚ฌ์šฉํ•œ๋‹ค๊ณ  ํ•œ๋‹ค.
100Mbps๋กœ Policingํ•œ๋‹ค = ์ตœ๋Œ€ ์†๋„๊ฐ€ 100Mbps๊นŒ์ง€ ๋‚˜์˜จ๋‹ค.


3. Marking – ์šฐ์„ ์ˆœ์œ„ ํ‘œ์‹œ

ํ”„๋ ˆ์ž„์— ์šฐ์„  ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•˜๋Š” ๊ฒƒ์ด๋‹ค. ๋งŒ์ผ, ์šฐ์„ ์ˆœ์œ„๋ฅผ ์„ค์ •ํ•˜์ง€ ์•Š์•˜๋‹ค๋ฉด, ์‹ค์‹œ๊ฐ„ ์ฒ˜๋ฆฌ๊ฐ€ ํ•„์š”ํ•œ ํŒจํ‚ท์ด ์ง€์—ฐ๋  ์ˆ˜ ์žˆ๋‹ค.
ํ”„๋กœํ† ์ฝœ์— ๋”ฐ๋ผ ์ง€์ •/์ง€์ • ๋ถˆ๊ฐ€ํ•˜๋‹ค.

3-1. Ethernet ํ”„๋ ˆ์ž„๊ณผ 802.1Q ํ”„๋ ˆ์ž„

Ethernet ํ”„๋ ˆ์ž„์—๋Š” ์šฐ์„ ์ˆ˜์œ„๋ฅผ ํ‘œ์‹œํ•  ํ•„๋“œ๊ฐ€ ์—†๋‹ค.
์ฆ‰, ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์—†๋‹ค.

802.1Q ํ”„๋ ˆ์ž„์˜ Tag ํ•„๋“œ์— CoS(Priority) ํ•ญ๋ชฉ์ด ์žˆ๋‹ค.
์šฐ์„ ์ˆ˜์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์žˆ๋‹ค.
์ฆ‰, Trunking ํฌํŠธ๋ฅผ ํ†ตํ•ด ์†ก์ˆ˜์‹ ๋˜๋Š” ํŠธ๋ž˜ํ”ฝ์€ ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์žˆ๋‹ค.

3-2. IP ํ—ค๋”

์ถœ์ฒ˜: What 8-bit field exists in IP packet for QoS?, ITExamAnswers, https://itexamanswers.net/question/what-8-bit-field-exists-in-ip-packet-for-qos

IP ํ—ค๋”์—์„œ IP Precedence ํ˜น์€ DSCP๋ฅผ ์ด์šฉํ•ด ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์žˆ๋‹ค.
IP Precedence : ๊ฐ’ 0~7, ๊ฐ’์ด ํด์ˆ˜๋ก ์šฐ์„ ์ˆœ์œ„๊ฐ€ ๋†’์•„์ง„๋‹ค.
DSCP : ๊ฐ’ 0~63, ๊ฐ’์˜ ํฌ๊ธฐ์˜ ๋”ฐ๋ฅธ ์˜๋ฏธ๋Š” ์—†๋‹ค. ๋ณดํ†ต VoIP์— DSCP ๊ฐ’ 46์„ ๋ถ€์—ฌํ•œ๋‹ค. 46์„ EF(Expected Forwarding)์ด๋ผ๊ณ  ํ•œ๋‹ค.
* DSCP ๊ฐ’ ์ฐธ๊ณ  : Cisco Configuration Guides

3-3. Marking ์‚ฌ์šฉ ์˜ˆ์‹œ

ํ† ํด๋กœ์ง€1. Marking ์‚ฌ์šฉ ์˜ˆ์‹œ

โ‘  โ‘ก : 802.1Q TAG์˜ CoS ํ•„๋“œ๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.
โ‘ข : Serial์€ Ethernet ๋ฐฉ์‹์ด ์•„๋‹Œ RS232C, RS422A, RS485 ๋ฐฉ์‹์„ ์‚ฌ์šฉํ•œ๋‹ค. ๊ทธ๋ž˜์„œ IPํ—ค๋”์˜ IP Precedence๋‚˜ DSCP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.
โ‘ฃ : Access ํฌํŠธ๋Š” ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•  ์ˆ˜ ์—†์–ด์„œ IPํ—ค๋”์˜ IP Precedence๋‚˜ DSCP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.
โ‘ค : 802.1Q TAG์˜ CoS ํ•„๋“œ๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.


4. Congestion Avoidance -ํ˜ผ์žก ํšŒํ”ผ

ํ”„๋ ˆ์ž„์„ ์ž„์‹œ ์ €์žฅํ•  ํ๊ฐ€ ๊ฐ€๋“ ์ฐจ ์žˆ๋Š” ์ƒํƒœ๋ฅผ ํ˜ผ์žก์ด๋ผ๊ณ  ํ‘œํ˜„ํ•œ ๊ฒƒ ๊ฐ™๋‹ค. ํ๊ฐ€ ๊ฐ€๋“ ์ฐจ์žˆ๋Š” ์ƒํƒœ์—์„œ ํ”„๋ ˆ์ž„์„ ํ๊ธฐํ•˜๋Š” ๊ฒƒ์„ ํ˜ผ์žก ํšŒํ”ผ๋ผ๊ณ  ํ•œ๋‹ค. ํ˜ผ์žก ํšŒํ”ผ๋Š” ํฌ๊ฒŒ 3๊ฐ€์ง€ ๋ฐฉ๋ฒ•์ด ์žˆ๋‹ค.

TailDrop, WTD, WRED

4-1. TailDrop

๊ฐ„๋‹จํ•˜๋‹ค. ํ๊ฐ€ ๊ฐ€๋“ ์ฐผ์„ ๋•Œ, ์ดํ›„์— ๋„์ฐฉํ•˜๋Š” ํŒจํ‚ท๋“ค์„ ๋ชจ์กฐ๋ฆฌ ํ๊ธฐํ•˜๋Š” ๋ฐฉ๋ฒ•์ด๋‹ค.

4-2. WTD

Weighted Tail Drop

CoS / DSCP ๊ฐ’์— ๋”ฐ๋ผ Taildrop์ด ์ผ์–ด๋‚˜๋Š” ์ž„๊ณ„์น˜(Threshold๋ผ๊ณ ๋„ ํ•จ)๋ฅผ ๋‹ค๋ฅด๊ฒŒ ํ•˜์—ฌ ํ๊ธฐํ•˜๋Š” ๋ฐฉ๋ฒ•์ด๋‹ค. UDP๊ฐ€ ๋งŽ์€ ํ™˜๊ฒฝ์—์„œ ์‚ฌ์šฉํ•˜๋ฉด ํ˜ผ์žก ์ œ์–ด์— ์œ ๋ฆฌํ•˜๋‹ค๊ณ  ํ•œ๋‹ค.

4-3. WRED

Weighted Random Early Detection

WRED๋ฅผ ์„ค๋ช…ํ•˜๊ธฐ ์•ž์„œ ๋จผ์ € ‘Global TCP Synchronization’์— ๋Œ€ํ•ด ์•Œ์•„๋ณด๋„๋ก ํ•˜์ž.


* Global TCP Synchronization์ด๋ž€?
TCP์™€ ๊ฐ™์ด ์‹ ๋ขฐ์„ฑ์ด ํ•„์š”ํ•œ ํ†ต์‹ ์€ ํŒจํ‚ท 1๊ฐœ๋ฅผ ๋ณด๋‚ด๊ณ  Ack๋ฅผ ๋ฐ›์•„์•ผ ๋‹ค์Œ ํŒจํ‚ท์„ ๋ณด๋‚ธ๋‹ค. ํ•˜์ง€๋งŒ ๊ณ„์† ์ด๋ ‡๊ฒŒ ํ†ต์‹ ํ•˜๋ฉด ๋‹น์—ฐํžˆ ํ†ต์‹ ์†๋„๋Š” ๋Š๋ ค์งˆ ๊ฒƒ์ด๋‹ค.
์ด ๋ฌธ์ œ๋ฅผ ํ•ด๊ฒฐํ•˜๊ณ ์ž ์ƒ๋Œ€ Ack์—†์ด ํ•œ๋ฒˆ์— ๋ณด๋‚ผ ์ˆ˜ ์žˆ๋Š” ํŒจํ‚ท ์ˆ˜๋ฅผ ์ง€์ •ํ•˜๋Š” ‘Window Size’๋ผ๋Š” ๊ฐœ๋…์„ ๋„์ž…ํ–ˆ๋‹ค. ์—๋Ÿฌ๊ฐ€ ์—†๋‹ค๋ฉด Window Size๊ฐ€ ํฐ ๊ฒƒ์ด ์œ ๋ฆฌํ•  ๊ฑฐ๊ณ , ์—๋Ÿฌ๊ฐ€ ๋นˆ๋ฒˆํ•˜๋‹ค๋ฉด Window Size๊ฐ€ ์ž‘์€ ๊ฒƒ์ด ์œ ๋ฆฌํ•  ๊ฒƒ์ด๋‹ค.
ํ•œ ๋ฒˆ์— 1500๊ฐœ TCP ํŒจํ‚ท์„ ๋ณด๋ƒˆ๋Š”๋ฐ ๊ทธ ์ค‘ ์ƒ๋Œ€๊ฐ€ 500๊ฐœ๋ฅผ ๋ชป๋ฐ›์€ ์ƒํ™ฉ์ด ์žˆ๋‹ค๊ณ  ๊ฐ€์ •ํ•ด๋ณด์ž. ์—๋Ÿฌ๊ฐ€ ๋ฐœ์ƒํ•œ ์ƒํ™ฉ์ธ๋ฐ, ์ด๋Ÿด ๋•Œ๋Š” Window Size๋ฅผ ์ค„์—ฌ์„œ ํŒจํ‚ท์„ ๋ณด๋‚ธ๋‹ค. ํ•œ๋ฒˆ์— ๋ณด๋‚ด๋Š” ํŒจํ‚ท๋Ÿ‰์ด ์ ์–ด์ง€๋‹ˆ ํ†ต์‹  ์†๋„๋„ ๋‚ฎ์•„์งˆ ๊ฒƒ์ด๋‹ค. ์ด ์ƒํ™ฉ์—์„œ ๋งŒ์•ฝ PC๊ฐ€ ์—ฌ๋Ÿฌ ๋Œ€ ์žˆ๋‹ค๋ฉด..? ์—ฌ๋Ÿฌ ๋Œ€์˜ PC๊ฐ€ ์ƒ๋Œ€์—๊ฒŒ ์ง€๊ธˆ ์—๋Ÿฌ๋‚ฌ์œผ๋‹ˆ ์žฌ์ „์†ก ์š”์ฒญ์„ ํ•  ๊ฒƒ์ด๋‹ค. ์ด๋ฏธ ์—๋Ÿฌ๊ฐ€ ๋ฐœ์ƒํ•œ ์ƒํ™ฉ์ด๋ฏ€๋กœ ์ƒ๋Œ€๊ฐ€ Window Size๋ฅผ ์ค„์—ฌ์„œ ์žฌ์ „์†กํ•œ๋‹ค. ๊ฒฐ๊ณผ์ ์œผ๋กœ ์ „์ฒด ํŒจํ‚ท ์ˆ˜๊ฐ€ ์ค„์–ด๋“ค๊ณ  ๋งํฌ ์‚ฌ์šฉ๋ฅ ๋„ ๋‚ฎ์•„์งˆ ๊ฒƒ์ด๋‹ค.
์ด๋ ‡๊ฒŒ ๋™์‹œ์— TCP Window Size ๋ฐ”๊พธ๋Š” ๊ฒƒ์„ ‘Global TCP synchronization’์ด๋ผ๊ณ  ํ•œ๋‹ค.


WRED๋Š” Global TCP Synchronization์„ ๋ฐฉ์ง€ํ•˜๊ธฐ ์œ„ํ•ด TailDrop(์ „์ฒด ์—๋Ÿฌ)๊ฐ€ ๋ฐœ์ƒํ•˜๊ธฐ ์ „ ์ž„์˜์˜ ํŒจํ‚ท์„ ํ๊ธฐํ•œ๋‹ค. ๊ทธ๋ ‡๊ฒŒ ๋˜๋ฉด ํŠน์ • ์žฅ๋น„์—์„œ๋งŒ ์—๋Ÿฌ๊ฐ€ ๋ฐœ์ƒํ•œ๋‹ค๊ณ  ์ธ์‹ํ•˜๊ณ  Window Size๋ฅผ ์ค„์ธ๋‹ค.

์ฆ‰, ๋Œ€์˜๋ฅผ ์œ„ํ•ด ์ผ๋ถ€๋ฅผ ํฌ์ƒํ•œ๋‹ค๊ณ  ์ƒ๊ฐํ•˜๋ฉด ๋  ๊ฒƒ ๊ฐ™๋‹ค.


5. Queueing – ํ์ž‰

ํ”„๋ ˆ์ž„์„ ์ „์†กํ•˜๊ธฐ ์ „ ์ž„์‹œ๋กœ ๋ณด๊ด€ํ•˜๋Š” ์žฅ์†Œ๋ฅผ Queue๋ผ๊ณ  ํ•œ๋‹ค.
๊ทธ๋ฆฌ๊ณ  ์ด Queue๋ฅผ ์ฒ˜๋ฆฌํ•˜๋Š” ๊ฒƒ์„ Queueing์ด๋ผ๊ณ  ํ•œ๋‹ค.

ํ†ต์‹ ์žฅ๋น„๋Š” ์ž…๋ ฅํ/์ถœ๋ ฅํ๋ฅผ ๊ฐ–๊ณ  ์žˆ๋‹ค. (์žฅ๋น„๋งˆ๋‹ค ํ์˜ ๊ฐœ์ˆ˜๊ฐ€ ๋‹ค๋ฅด๋‹ค.)
– ์ž…๋ ฅํ: ํ”„๋ ˆ์ž„ ์ˆ˜์‹  ํ›„ ์ฒ˜๋ฆฌํ•˜๊ธฐ ์ „ ๋ณด๊ด€ํ•˜๋Š” ํ
– ์ถœ๋ ฅํ: ์ฒ˜๋ฆฌ ํ›„ ์™ธ๋ถ€๋กœ ์ „์†กํ•˜๊ธฐ ์ „ ๋ณด๊ด€ํ•˜๋Š” ํ
ํ ์ „์†ก ๋ฐฉ๋ฒ•์— ๋”ฐ๋ผ ํ‘œ์ค€ํ/์šฐ์„ ํ๋กœ ๋‚˜๋ˆˆ๋‹ค. ์šฐ์„ ํ์— ์ €์žฅ๋œ ํ”„๋ ˆ์ž„์ด ๋” ๋จผ์ € ์ „์†ก๋œ๋‹ค.


6. Scheduling – ์Šค์ผ€์ค„๋ง

Queue์— ์ €์žฅ๋œ ํ”„๋ ˆ์ž„์„ ์™ธ๋ถ€๋กœ ์ „์†กํ•œ๋‹ค.
Scheduling ๋ฐฉ์‹์€ ํฌ๊ฒŒ 3๊ฐ€์ง€๋กœ ๋‚˜๋‰œ๋‹ค.

WRR, DWRR, Strict-priority queueing

6-1. WRR

Weighted Round Robin

์ •ํ•ด์ง„ ๋น„์œจ๋Œ€๋กœ ์ฐจ๋ก€์ฐจ๋ก€ ๋Œ์•„๊ฐ€๋ฉฐ ํ”„๋ ˆ์ž„์„ ์ „์†กํ•œ๋‹ค.

6-2. DWRR

Deficit Weighted Round Robin

์ˆœ์„œ(์ฐจ๋ก€)๊ฐ€ ๋˜์–ด๋„ ์ „์†กํ•  ํ”„๋ ˆ์ž„ ํฌ๊ธฐ๋ณด๋‹ค deficit counter ์ž‘์œผ๋ฉด, ํ”„๋ ˆ์ž„์„ ์ „์†กํ•˜์ง€ ์•Š๊ณ  deficit counter๋ฅผ ์ฆ๊ฐ€์‹œํ‚จ ๋’ค ๋‹ค์Œ ์ฐจ๋ก€์— ์ „์†กํ•œ๋‹ค.

6-3. Strict-priority Queueing

์ตœ์šฐ์„  ํ์ž‰

์šฐ์„ ํ์— ์ €์žฅ๋œ ํ”„๋ ˆ์ž„์„ ๋จผ์ € ์ „์†กํ•œ๋‹ค.
๋ณดํ†ต VoIP ํ”„๋ ˆ์ž„์„ ์ตœ์šฐ์„ ํ์ž‰ํ•œ๋‹ค.


7. Switch QoS ์„ค์ •

QoS ์„ค์ •์€ MQC ๊ด€๋ จ ๋ช…๋ น์–ด์™€ mls qos ๊ด€๋ จ ๋ช…๋ น์–ด๊ฐ€ ์žˆ๋‹ค.

7-1. MQC ๊ด€๋ จ ๋ช…๋ น์–ด

Modular QoS CLI

์Šค์œ„์น˜๋‚˜ ๋ผ์šฐํ„ฐ์—์„œ ์‚ฌ์šฉ๋˜๋Š” QoS ๋ช…๋ น์–ด ์ฒด๊ณ„์ด๋‹ค. ์Šค์œ„์น˜์—์„œ๋Š” ์ฃผ๋กœ Marking์ด๋‚˜ Policing์„ ์œ„ํ•ด ์‚ฌ์šฉํ•œ๋‹ค.

– ์„ค์ •4๋‹จ๊ณ„
(1) class-map : QoS ์ž‘์—… ๋Œ€์ƒ ๋ถ„๋ฅ˜
(2) policy-map : QoS ์ •์ฑ… ํ‘œ์‹œ
(3) service-policy : policy-map ์ ์šฉ
(4) show policy-map interface <INTERFACE> : QoS ๋™์ž‘ ํ™•์ธ

7-2. mls qos ๊ด€๋ จ ๋ช…๋ น์–ด

Queue ๋ณ„ ๋Œ€์—ญํญ ๋น„์œจ, ๊ธธ์ด, ๋งคํ•‘ ๋“ฑ Queue์™€ ๊ด€๋ จ๋œ ์„ค์ •์ด๋‹ค.

DHCP 2: ๋ณด์•ˆ

DHCP์™€ ๊ด€๋ จ๋œ ๋ณด์•ˆ์— ๋Œ€ํ•ด์„œ ์•Œ์•„๋ณด๋„๋ก ํ•˜์ž.

1. DHCP Snooping
2. IP Source Guard
3. Dynamic ARP Inspection


1. DHCP Snooping

์ผ๋ฐ˜์ ์œผ๋กœ DHCP์™€ ๊ด€๋ จ๋œ ๊ณต๊ฒฉ์œผ๋กœ
โ‘  ๊ณต๊ฒฉ์ž๊ฐ€ DHCP ์„œ๋ฒ„ ํ–‰์„ธ ๋ฐ ํด๋ผ์ด์–ธํŠธ๋“ค์ด ๊ณต๊ฒฉ์ž์™€ ํ†ต์‹ ํ•˜๋Š” ๊ฒƒ โ‘ก ๊ณต๊ฒฉ์ž๊ฐ€ ํ• ๋‹นํ•  ์ˆ˜ ์žˆ๋Š” IP๋ฅผ ๋ชจ๋‘ ๋ฐ›์•„๊ฐ€์„œ ๋‹ค๋ฅธ ํด๋ผ์ด์–ธํŠธ๋“ค์ด IPํ• ๋‹น์„ ๋ฐ›์ง€ ๋ชปํ•˜๊ฒŒ ํ•˜๋Š” ๊ฒƒ
์ด ๋‘ ๊ฐ€์ง€๊ฐ€ ์žˆ๋‹ค. 

์ด๋Ÿฐ ์œ ํ˜•์˜ ๊ณต๊ฒฉ์„ ๋ฐฉ์ง€ํ•˜๋Š” ๊ธฐ์ˆ ์ด DHCP Snooping์ด๋‹ค.

1-1. DHCP Snooping ๋™์ž‘ ๋ฐฉ์‹

DHCP ์„œ๋ฒ„ ํ˜น์€ DHCP ๋ฆด๋ ˆ์ด ์„œ๋ฒ„๊ฐ€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ๋ฅผ ‘Trusted’๋กœ ์ง€์ •ํ•˜๊ณ , ํด๋ผ์ด์–ธํŠธ๊ฐ€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ๋ฅผ ‘Untrusted’๋กœ ์ง€์ •ํ•œ๋‹ค.

Trusted ํฌํŠธ์—์„œ ์ˆ˜์‹ ํ•œ DHCP ๋ฉ”์„ธ์ง€๋Š” ๋ณ„๋„๋กœ ํ™•์ธ์„ ํ•˜์ง€ ์•Š๊ณ ,
Untrusted ํฌํŠธ์—์„œ ์ˆ˜์‹ ํ•œ DHCP ์„œ๋ฒ„์˜ ๋ฉ”์„ธ์ง€, DHCP ๋ฆด๋ ˆ์ด ์„œ๋ฒ„์˜ ๋ฉ”์„ธ์ง€๋Š” ์ฐจ๋‹จํ•œ๋‹ค.
๋˜ํ•œ, Ethernet ํ”„๋ ˆ์ž„์˜ MAC ์ฃผ์†Œ์™€ DHCP ๋ฉ”์„ธ์ง€์˜ Client Hardware ์ฃผ์†Œ๊ฐ€ ๋‹ค๋ฅด๋ฉด ์ฐจ๋‹จํ•œ๋‹ค.

1-2. DHCP Snooping ๋™์ž‘ ๊ณผ์ •

ํ† ํด๋กœ์ง€1. DHCP Snooping

– DHCP ์„œ๋ฒ„์™€ ์—ฐ๊ฒฐ๋œ F0/3 : Trusted Port
– ์ด์™ธ ๋‚˜๋จธ์ง€ ์ธํ„ฐํŽ˜์ด์Šค : Untrusted Port

1-3. DHCP Snooping ์„ค์ •

Switch(config)# ip dhcp snooping
Switch(config)# ip dhcp snooping <INTERFACE>
Switch(config)# 
Switch(config)# int <interface>
Switch(config-if)# ip dhcp snooping trust

# DHCP Snooping Binding Table ํ™•์ธ
Switch# show ip dhcp snooping binding

2. IP Source Guard

๊ณต๊ฒฉ์ž๊ฐ€ Source IP๋ฅผ ์†์—ฌ ํ†ต์‹ ํ•˜๋Š” ๊ฒƒ์„ ์ฐจ๋‹จํ•œ๋‹ค. L2 ์žฅ๋น„์—์„œ ์‚ฌ์šฉํ•œ๋‹ค. DHCP Snooping๊ณผ ๋™์‹œ์— ์‚ฌ์šฉํ•œ๋‹ค.

* IP Spoofing = ๋‚จ์˜ IP๋ฅผ ์ž์‹ ์˜ ๊ฒƒ์ฒ˜๋Ÿผ ์†์ด๋Š” ํ–‰์œ„.

ํ† ํด๋กœ์ง€2. IP Spoofing ๋™์ž‘ ๋ฐฉ์‹

2-1. IP Source Guard ๋™์ž‘ ๋ฐฉ์‹

โ‘  ๊ณต๊ฒฉ์ž๊ฐ€ PING ํŒจํ‚ท์„ ์Šค์œ„์น˜๋กœ ์ „์†กํ•œ๋‹ค.

โ‘ก ํŒจํ‚ท์„ ๋ฐ›์€ PC๋Š” ๋ชฉํ‘œ ๋Œ€์ƒ์œผ๋กœ ์‘๋‹ตํ•œ๋‹ค.

ํ•˜์ง€๋งŒ IP Source Guard๋ฅผ ์‚ฌ์šฉํ•˜๋ฉด,  โ‘  ์ดํ›„ ์Šค์œ„์น˜๊ฐ€ DHCP Binding Table์™€ ๋น„๊ตํ•œ๋‹ค.(IP Source Binding์œผ๋กœ ๋น„๊ตํ•  ์ˆ˜๋„ ์žˆ๋‹ค.) 
๋น„๊ต ํ›„ ์ˆ˜์‹ ํ•œ ํ”„๋ ˆ์ž„์˜ ์ถœ๋ฐœ์ง€ IP๊ฐ€ ๋‹ค๋ฅด๋‹ค๋ฉด, ํ•ด๋‹น ํŒจํ‚ท์„ ์ฐจ๋‹จํ•œ๋‹ค.

2-2. IP Source Guard ์„ค์ •

[์„ค์ •]
๊ธฐ๋ณธ์œผ๋กœ DHCP Snooping ์„ค์ •์ด ๋˜์–ด ์žˆ์–ด์•ผ ํ•œ๋‹ค.

Switch(config)# int <interface>
Switch(config-if)# ip verify source

#IP Source Binding Table
Switch# show ip verify source

[IP Source Binding ์„ค์ •]

Switch(config)# ip source binding <MAC> <VLAN> <IP> <INTERFACE>

3. Dynamic ARP Inspection ; DAI

ARP Spoofing์„ ์ฐจ๋‹จํ•˜๊ธฐ ์œ„ํ•ด DAI๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.

3-1.  ARP Spoofing์ด๋ž€?

๊ณต๊ฒฉ์ž๊ฐ€ ARP ํŒจํ‚ท์„ ๋ณด๋‚ผ ๋•Œ, ์ž์‹ ์˜ MAC ์ฃผ์†Œ๋ฅผ GW๋‚˜ Server ๋“ฑ์˜ MAC ์ฃผ์†Œ๋กœ ์†์—ฌ์„œ ๋ณด๋‚ธ๋‹ค. ๊ทธ๋ฆฌ๊ณ  GW๋กœ๋Š” ์ž์‹ ์ด Host, Server๋ผ๊ณ  ๊ด‘๊ณ ํ•œ๋‹ค.  ์ด๋ ‡๊ฒŒ ๋˜๋ฉด ๊ฒฐ๊ตญ ๋ชจ๋“  ๋ฐ์ดํ„ฐ๋Š” ๊ณต๊ฒฉ์ž๋ฅผ ๊ฑฐ์น˜๊ฒŒ ๋  ๊ฒƒ์ด๋‹ค.

ํŠนํžˆ๋‚˜, ARP๋Š” ๊ฐ€์žฅ ๋งˆ์ง€๋ง‰์— ๋“ค์–ด์˜จ ์ •๋ณด๋ฅผ ์‚ฌ์šฉํ•˜๊ธฐ ๋•Œ๋ฌธ์— ์ฃผ๊ธฐ์ ์œผ๋กœ ์ด๋Ÿฐ ์‹์œผ๋กœ ARP ๊ด‘๊ณ ๋ฅผ ํ•œ๋‹ค๋ฉด ๋‚ด๋ถ€ ํ˜ธ์ŠคํŠธ๋“ค์€ ๊ณต๊ฒฉ์ž์˜ MAC์ฃผ์†Œ๊ฐ€ GW๋‚˜ ์„œ๋ฒ„์˜ MAC ์ฃผ์†Œ์ธ ์ค„ ์•Œ๊ฒŒ ๋˜๋ฏ€๋กœ ์œ„ํ—˜ํ•˜๋‹ค.

์ด๋Ÿฐ ํŒจํ‚ท์„ ์ฐจ๋‹จํ•˜๊ธฐ ์œ„ํ•ด DAI๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.


3-2. Dynamic ARP Inspection ๋™์ž‘ ๋ฐฉ์‹

DAI๊ฐ€ ๋™์ž‘ํ•˜๋ฉด ๋ชจ๋“  ARP ์š”์ฒญ/์‘๋‹ต ํŒจํ‚ท์„ ๊ฒ€์‚ฌํ•˜๊ฒŒ ๋œ๋‹ค.
์Šค์œ„์น˜๊ฐ€ ์ˆ˜์‹ ํ•œ ARP ํ”„๋ ˆ์ž„๊ณผ DHCP Binding Table ๋˜๋Š” ARP ACL์ด ์ผ์น˜ํ•ด์•ผ ํ”„๋ ˆ์ž„์„ ์ „์†กํ•œ๋‹ค.

3-3. Dynamic ARP Inspection ์„ค์ •

[์„ค์ •]
DAI๊ฐ€ ๋™์ž‘ํ•˜๊ธฐ ์œ„ํ•ด์„  DHCP Snooping์ด ๋™์ž‘ํ•ด์•ผ ํ•œ๋‹ค.

Switch(config)# ip dhcp snooping
Switch(config)# ip dhcp snooping <VLAN>
Switch(config)# ip arp inspection <VLAN>
Switch(config)# 
Switch(config)# int <INTERFACE>
Switch(config-if)# ip dhcp snooping trust
Switch(config-if)# ip arp inspection trust

[ARP ACL ์„ค์ •]

Switch(config)# arp access-list <NAME>
Switch(config-arp-nacl)# permit ip <SOURCE> mac <DESTINATION>
Switch(config-arp-nacl)# exit
Switch(config)# 
Switch(config)# ip arp inspection filter <NAME> <VLAN>

DHCP 1: ๊ฐœ๋…

Dynamic Host Configuration Protocol

๋™์  ํ˜ธ์ŠคํŠธ ์„ค์ • ํ”„๋กœํ† ์ฝœ.
๋ง ๊ทธ๋Œ€๋กœ ๋™์ ์œผ๋กœ ํ˜ธ์ŠคํŠธ IP๋ฅผ ๋ถ€์—ฌํ•˜๊ณ  ๊ด€๋ฆฌํ•˜๋Š” ํ”„๋กœํ† ์ฝœ.

1. DHCP ๋™์ž‘๊ณผ์ •
2. DHCP Relay Agent


1. DHCP ๋™์ž‘๊ณผ์ •

โ‘  PC๋Š” DHCP ์„œ๋ฒ„๋ฅผ ์ฐพ๊ธฐ ์œ„ํ•ด DHCP DISCOVER ๋ฉ”์„ธ์ง€๋ฅผ Broadcastํ•œ๋‹ค.
– ์ถœ๋ฐœ์ง€: 0.0.0.0
– ๋ชฉ์ ์ง€: 255.255.255.255 / udp 67
– ๋ณธ์ธ์˜ MAC์ฃผ์†Œ๋ฅผ ํฌํ•จํ•˜์—ฌ ๋ณด๋‚ธ๋‹ค. 

โ‘ก DHCP ์„œ๋ฒ„๋Š” IP๋ฅผ ์ œ์•ˆํ•˜๊ธฐ ์œ„ํ•ด DHCP OFFER ๋ฉ”์„ธ์ง€๋ฅผ Broadcastํ•œ๋‹ค.
– ์ถœ๋ฐœ์ง€: DHCP ์„œ๋ฒ„์˜ IP
– ๋ชฉ์ ์ง€: 255.255.255.255
– ํด๋ผ์ด์–ธํŠธ์—์„œ ์‚ฌ์šฉํ•  IP, Subnet, GW, DNS, IP ์ž„๋Œ€ ์‹œ๊ฐ„, ๊ทธ๋ฆฌ๊ณ  ํด๋ผ์ด์–ธํŠธ์˜ MAC์„ ํฌํ•จํ•˜์—ฌ ๋ณด๋‚ธ๋‹ค.

โ‘ข PC๋Š” OFFER ๋ฉ”์„ธ์ง€๋กœ ๋ฐ›์€ ์ •๋ณด๋ฅผ ์‚ฌ์šฉํ•˜๊ธฐ ์œ„ํ•ด DHCP REQUEST ๋ฉ”์„ธ์ง€๋ฅผ Broadcastํ•œ๋‹ค.
– ์ถœ๋ฐœ์ง€: 0.0.0.0
– ๋ชฉ์ ์ง€: 255.255.255.255
– ์„œ๋ฒ„ IP๋ฅผ ์•Œ์•„๋„ Broadcast๋กœ ๋ณด๋‚ด๋Š” ์ด์œ ๋Š” ๋‹ค๋ฅธ DHCP์„œ๋ฒ„์—๊ฒŒ ์•Œ๋ฆฌ๊ธฐ ์œ„ํ•จ์ด๋‹ค.

โ‘ฃ ์„œ๋ฒ„๊ฐ€ ํด๋ผ์ด์–ธํŠธ์˜ ์š”์ฒญ์„ ์ˆ˜๋ฝํ•˜๊ธฐ ์œ„ํ•ด DHCP ACK๋ฅผ Broadcastํ•œ๋‹ค.
– ์ถœ๋ฐœ์ง€: DHCP ์„œ๋ฒ„์˜ IP
– ๋ชฉ์ ์ง€: 255.255.255.255


2. DHCP Relay Agent

DHCP ์„œ๋ฒ„๊ฐ€ ํ•ญ์ƒ ๊ฐ™์€ ๋ง์— ์†ํ•ด์žˆ์œผ๋ฆฌ๋ž€ ๋ณด์žฅ์€ ์—†๋‹ค.
์„œ๋กœ ๋‹ค๋ฅธ ๋ง์ด๋ผ๋ฉด L3์žฅ๋น„์—์„œ Relay Agent๋ฅผ ์„ค์ •ํ•ด์•ผํ•œ๋‹ค.

[ DHCP ์„œ๋ฒ„๊ฐ€ 1๋Œ€์ธ ๊ฒฝ์šฐ]

Router(config)# service dhcp
Router(config)# int <INTERFACE_CONNECTD_BY_CLIENT>
Router(config-if)# ip helper-address <DHCP_SERVER_IP>
๏ปฟ

[ DHCP ์„œ๋ฒ„๊ฐ€ ์—ฌ๋Ÿฌ๋Œ€์ธ ๊ฒฝ์šฐ ]

#์ˆ˜๋™์œผ๋กœ ์„œ๋ฒ„ ์ง€์ •
Router(config)# int <INTERFACE_CONNECTD_BY_CLIENT>
Router(config-if)# ip helper-address <DHCP_SERVER_IP_1>
Router(config-if)# ip helper-address <DHCP_SERVER_IP_2>

#์ž๋™์œผ๋กœ ์„œ๋ฒ„ ์ง€์ •
Router(config)# ip helper-address <DHCP_BROADCAST_IP>
Router(config)# int <INTERFACE_CONNECTD_BY_CLIENT>
Router(config-if)# ip directed-broadcast

[Switch] VLAN Hopping Attack

์„œ๋กœ ๋‹ค๋ฅธ VLAN์˜ ํ˜ธ์ŠคํŠธ๋“ค๋ผ๋ฆฌ ํ†ต์‹ ํ•˜๋ ค๋ฉด, L3 ์žฅ๋น„๋ฅผ ๊ฑฐ์ณ์„œ ํ†ต์‹ ํ•ด์•ผํ•œ๋‹ค. ๊ทธ๋Ÿฌ๋‚˜, ๋‹ค๋ฅธ VLAN์— ์†ํ•œ ๋Œ€์ƒ์„ ๊ณต๊ฒฉํ•  ๋•Œ, L3 ์žฅ๋น„๋ฅผ ๊ฑฐ์น˜์ง€ ์•Š๊ณ  ๊ณต๊ฒฉํ•˜๋Š” ๊ฒƒ์„ VLAN Hopping Attack์ด๋ผ๊ณ  ํ•œ๋‹ค.

์•„๋ž˜ ํ† ํด๋กœ์ง€๋ฅผ ๋ณด๊ณ  ์–ด๋–ป๊ฒŒ Hopping Attack์ด ์ง„ํ–‰๋˜๋Š”์ง€ ๋ณด์ž.

ํ† ํด๋กœ์ง€ 1. VLAN Hopping Attack

[ํ˜„์žฌ ํ† ํด๋กœ์ง€ ๊ตฌ์„ฑ ์ƒํƒœ]
(1) ํ˜„์žฌ ๊ด€๋ฆฌ์ž๊ฐ€ PC์™€ ์—ฐ๊ฒฐ๋œ SW2์˜ ํฌํŠธ๋ฅผ ์„ค์ •ํ•  ๋•Œ,
‘switchport access vlan 20’๋งŒ ์„ค์ •ํ•œ ์ƒํ™ฉ.
(2) ‘switchport mode access’๋ฅผ ๋ˆ„๋ฝํ–ˆ๊ณ , native vlan ๋„ 1์ธ ์ƒํ™ฉ์ด๋‹ค.

์ด ์ƒํƒœ๋ผ๋ฉด ๊ณต๊ฒฉ์ž๋Š” DTP ํ”„๋ ˆ์ž„์„ ์ด์šฉํ•ด SW2-๊ณต๊ฒฉ์ž PC์˜ mode๋ฅผ Trunk๋กœ ๋ณ€๊ฒฝํ•  ์ˆ˜ ์žˆ๊ฒŒ ๋œ๋‹ค.


โ‘  TrunkํฌํŠธ๋กœ ๋ณ€๊ฒฝํ•˜๊ณ , Data๋ฅผ ๋ณด๋‚ธ๋‹ค.

SW2—–๊ณต๊ฒฉ์ž์˜ Port mode๊ฐ€ Trunk๋กœ ๋ณ€๊ฒฝ๋˜๊ณ ,

๊ณต๊ฒฉ์ž๋Š” SW2๋กœ ํŒจํ‚ท์„ ๋ณด๋‚ธ๋‹ค.
( Vlan 1 Tag | Vlan 10 Tag | ๊ณต๊ฒฉ Data )

SW2์˜ Native VLAN์ด 1 ์ด๋ฏ€๋กœ
VLAN 1 TAG๋ฅผ ์ œ๊ฑฐ ํ›„ SW1๋กœ ์ „๋‹ฌํ•œ๋‹ค.

โ‘ก VLAN 1 TAG๋ฅผ ์ œ๊ฑฐ ํ›„ SW1๋กœ ๋ฐ์ดํ„ฐ๋ฅผ ์ „์†กํ•œ๋‹ค.

SW1์€ ํŒจํ‚ท์˜ VLAN 10 TAG๋ฅผ ๋ณด๊ณ , VLAN 10์— ์†ํ•œ PC1์—๊ฒŒ ํŒจํ‚ท์„ ์ „๋‹ฌํ•œ๋‹ค.
์ด๋ ‡๊ฒŒ ๊ณต๊ฒฉ์ž์˜ ํŒจํ‚ท์€ ๋ฌดํƒˆํžˆ PC1๋กœ ์ „์†ก๋˜์—ˆ๋‹ค.

๊ทธ๋ ‡๋‹ค๋ฉด, ์ด๋Ÿฐ ๊ณต๊ฒฉ์„ ๋ง‰์„ ์ˆ˜ ์žˆ๋Š” ๋ฐฉ๋ฒ•์€ ๋ฌด์—‡์ผ๊นŒ?
๋‹น์—ฐํ•˜๊ฒŒ๋„ ์ด๋ฏธ ๋ฐฉ๋ฒ•์€ ๋‚˜์™€์žˆ๋‹ค.

โ‘ Trunking์„ ์‚ฌ์šฉํ•˜์ง€ ์•Š๋Š” ํฌํŠธ๋Š” ๋ฐ˜๋“œ์‹œ Access๋กœ ์„ค์ •ํ•ด์ฃผ๊ณ ,
โ‘กNative VLAN์€ ๋ฐ˜๋“œ์‹œ ๋‹ค๋ฅธ ๋ฒˆํ˜ธ๋กœ ๋ณ€๊ฒฝํ•˜๋Š” ๊ฒƒ์ด๋‹ค.

[Switch] ํฌํŠธ ํŠธ๋ž˜ํ”ฝ ์ œ์–ด

์Šค์œ„์น˜ ๋ณด์•ˆ ์ค‘ ํŠธ๋ž˜ํ”ฝ์˜ ์ถœ๋ฐœ์ง€๋ฅผ ๋ณด๊ณ  ์ฐจ๋‹จํ•˜๋Š” ๋ฐฉ๋ฒ•๋งŒ ์žˆ๋Š” ๊ฒƒ์ด ์•„๋‹ˆ๋‹ค. ํŠธ๋ž˜ํ”ฝ์˜ ์ข…๋ฅ˜, ํŠธ๋ž˜ํ”ฝ์˜ ์–‘์— ๋”ฐ๋ผ ์ฐจ๋‹จํ•˜๋Š” ๋ฐฉ๋ฒ•๋„ ์žˆ๋‹ค. ๋ฐ”๋กœ ํฌํŠธ ํŠธ๋ž˜ํ”ฝ์„ ์ œ์–ดํ•˜๋Š” ๊ฒƒ์ด๋‹ค. ํฌํŠธ ํŠธ๋ž˜ํ”ฝ์— ๋Œ€ํ•ด ์•Œ์•„๋ณด์ž.

  1. Storm Control
  2. Protected Port
  3. Port Blocking

ํ† ํด๋กœ์ง€1. ํฌํŠธ ํŠธ๋ž˜ํ”ฝ ์ œ์–ด

1. Storm Control (๊ณผ๋‹ค ํŠธ๋ž˜ํ”ฝ ์ œ์–ด)

์Šค์œ„์น˜์˜ ํฌํŠธ๋กœ Unicast / Multicast / Broadcast ํŠธ๋ž˜ํ”ฝ์ด 1์ดˆ ๋™์•ˆ ์‚ฌ์šฉ์ž๊ฐ€ ์„ค์ •ํ•œ ์ˆ˜์ค€ ์ด์ƒ์œผ๋กœ ๋งŽ์ด ์ˆ˜์‹ ๋˜์—ˆ์„ ๋•Œ, ํ•ด๋‹น ํŠธ๋ž˜ํ”ฝ์„ ๋ชจ๋‘ ์ฐจ๋‹จํ•œ๋‹ค.

์„ค์ •

์˜ˆ๋ฅผ ๋“ค์–ด, SW2์˜ F0/3์—์„œ Broadcast ํŒจํ‚ท์ด ๋Œ€์—ญํญ์˜ 25% ์ด์ƒ์„ ์ฐจ์ง€ํ•  ๊ฒฝ์šฐ ์ฐจ๋‹จํ•˜๋Š” ๊ฒƒ์„ ์„ค์ •ํ•ด๋ณด์ž.

SW2(config)# int fa0/3
SW2(config-if)# storm-control broadcast level 25

3: broadcast ๋Œ€์‹  unicast, multicast๋กœ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค. level 25๋Š” ๋Œ€์—ญํญ์˜ 25%๋ฅผ ์˜๋ฏธํ•˜๋ฏ€๋กœ ์ ์ ˆํ•œ ๊ฐ’์œผ๋กœ ๋ณ€๊ฒฝํ•˜์—ฌ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค.


2. Protected Port (๋ฐฉ์–ด ํฌํŠธ)

ํ•˜๋‚˜์˜ ์Šค์œ„์น˜์—์„œ Protected Port๋กœ ์„ค์ •๋œ ํฌํŠธ๋ผ๋ฆฌ Unicast / Multicast / Broadcast๋ฅผ ์ฐจ๋‹จํ•œ๋‹ค. ์„œ๋กœ ๋‹ค๋ฅธ ์Šค์œ„์น˜์˜ Protected Port๋ผ๋ฆฌ๋Š” ์ •์ƒ์ ์œผ๋กœ ํŠธ๋ž˜ํ”ฝ์„ ์ฃผ๊ณ  ๋ฐ›๋Š”๋‹ค.
(๋‹จ, ๋ชฉ์ ์ง€๊ฐ€ ์—†๋Š” ํ”„๋ ˆ์ž„์€ Flooding ๋œ๋‹ค.)
Protected Port๋กœ ์„ค์ •๋˜์ง€ ์•Š์€ ํฌํŠธ์™€๋Š” ์ •์ƒ์ ์œผ๋กœ ํŠธ๋ž˜ํ”ฝ์„ ์ฃผ๊ณ  ๋ฐ›์„ ์ˆ˜ ์žˆ๋‹ค.

์„ค์ •

SW2์˜ F0/2, F0/3์„ Protected Port๋กœ ์„ค์ •ํ•ด๋ณด์ž.

SW2(config)# int ran fa0/2 - 3
SW2(config-if)# switchport protected

์ด์ œ PC1๊ณผ PC2๋ฅผ PING ํ…Œ์ŠคํŠธํ•ด๋ณด๋ฉด ์‘๋‹ต์ด ์—†๋Š” ๊ฒƒ์„ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.
PC1 – PC3, PC2 – PC3 ๊ฐ„์˜ PING์€ ์ •์ƒ์ ์œผ๋กœ ๋‚˜๊ฐ„๋‹ค.


3. Port Blocking (ํฌํŠธ ์ฐจ๋‹จ)

์Šค์œ„์น˜๊ฐ€ ์ˆ˜์‹ ํ•œ ํ”„๋ ˆ์ž„์˜ ๋ชฉ์ ์ง€๊ฐ€ MAC Table์— ์—†๋‹ค๋ฉด, Flooding ๋˜๋Š” ๊ฒƒ์„ ์ฐจ๋‹จํ•œ๋‹ค. Unicast / Multicast ํŒจํ‚ท์—๋งŒ ์ ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค.

์„ค์ •

SW2์˜ F0/4์— ๋ชฉ์ ์ง€๊ฐ€ ์—†๋Š” Multicast ํ”„๋ ˆ์ž„์„ ์ฐจ๋‹จํ•˜๋„๋ก ์„ค์ •ํ•ด๋ณด์ž.

SW2(config)# int fa0/4
SW2(config-if)# switchport block multicast

3: multicast ๋Œ€์‹  unicast๋ฅผ ์‚ฌ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค.

ACL์„ ์•Œ์•„๋ณด์ž 3: MAC/Port/VLAN ACL, PBACL

ACL์€ ๋ผ์šฐํ„ฐ ๋ฟ๋งŒ ์•„๋‹ˆ๋ผ ์Šค์œ„์น˜์—์„œ๋„ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค. ์Šค์œ„์น˜์—์„œ ๊ตฌ์„ฑํ•  ์ˆ˜ ์žˆ๋Š” ACL์€ ์•„๋ž˜์™€ ๊ฐ™๋‹ค.

  1. MAC ACL
    IP ACL (์ด์ „ ๊ฒŒ์‹œ๊ธ€ ์ฐธ๊ณ )
  2. Port ACL
  3. VLAN ACL
  4. PBACL

1. MAC ACL

MAC ์ฃผ์†Œ๋ฅผ ์ด์šฉํ•ด ํŠธ๋ž˜ํ”ฝ์„ ์ œ์–ดํ•œ๋‹ค. ์ผ๋ฐ˜์ ์ธ IP ACL๊ณผ ๋‹ค๋ฅด๊ฒŒ MAC ACL์€ ๋ฐ˜๋“œ์‹œ Named ACL์„ ์‚ฌ์šฉํ•ด์•ผ ํ•œ๋‹ค.

์„ค์ •

Switch(config)# mac access-list extended <name>
Switch(config-ext-macl)# deny host <MAC> host <MAC>
Switch(config-ext-macl)# permit any any

๋งŒ์ผ, ์—ฌ๋Ÿฌ ๊ฐœ์˜ MAC์ฃผ์†Œ๋ฅผ ์ง€์ •ํ•˜๋ ค๋ฉด, ์™€์ผ๋“œ์นด๋“œ ๋งˆ์Šคํฌ๋ฅผ ์ด์šฉํ•ด ์ง€์ •ํ•œ๋‹ค.
ex) 0011. CB ๋กœ ์‹œ์ž‘ํ•˜๋Š” ๋ชจ๋“  MAC์ฃผ์†Œ๋ฅผ ์ง€์ •ํ•œ๋‹ค๋ฉด, ์™€์ผ๋“œ์นด๋“œ ๋งˆ์Šคํฌ๊ฐ€ 0000.00FF.FFFF๊ฐ€ ๋  ๊ฒƒ์ด๋‹ค.


2. Port ACL

์ผ๋ฐ˜์ ์œผ๋กœ ๋ผ์šฐํ„ฐ์— ์‚ฌ์šฉํ•˜๋Š” IP ACL๊ณผ ๋น„์Šทํ•ด๋ณด์ด์ง€๋งŒ, Port ACL์€ L2 ํฌํŠธ์— ACL์„ ์ ์šฉํ•˜๋Š” ๊ฒƒ์ด๋‹ค. IP์ฃผ์†Œ/MAC์ฃผ์†Œ ๋ชจ๋‘ ์‚ฌ์šฉํ•  ์ˆ˜ ์žˆ๊ณ , ๋™์‹œ์— ํ•„ํ„ฐ๋ง์„ ํ•  ์ˆ˜๋„ ์žˆ๋‹ค.

  • ํ”„๋ ˆ์ž„์„ ์ˆ˜์‹ ํ•˜๋Š” ๊ฒฝ์šฐ(in๋ฐฉํ–ฅ)์—๋งŒ ACL์„ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค.
  • ํŠน์ • ์Šค์œ„์น˜์— VLAN ACL์ด ์„ค์ •๋˜์—ˆ๊ฑฐ๋‚˜ ๋ผ์šฐํ„ฐ์— Inbound ACL์ด ์„ค์ •๋˜์–ด์žˆ๋‹ค๋ฉด, ์‚ฌ์šฉํ•  ์ˆ˜ ์—†๋‹ค.
  • Etherchannel์„ ์‚ฌ์šฉํ•˜๋Š” ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ์‚ฌ์šฉํ•  ์ˆ˜ ์—†๋‹ค.
  • MAC์ฃผ์†Œ๋กœ๋งŒ ํ•„ํ„ฐ๋ง ํ•œ๋‹ค๋ฉด, MAC์˜ ์ ‘๊ทผ์€ ์ฐจ๋‹จ๋˜์–ด๋„ ํ•ด๋‹น MAC์˜ IP๋กœ๋Š” ์ ‘๊ทผํ•  ์ˆ˜ ์žˆ๋‹ค.

3. VLAN ACL

VLAN์— ์ ์šฉํ•˜๋Š” ACL์ด๋‹ค. ์„œ๋กœ ๋‹ค๋ฅธ VLAN ๋ฒˆํ˜ธ ๊ฐ„ ์ œ์–ด, ๊ฐ™์€ VLAN ๋ฒˆํ˜ธ ๊ฐ„ ํŠธ๋ž˜ํ”ฝ์„ ์ œ์–ดํ•œ๋‹ค.
VACL, VLAN Map ์ด๋ผ๊ณ ๋„ ํ•œ๋‹ค.

์„ค์ •

(1) ACL ์ƒ์„ฑ
(2) VLAN MAP ์ƒ์„ฑ
(3) VLAN MAP์„ VLAN์— ์ ์šฉ

[์„ค์ • ์˜ˆ์‹œ]

-
Switch(config)# access-list 100 permit tcp host 10.10.10.1 host 10.10.10.3 eq ssh
Switch(config)# access-list 100 permit tcp host 10.10.20.1 host 10.10.10.3 eq ssh
Switch(config)# access-list 101 permit ip any any
Switch(config)# 
Switch(config)# vlan access-map <VLAN_MAP_NAME>
Switch(config-access-map)# match ip address 100
Switch(config-access-map)# action drop
Switch(config-access-map)# exit
Switch(config)# 
Switch(config)# vlan access-map <VLAN_MAP_NAME>
Switch(config-access-map)# match ip address 101
Switch(config-access-map)# action forward
Switch(config-access-map)# exit
Switch(config)# 
Switch(config)# vlan filter <VLAN_MAP_NAME> vlan-list <VLAN_NUM>
-

2,3,4 : Access list๋ฅผ ํ†ตํ•ด ํ—ˆ์šฉํ•  ํ˜ธ์ŠคํŠธ๋ฅผ ์ง€์ •ํ•œ๋‹ค.
6: VLAN Map์„ ์„ค์ •ํ•œ๋‹ค.
7: ํ—ˆ์šฉํ•˜๊ฑฐ๋‚˜ ์ฐจ๋‹จํ•  ๋Œ€์ƒ์„ ๋ถˆ๋Ÿฌ์˜จ๋‹ค.
8: 7๋ฒˆ ๋Œ€์ƒ์ด ์˜ค๋ฉด Drop(์ฐจ๋‹จ)ํ•˜๋„๋ก ์„ค์ •ํ•œ๋‹ค. ๋ณ„๋„ action ์„ค์ •์„ ํ•˜์ง€ ์•Š์œผ๋ฉด, Forward(ํ—ˆ์šฉ)์ด๋‹ค.
11: 6๋ฒˆ๊ณผ ๊ฐ™์€ ์ด๋ฆ„์„ ์‚ฌ์šฉํ•œ๋‹ค. ์ด๋ฆ„์ด ๊ฐ™์•„๋„ ์ƒ๊ด€์—†๋‹ค. ์–ด์ฐจํ”ผ access-map์„ ๋ณด๊ฒŒ ๋˜๋ฉด ์ž๋™์œผ๋กœ ๋งต ์ด๋ฆ„ ๋’ค์— 20์ด ์ถ”๊ฐ€๋กœ ๋ถ™๊ฒŒ ๋˜์–ด ์„œ๋กœ ๋‹ค๋ฅธ ๋งต์ด๋‹ค.
12,13: ๋งต ์ด๋ฆ„๋งŒ ์ •์˜ํ•˜๋ฉด, match / action์„ ์„ค์ •ํ•˜์ง€ ์•Š์œผ๋ฉด ๋‚˜๋จธ์ง€ ๋ชจ๋“  ๊ฒƒ์„ ํ—ˆ์šฉํ•œ๋‹ค๋Š” ์˜๋ฏธ์ด๋ฏ€๋กœ 12,13๋Š” ์ƒ๋žตํ•ด๋„ ๋œ๋‹ค.
16: ์›ํ•˜๋Š” VLAN์— VLAN ๋งต์„ ์ ์šฉํ•œ๋‹ค.


4. PBACL

Policy-Based ACL
IP ์ฃผ์†Œ๋‚˜ ํฌํŠธ ๋ฒˆํ˜ธ๋ฅผ ‘Object Group’์œผ๋กœ ์ง€์ •ํ•˜๊ณ , ACL ์ƒ์„ฑ ์‹œ ‘Object Group’์„ ์‚ฌ์šฉํ•ด ์ง€์ •ํ•˜๋Š” ๋ฐฉ์‹์ด๋‹ค. Routed / SVI์™€ ๊ฐ™์€ L3 ์ธํ„ฐํŽ˜์ด์Šค์™€ IPv4๋งŒ ์ ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค. ๋˜ํ•œ, Named ACL๋กœ๋งŒ ์ ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค.

์„ค์ •

-
Switch(config)# object-group ip address <OBJECT_NAME>
Switch(config-port-ogroup)# host <IP>
Switch(config-port-ogroup)# <NETWORK_ID> <SUBNETMASK>
Switch(config-port-ogroup)# exit
Switch(config)#
Switch(config)# object-group ip address <OBJECT_NAME2>
Switch(config-port-ogroup)# eq <PORT_NUM>
Switch(config-port-ogroup)# <NETWORK_ID> <SUBNETMASK>
Switch(config-port-ogroup)# exit
Switch(config)#
Switch(config)# ip access-list extended <ACL_NAME>
Switch(config-ext-nacl)# permit tcp addgroup <OBJECT_NAME> portgroup <OBJECT_NAME2> any
Switch(config-ext-nacl)# deny tcp any any
Switch(config-ext-nacl)# exit
Switch(config)# int <interface>
Switch(config-if)# ip access-group <ACL_NAME> in
๏ปฟ-

[Switch] ํฌํŠธ ๋ณด์•ˆ

์Šค์œ„์น˜์˜ ํŠน์ • ํฌํŠธ์— ํŠน์ • MAC๋งŒ ํ—ˆ์šฉํ•  ์ˆ˜ ์žˆ๋Š” ๊ธฐ๋Šฅ์ด๋‹ค.
Access / Trunk / Tunnel ์ด ์•„๋‹Œ ๋™์  ๋ชจ๋“œ์—์„œ๋Š” ์‚ฌ์šฉํ•  ์ˆ˜ ์—†๋‹ค.

  1. ์ •์  MAC ์ง€์ •
  2. ๋™์  MAC ์ง€์ •
  3. Port-Sticky
  4. ํฌํŠธ ๋ณด์•ˆ ์นจํ•ด ์‹œ ๋™์ž‘

ํ† ํด๋กœ์ง€1. ํฌํŠธ๋ณด์•ˆ

1. ์ •์  MAC ์ง€์ •

-
Switch0(config)# int <INTERFACE>
Switch0(config-if)# switchport mode access
Switch0(config-if)# switchport port-security mac-address <MAC>
Switch0(config-if)# switchport port-security
-

5: switchport port-security ๋ถ€ํ„ฐ ์„ค์ •ํ•˜๋ฉด, ๋™์  MAC ์ง€์ •์ด ๋˜๋ฏ€๋กœ ๋ฐ˜๋“œ์‹œ ์ •์ ์œผ๋กœ MAC ์ง€์ •ํ•  ๋•Œ๋Š” 4:์„ ๋จผ์ € ์„ค์ •ํ•œ๋‹ค.

๋˜ํ•œ, fa0/1์— ์„ค์ •ํ–ˆ๋˜ MAC์ด fa0/2๋กœ ๋“ค์–ด์˜จ๋‹ค๋ฉด, fa0/2๋„ ํฌํŠธ๊ฐ€ ๋น„ํ™œ์„ฑํ™”๋œ๋‹ค.

2. ๋™์  MAC ์ง€์ •

๋™์  MAC์œผ๋กœ ์ง€์ •ํ•˜๋„๋ก ์„ค์ •ํ•œ๋‹ค๋ฉด, MAC Table์— ์žˆ๋Š” ์ฒซ๋ฒˆ์งธ MAC ๋˜๋Š” ์ฒ˜์Œ MAC Table์— ๊ธฐ๋ก๋˜๋Š” ๊ฒƒ์œผ๋กœ ์ง€์ •ํ•œ๋‹ค. ์Šค์œ„์น˜๊ฐ€ ์žฌ๋ถ€ํŒ…๋˜๋ฉด ๋™์ ์œผ๋กœ ์ง€์ •๋œ MAC์€ ์‚ญ์ œ๋œ๋‹ค.

-
Switch0(config)# int <INTERFACE>
Switch0(config-if)# switchport port-security
-

3. Port-Sticky

ํ•œ๋ฒˆ์— ์—ฌ๋Ÿฌ ๊ฐœ์˜ MAC์„ ์ง€์ •ํ•ด์•ผ๋  ๋•Œ, ์œ ์šฉํ•˜๋‹ค.
๋™์  MAC ์ง€์ •๊ณผ๋Š” ๋‹ค๋ฅด๊ฒŒ ์Šค์œ„์น˜๊ฐ€ ์žฌ๋ถ€ํŒ…๋˜๋„ ์ง€์ •๋œ MAC์ •๋ณด๊ฐ€ ์œ ์ง€๋œ๋‹ค.

-
Switch0(config)# int <INTERFACE>
Switch0(config-if)# switchport trunk encapsulation dot1q
Switch0(config-if)# switchport mode trunk
Switch0(config-if)# switchport port-security
Switch0(config-if)# switchport port-security maximum 3
Switch0(config-if)# switchport port-security mac-address sticky
-

4. ํฌํŠธ ๋ณด์•ˆ ์นจํ•ด ์‹œ ๋™์ž‘

๊ธฐ๋ณธ์ ์œผ๋กœ ํฌํŠธ ๋ณด์•ˆ ์นจํ•ด ์‹œ Shutdown.

  • protect : ๋ณด์•ˆ ์นจํ•ด ์‹œ ์นจํ•ดํ•œ ์žฅ๋น„๋ฅผ ์ฐจ๋‹จํ•œ๋‹ค. ์ ‘์† ํ—ˆ์šฉ๋œ ์žฅ๋น„๋Š” ๊ทธ๋Œ€๋กœ ํ—ˆ์šฉํ•œ๋‹ค.
  • restrict : ๋ณด์•ˆ ์นจํ•ด ์‹œ ์นจํ•ดํ•œ ์žฅ๋น„๋ฅผ ์ฐจ๋‹จํ•œ๋‹ค. ์ ‘์† ํ—ˆ์šฉ๋œ ์žฅ๋น„๋Š” ๊ทธ๋Œ€๋กœ ํ—ˆ์šฉํ•œ๋‹ค. Log๋ฅผ ๋ฐœ์ƒ์‹œํ‚ค๊ณ , ๋ณด์•ˆ ์นจํ•ด ์นด์šดํ„ฐ๋ฅผ ์ฆ๊ฐ€์‹œํ‚จ๋‹ค.
  • shutdown : ํฌํŠธ๋ฅผ ์…ง๋‹ค์šดํ•œ๋‹ค.
-
Switch0(config)# int <INTERFACE>
Switch0(config-if)# switchport port-security violation [protect|restrict|shutdown]
-

Multicast Routing Protocol: PIM-DM / PIM-SM

Multicast ํŒจํ‚ท์„ ์ฒ˜๋ฆฌํ•˜๊ธฐ ์œ„ํ•ด ํ•„์š”ํ•œ ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ.
๋ณดํ†ต PIM-DM ์ด๋‚˜ PIM-SM์„ ์‚ฌ์šฉํ•œ๋‹ค. PIM์€ ‘Protocol Independent Multicast’์˜ ์•ฝ์ž์ธ๋ฐ, ํ”„๋กœํ† ์ฝœ๊ณผ ๋…๋ฆฝ๋œ ๋ฉ€ํ‹ฐ์บ์ŠคํŠธ ์ฆ‰, ์œ ๋‹ˆ์บ์ŠคํŠธ ๋ผ์šฐํŒ…์€ ์•„๋ฌด๊ฑฐ๋‚˜ ์‚ฌ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค๋Š” ์˜๋ฏธ๋‹ค.

  1. PIM-DM
  2. PIM-SM

1. PIM-DM

Protocol Independent Multicast – Dense Mode

๋ณดํ†ต LAN์ฒ˜๋Ÿผ Multicast ๋ชฉ์ ์ง€๊ฐ€ ๋ฐ€์ง‘(Dense)ํ•œ ๋ง์—์„œ ์‚ฌ์šฉํ•œ๋‹ค. ์ฃผ๊ธฐ์ ์œผ๋กœ Multicast ์ •๋ณด๋ฅผ ์ „์†กํ•˜๊ณ , ๋งŒ์ผ Neighbor๋กœ๋ถ€ํ„ฐ ์ผ์ • ๊ธฐ๊ฐ„ ๋™์•ˆ ์ •๋ณด๋ฅผ ๋ฐ›์ง€ ๋ชปํ•˜๋ฉด ํ•ด๋‹น ๊ฒฝ๋กœ๋ฅผ ์‚ญ์ œํ•œ๋‹ค.

PIM-DM ๋™์ž‘ ๋ฐฉ์‹

PIM-DM ์„ค์ •

ํ† ํด๋กœ์ง€1. PIM-DM ์„ค์ •

[๊ธฐ๋ณธ]
– Access ํฌํŠธ ์„ค์ • ( L3SW1, L3SW2, SW1 )
– IP์ฃผ์†Œํ• ๋‹น ( SW1 ์ œ์™ธ )
– ๋ผ์šฐํŒ… ( OSPF )

[PIM-DM ์„ค์ •]

-
L3SW1(config)# ip multicast-routing
L3SW1(config)#
L3SW1(config)# int vlan 10
L3SW1(config-if)# ip pim dense-mode
L3SW1(config-if)# int vlan 20
L3SW1(config-if)# ip pim dense-mode

L3SW2(config)# ip multicast-routing
L3SW2(config)#
L3SW2(config)# int vlan 20
L3SW2(config-if)# ip pim dense-mode
L3SW2(config-if)# int vlan 30
L3SW2(config-if)# ip pim dense-mode
-

[ํ™•์ธ]

show ip pim neighbor

Neighbor๋งบ์€ ๊ฒƒ์„ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

Multicast ์‹œ๋ฎฌ๋ ˆ์ด์…˜

-
PC(config)# int fa0/0
PC(config-if)# ip igmp join-group 239.1.1.2

Server# ping 239.1.1.2 repeat 10000 
-
๋ฉ€ํ‹ฐ์บ์ŠคํŒ… ํŒจํ‚ท์˜ ์†Œ์Šค์ฃผ์†Œ์™€ ๊ทธ๋ฃน ๋ฒˆํ˜ธ๋ฅผ ํ™•์ธํ•  ์ˆ˜ ์žˆ๋‹ค.

(10.10.1.2, 239.1.1.2) = ์†Œ์ŠคIP, Multicast ๊ทธ๋ฃน๋ฒˆํ˜ธ


2. PIM-SM

Protocol Independent Multicast – Sparse Mode

Multicast ํŒจํ‚ท์„ ์ˆ˜์‹ ํ•˜๋Š” ์žฅ๋น„๋“ค์ด ์—ฌ๋Ÿฌ ๊ณณ์œผ๋กœ ๋ถ„์‚ฐ๋˜์—ˆ์„ ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค. ๋‹ค์–‘ํ•œ ๊ธฐ๋Šฅ์œผ๋กœ LAN์—์„œ ์‚ฌ์šฉํ•˜๊ธฐ๋„ ํ•œ๋‹ค.

PIM-SM ๋™์ž‘๋ฐฉ์‹

(1) ์‚ฌ์šฉ ์ค‘์ธ Multicast Source ์ •๋ณด๋ฅผ ๊ฐ–๊ณ  ์žˆ๋Š” Redezvous Point(RP)๋ฅผ ์ง€์ •ํ•œ๋‹ค. ์ง€์ •๋ฐฉ์‹์—๋Š” Static RP / Auto RP / BSR ์ด ์žˆ๋‹ค.

(2) Designated Router ( Multicast Source์™€ ์ธ์ ‘ํ•œ ์žฅ๋น„ )๊ฐ€ Source IP, Multicast Group ๋ฒˆํ˜ธ๋ฅผ RP์—๊ฒŒ ํ†ต๋ณดํ•œ๋‹ค.

(3) ์œ„ ์ •๋ณด๋ฅผ ๋ฐ”ํƒ•์œผ๋กœ RP๋Š” Multicast Routing Table์„ ์ƒ์„ฑํ•œ๋‹ค. DR์—๊ฒŒ ํŒจํ‚ท ์ „์†ก ์ค‘์ง€๋ฅผ ์š”์ฒญํ•œ๋‹ค.

(4) ํ•ด๋‹น ๊ฒฝ๋กœ๊ฐ€ MRT์— ์‚ญ์ œ ๋˜์ง€ ์•Š๋„๋ก ์ฃผ๊ธฐ์ ์œผ๋กœ DR์ด RP๋กœ Source ๊ด€๋ จ ์ •๋ณด๋ฅผ ์ „์†กํ•œ๋‹ค.

(5) Host๊ฐ€ ๋ผ์šฐํ„ฐ์—๊ฒŒ Multicast ๊ทธ๋ฃน ๊ฐ€์ž… ์š”์ฒญํ•œ๋‹ค. ์ด ๋•Œ IGMP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.

(6) ๋ผ์šฐํ„ฐ๊ฐ€ RP์—๊ฒŒ PIM-SM์„ ์ด์šฉํ•ด Multicast ํŒจํ‚ท์„ ์š”์ฒญํ•œ๋‹ค.

(7) RP๊ฐ€ MRT๋ฅผ ์ฐธ๊ณ ํ•˜์—ฌ, Source์— ์ธ์ ‘ํ•œ DR๋กœ๋ถ€ํ„ฐ Multicast ํŒจํ‚ท์„ ์š”์ฒญํ•œ๋‹ค. ์ด ํŒจํ‚ท์„ ์ˆ˜์‹ ํ•˜๋ฉด, Host๋กœ ์ „์†กํ•œ๋‹ค.

PIM-SM ์„ค์ •

ํ† ํด๋กœ์ง€2. PIM-SM ์„ค์ •

1. Static RP

-
L3SW1(config)# ip multicast-routing
L3SW1(config)# ip pim rp-address 1.1.1.1
L3SW1(config)# int vlan 10
L3SW1(config-if)# ip pim sparse-mode
L3SW1(config-if)# int vlan 20
L3SW1(config-if)# ip pim sparse-mode

L3SW2(config)# ip multicast-routing
L3SW2(config)# ip pim rp-address 1.1.1.1
L3SW2(config)# int vlan 20
L3SW2(config-if)# ip pim sparse-mode
L3SW2(config-if)# int vlan 30
L3SW2(config-if)# ip pim sparse-mode
-

2. Auto RP ; Cisco ์ „์šฉ
– ๋™์ž‘๊ณผ์ •
(1) Candidate RP๊ฐ€ 224.0.1.39๋ฅผ ์ด์šฉํ•ด ์ž์‹ ์ด RP ํ›„๋ณด์ž„์„ ์•Œ๋ฆผ.
(2) RP Mapping Agent๊ฐ€ RP ํ›„๋ณด ์ทจํ•ฉ ๋ฐ Multicast ๊ทธ๋ฃน ๋ณ„ RP๋ฅผ ์ง€์ •ํ•˜์—ฌ 224.0.1.40์œผ๋กœ ๋‹ค๋ฅธ ๋ผ์šฐํ„ฐ์—๊ฒŒ ์•Œ๋ฆผ.
(3) Multicast ๋™์ž‘ํ•˜๋Š” ๋ผ์šฐํ„ฐ๋“ค์€ Mapping Agent๊ฐ€ ๋ณด๋‚ธ ์ฃผ์†Œ๋ฅผ RP๋กœ ์„ค์ •.

-
L3SW1(config)# ip multicast-routing
L3SW1(config)# 
L3SW1(config)# int lo 0
L3SW1(config-if)# ip pim sparse-dense-mode
L3SW1(config-if)# exit
L3SW1(config)# 
L3SW1(config)# ip pim send-rp-announce lo0 scope 10
L3SW1(config)# ip pim send-rp-deiscovery lo0 scope 10
L3SW1(config)# 
L3SW2(config)# int vlan 10
L3SW2(config-if)# ip pim sparse-dense-mode
L3SW1(config-if)# int vlan 20
L3SW1(config-if)# ip pim sparse-dense-mode

L3SW2(config)# ip multicast-routing
L3SW2(config)# 
L3SW2(config)# int vlan 20
L3SW2(config-if)# ip pim sparse-dense-mode
L3SW2(config-if)# int vlan 30
L3SW2(config-if)# ip pim sparse-dense-mode
-

3. BSR (Bootstrap Router) ; ํ‘œ์ค€

-๋™์ž‘๊ณผ์ •
(1) BSR์ด 224.0.0.13์„ ์ด์šฉํ•ด ์ž์‹ ์ด BSR์ž„์„ ์•Œ๋ฆผ.
(2) RPํ›„๋ณด๊ฐ€ BSR Unicast ์ฃผ์†Œ๋กœ ์ž์‹ ์ด RP ํ›„๋ณด์ž„์„ ์•Œ๋ฆผ.
(3) BSR์ด 224.0.0.13์„ ์ด์šฉํ•ด ๊ฐ ๋ผ์šฐํ„ฐ๋กœ RP ํ›„๋ณด๋ฆฌ์ŠคํŠธ๋ฅผ ์ „์†กํ•œ๋‹ค.
(4) ํ›„๋ณด ๋ฆฌ์ŠคํŠธ๋ฅผ ๋ฐ›์€ ๋ผ์šฐํ„ฐ๋“ค์ด ์•Œ์•„์„œ RP๋ฅผ ์„ ํƒํ•œ๋‹ค.

-
L3SW1(config)# ip multicast-routing
L3SW1(config)# 
L3SW1(config)# int lo 0
L3SW1(config-if)# ip pim sparse-mode
L3SW1(config-if)# exit
L3SW1(config)# 
L3SW1(config)# ip pim bsr-candidate lo0
L3SW1(config)# ip pim rp-candidate lo0
L3SW1(config)# 
L3SW2(config)# int vlan 10
L3SW2(config-if)# ip pim sparse-mode
L3SW1(config-if)# int vlan 20
L3SW1(config-if)# ip pim sparse-mode

L3SW2(config)# ip multicast-routing
L3SW2(config)# 
L3SW2(config)# int vlan 20
L3SW2(config-if)# ip pim sparse-mode
L3SW2(config-if)# int vlan 30
L3SW2(config-if)# ip pim sparse-mode
-

Multicasting

1. Multicast
2. Multicast์™€ ๊ด€๋ จ๋œ ํ”„๋กœํ† ์ฝœ


๋„คํŠธ์›Œํฌ ํ†ต์‹  ํ˜•ํƒœ์—๋Š” Unicast, Multicast, Broadcast๊ฐ€ ์žˆ๋‹ค.
Unicast๋Š” ์ˆ˜์‹ ์ž๋ฅผ ์ง€์ •ํ•˜์—ฌ ‘1 : 1’ ํ†ต์‹ ํ•  ๋•Œ, Broadcast๋Š” ์ˆ˜์‹ ์ž๋ฅผ ์ง€์ •ํ•˜์ง€ ์•Š๊ณ  ‘1 : ๋ชจ๋“  ๋ถˆํŠน์ •N’ ์œผ๋กœ ํ†ต์‹ ํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค.

Multicast๋Š” ๊ทธ๋Ÿผ ์–ธ์ œ ์‚ฌ์šฉํ• ๊นŒ?
ํŠน์ • ๊ทธ๋ฃน์— ์†ํ•œ ์ˆ˜์‹ ์ž๋ฅผ ์ง€์ •ํ•˜์—ฌ ‘1 : ํŠน์ •N’์œผ๋กœ ํ†ต์‹ ํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค.

ํ† ํด๋กœ์ง€1. Multicasting ์˜ˆ์‹œ

Multicast IP

A , B, C ํด๋ž˜์Šค์˜ IP๋Š” ๋„คํŠธ์›Œํฌ ๋ถ€๋ถ„๊ณผ ํ˜ธ์ŠคํŠธ ๋ถ€๋ถ„์œผ๋กœ ๋‚˜๋ˆˆ๋‹ค. ํ•˜์ง€๋งŒ Dํด๋ž˜์Šค ๋Œ€์—ญ์„ ์‚ฌ์šฉํ•˜๋Š” Multicast IP๋Š” ๋„คํŠธ์›Œํฌ์™€ ํ˜ธ์ŠคํŠธ์˜ ๊ตฌ๋ถ„์ด ์—†๋‹ค. (์ฐธ๊ณ ๋กœ Dํด๋ž˜์Šค ๋ฒ”์œ„๋Š” 224.0.0.0~239.255.255.255).
ํ•˜๋‚˜์˜ ์ฃผ์†Œ๊ฐ€ ๊ณง ํŠน์ • ๊ทธ๋ฃน ์ „์ฒด๋ฅผ ์ง€์นญํ•œ๋‹ค. ์˜ค์ง ๋™์ผ ๊ทธ๋ฃน์ธ์ง€ ๋„์ผํ•œ ๊ทธ๋ฃน์ด ์•„๋‹Œ์ง€๋งŒ ํŒ๋‹จํ•  ์ˆ˜ ์žˆ๋‹ค.

Multicast๊ฐ€ IPํŒจํ‚ท์„ ๋ณด๋‚ผ ๋•Œ, ์ฃผ์†Œ๋Š” ์•„๋ž˜์™€ ๊ฐ™์ด ์ง€์ •ํ•œ๋‹ค.
์ถœ๋ฐœ์ง€: ‘์†ก์‹  ์žฅ๋น„์˜ ์ธํ„ฐํŽ˜์ด์Šค IP’
๋ชฉ์ ์ง€: ‘Multicast IP’

Multicast MAC

 ” XXXX . XXXX . XXXX “
MAC ์ฃผ์†Œ๋Š” 16์ง„์ˆ˜๋กœ ์ด๋ฃจ์–ด์ ธ์žˆ์œผ๋ฏ€๋กœ
๊ฐ ์ž๋ฆฌ๋‹น 4 Bit, ์ฆ‰, ๋‘ ์ž๋ฆฌ๋‹น 1 Byte์ด๋‹ค.

IP์ฃผ์†Œ 1๋ฒˆ์งธ Byte โ†’ MAC์ฃผ์†Œ์˜ ์ฒซ 3 Byte  0100.5e ๋กœ ๋ณ€ํ™˜.
IP์ฃผ์†Œ 2๋ฒˆ์งธ Byte โ†’ ์ฒซ๋ฒˆ์งธ Bit๋ฅผ 0์œผ๋กœ ๋ณ€๊ฒฝํ•œ ๋’ค 16์ง„์ˆ˜๋กœ ๋ณ€ํ™˜.
IP์ฃผ์†Œ 3, 4๋ฒˆ์งธ Byte โ†’ 16์ง„์ˆ˜๋กœ ๋ณ€ํ™˜.

๊ทธ๋ž˜์„œ Multicast MAC์€
0100.5eXX.XXXX

Multicast IP ์™€ MAC ๊ด€๊ณ„

(1) Multicast IP๋Š” ์ฒซ๋ฒˆ์งธ ์˜ฅํ…Ÿ์ด 224~239์ด๋ฏ€๋กœ ํ•ญ์ƒ ์ฒซ 4 Bit๋Š” 1110์œผ๋กœ ๊ณ ์ •๋œ๋‹ค. 224~239๋Š” 1110 0000 ~ 1110 1111์ด๋‹ค.

(2) ๊ทผ๋ฐ ์œ„์— ์–ธ๊ธ‰ํ•œ ๋ฐ”์™€ ๊ฐ™์ด IP์ฃผ์†Œ 1๋ฒˆ์งธ Byte๋ฅผ MAC์ฃผ์†Œ 3 Byte๋กœ ๋ณ€ํ™˜ํ•œ๋‹ค๊ณ  ํ–ˆ๋‹ค. ๋‹ค์‹œ๋งํ•ด, IP์ฃผ์†Œ 8 Bit๋ฅผ MAC์ฃผ์†Œ 24 Bit๋กœ ๋ณ€ํ™˜ํ•œ ๊ฒƒ์ด๊ณ ,  ๋ณ€ํ™˜ ํ›„ IP์ฃผ์†Œ๋Š” 24Bit, MAC์ฃผ์†Œ๋Š” 24 Bit๊ฐ€ ๋‚จ๋Š”๋‹ค.

(3) ๋‚จ๋Š” IP์ฃผ์†Œ 24Bit๋Š” MAC์ฃผ์†Œ 24Bit๋กœ ๋ณ€ํ™˜ํ•œ๋‹ค.

์œ„ ์ˆœ์„œ๋Œ€๋กœ ์ง„ํ–‰ํ•ด๋ณด๋ฉด

1110 _ _ _ _ . _ XXX XXXX . XXXX XXXX

์ด๋ ‡๊ฒŒ ๋‚˜์˜ค๋Š”๋ฐ
“_”๋Š” 0์ด๋‚˜ 1์ด ์˜ฌ ์ˆ˜ ์žˆ๋Š” Bit.
“X”๋Š” IP๊ฐ€ MAC์œผ๋กœ ๋ณ€ํ™˜๋œ Bit.

25 = 32, ์ฆ‰ 32๊ฐœ์˜ IP ์ฃผ์†Œ๊ฐ€ ๊ฐ™์€ MAC ์ฃผ์†Œ๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.


2. Multicast ๊ด€๋ จ ํ”„๋กœํ† ์ฝœ

ํ† ํด๋กœ์ง€2. Multicast ๊ด€๋ จ ํ”„๋กœํ† ์ฝœ
๋™์ž‘๊ณผ์ •

(1) IGMP
PC๊ฐ€ ๋ผ์šฐํ„ฐ์—๊ฒŒ Multicast IP๊ฐ€ 239.1.1.1์ธ ํŒจํ‚ท์„ ๋‹ฌ๋ผ๊ณ  ์š”์ฒญ.

(2) IGMP Snooping
์Šค์œ„์น˜๋Š” 239.1.1.1 ํŒจํ‚ท์„ ์š”์ฒญํ•œ PC๋กœ๋งŒ ๋ณด๋‚ด๊ธฐ ์œ„ํ•ด
๋‚˜์ค‘์— 239.1.1.1 ํŒจํ‚ท์„ ๋ฐ›์œผ๋ฉด ํ•ด๋‹น PC๋กœ ๋ณด๋‚ผ ์ค€๋น„๋ฅผ ํ•œ๋‹ค.
๋งŒ์•ฝ, IGMP Snooping์„ ํ•˜์ง€ ์•Š๋Š”๋‹ค๋ฉด ํ•ด๋‹น ํŒจํ‚ท์„ Flooding ํ•œ๋‹ค.

(3) Multicast Routing Protocol
PC๋กœ๋ถ€ํ„ฐ 239.1.1.1 ํŒจํ‚ท์„ ์š”์ฒญ๋ฐ›์€ ๋ผ์šฐํ„ฐ๋Š” ์–ด๋Š ๊ฒฝ๋กœ๋ฅผ ํ†ตํ•ด ํ•ด๋‹น ํŒจํ‚ท์„ ๋ฐ›์„ ์ˆ˜ ์žˆ๋Š”์ง€ ์•Œ๊ณ  ์žˆ๋‹ค. PIM-DM / PIM-SM ๊ฐ™์€ MRP๊ฐ€ ์žˆ๋‹ค.

2-1. IGMP : Internet Group Management Protocol

– Multicast๊ฐ€ ๋™์ž‘ํ•˜๋Š” ํ˜ธ์ŠคํŠธ์™€ ๋ผ์šฐํ„ฐ ๊ฐ„์— ์‚ฌ์šฉ๋œ๋‹ค.
– ํ˜ธ์ŠคํŠธ๊ฐ€ ํŠน์ • Multicast Group์— ๊ฐ€์ž… or ๊ฐ€์ž… ์ค‘์ง€ํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค.
– IGMP๋Š” ๋ฒ„์ „ 1, 2, 3, 3 Lite๊ฐ€ ์žˆ๋‹ค. ( ๋ฒ„์ „ ๋ณ„ ์ฐจ์ด )
– ์ธํ„ฐํŽ˜์ด์Šค์— Multicast Routing Protocol์„ ์„ค์ •ํ•˜๋ฉด ์ž๋™์œผ๋กœ ๋™์ž‘ํ•œ๋‹ค.
– IPv4 ํŒจํ‚ท  ‘Protocol’ ํ•„๋“œ๋ฒˆํ˜ธ 2, TTL 1๋กœ ๊ณ ์ •๋œ๋‹ค.

2-2. Multicast Routing Protocol

MULTICAST ROUTING PROTOCOL: PIM-DM / PIM-SM ์ฐธ๊ณ 

2-3. IGMP Snooping

Transparent Bridging์— ์˜ํ•˜๋ฉด, Multicast ํŒจํ‚ท์€ Flooding ํ•ด์•ผํ•œ๋‹ค.
ํ•˜์ง€๋งŒ Multicast ํŒจํ‚ท์ด ๋งŽ์•„์งˆ์ˆ˜๋ก ์žฅ๋น„์—๊ฒŒ ์˜ค๋Š” ๋ถ€ํ•˜๋„ ์ปค์ง„๋‹ค.
์ด๋Ÿฐ ๋ฌธ์ œ๋ฅผ ํ•ด๊ฒฐํ•˜๊ณ ์ž IGMP Snooping๊ณผ CGMP๊ฐ€ ์žˆ๋‹ค.

IGMP Snooping ๋™์ž‘๊ณผ์ •
(1) PC๊ฐ€ ๋ผ์šฐํ„ฐ๋กœ IGMP๋ฅผ ์ด์šฉํ•ด ํŠน์ • Multicast ํŒจํ‚ท์„ ์š”์ฒญํ•œ๋‹ค.
(2) ์ด ๋•Œ, ์Šค์œ„์น˜๊ฐ€ ์ด ํŒจํ‚ท์„ ์—ฟ๋ณด๊ณ , ์ดํ›„์— ๋ผ์šฐํ„ฐ๋กœ๋ถ€ํ„ฐ ํ•ด๋‹น Multicast ํŒจํ‚ท์„ ์ˆ˜์‹ ํ•˜๋ฉด ์š”์ฒญํ•œ PC๋กœ ๋ณด๋‚ผ ์ˆ˜ ์žˆ๋„๋ก ์ค€๋น„ํ•œ๋‹ค.
(3) ๋ผ์šฐํ„ฐ์—์„œ PC๋กœ Multicast ํŒจํ‚ท์„ ์ „์†กํ•  ๋•Œ, ์Šค์œ„์น˜๊ฐ€ ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค๋กœ๋งŒ ํŒจํ‚ท์„ ์ค‘๊ณ„ํ•œ๋‹ค.

CGMP ๋™์ž‘๊ณผ์ •
Cisco Group Management Protocol
๋ผ์šฐํ„ฐ๊ฐ€ ์Šค์œ„์น˜์—๊ฒŒ ํŠน์ • Multicast ํŒจํ‚ท์€ ํŠน์ • Unicast MAC์„ ์†Œ์œ ํ•œ ํ˜ธ์ŠคํŠธ๋กœ ์ „์†กํ•˜๋ผ๊ณ  ์•Œ๋ ค์ค€๋‹ค.

2-4. RPF

Reverse Path Forwarding Check.

Multicast ํŒจํ‚ท ๋ฃจํ”„๋ฅผ ๋ฐฉ์ง€ํ•˜๊ธฐ ์œ„ํ•ด RPF๋ฅผ ํ™•์ธํ•ด์•ผ ํ•œ๋‹ค. ๋˜ํ•œ, RPF๋ฅผ ํ™•์ธํ•˜๊ธฐ ์œ„ํ•ด์„  Unicast ๋ผ์šฐํŒ…์ด ๋™์ž‘ ์ค‘์ด์–ด์•ผ ํ•œ๋‹ค.
ํ•ญ์ƒ Multicast ํŒจํ‚ท์˜ Source IP๋ฅผ ํ™•์ธํ•œ๋‹ค.

๊ทธ๋ฆผ. RPF

์šฐ์„  SW1์—์„œ 10.10.0.0/24๋กœ ์˜ค๋Š” ํŒจํ‚ท์€ F0/5๋กœ ์ˆ˜์‹ ํ•œ๋‹ค.

โ‘ ์€ ์ •์ƒ์ด๋‹ค.

โ‘ก๋Š” F0/2๋กœ ์ˆ˜์‹ ํ•œ๋‹ค.
Source IP – ์ธํ„ฐํŽ˜์ด์Šค๊ฐ€ ์ผ์น˜ํ•˜์ง€ ์•Š์•„ ํ๊ธฐ๋œ๋‹ค.

[FHRP] GLBP์— ๋Œ€ํ•ด

  1. GLBP
  2. GLBP ์„ค์ •

1. GLBP

Gateway Load Balancing Protocol

๊ทธ๋ฆผ1. GLBP

Cisco์—์„œ HSRP ๊ธฐ๋Šฅ์„ ๊ฐ•ํ™”ํ•˜๊ธฐ ์œ„ํ•ด GLBP๋ฅผ ๊ฐœ๋ฐœํ–ˆ๋‹ค.
๊ฒŒ์ดํŠธ์›จ์ด ์ด์ค‘ํ™”๋Š” ๋ฌผ๋ก , ๋ณ„๋„์˜ ์„ค์ •์—†์ด๋„ ๋ถ€ํ•˜ ๋ถ„์‚ฐ์„ ์ œ๊ณตํ•˜๋Š” ๊ฒƒ์ด๋‹ค.

1-1. GLBP ์—ญํ• 

Group ๋‹น
AVG ๋ผ์šฐํ„ฐ 1๊ฐœ, Standby ๋ผ์šฐํ„ฐ 1๊ฐœ, ๋‚˜๋จธ์ง€ ๋ผ์šฐํ„ฐ๋Š” Listen ์ƒํƒœ.


๋งŒ์ผ, AVG ๋ผ์šฐํ„ฐ๊ฐ€ Down ๋๋‹ค๋ฉด,
Standby ๋ผ์šฐํ„ฐ โ†’ AVG ๋ผ์šฐํ„ฐ,
Listen ์ƒํƒœ ๋ผ์šฐํ„ฐ ์ค‘ ํ•˜๋‚˜ โ†’ Standby ๋ผ์šฐํ„ฐ๊ฐ€ ๋œ๋‹ค.

AVG ( Active Virtual Gateway) ์—ญํ• 
1. ๊ฐ ๋ผ์šฐํ„ฐ๋“ค(๋ฉค๋ฒ„๋“ค)์—๊ฒŒ ๊ฐ€์ƒ MAC์„ ํ• ๋‹นํ•œ๋‹ค.
์ด ๋ผ์šฐํ„ฐ๋“ค์„ ๊ฐ€์ƒ MAC์˜ AVF(Active Virtual Forwarder)๋ผ๊ณ  ํ•œ๋‹ค.
2. ๊ฒŒ์ดํŠธ์›จ์ด ์ฃผ์†Œ์— ๋Œ€ํ•œ ARP ์š”์ฒญ์— ์‘๋‹ตํ•œ๋‹ค.
PC์—์„œ ๊ฒŒ์ดํŠธ์›จ์ด IP์— ๋Œ€ํ•œ ARP ์š”์ฒญ์„ ํ•˜๋ฉด, AVF์— ํ• ๋‹นํ–ˆ๋˜ MAC๋“ค ์ค‘ ํ•˜๋‚˜๋กœ ์‘๋‹ตํ•œ๋‹ค. ์ฆ‰, ์ž๋™์œผ๋กœ ๋ถ€ํ•œ ๋ถ„์‚ฐ์ด ๋˜๋Š” ๊ฒƒ์ด๋‹ค.

AVG๊ฐ€ ๊ฒฐ์ •๋˜๋Š” ์šฐ์„ ์ˆœ์œ„
๋†’์€ GLBP Priority โ†’ ๋†’์€ ์ธํ„ฐํŽ˜์ด์Šค IP

1-2. GLBP ํŠน์„ฑ

  • Group ๋‹น ๋‹จ์ผ Virtual IP์™€ ์ตœ๋Œ€ 4๊ฐœ์˜ MAC์„ ์‚ฌ์šฉํ•œ๋‹ค.
  • ์ถœ๋ฐœ์ง€ / ๋ชฉ์ ์ง€ IP : 224.0.0.102 , Multicast
  • UDP 3222
  • 3์ดˆ ์ฃผ๊ธฐ๋กœ GLBP ์ •๋ณด ๊ด‘๊ณ 

1-3. GLBP ์ธ์ฆ

๊ณต๊ฒฉ์ž์˜ ์žฅ๋น„๊ฐ€ AVG ๋˜๋Š” AVF ๋˜๋Š” GLBP Spoofing ๊ณต๊ฒฉ์„ ๋ฐฉ์ง€ํ•˜๊ณ ์ž ์ธ์ฆ์„ ์„ค์ •ํ•œ๋‹ค. ์—ฌํƒ€ FHRP์ฒ˜๋Ÿผ Plain-Text, MD5 ์ธ์ฆ์„ ์„ค์ •ํ•  ์ˆ˜ ์žˆ๋‹ค.


2. GLBP ์„ค์ •

ํ† ํด๋กœ์ง€1. GLBP

๊ธฐ๋ณธ ์„ค์ • โ†’ GLBP ์„ค์ • โ†’ GLBP ์„ค์ • ํ™•์ธ โ†’ GLBP ์ธ์ฆ ์„ค์ •

[๊ธฐ๋ณธ]
– IP ์„ค์ •
๊ฐ ์žฅ๋น„์˜ ์ธํ„ฐํŽ˜์ด์Šค
(PC GW๋Š” Virtual IP๋กœ ์„ค์ •)

– OSPF ๋ผ์šฐํŒ…
R1 fa0/0, fa1/0
R2 fa0/1, fa1/0
SW2 fa0/0, fa0/1, loopback 0

[GLBP ์„ค์ •]

-
R1(config)# track 1 int fa0/0 line-protocol
R1(config-track)# exit
R1(config)#
R1(config)# int fa1/0
R1(config-if)# glbp 1 ip 10.10.100.254
R1(config-if)# glbp 1 priority 105
R1(config-if)# glbp 1 timers 2 6
R1(config-if)# glbp 1 preempt delay minimum 60
R1(config-if)# glbp 1 forwarder preempt delay minimum 50
R1(config-if)# glbp 1 weighting 100 lower 90 upper 100
R1(config-if)# glbp 1 load-balancing round-robin
R1(config-if)# glbp 1 weighting track 1 decrement 20

R2(config)# track 1 int fa0/1 line-protocol
R2(config-track)# exit
R2(config)#
R2(config)#int fa1/0
R2(config-if)# glbp 1 ip 10.10.100.254
R2(config-if)# glbp 1 timers 2 6
R2(config-if)# glbp 1 weighting 100 lower 95
R2(config-if)# glbp 1 weighting track 1
R2(config-if)#
-

2: ๊ฐ์‹œํ•  ์ธํ„ฐํŽ˜์ด์Šค๋‚˜ ๊ฒฝ๋กœ๋ฅผ ์ง€์ •ํ•œ๋‹ค. line-protocol ์˜ต์…˜์„ ์‚ฌ์šฉํ•˜๋ฉด ํ•ด๋‹น ์ธํ„ฐํŽ˜์ด์Šค์˜ Layer 2 ์ƒํƒœ์— ๋”ฐ๋ผ Up / Down ์ƒํƒœ๋กœ ํŒ๋‹จํ•œ๋‹ค. ๊ฒฝ๋กœ๋ฅผ ์ง€์ •ํ•˜๊ณ ์ž ํ•œ๋‹ค๋ฉด, “track 2 ip route 10.10.0.1/32 reachability” ์ด๋ ‡๊ฒŒ ํ•  ์ˆ˜ ์žˆ๋‹ค.
6: GLBP ๊ทธ๋ฃน ๋ฒˆํ˜ธ๋Š” 0-1023 ์‚ฌ์ด ๊ฐ’๋ฅผ ๋„ฃ์„ ์ˆ˜ ์žˆ๋‹ค. ์—ฌ๊ธฐ๊นŒ์ง€์˜ ์„ค์ •๋งŒ์œผ๋กœ GLBP๊ฐ€ ๋™์ž‘ํ•œ๋‹ค.
7: GLBP ์šฐ์„ ์ˆœ์œ„๋ฅผ ์„ค์ •ํ•œ๋‹ค. 0 -255 ์‚ฌ์ด ๊ฐ’์„ ๋„ฃ์„ ์ˆ˜ ์žˆ๋‹ค.
8: ๊ธฐ๋ณธ Hello Timer 3์ดˆ, Hold Timer 10์ดˆ์ง€๋งŒ, Hello 2 Hold 6์œผ๋กœ ์„ค์ •ํ–ˆ๋‹ค. 2์ดˆ ์ฃผ๊ธฐ๋กœ Hello๋ฅผ ์ „์†กํ•˜๊ณ , 6์ดˆ๋™์•ˆ Hello๋ฅผ ๋ฐ›์ง€๋ชปํ•˜๋ฉด ์ƒ๋Œ€์—๊ฒŒ ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ–ˆ๋‹ค๊ณ  ๊ฐ„์ฃผํ•œ๋‹ค.
9: ์žฅ์•  ๋ฐœ์ƒ์œผ๋กœ ์ธํ•ด ๋‹ค๋ฅธ ๋ผ์šฐํ„ฐ๋กœ AVG ์—ญํ• ์„ ์œ„์ž„ํ–ˆ๋‹ค๊ฐ€ ์žฅ์•  ๋ณต๊ตฌ ์‹œ 60์ดˆ ํ›„ ๋‹ค์‹œ AVG ์—ญํ• ์„ ์ˆ˜ํ–‰ํ•œ๋‹ค. ๊ธฐ๋ณธ์ ์œผ๋กœ ๋น„ํ™œ์„ฑํ™” ๋˜์–ด์žˆ๋‹ค.
10: ์žฅ์•  ๋ฐœ์ƒ์œผ๋กœ ์ธํ•ด ๋‹ค๋ฅธ ๋ผ์šฐํ„ฐ๋กœ AVF ์—ญํ• ์„ ์œ„์ž„ํ–ˆ๋‹ค๊ฐ€ ์žฅ์•  ๋ณต๊ตฌ ์‹œ 50์ดˆ ํ›„ ๋‹ค์‹œ AVF ์—ญํ• ์„ ์ˆ˜ํ–‰ํ•œ๋‹ค. ๊ธฐ๋ณธ 30์ดˆ๋กœ ํ™œ์„ฑํ™”๋˜์–ด์žˆ๋‹ค.
11: ๋จผ์ €, R1์˜ ์ „์†ก ๊ฐ€์ค‘์น˜๋ฅผ 100์œผ๋กœ ์„ค์ •ํ•œ๋‹ค. ๊ฐ€์ค‘์น˜๊ฐ€ 90์ด ๋˜๋ฉด AVF์˜ ์—ญํ• ์„ ๋„˜๊ธฐ๊ณ , 100์ด ๋˜๋ฉด ๋‹ค์‹œ AVF ์—ญํ• ์„ ์ˆ˜ํ–‰ํ•œ๋‹ค.
12: ๋ถ€ํ•˜๋ถ„์‚ฐ ๋ฐฉ์‹์„ round-robin์œผ๋กœ ์„ค์ •ํ•œ๋‹ค.
13: track 1์ด Down๋˜์—ˆ์„ ๋•Œ, ๊ฐ€์ค‘์น˜ 20์„ ๊ฐ์†Œํ•œ๋‹ค.

[GLBP ์„ค์ •ํ™•์ธ]
– show glbp brief

GLBP ์ƒํƒœ, ๊ฐ€์ƒ IP, Standby ๋ผ์šฐํ„ฐ๋ฅผ ํ™•์ธ ํ•  ์ˆ˜ ์žˆ๋‹ค.

[GLBP ์ธ์ฆ]
– Plain-Text ์ธ์ฆ

R1(config)# int fa1/0
R1(config-if)# glbp 1 authentication text <WORD>


R2(config)# int fa1/0
R2(config-if)# glbp 1 authentication text <WORD>

– MD5 ์ธ์ฆ (Key-String)

R1(config)# int fa1/0
R1(config-if)# glbp 1 authentication md5 key-string <WORD>


R2(config)# int fa1/0
R2(config-if)# glbp 1 authentication md5 key-string <WORD>

– MD5 ์ธ์ฆ (Key-Chain)

R1(config)# key chain <NAME>
R1(config-keychain)# key [0-2147483647]
R1(config-keychain-key)# key-string <WORD>
R1(config-keychain-key)# exit
R1(config-keychain)# exit
R1(config)#
R1(config)# int fa1/0
R1(config-if)# glbp 1 authentication md5 key-chain <NAME>


R2(config)# key chain <NAME>
R2(config-keychain)# key [0-2147483647]
R2(config-keychain-key)# key-string <WORD>
R2(config-keychain-key)# exit
R2(config-keychain)# exit
R2(config)#
R2(config)# int fa1/0
R2(config-if)# glbp 1 authentication md5 key-chain <NAME>