[Switch] MSTP

Multiple Spanning Tree Protocol

๊ทธ๋™์•ˆ ํ•™์Šตํ•œ STP์™€ RSTP๋Š” VLAN ํ•˜๋‚˜ ๋‹น 1๊ฐœ์˜ ์ŠคํŒจ๋‹ ํŠธ๋ฆฌ๊ฐ€ ๋™์ž‘ํ•œ๋‹ค. VLAN์ด 200๊ฐœ๋ผ๋ฉด, 200๊ฐœ์˜ ์ŠคํŒจ๋‹ ํŠธ๋ฆฌ๊ฐ€ ๋Œ์•„๊ฐ„๋‹ค๋Š” ์˜๋ฏธ์ด์ž 2์ดˆ๋งˆ๋‹ค 200๊ฐœ์˜ BPDU๋ฅผ ์ˆ˜์‹ ํ•œ๋‹ค๋Š” ์˜๋ฏธ์ด๋‹ค.
์™ ์ง€ Switch์— ๋ถ€๋‹ด์ด ๊ฐ€์ง€ ์•Š์„๊นŒ ์‹ถ๋‹ค..

๋‹คํ–‰ํžˆ ์ด๋Ÿฐ ๋ฌธ์ œ์ ์„ ํ•ด๊ฒฐํ•˜๊ธฐ ์œ„ํ•ด ๋‚˜์˜จ ํ”„๋กœํ† ์ฝœ์ด ์žˆ์œผ๋‹ˆ,,
์ด๋ฆ„ํ•˜์—ฌ MSTP๋‹ค. ์—ฌ๋Ÿฌ ๊ฐœ์˜ VLAN์„ ๋ฌถ์–ด ํ•˜๋‚˜์˜ ์ŠคํŒจํŒ… ํŠธ๋ฆฌ๋งŒ ๋™์ž‘๋˜๋„๋ก ํ•˜๋Š” ๊ฒƒ์ด๋‹ค.
VLAN ๋ฌถ๋Š”๋‹ค๋ฉด ๋ฌถ์ธ VLAN์„ ์…€ ๋•Œ ํ•„์š”ํ•œ ๋‹จ์œ„๊ฐ€ ์žˆ์„๊ฑฐ๊ณ , ์—ฌ๋Ÿฌ ๊ฐœ์˜ Switch ์ค‘ ํ•˜๋‚˜๋Š” ๋Œ€ํ‘œ ์—ญํ• ์„ ํ•ด์•ผํ•  ๊ฒƒ์ด๋‹ค. ๊ทธ๋ž˜์•ผ ๊ด€๋ฆฌํ•˜๊ธฐ ์‰ฌ์šธ ํ…Œ๋‹ˆ ๋ง์ด๋‹ค.

  1. MSTP ๋‹จ์œ„
  2. CIST์™€ MSTI
  3. MSTP ๋™์ž‘๊ณผ์ •
  4. MSTP์˜ BPDU
  5. MSTP ์„ค์ •

1. MSTP ๋‹จ์œ„

VLAN ์—ฌ๋Ÿฌ ๊ฐœ๋ฅผ ๋ฌถ์œผ๋ฉด, Instance
Instance ์—ฌ๋Ÿฌ ๊ฐœ๋ฅผ ๋ฌถ์œผ๋ฉด, Region

Instance ๋‹น 1๊ฐœ์˜ ์ŠคํŒจ๋‹ ํŠธ๋ฆฌ๊ฐ€ ๋™์ž‘ํ•œ๋‹ค.

์ฐธ๊ณ ๋กœ, ๋™์ผ VLAN ๋ฒˆํ˜ธ์ผ์ง€๋ผ๋„ ์„œ๋กœ ๋‹ค๋ฅธ Instance์— ์†ํ•  ์ˆ˜ ์žˆ๋‹ค.


2. CIST์™€ MSTI

MSTP์—๋Š” 2๊ฐ€์ง€ ์ŠคํŒจ๋‹ ํŠธ๋ฆฌ๊ฐ€ ์‚ฌ์šฉ๋œ๋‹ค.

CIST

Common and Internal Spanning Tree

์ „์ฒด Switch ๋„คํŠธ์›Œํฌ๋ฅผ ๋ฃจํ”„์—†์ด ์—ฐ๊ฒฐํ•˜๋Š” ๋ชฉ์ ์„ ๊ฐ–๊ณ  ์žˆ๋‹ค.
์ „์ฒด Switch ๋„คํŠธ์›Œํฌ์˜ ํ†ต์‹  ๊ฒฝ๋กœ๋ฅผ ์„ค์ •ํ•œ๋‹ค.
CIST Root Switch – 1๊ฐœ
CIST Regional Root Switch – Region๋ณ„ 1๊ฐœ

MSTI

Multiple Spanning Tree Instance

Region์˜ ๊ฐ Instance ํ†ต์‹  ๊ฒฝ๋กœ๋ฅผ ์„ค์ •ํ•œ๋‹ค.
Root Switch – MST Instance๋ณ„ 1๊ฐœ


3. MSTP ๋™์ž‘๊ณผ์ •

CIST ์ŠคํŒจ๋‹ ํŠธ๋ฆฌ์˜ ๋™์ž‘ ๊ณผ์ •

  1. ๊ฐ Switch๋Š” ํŠน์ • VLAN ID๋ฅผ ํŠน์ • MSTI์— ํ• ๋‹นํ•˜๋Š” ‘MST Configuration ID’๋ฅผ ๊ด‘๊ณ ํ•œ๋‹ค.
  2. Bridge ID์™€ Path Cost๋ฅผ ์ด์šฉํ•ด CIST๋ฅผ ๊ตฌ์„ฑํ•œ๋‹ค.
    โ‘  ์ „์ฒด LAN์—์„œ ‘CIST Root Switch’ 1๊ฐœ ์„ ํƒ
    โ‘ก ๊ฐ Switch์™€ LAN์—์„œ CIST Root๊นŒ์ง€์˜ ์ตœ์†Œ๊ฐ’ ๊ฒฝ๋กœ ์„ ํƒ
    ์—ฌ๊ธฐ์„œ ๊ฐ Region ๋ณ„๋กœ CIST Root๊นŒ์ง€ ์ตœ์†Œ ๊ฒฝ๋กœ๊ฐ’์„ ๊ฐ–๋Š” Switch๊ฐ€ ‘CIST Regional Root Switch’๊ฐ€ ๋œ๋‹ค.

CIST์˜ ํฌํŠธ ์—ญํ• 
CIST Root Port: CIST Regional Root Switch๋ฅผ ํ†ตํ•ด CIST Root Switch๋กœ ๊ฐ€๋Š” ์ตœ์†Œ ๊ฒฝ๋กœ๊ฐ’์„ ๊ฐ€์ง„ ํฌํŠธ
CIST Designated Port: ์ ‘์†๋œ LAN์—์„œ CIST Root Switch๊นŒ์ง€ ์ตœ์ € ๊ฒฝ๋กœ๊ฐ’์„ ๊ฐ€์ง„ ํฌํŠธ
CIST Alternate Port / Backup Port: ํƒ€ Switch / ํฌํŠธ ๋˜๋Š” LAN์— ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ–ˆ์„ ๋•Œ ์‚ฌ์šฉ๋˜๋Š” ํฌํŠธ

CIST์˜ ํŠน์ง•
๋ชจ๋“  Switch๋ฅผ ํ•˜๋‚˜์˜ ๋„คํŠธ์›Œํฌ๋กœ ์—ฐ๊ฒฐํ•œ๋‹ค.
(=๊ฐ Region์„ ํ•˜๋‚˜๋กœ ์—ฐ๊ฒฐํ•œ๋‹ค.)
์˜์—ญ๋‚ด๋ถ€ ๊ฒฝ๋กœ๊ฐ€ ์˜์—ญ์™ธ๋ถ€ ๊ฒฝ๋กœ๋ณด๋‹ค ์šฐ์„ ๋œ๋‹ค.

MSTI ์ŠคํŒจ๋‹ ํŠธ๋ฆฌ์˜ ๋™์ž‘ ๊ณผ์ •

  1. ๊ฐ Region์—์„œ MSTI Root Switch 1๊ฐœ๋ฅผ ์„ ํƒํ•œ๋‹ค.
  2. ๊ฐ Switch์—์„œ MSTI Root๋กœ ๊ฐ€๋Š” ์ตœ์ € ๊ฒฝ๋กœ๊ฐ’์„ ์„ ํƒํ•œ๋‹ค.

MSTI์˜ ํฌํŠธ ์—ญํ• 
MSTI Root Port: MSTI Root Switch๊นŒ์ง€ ์ตœ์†Œ ๊ฒฝ๋กœ๊ฐ’์„ ๊ฐ€์ง„ ํฌํŠธ
MSTI Designated Port: ์ ‘์†๋œ LAN์—์„œ MSTI Root Switch๊นŒ์ง€ ์ตœ์ € ๊ฒฝ๋กœ๊ฐ’์„ ๊ฐ€์ง„ ํฌํŠธ
MSTI Master Port: Region ์™ธ๋ถ€์— ์žˆ๋Š” CIST Root Switch์™€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ
MSTI Alternate Port / Backup Port: ํƒ€ Switch/ํฌํŠธ ๋˜๋Š” LAN์— ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ–ˆ์„ ๋•Œ ์‚ฌ์šฉ๋˜๋Š” ํฌํŠธ


4. MSTI BPDU

์ถœ์ฒ˜: MSTP protocol frames, https://techhub.hpe.com/eginfolib/networking/docs/switches/10500/cg/5200-1896_l2-lan_cg/content/470790451.htm

MSTP BPDU์ด๋ฏ€๋กœ
Protocol Version ID๋Š” 3, BPDU Type์€ 2์ด๋‹ค.
Flags (CIST Flag): RSTP์˜ Flag์™€ ๋™์ผํ•œ Flag ๊ฐ’์„ ๊ฐ€์ง„๋‹ค.
CIST Root ID: ์ „์ฒด Switch ๋„คํŠธ์›Œํฌ์˜ Root Switch ID
CIST Path Cost: CIST ์™ธ๋ถ€์˜ Root Switch๊นŒ์ง€์˜ ๊ฒฝ๋กœ๊ฐ’
Bridge ID:
MSTP์ผ ๋•Œ, CIST Regional Root Switch ID
RSTP/STP์ผ ๋•Œ, Designated Switch ID
MST Configure ID: ๋™์ผ VLAN์— ์†Œ์†๋œ Switch๋“ค๋ผ๋ฆฌ๋Š” VLAN ๋ฒˆํ˜ธ์™€ Instance ๋งคํ•‘ ์ •๋ณด๊ฐ€ ๋™์ผํ•ด์•ผํ•œ๋‹ค. ์•„๋ž˜์˜ ๋‚ด์šฉ์„ ๋‹ด๊ณ  ์žˆ๋‹ค.
Selector(1 Byte): ํ•ญ์ƒ ๊ฐ’ 0
Configuration name(32 Byte): ๊ฐ€๋ณ€
Revision level(2 Byte)
Configuration Digest(16 Byte): MSTP Configuration Table๋กœ๋ถ€ํ„ฐ ์ƒ์„ฑ๋œ MD5 Signature.
CIST Bridge ID: BPDU๋ฅผ ์ „์†กํ•˜๋Š” Switch์˜ Bridge ID
MSTI Configuration Messages: Region ๋‚ด Instance ๋ณ„๋กœ ์ŠคํŒจ๋‹ํŠธ๋ฆฌ๋ฅผ ๊ณ„์‚ฐํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค.


5. MSTP ์„ค์ •

[๊ธฐ๋ณธ MSTP ์„ค์ •]

Switch(config)# spanning-tree mode mst
Switch(config)# spanning-tree mst configuration
Switch(config-mst)# name <name>
Switch(config-mst)# instance <INSTANCE_NUM> vlan <VLAN_NUM>
Switch(config-mst)# instance 1 vlan 101-102 #(์˜ˆ์‹œ)#
Switch(config-mst)# revision 1
Switch(config-mst)# exit

[MSTP ์šฐ์„ ์ˆœ์œ„ ์„ค์ •]

Switch(config)# spanning-tree mst 0 priority 0
Switch(config)# spanning-tree mst 1 priority 0

1: CIST Root Switch ์„ค์ •
2: Instance 1์˜ Root Switch ์„ค์ •

[MSTP ์„ค์ • ํ™•์ธ]

Switch# show spanning-tree mst 0
Switch# show spanning-tree mst 1(or 2)

1: CIST ์ŠคํŒจ๋‹ ํŠธ๋ฆฌ ๋™์ž‘ ํ™•์ธ
2: MSTI ์ŠคํŒจ๋‹ ํŠธ๋ฆฌ ๋™์ž‘ ํ™•์ธ

[Switch] RSTP ์ƒ์„ธ ๋™์ž‘๊ณผ์ •

  1. ์ตœ์ดˆ RSTP ๊ตฌ์„ฑ ๊ณผ์ •
  2. ๊ฐ„์ ‘ ๋งํฌ ์žฅ์•  ์‹œ RSTP ๋™์ž‘๊ณผ์ •
  3. ์ง์ ‘ ๋งํฌ ์žฅ์•  ์‹œ RSTP ๋™์ž‘๊ณผ์ •
  4. DP ์žฅ์•  ์‹œ BP ๋™์ž‘๊ณผ์ •

1. ์ตœ์ดˆ RSTP ๊ตฌ์„ฑ ๊ณผ์ •

1๋‹จ๊ณ„ – Root Switch ์„ ์ •
์šฐ์„ ์ˆœ์œ„๊ฐ€ ๊ฐ€์žฅ ๋‚ฎ์€ SW1๊ฐ€ Root Switch๊ฐ€ ๋œ๋‹ค.

2๋‹จ๊ณ„ – Proposal BPDU ์ „์†ก ๋ฐ DP ์„ ํƒ
Root Switch๊ฐ€ ์ƒ๋Œ€ Switch๋กœ Proposal BPDU๋ฅผ ์ „์†กํ•œ๋‹ค.
์ด ๋•Œ, P-BPDU๋ฅผ ์ „์†กํ•˜๋Š” ํฌํŠธ๋Š” Designated Port(DP)๊ฐ€ ๋œ๋‹ค.

3๋‹จ๊ณ„ – ๋™๊ธฐํ™”
P-BPDU๋ฅผ ์ˆ˜์‹ ํ•œ Switch๋Š” ์ˆ˜์‹ ํ•œ ํฌํŠธ๋Š” Root Port(RP) ํ›„๋ณด๊ฐ€ ๋˜๊ณ , ๋‚˜๋จธ์ง€ ํฌํŠธ๋Š” Blocking ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.
RPํ›„๋ณด๋ฅผ ์ œ์™ธํ•˜๊ณ  ๋‚˜๋จธ์ง€ ํฌํŠธ๋ฅผ Blocking ํ•˜๋Š” ๊ฒƒ์„ ๋™๊ธฐํ™”(Synchronizational)์ด๋ผ๊ณ  ํ•œ๋‹ค. ๋‹ค์Œ ๋‹จ๊ณ„์—์„œ RP๋ฅผ Forwarding ์ƒํƒœ๋กœ ๋ณ€๊ฒฝํ•ด๋„ ๋ฃจํ”„๊ฐ€ ๋ฐœ์ƒ๋˜์ง€ ์•Š๋„๋ก ํ•˜๊ธฐ ์œ„ํ•ด์„œ์ด๋‹ค.

4๋‹จ๊ณ„ – Agreement BPDU ์ „์†ก ๋ฐ RP ์„ ํƒ
SW2, SW3์€ SW2์˜ F0/2, SW3์˜ F0/1์„ RP๋กœ ์„ค์ •ํ•œ Agreement BPDU๋ฅผ Root Switch๋กœ ์ „์†กํ•˜๊ณ , Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.
์ด ๋•Œ, A-BPDU๋ฅผ ์ „์†กํ•œ ํฌํŠธ๋Š” Root Port(RP)๊ฐ€ ๋œ๋‹ค.

5๋‹จ๊ณ„ – Root Switch์˜ Forwarding ์ƒํƒœ ์ „ํ™˜
A-BPDU๋ฅผ ์ˆ˜์‹ ํ•œ SW1์€ SW2,SW3์™€ ์—ฐ๊ฒฐ๋œ F0/1, F0/2๋ฅผ Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.

6๋‹จ๊ณ„ SW2<->SW3 ๋™์ž‘
SW2๋Š” ์ž์‹ ์˜ DP์— ๋Œ€ํ•œ P-BPDU๋ฅผ SW3์œผ๋กœ ์ „์†กํ•˜์ง€๋งŒ, SW3์˜ F0/3์€ AP ์ƒํƒœ์ด๋ฏ€๋กœ A-BPDU๋ฅผ ์ „์†กํ•˜์ง€ ์•Š๋Š”๋‹ค.

7๋‹จ๊ณ„ SW2<->SW3 ๋™์ž‘
SW3๋กœ๋ถ€ํ„ฐ ์‘๋‹ต์„ ๋ฐ›์ง€ ๋ชปํ•œ SW2๋Š” 15์ดˆ๋™์•ˆ P-BPDU๋ฅผ ์ „์†กํ•œ๋‹ค.
๊ทธ๋ž˜๋„ ์‘๋‹ต์ด ์—†์œผ๋ฉด Learning ์ƒํƒœ๋กœ ๋ณ€๊ฒฝํ•˜๊ณ , ๋‹ค์‹œ 15์ดˆ ๋™์•ˆ P-BPDU๋ฅผ ์ „์†กํ•œ๋‹ค. ์ดํ›„ 15์ดˆ๊ฐ€ ์ง€๋‚˜๋ฉด Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.

P-BPDU / A-BPDU๋Š” ์‰ฝ๊ฒŒ ์„ค๋ช…ํ•˜๊ธฐ ์œ„ํ•ด ์ค„์ธ ๋‹จ์–ด์ด๋‹ค. ํ•ด๋‹น ์šฉ์–ด๊ฐ€ ์‹ค์ œ ์‚ฌ์šฉ๋˜๋Š”์ง€๋Š” ๋ชจ๋ฅธ๋‹ค.


2. ๊ฐ„์ ‘ ๋งํฌ ์žฅ์•  ์‹œ RSTP ๋™์ž‘๊ณผ์ •

๋งŒ์•ฝ STP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค๋ฉด,
SW3์˜ F0/3์€ Max-Age 20์ดˆ๋™์•ˆ ํ›„์ˆœ์œ„ BPDU๋ฅผ ๋ฐ›๊ณ , Listening, Learning ์ˆœ์ฐจ์ ์œผ๋กœ ์ƒํƒœ๊ฐ€ ์ „ํ™˜๋˜์–ด 50์ดˆ๊ฐ€ ์ง€๋‚˜์•ผ Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜๋˜์—ˆ์„ ๊ฒƒ์ด๋‹ค.

RSTP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค๋ฉด,
SW3์˜ F0/3์ด ํ›„์ˆœ์œ„ BPDU๋ฅผ ์ˆ˜์‹ ํ•˜์ž๋งˆ์ž DP์—ญํ• ์„ ํ•˜๊ธฐ ์œ„ํ•ด SW2์—๊ฒŒ Proposal BPDU๋ฅผ ์ „์†กํ•œ๋‹ค. SW2๋Š” Agreement BPDU๋กœ ์‘๋‹ตํ•˜๊ณ , SW3์€ A-BPDU๋ฅผ ๋ฐ›์ž๋งˆ์ž F0/3์„ Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.


3. ์ง์ ‘ ๋งํฌ ์žฅ์•  ์‹œ RSTP ๋™์ž‘๊ณผ์ •

1๋‹จ๊ณ„.
SW3์˜ RP์ธ F0/2๊ฐ€ ๋‹ค์šด๋˜๋ฉด, F0/3์ด ์ฆ‰์‹œ RP์—ญํ• ์„ ์ด์–ด๋ฐ›๊ณ  Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.

2๋‹จ๊ณ„.
๋™๊ธฐํ™”๋ฅผ ์œ„ํ•ด F0/14๋Š” Blocking ์ƒํƒœ๋กœ ์ „ํ™˜ํ•˜๊ณ , BP์ธ F0/15๋ฅผ AP๋กœ ๋ณ€๊ฒฝํ•œ๋‹ค.

3๋‹จ๊ณ„.
DP์ธ F0/14๋ฅผ ํ†ตํ•ด Proposal BPDU๋ฅผ ์ „์†กํ•˜๊ณ , F0/15๋กœ ๋‹ค์‹œ ๋˜๋Œ์•„์˜จ ๊ฒƒ์„ ํ™•์ธํ•จ๊ณผ ๋™์‹œ์— F0/15๋ฅผ BP๋กœ ๋ณ€๊ฒฝํ•œ๋‹ค.

4๋‹จ๊ณ„.
F0/14๋กœ Proposal BPDU๋ฅผ 30์ดˆ๊ฐ„ ์ „์†กํ•˜๊ณ , ์ดํ›„ Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.


4. DP ์žฅ์•  ์‹œ BP ๋™์ž‘๊ณผ์ •

SW3์˜ DP์ธ F0/14๊ฐ€ ๋‹ค์šด๋˜๋ฉด, F0/15๊ฐ€ DP ์—ญํ• ์„ ์ด์–ด๋ฐ›๋Š”๋‹ค.
30์ดˆ๊ฐ„ Proposal BPDU๋ฅผ ์ „์†กํ•˜๊ณ  Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.

๋งŒ์•ฝ F0/14๊ฐ€ ๋ณต๊ตฌ๋œ๋‹ค๋ฉด,
F0/14๋Š” DP, F0/15๋Š” BP๋กœ ๋ณ€๊ฒฝ๋˜๊ณ , F0/14๊ฐ€ 30์ดˆ๊ฐ„ Proposal BPDU๋ฅผ ์ „์†กํ•˜๊ณ  Forwarding ์ƒํƒœ๋กœ ์ „ํ™˜ํ•œ๋‹ค.

[Switch] RSTP

Rapid Spanning-Tree Protocol

๋™์ž‘ ์‹œ๊ฐ„์ด ๋Š๋ฆฐ STP๋ฅผ ๋Œ€์ฒดํ•  ์ˆ˜ ์žˆ๋Š” RSTP์ด๋‹ค. STP ํƒ€์ด๋จธ๋‚˜ Fast ์„ค์ •์„ ํ•ด๋„ ๋‹จ์ถ•๋œ๋‹ค๊ณค ํ•œ๋‹ค๋งŒ,, ์—ฌ์ „ํžˆ ํ•œ๊ณ„๊ฐ€ ์žˆ๋‹ค. ๊ทธ๋ž˜์„œ IEEE๋Š” 2001๋…„ 6์›” RSTP๋ฅผ ๋ฐœํ‘œํ–ˆ์œผ๋ฉฐ ์ง€๊ธˆ์€ 802.1W์— ์ •์˜๋˜์–ด์žˆ๋‹ค.

STP๋Š” ๊ฒฝ์šฐ์— ๋”ฐ๋ผ Blocking ์ƒํƒœ์—์„œ Forwarding ์ƒํƒœ๊นŒ์ง€ ์†Œ์š” ์‹œ๊ฐ„์ด30์ดˆ or 50์ดˆ์ง€๋งŒ, RSTP๋Š” ํ† ํด๋กœ์ง€์— ๋ณ€ํ™”๊ฐ€ ์ƒ๊ธธ ๊ฒฝ์šฐ ์ฆ‰์‹œ ๋ฐ˜์˜๋œ๋‹ค. RTSP์—์„œ๋Š” ์ž์‹ ์˜ BPDU๊ฐ€ ๋” ์šฐ์„ธํ•˜๋ฉด ๋ฐ”๋กœ ๋ณธ์ธ์ด Designated Port๋ผ๊ณ  ์ฃผ์žฅํ•˜๋Š” Proposal BPDU๋ฅผ ๋ณด๋‚ธ๋‹ค. ์ด Proposal BPDU๋ฅผ ์ˆ˜์‹ ํ•œ ์ƒ๋Œ€๊ฐ€ ๋™์˜ํ•˜๋ฉด Agreement BPDU๋กœ ์‘๋‹ตํ•œ๋‹ค.

์ด์™ธ Root Switch๋ฅผ ์„ ์ •ํ•˜๊ณ , Root Port/Designated Port๋ฅผ ๊ฒฐ์ •ํ•˜์—ฌ ํ™œ์„ฑ ํ† ํด๋กœ์ง€๋ฅผ ๊ตฌ์„ฑํ•˜๋Š” ๊ฒƒ์€ ๋™์ผํ•˜๋‹ค.

RSTP์™€ STP๋Š” ๋ณ„๋„ ์„ค์ •์—†์ด ํ˜ธํ™˜๋œ๋‹ค.
RSTP๋ฅผ ์‚ฌ์šฉํ•˜๋Š” Switch์˜ ํŠน์ •ํฌํŠธ๊ฐ€ STP๋ฅผ ์‚ฌ์šฉํ•˜๋Š” Switch์™€ ์—ฐ๊ฒฐ๋˜์—ˆ๋‹ค๋ฉด, STP์—์„œ ์‚ฌ์šฉํ•˜๋Š” Configuration BPDU์™€ TCN BPDU๊ฐ€ ์ „์†ก๋œ๋‹ค.

  1. RSTP์˜ BPDU
  2. RSTP ํฌํŠธ ์ƒํƒœ
  3. RSTP ํฌํŠธ ์ข…๋ฅ˜
  4. RSTP ๋งํฌ ์ข…๋ฅ˜
  5. RSTP ์„ค์ •

1. RSTP์˜ BPDU

STP์˜ Configuration BPDU์™€ ๋น„์Šทํ•˜๋‹ค.

์ถœ์ฒ˜: Ethernet, VLAN, STP, https://www.slideshare.net/isikalp82/alp-stp
  • Version ๊ฐ’์€ ํ•ญ์ƒ 2์ด๋‹ค.
  • Message Type(BPDU Type) ๊ฐ’์€ ํ•ญ์ƒ 2์ด๋‹ค.
    RSTP BPDU์ž„์„ ํ‘œ์‹œํ•˜๊ธฐ ์œ„ํ•จ์ด๋‹ค.
  • Flag ํ•„๋“œ๋Š” ๋ชจ๋‘ ๋‹ค ์‚ฌ์šฉํ•œ๋‹ค.
    STP์—์„œ Bit 0๊ณผ Bit 7๋งŒ ์‚ฌ์šฉํ•œ๋‹ค.
    Bit 7์€ TCN BPDU๋ฅผ ์ˆ˜์‹ ํ–ˆ์Œ์„ ์•Œ๋ฆด ๋•Œ ์‚ฌ์šฉํ•˜์ง€๋งŒ, RSTP๋Š” TCN BPDU ์ฐจ์ œ๋ฅผ ์‚ฌ์šฉํ•˜์ง€ ์•Š๊ธฐ ๋•Œ๋ฌธ์— ๊ฑฐ์˜ Bit 7์„ ์‚ฌ์šฉํ•˜์ง„ ์•Š๋Š”๋‹ค. ๋‹ค๋งŒ, STP๊ฐ€ ๋™์ž‘ํ•˜๋Š” Switch์™€์˜ ํ˜ธํ™˜์„ฑ์„ ์œ„ํ•ด ์‚ฌ์šฉํ•œ๋‹ค.
  • ๋งˆ์ง€๋ง‰์— ‘Version 1 length’๊ฐ€ ์ถ”๊ฐ€ ๋˜์—ˆ๋‹ค.

2. RSTP ํฌํŠธ ์ƒํƒœ

Discarding
STP์˜ Blocking ์ƒํƒœ์™€ ๋™์ผํ•˜๋‹ค.

Learning
STP์˜ Learning ์ƒํƒœ์™€ ๋™์ผํ•˜๋‹ค.
ํ•™์Šต ์‹œ๊ฐ„์€ ๊ธฐ์กด 15์ดˆ๋ณด๋‹ค ํ›จ์”ฌ ์งง๋‹ค.

Forwarding
STP์˜ Forwarding ์ƒํƒœ์™€ ๋™์ผํ•˜๋‹ค.


3. RSTP ํฌํŠธ ์ข…๋ฅ˜

Root Port
STP์˜ Root Port์™€ ๋™์ผํ•˜๋‹ค.
Switch ๋‹น RP 1๊ฐœ์”ฉ ์„ ํƒ๋œ๋‹ค.

Designated Port
STP์˜ Designated Port์™€ ๋™์ผํ•˜๋‹ค.

Alternate Port
RP๊ฐ€ ๋‹ค์šด๋˜๋ฉด RP ์—ญํ• ์„ ์ด์–ด๋ฐ›๋Š” ํฌํŠธ์ด๋‹ค.
Blocking ์ƒํƒœ์— ์žˆ์œผ๋ฉฐ, ๋ฐ์ดํ„ฐ ์†ก์ˆ˜์‹ ์€ ํ•˜์ง€ ์•Š๊ณ  BPDU๋งŒ ์ˆ˜์‹ ํ•œ๋‹ค.

Backup Port
DP๊ฐ€ ๋‹ค์šด๋˜๋ฉด DP ์—ญํ• ์„ ์ด์–ด๋ฐ›๋Š” ํฌํŠธ์ด๋‹ค.
๋ณต์ˆ˜๊ฐœ์˜ ๋งํฌ๋กœ ๊ตฌ์„ฑํ•˜๋ฉด, BP๊ฐ€ ์ƒ๊ธด๋‹ค.
Blocking ์ƒํƒœ์— ์žˆ์œผ๋ฉฐ, ๋ฐ์ดํ„ฐ ์†ก์ˆ˜์‹ ์„ ํ•˜์ง€ ์•Š๋Š”๋‹ค.

Disabled Port
RSTP์—์„œ ์—ญํ• ์ด ์—†๋Š” ํฌํŠธ์ด๋‹ค.
ex) ์…ง๋‹ค์šด๋œ ํฌํŠธ


4. RSTP ๋งํฌ ์ข…๋ฅ˜

Duplex์— ๋”ฐ๋ฅธ ๊ตฌ๋ถ„

(1) Point-to-Point Link : Full-Duplex๋กœ ๋™์ž‘ํ•˜๋Š” ํฌํŠธ
(2) Shared Link : Half-Duplex๋กœ ๋™์ž‘ํ•˜๋Š” ํฌํŠธ

์ƒ๋Œ€ ์žฅ๋น„์— ๋”ฐ๋ฅธ ๊ตฌ๋ถ„

(1) Link : RSTP๋กœ ๋™์ž‘ํ•˜๋Š” Switch์™€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ
(2) Edge : STP๊ฐ€ ๋™์ž‘ํ•˜์ง€ ์•Š๋Š” ์žฅ๋น„(PC,๋ผ์šฐํ„ฐ)์™€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ, Catalyst Switch์—์„œ๋Š” portfast๋ฅผ ์„ค์ •ํ•ด์•ผ๋งŒ Edge ํฌํŠธ๋กœ ๋™์ž‘.
(3) Peer : STP์™€ ๊ฐ™์€ (RSTP๊ฐ€ ์•„๋‹Œ) ํ”„๋กœํ† ์ฝœ๋กœ ๋™์ž‘ํ•˜๋Š” Switch์™€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ

  • Point-to-Point Peer
    Full-Duplex๋กœ ๋™์ž‘ํ•˜๊ณ , STP๊ฐ€ ๋™์ž‘์ค‘์ธ Switch์™€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ
    (STP๊ฐ€ ์•„๋‹์ˆ˜๋„ ์žˆ์Œ)
  • Point-to-Point Link
    Full-Duplex๋กœ ๋™์ž‘ํ•˜๊ณ , RSTP๊ฐ€ ๋™์ž‘์ค‘์ธ Switch์™€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ
๋งํฌ ์ข…๋ฅ˜ ์„ค์ •
Switch(config)# interface <INTERFACE>
Switch(config-if)# spanning-tree link-type [point-to-point | shared]

5. RSTP ์„ค์ •

Switch(config)# spanning-tree mode rapid-pvst
Switch(config)# spanning-tree vlan 1 priority <num>
Switch(config)# interface <INTERFACE>
Switch(config-if)# spanning-tree portfast

1: RSTP๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.
2: RSTP ์šฐ์„ ์ˆœ์œ„๋ฅผ ์กฐ์ •ํ•˜์—ฌ Root Switch๋กœ ๋งŒ๋“ค ์ˆ˜ ์žˆ๋‹ค.
3,4: RSTP๊ฐ€ ๋™์ž‘ํ•œ๋‹ค๋ฉด ์ข…๋‹จ์žฅ์น˜๋‚˜ ๋ผ์šฐํ„ฐ๊ฐ€ ์—ฐ๊ฒฐ๋œ ํฌํŠธ๋Š” portfast ์„ค์ •ํ•˜์—ฌ ๋ฐ”๋กœ Forwarding ์ƒํƒœ๋กœ ๋ณ€๊ฒฝ๋˜๋„๋ก ํ•œ๋‹ค.

[Switch] ์ด๋”์ฑ„๋„

์ด๋”์ฑ„๋„; Etherchannel
๋‘ Switch ์‚ฌ์ด์— ์—ฌ๋Ÿฌ ํฌํŠธ๋“ค์„ ํ•˜๋‚˜์˜ ํฌํŠธ์ฒ˜๋Ÿผ ๋™์ž‘ํ•˜๊ฒŒ ํ•œ๋‹ค. STP๋Š” ์ด๋”์ฑ„๋„์„ ํ•˜๋‚˜์˜ ํฌํŠธ๋กœ ๊ฐ„์ฃผํ•œ๋‹ค.
์ด๋”์ฑ„๋„์„ ์ƒ์„ฑํ•˜๊ณ ๋‚˜์„  ๋ฐ˜๋“œ์‹œ port-channel์—์„œ ์„ค์ •์„ ๋ณ€๊ฒฝํ•ด์•ผ ํ•œ๋‹ค.

์ด๋”์ฑ„๋„ Protocol Type

  1. ์‹œ์Šค์ฝ”์—์„œ ๋งŒ๋“  PAgP(Port Aggregation Protocol)
    1๊ฐœ์˜ ์ด๋”์ฑ„๋„์€ ์ตœ๋Œ€ 8 ํฌํŠธ๋กœ ๊ตฌ์„ฑํ•  ์ˆ˜ ์žˆ๋‹ค.
    Desirable๊ณผ Auto Mode ์‚ฌ์šฉ.
  2. IEEE์—์„œ ๋งŒ๋“  LACP(Link Aggregation Control Protocol)
    1๊ฐœ์˜ ์ด๋”์ฑ„๋„์€ ์ตœ๋Œ€ 16 ํฌํŠธ๋กœ ๊ตฌ์„ฑํ•  ์ˆ˜ ์žˆ๋‹ค.
    (8๊ฐœ ์‚ฌ์šฉ + 8๊ฐœ ๋ฐฑ์—…์šฉ)
    Active์™€ Passive Mode ์‚ฌ์šฉ.

์ด๋”์ฑ„๋„ Mode

Active – ๋ฌด์กฐ๊ฑด LACP ์‚ฌ์šฉ, ๋งŒ์ผ ์ƒ๋Œ€ Switch์™€ ์ด๋”์ฑ„๋„์ด ์•ˆ๋˜๋ฉด ์ผ๋ฐ˜ ๋‹จ์ผ ํฌํŠธ๋กœ ์‚ฌ์šฉ๋จ.
Desirable – ๋ฌด์กฐ๊ฑด PAgP ์‚ฌ์šฉ, ๋งŒ์ผ ์ƒ๋Œ€ Switch์™€ ์ด๋”์ฑ„๋„์ด ์•ˆ๋˜๋ฉด ์ผ๋ฐ˜ ๋‹จ์ผ ํฌํŠธ๋กœ ์‚ฌ์šฉ๋จ.
Passive – ์ƒ๋Œ€๊ฐ€ LACP ์‚ฌ์šฉํ•  ๋•Œ๋งŒ, LACP ํ™œ์„ฑํ™”
Auto – ์ƒ๋Œ€๊ฐ€ PAgP ์‚ฌ์šฉํ•  ๋•Œ๋งŒ, PAgP ํ™œ์„ฑํ™”
on – ์ƒ๋Œ€ Switch์™€ ํ˜‘์ƒ์—†์ด ์ด๋”์ฑ„๋„ ๋ฉค๋ฒ„ํฌํŠธ๋ฅผ ๋ชจ๋‘ ํ™œ์„ฑํ™”, ์ƒ๋Œ€ Switch๋„ on์œผ๋กœ ์„ค์ •ํ•ด์•ผํ•จ.


์ด๋”์ฑ„๋„ ์„ค์ •

1. Routed ์ด๋”์ฑ„๋„

Routed ํฌํŠธ๋กœ ๋™์ž‘ํ•˜๋Š” ์ด๋”์ฑ„๋„.

Switch(config)# interface range <port range>
Switch(config-if)# no switchport
Switch(config-if)# channel <channel_num> mode <mode>
Switch(config-if)# exit
Switch(config)#
Switch(config)# interface port-channel <channel_num>
Switch(config-if)# ip addr <ip> <subnet>
Switch(config-if)# exit
Switch(config)# exit
Switch# show etherchannel summary
Switch# show interface port-channel <num>

3: channel์˜ ํฌํŠธ๋ฒˆํ˜ธ๋Š” Switch ๋ชจ๋ธ์— ๋”ฐ๋ผ ๋‹ค๋ฅด๋‹ค. ex) catalyst 3550: 1-64, 3560: 1-48.
mode๋Š” active/desirable/passive/auto/on ์ค‘ ํ•˜๋‚˜๋ฅผ ์„ ํƒํ•œ๋‹ค.
6: ์ด๋”์ฑ„๋„ ํฌํŠธ๋กœ ์ ‘์† ํ•˜์—ฌ IP๋ฅผ ์„ค์ •ํ•œ๋‹ค.
10,11: ์ด๋”์ฑ„๋„์ด ์ •์ƒ ์„ค์ •๋˜์–ด์žˆ๋Š”์ง€ ํ™•์ธํ•œ๋‹ค.

2. SVI ์ด๋”์ฑ„๋„

๊ฐ€์ƒ VLAN ํฌํŠธ๋กœ ๋™์ž‘ํ•˜๋Š” ์ด๋”์ฑ„๋„.

Switch(config)# interface range <port range>
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan <vlan_num>
Switch(config-if)# channel <channel_num> mode <mode>
Switch(config-if)# exit
Switch(config)#
Switch(config)# interface vlan <vlan_num>
Switch(config-if)# ip addr <ip> <subnet>
Switch(config-if)# exit
Switch(config)# exit
Switch# show etherchannel summary
Switch# show ip interface brief

2,3: Access ํฌํŠธ๋กœ ์„ค์ •ํ•˜๊ณ  ํ—ˆ์šฉํ•  VLAN์„ ์„ค์ •ํ•œ๋‹ค.

3. Access ํฌํŠธ ์ด๋”์ฑ„๋„

AccessํฌํŠธ๋กœ ๋™์ž‘ํ•˜๋Š” ์ด๋”์ฑ„๋„

Switch(config)# interface range <port range>
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan <vlan_num>
Switch(config-if)# channel <channel_num> mode <mode>
Switch(config-if)# exit
Switch(config)# exit
Switch# show etherchannel summary
Switch# show interface port-channel <num>

4. Trunk ํฌํŠธ ์ด๋”์ฑ„๋„

Trunk ํฌํŠธ๋กœ ๋™์ž‘ํ•˜๋Š” ์ด๋”์ฑ„๋„.

Switch(config)# interface range <port range>
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# channel <channel_num> mode <mode>
Switch(config-if)# exit
Switch(config)# exit
Switch# show etherchannel summary
Switch# show interface port-channel <num>

2,3: Trunk ์ธ์บก์Š๋ ˆ์ด์…˜ ๋ฐ Trunk ํฌํŠธ๋กœ ์„ค์ •

[Switch] STP ์กฐ์ • ๋ฐ ๋ณดํ˜ธ๊ธฐ์ˆ 

STP๋Š” ์ „์›์„ ๊ฝ‚๊ธฐ๋งŒ ํ•˜๋ฉด ๋™์ž‘๋˜๋Š” ‘Plug and Play’ Protocol์ด๋ผ๊ณ  ํ•œ๋‹ค. ๊ทธ๋Ÿฌ๋‚˜ STP ๊ฐ’์„ ์กฐ์ •ํ•˜์ง€ ์•Š๊ณ  ๊ทธ๋Œ€๋กœ ์‚ฌ์šฉํ•œ๋‹ค๋ฉด, ๋„คํŠธ์›Œํฌ์˜ ๋™์ž‘ ์†๋„๋Š” ๋Š๋ฆด ๊ฒƒ์ด๋‹ค. ์žฅ์• ๊ฐ€ ๋ฐœ์ƒ๋˜์–ด ๋ณต๊ตฌํ•˜๋Š” ์‹œ๊ฐ„๋„ ์˜ค๋ž˜ ์†Œ์š”๋˜๊ณ , ๊ฐ„๋‹จํ•œ ์กฐ์ž‘์— ์˜ํ•ด์„œ๋„ ์Šค์œ„์น˜ ๋„คํŠธ์›Œํฌ๊ฐ€ ๋งˆ๋น„๋  ์ˆ˜ ์žˆ๋‹ค.

์ด๋Ÿฌํ•œ ์œ„ํ—˜(?)์„ ๋ฐฉ์ง€ํ•˜๊ณ ์ž STP๋ฅผ ์ข€ ๋” ์œ ์šฉํ•˜๊ฒŒ ์‚ฌ์šฉํ•˜๋ ค๋ฉด, ์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์„ ์กฐ์ •ํ•ด์•ผ ํ•œ๋‹ค. ‘์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„’์ด๋ž€, ํ† ํด๋กœ์ง€์— ๋ณ€๋™์ด ์ƒ๊ฒผ์„ ๋•Œ ๋„คํŠธ์›Œํฌ๊ฐ€ ์žฌ๊ตฌ์„ฑ๋  ๋•Œ๊นŒ์ง€ ์†Œ์š”๋˜๋Š” ์‹œ๊ฐ„์ด๋‹ค.

์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์„ ์ค„์ด๋Š” ๋ฐฉ๋ฒ•์€ ์•„๋ž˜์™€ ๊ฐ™๋‹ค.

โ”Œโ”€ Port Fast
โ”œโ”€ Uplink Fast
โ”œโ”€ Backbone Fast
โ”œโ”€ Hello / Max-Age / Forward-Delay ์กฐ์ •
โ””โ”€ RSTP ๋˜๋Š” MSTP ์‚ฌ์šฉ

๋˜ํ•œ, STP๋Š” ๋ณด์•ˆ์— ์ทจ์•ฝํ•˜๋‹ค.
STP ๋„คํŠธ์›Œํฌ๋ฅผ ๋ณดํ˜ธํ•˜๋Š” ๋ฐฉ๋ฒ•์€ ์•„๋ž˜์™€ ๊ฐ™๋‹ค.

โ”Œโ”€ BPDU Guard
โ”œโ”€ BPDU Filtering
โ”œโ”€ Loop Guard
โ”œโ”€ Root Guard
โ””โ”€ UDLD


1. STP ์กฐ์ •

1-1. Port Fast

Switch์˜ Port๊ฐ€ ํ™œ์„ฑํ™”๋˜๋ฉด, Listening ์ƒํƒœ๋ถ€ํ„ฐ ์‹œ์ž‘ํ•œ๋‹ค.
(Blocking โ†’ Listening โ†’ Learning โ†’Forwarding)
๊ทธ๋Ÿฌ๋‚˜ Port Fast ๊ธฐ๋Šฅ์„ ์‚ฌ์šฉํ•˜๋ฉด, Listening ์ƒํƒœ๊ฐ€ ์•„๋‹Œ ๋ฐ”๋กœ Forwarding ์ƒํƒœ๊ฐ€ ๋˜๋„๋ก ํ•œ๋‹ค.
(Blocking โ†’ Forwarding)
๋ณดํ†ต PC๋‚˜ ์„œ๋ฒ„ ๋“ฑ๊ณผ ๊ฐ™์ด ์ข…๋‹จ ์žฅ์น˜๊ฐ€ ์—ฐ๊ฒฐ๋œ Port์— ์„ค์ •ํ•œ๋‹ค.

์„ค์ •

[๋ฐฉ๋ฒ•1. ๋ชจ๋“  Access port์— Port Fast ์ ์šฉ]

Switch(config)# spanning-tree portfast default

Hub/Switch/Bridge๊ฐ€ ์—ฐ๊ฒฐ๋˜์–ด์žˆ๋‹ค๋ฉด, ์ผ์‹œ์ ์œผ๋กœ ํ”„๋ ˆ์ž„ ๋ฃจํ”„๊ฐ€ ๋ฐœ์ƒํ•  ์ˆ˜ ์žˆ๋‹ค. Switch ๊ฐ„ Access port๋ฅผ ์‚ฌ์šฉํ•˜๋Š” ์ถ”์„ธ์ด๋ฏ€๋กœ ๊ฐ€๋Šฅํ•œ ์ด ๋ฐฉ๋ฒ•์€ ๊ถŒ์žฅํ•˜์ง€ ์•Š๋Š”๋‹ค.

[๋ฐฉ๋ฒ•2. ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์— Port Fast ์ ์šฉ]

Switch(config)# interface <INTERFACE>
Switch(config-if)# spanning-tree portfast

[Trunk ํฌํŠธ์— Port Fast ์ ์šฉ]
Server/Router ๋“ฑ๊ณผ ์—ฐ๊ฒฐ๋˜๋Š” Trunk ํฌํŠธ๋‚˜ ๋งํฌ๊ฐ€ ํ•˜๋‚˜ ๋ฟ์ธ Switch๋ฅผ ์—ฐ๊ฒฐํ•˜๋Š” Trunk ํฌํŠธ์—์„  ์‚ฌ์šฉํ•  ์ˆ˜ ์žˆ๋‹ค.

Switch(config)# interface <TRUNK_INTERFACE>
Switch(config-if)# spanning-tree portfast trunk

์ง์ ‘ ์—ฐ๊ฒฐ๋œ ๋งํฌ๊ฐ€ ๋‹ค์šด๋˜์—ˆ์„ ๋•Œ, Blocking ์ƒํƒœ์— ์žˆ๋Š” ํฌํŠธ๋ฅผ ์ฆ‰์‹œ Forwarding ์ƒํƒœ๋กœ ๋ณ€๊ฒฝํ•œ๋‹ค. Root Switch์—์„  ์ฐจ๋‹จ ์ƒํƒœ ํฌํŠธ๊ฐ€ ์—†์œผ๋ฏ€๋กœ Access(์ข…๋‹จ) Switch์—์„œ ์„ค์ •ํ•œ๋‹ค. Uplink Fast ์„ค์ • ์‹œ ์ž์‹ ์„ Access Switch๋กœ ๋งŒ๋“ค๊ธฐ ์œ„ํ•ด Priority๋ฅผ 32768์—์„œ 49152๋กœ ๋ณ€๊ฒฝํ•œ๋‹ค.

์„ค์ •
Switch(config)# spanning-tree uplinkfast

1-3. Backbone Fast

์ง์ ‘ ์ ‘์†๋˜์ง€ ์•Š์€ ๊ฐ„์ ‘ ๋งํฌ๊ฐ€ ๋‹ค์šด๋˜์—ˆ์„ ๋•Œ, Blocking ์ƒํƒœ์˜ ํฌํŠธ์—์„œ Max-Age๋ฅผ ์ƒ๋žตํ•˜๊ณ  ๋ฐ”๋กœ Listening ์ƒํƒœ๋กœ ๋ณ€๊ฒฝํ•œ๋‹ค. Max-Age๋ฅผ ์ƒ๋žตํ•˜๋ฉด Forwarding ๋‹จ๊ณ„๊นŒ์ง€ 20์ดˆ ๋‹จ์ถ•ํ•  ์ˆ˜ ์žˆ๋‹ค.

๋™์ž‘๊ณผ์ •
  1. ‘SW1—SW2’ ๋งํฌ ๋‹ค์šด
  2. SW2๋Š” ์ž์‹ ์ด Root Switch๋ผ๊ณ  ์ฃผ์žฅํ•˜๋Š” ํ›„์ˆœ์œ„ BPDU๋ฅผ SW3๋กœ ์ „์†ก
  3. SW3์ด ‘SW1—SW2’ ๋งํฌ ๋‹ค์šด ์ธ์ง€
  4. SW3๊ฐ€ SW1๋กœ RLQ ์ „์†ก (‘SW3—SW1’ ๋งํฌ ์ƒํƒœ ํ™•์ธ์„ ์œ„ํ•จ)
  5. SW1์€ ์ด์ƒ์ด ์—†๋‹ค๋Š” ์˜๋ฏธ๋กœ RLQ ์‘๋‹ตํŒจํ‚ท ์ „์†ก
  6. ํ•ด๋‹น ํŒจํ‚ท์„ ๋ฐ›์€ SW3๋Š” Blocking ์ƒํƒœ ํฌํŠธ์˜ Max-Age๋ฅผ ๋งŒ๋ฃŒ์‹œ์ผœ ๋ฐ”๋กœ Listening ์ƒํƒœ๋กœ ๋ณ€๊ฒฝ
์„ค์ •

Backbone Fast๋ฅผ ๊ตฌ์„ฑํ•˜๋ ค๋ฉด ์ „์ฒด Switch์—์„œ ์„ค์ •ํ•ด์•ผํ•œ๋‹ค.

Switch(config)# spanning-tree backbonefast

1-4. STP Timer ์กฐ์ •

์•ž์„œ ๋ณธ Fast ๋ฐฉ์‹ ์„ค์ • ๋ง๊ณ , ์ง์ ‘ ํƒ€์ด๋จธ๋ฅผ ์กฐ์ •ํ•˜์—ฌ ์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์„ ๋‹จ์ถ•ํ•  ์ˆ˜ ์žˆ๋‹ค.

– ๊ธฐ๋ณธ๊ฐ’
Diameter ๋ณ„๋กœ ํƒ€์ด๋จธ ๊ธฐ๋ณธ ๊ฐ’์ด ์ƒ์ดํ•˜๋‹ค.
๊ธฐ๋ณธ Diameter ๊ฐ’์€ 7์ด๋‹ค.

Diameter ๊ฐ’์„ ์กฐ์ •ํ•ด STP ํƒ€์ด๋จธ๋ฅผ ๋ณ€๊ฒฝํ•˜๋ ค๋ฉด, ๋ฐ˜๋“œ์‹œ Root Switch์—์„œ ์กฐ์ •ํ•ด์•ผ ํ•œ๋‹ค. ์ผ๋ฐ˜ Switch์—์„œ ์„ค์ •ํ•˜๋ฉด ๋‚˜์ค‘์— ํ•ด๋‹น Switch๊ฐ€ Root Switch๊ฐ€ ๋˜์–ด์•ผ๋งŒ ์ „์ฒด ๋„คํŠธ์›Œํฌ์— ์ ์šฉ๋˜๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

[Root Switch์—์„œ Diameter ์กฐ์ •]

Switch(config)# spanning-tree vlan <VLAN_NUM> root primary diameter [2-7]

[Hello / Max-Age / Forward-Delay ์กฐ์ •]

Switch(config)# spanning-tree vlan <VLAN_NUM> hello-timer [1-10]
Switch(config)# spanning-tree vlan <VLAN_NUM> max-age [6-40]
Switch(config)# spanning-tree vlan <VLAN_NUM> forward-time [4-30]

2. STP ๋„คํŠธ์›Œํฌ ๋ณดํ˜ธ

2-1. BPDU Guard

ํŠน์ • Port๋ฅผ ํ†ตํ•ด BPDU ์ˆ˜์‹  ์‹œ ํ•ด๋‹น Port๋ฅผ ์ž๋™์œผ๋กœ Shutdownํ•œ๋‹ค. ์ด๋ ‡๊ฒŒ shutdown๋œ Port๋Š” ‘๋‹ค์‹œ ์ง์ ‘ shutdown โ†’ no shutdown’ ํ•ด์•ผ up๋œ๋‹ค. ์ผ๋ฐ˜์ ์œผ๋กœ PC/Server์™€ ๊ฐ™์€ ์ข…๋‹จ ์žฅ์น˜๊ฐ€ BPDU๋ฅผ ์ „์†กํ•˜์ง€ ์•Š์œผ๋ฏ€๋กœ ์ด๋Ÿฌํ•œ Port์— ์„ค์ •ํ•œ๋‹ค.

์„ค์ •

[๋ฐฉ๋ฒ•1. Port Fast๊ฐ€ ์ ์šฉ๋œ Port์— ์„ค์ •]

Switch(config)# spanning-tree portfast bpduguard default

[๋ฐฉ๋ฒ•2. ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์— ์ ์šฉ]

Switch(config)# interface <INTERFACE>
Switch(config-if)# spanning-tree bpduguard enable

[๋ณต๊ตฌ]

Switch(config)# errdisable recovery cause bpduguard
Switch(config)# errdisable recovery interval 120

1: 300์ดˆ ํ›„ ์ž๋™์œผ๋กœ Port ๋ณต๊ตฌ
2: 120์ดˆ ํ›„ ์ž๋™์œผ๋กœ Port ๋ณต๊ตฌ


2-2. BPDU Filtering

ํŠน์ • Port๋กœBPDU๋ฅผ ๋ณด๋‚ด๊ฑฐ๋‚˜ ๋ฐ›์ง€ ์•Š๊ฒŒ ํ•œ๋‹ค. ๋ณดํ†ต BPDU๋ฅผ ์ˆ˜์‹ ํ•˜์ง€ ์•Š์•„๋„ ๋˜๋Š” ์ข…๋‹จ ์žฅ์น˜์— ๋ถˆํ•„์š”ํ•œ ํ”„๋ ˆ์ž„์ด ์ „์†ก๋˜๋Š” ๊ฒƒ์„ ๋ฐฉ์ง€ํ•œ๋‹ค. BPDU๋ฅผ ๋ณด๋‚ด์ง€ ์•Š๊ธฐ ๋•Œ๋ฌธ์— STP๊ฐ€ ๋™์ž‘ํ•˜์ง€ ์•Š๋Š” ๊ฒƒ๊ณผ ๋น„์Šทํ•˜๋‹ค.

์„ค์ •

[๋ฐฉ๋ฒ•1. portfast๊ฐ€ ์ ์šฉ๋œ ํฌํŠธ์—๋งŒ BPDU Filtering ์„ค์ •]

Switch(config)# spanning-tree portfast bpdufilter default

[๋ฐฉ๋ฒ•2. ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์— ์„ค์ •]

Switch(config)# interface <INTERFACE>
Switch(config-if)# spanning-tree bpdufilter enable
๋งŒ์•ฝ, SW3์˜ F0/3์— BPDU Filtering์„ ํ•˜๋ฉด ์–ด๋–ป๊ฒŒ ๋ ๊นŒ?

SW3์˜ F0/3์€ ํ˜„์žฌ Alternate Port์ด๋‹ค. ์ด๋Ÿฐ ์ƒํ™ฉ์—์„œ BPDU Filtering์„ ์„ค์ •ํ•˜๋ฉด, F0/3์€ BPDU๋ฅผ ๋ฐ›์ง€ ๋ชปํ•  ๊ฒƒ์ด๊ณ  STP๋กœ ์ธํ•ด Designated Port๋กœ ๋ณ€๊ฒฝ๋  ๊ฒƒ์ด๋‹ค. ๊ทธ๋Ÿผ SW3 — SW2 ๋งํฌ๊ฐ€ ์‚ด์•„๋‚˜๊ณ , ๋ฃจํ”„๊ฐ€ ์ƒ๊ธธ ๊ฒƒ์ด๋‹ค.


2-3. Loop Guard

์ผ๋ฐ˜์ ์œผ๋กœ Blocking ์ƒํƒœ์— ์žˆ๋Š” ํฌํŠธ๊ฐ€ BPDU๋ฅผ ๋ฐ›์ง€ ๋ชปํ–ˆ์„ ๋•Œ, ์ผ์ • ์‹œ๊ฐ„์ด ์ง€๋‚˜๊ฒŒ ๋˜๋ฉด Forwarding ์ƒํƒœ๋กœ ๋ณ€๊ฒฝ๋œ๋‹ค. ์ด ๊ฒƒ์„ ๋ฐฉ์ง€ํ•˜๋Š” ๊ธฐ๋Šฅ์ด๋‹ค. ์ด ๊ธฐ๋Šฅ์„ ์‚ฌ์šฉํ•˜๋ฉด Blocking ์ƒํƒœ์˜ ํฌํŠธ๊ฐ€ Loop Inconsistent(๋ฃจํ”„ ๋น„์ผ๊ด€) ์ƒํƒœ๋กœ ๋ฐ”๋€๋‹ค. Loop Inconsistent๋„ Blocking๊ณผ ๋น„์Šทํ•˜๋‹ค.

๋‹ค์‹œ BPDU๋ฅผ ๋ฐ›๊ฒŒ ๋˜๋ฉด ์ž๋™์œผ๋กœ ์ •์ƒ์ ์ธ Blocking ์ƒํƒœ๋กœ ๋Œ์•„๊ฐ„๋‹ค. ๋ฌผ๋ก , Loop Guard๊ฐ€ ์„ค์ •๋˜์–ด๋„ ๋งํฌ๊ฐ€ ๋‹ค์šด๋˜๊ฑฐ๋‚˜ ํ›„์ˆœ์œ„ BPDU๋ฅผ ๋ฐ›๋Š” ๊ฒฝ์šฐ์—” Blocking ์ƒํƒœ์—์„œ Forwarding ์ƒํƒœ๋กœ ๋ณ€๊ฒฝ๋œ๋‹ค.

์„ค์ •

[๋ฐฉ๋ฒ•1. ์ „์ฒด ์ธํ„ฐํŽ˜์ด์Šค์— ์ ์šฉ]

Switch(config)# spanning-tree loopguard default

[๋ฐฉ๋ฒ•2. ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์— ์ ์šฉ]

Switch(config)# interface <INTERFACE>
Switch(config-if)# spanning-tree guard loop

2-4. Root Guard

ํŠน์ • ํฌํŠธ์— ์ ‘์†๋œ ๋„คํŠธ์›Œํฌ์— ์žˆ๋Š” Switch๋“ค์ด Root Switch๊ฐ€ ๋  ์ˆ˜ ์—†๋„๋ก ํ•œ๋‹ค. Root Guard๊ฐ€ ์„ค์ •๋œ ํฌํŠธ์—์„œ ํ˜„์žฌ์˜ Root Bridge ID๋ณด๋‹ค ๋” ์šฐ์„ ๋˜๋Š” Bridge ID๋ฅผ ์ˆ˜์‹ ํ•˜๋ฉด ํ•ด๋‹น ํฌํŠธ๋ฅผ ๋‹ค์šด์‹œํ‚จ๋‹ค.

์„ค์ •

[๋ฐฉ๋ฒ•. ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์—์„œ ์„ค์ •]

Switch(config)# interface <INTERFACE>
Switch(config-if)# spanning-tree guard root

[๋ณต๊ตฌ]
๋ฌธ์ œ๋˜๋Š” Bridge ID๋ฅผ ๊ฐ€์ง„ Switch์—์„œ ์šฐ์„ ์ˆœ์œ„๋ฅผ ์กฐ์ •ํ•˜๋ฉด ์ฐจ๋‹จ๋œ ํฌํŠธ๊ฐ€ ๋‹ค์‹œ ํ™œ์„ฑํ™”๋œ๋‹ค. ๋˜๋Š”, ํ•ด๋‹น ํฌํŠธ๋ฅผ shutdown โ†’ no shutdownํ•˜์—ฌ ํ™œ์„ฑํ™”ํ•  ์ˆ˜ ์žˆ๋‹ค.


2-5. UDLD

Unidirectional Link Detection
Switch ๊ฐ„ ๋งํฌ์—์„œ ๋‹จ๋ฐฉํ–ฅ ๋งํฌ๊ฐ€ ์ƒ๊ฒผ์„ ๋•Œ, ํ•ด๋‹น ํฌํŠธ๋ฅผ ๋‹ค์šด์‹œํ‚จ๋‹ค. ๋‹จ๋ฐฉํ–ฅ ๋งํฌ๋กœ ์ธํ•ด L2 ๋ฃจํ”„๊ฐ€ ๋ฐœ์ƒํ•˜๊ฑฐ๋‚˜ ํ•œ ์ชฝ์—์„œ ๋ณด๋‚ธ ํ”„๋ ˆ์ž„์ด ์‚ฌ๋ผ์ง€๋Š” ๋ธ”๋ž™ํ™€ ํ˜„์ƒ์ด ๋ฐœ์ƒํ•  ์ˆ˜ ์žˆ๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

์ฃผ๊ธฐ์ ์œผ๋กœ ์†ก์‹ ํฌํŠธ๋ฅผ ํ†ตํ•ด UDLDํŒจํ‚ท์„ ์ „์†กํ•œ๋‹ค. ์ด ํŒจํ‚ท์„ ์ˆ˜์‹ ํ•œ ์ƒ๋Œ€๋Š” ๋‹ค์‹œ ์ž์‹ ์˜ ์†ก์‹ ํฌํŠธ๋ฅผ ํ†ตํ•ด Echo์‹œํ‚ด์œผ๋กœ์จ ์–‘๋ฐฉํ–ฅ ๋งํฌ๊ฐ€ ์ •์ƒ ๋™์ž‘ํ•˜๋Š”์ง€ ํ™•์ธํ•œ๋‹ค.

์–ผํ• ๋ณด๋ฉด, Loop Guard์™€ ๋น„์Šทํ•œ ๊ธฐ๋Šฅ์ด๋ผ๊ณ  ์ƒ๊ฐํ•  ์ˆ˜ ์žˆ์ง€๋งŒ, Loop Guard๋Š” ์†Œํ”„ํŠธ์›จ์–ด์ ์ธ ์ƒํ™ฉ(์ƒ๋Œ€ Swtich ์ด์ƒ)์œผ๋กœ ์ธํ•ด BPDU๋ฅผ ์†ก์‹ ํ•˜์ง€ ๋ชปํ•  ๋•Œ ๋™์ž‘ํ•˜๊ณ  UDLD๋Š” ์ผ€์ด๋ธ”๋ง์„ ๊ฐ์ง€ํ•˜์—ฌ ๋™์ž‘ํ•œ๋‹ค. UDLD๋ฅผ ์‚ฌ์šฉํ•˜๋ ค๋ฉด ์ƒ๋Œ€ Switch๋„ UDLD ๊ธฐ๋Šฅ์„ ์ง€์›ํ•ด์•ผํ•œ๋‹ค.

UDLD Mode
  • Normal Mode(์ผ๋ฐ˜๋ชจ๋“œ): ๊ด‘์ผ€์ด๋ธ” ๊ฒฐ์„  ์˜ค๋ฅ˜๋กœ ์ธํ•œ ๋‹จ๋ฐฉํ–ฅ ๋งํฌ๋ฅผ ๊ฐ์ง€ํ•œ๋‹ค.
  • Aggressive Mode(์ ๊ทน?๋ชจ๋“œ): ๊ด‘์ผ€์ด๋ธ” ๋ฐ UTP์˜ ๋‹จ๋ฐฉํ–ฅ ํŠธ๋ž˜ํ”ฝ์œผ๋กœ ์ธํ•œ ๋‹จ๋ฐฉํ–ฅ ๋งํฌ๋ฅผ ๊ฐ์ง€ํ•œ๋‹ค.
์„ค์ •

[๋ฐฉ๋ฒ•1. ์ „์ฒด ์ธํ„ฐํŽ˜์ด์Šค์— ์„ค์ •]

Switch(config)# udld [Aggressive | normal]

[๋ฐฉ๋ฒ•2. ํŠน์ • ์ธํ„ฐํŽ˜์ด์Šค์— ์„ค์ •]

Switch(config)# interface <INTERFACE>
Switch(config-if)# udld port 
Switch(config-if)# udld port aggressive

2: or 3: ๋‘˜ ์ค‘ ํ•˜๋‚˜๋ฅผ ํƒํ•˜์—ฌ ์„ค์ •ํ•œ๋‹ค.
2-Normal, 3-Aggressive

[๋ณต๊ตฌ]

Switch# udld reset
OR
Switch(config)# errdiasble recovery cause udld

์ด์™ธ์—๋„ ๋‹ค์šด๋œ ํฌํŠธ์—์„œ ์ง์ ‘ ๋ณต๊ตฌํ•˜๋Š” ๋ฐฉ๋ฒ•๋„ ์žˆ๋‹ค.

[Switch] ์ข…๋‹จ/์ง€์—ญ VLAN ๋„คํŠธ์›Œํฌ

  1. ์ข…๋‹จ VLAN (End-to-End)
  2. ์‚ฌ์„ค VLAN (Local)

1. ์ข…๋‹จ VLAN

End-to-End VLAN

์ข…๋‹จ VLAN์ด๋ž€, VLAN ํ•˜๋‚˜๊ฐ€ ์ „์ฒด Switch์— ๊ฑธ์ณ์žˆ๋Š” VLAN์ด๋‹ค. Switch ๊ฒฝ๋กœ๋ฅผ ์กฐ์ •ํ•˜๊ธฐ ๊นŒ๋‹ค๋กญ๋‹ค. ๋ผ์šฐํ„ฐ๋‚˜ L3 ์Šค์œ„์น˜์™€ ๊ฐ™์€ ๋ผ์šฐํŒ…์ด ๊ฐ€๋Šฅํ•œ ์žฅ๋น„์™€ ๊ฐ€๊นŒ์šด ๊ณณ์— Root Switch๋ฅผ ์ง€์ •ํ•˜๋Š” ๊ฒƒ์ด ๊ฒฝ๋กœ ์กฐ์ •ํ•˜๊ธฐ์— ํŽธํ•˜๋‹ค.

์œ„์™€ ๊ฐ™์€ ๋„คํŠธ์›Œํฌ๊ฐ€ ์žˆ๋‹ค๊ณ  ์ƒ๊ฐํ•ด๋ณด์ž. Switch ๋„คํŠธ์›Œํฌ๋ฅผ ๋ณด๋ฉด ๋ฌด์—‡์ด ๋– ์˜ค๋ฅด๋Š”๊ฐ€? ๊ทธ๋ ‡๋‹ค. ์ด Switch๋Š” ํ•„์—ฐ์ ์œผ๋กœ STP๊ฐ€ ๋™์ž‘๋˜์–ด Switch ํฌํŠธ๋“ค ์ค‘ ํ•˜๋‚˜๋Š” Blocking ์ƒํƒœ๋กœ ์ „ํ™˜๋  ๊ฒƒ์ด๋‹ค. ์ด๋ ‡๊ฒŒ ๋˜๋ฉด ์‚ฌ์‹ค์ƒ ๋„คํŠธ์›Œํฌ๋ฅผ ์ œ๋Œ€๋กœ ์‚ฌ์šฉํ•œ๋‹ค๊ณ  ๋ณด๊ธด ์–ด๋ ค์šธ ๊ฒƒ์ด๋‹ค.

๋‹น์—ฐํžˆ ์ด ์ƒํ™ฉ์„ ํ•ด๊ฒฐํ•  ์ˆ˜ ์žˆ๋‹ค.
VLAN 10์€ SW4 โ†’ SW3 โ†’ SW1๋กœ ์ด๋™ํ•˜๋„๋ก ํ•  ๊ฒƒ์ด๊ณ ,
VLAN 20์€ SW4 โ†’ SW2 โ†’ SW1๋กœ ์ด๋™ํ•˜๋„๋ก ํ•  ๊ฒƒ์ด๋‹ค.
๋งŒ์ผ์— ๋Œ€๋น„ํ•ด ๋งํฌ ํ•˜๋‚˜๊ฐ€ Down๋˜๋ฉด, ํ•œ์ชฝ์œผ๋กœ ์Šค์œ„์นญํ•˜๋„๋ก ํ•œ๋‹ค.

์ด๋ ‡๊ฒŒ ๊ตฌ์„ฑํ•˜๋ ค๋ฉด
SW1์€ Root Switch,
SW2๋Š” VLAN 20์˜ ์ œ 2 Root Switch,
SW3์€ VLAN 10์˜ ์ œ 2 Root Switch๋กœ ์„ค์ •ํ•˜๋ฉด ๋œ๋‹ค.

VLAN 10 ์ž…์žฅ์—์„  SW2-SW4 ๋งํฌ๊ฐ€ ๋Š๊ธด ๊ฒƒ์œผ๋กœ ๊ฐ„์ฃผํ•˜๊ณ ,
VLAN 20 ์ž…์žฅ์—์„  SW3-SW4 ๋งํฌ๊ฐ€ ๋Š๊ธด ๊ฒƒ์œผ๋กœ ๊ฐ„์ฃผํ•œ๋‹ค.

1-1) Root Switch ๋ฐ ์ œ 2 Root Switch ์„ค์ •

[๋ฐฉ๋ฒ•1: Spanning-tree vlan priority]

SW1(config)# spanning-tree vlan 10,20 priority 0
SW2(config)# spanning-tree vlan 20 priority 4096
SW3(config)# spanning-tree vlan 10 priority 4096

[๋ฐฉ๋ฒ•2: Spanning-tree vlan root]

SW1(config)# spanning-tree vlan 10,20 root primary diameter 4
SW2(config)# spanning-tree vlan 20 root secondary
SW3(config)# spanning-tree vlan 10 root secondary

primary ์˜ต์…˜์„ ์‚ฌ์šฉํ•œ Switch๋Š” ์ž์‹ ์˜ ์šฐ์„ ์ˆœ์œ„๋ฅผ ๋‹ค๋ฅธ Switch๋“ค๋ณด๋‹ค ๋‚ฎ์ถฐ Root Switch๊ฐ€ ๋œ๋‹ค.
Secondary ์˜ต์…˜์€ Root Switch๋ณด๋‹ค ์šฐ์„ ์ˆœ์œ„๋ฅผ ๋†’๊ฒŒ, ๋‹ค๋ฅธ Switch๋ณด๋‹ค๋Š” ๋‚ฎ๊ฒŒ ์„ค์ •ํ•œ๋‹ค.

์šฐ์„ ์ˆœ์œ„๋ฅผ ์กฐ์ •ํ•ด๋„ Bridge ID๊ฐ€ ๋‚ฎ์€ Switch๊ฐ€ ์กด์žฌํ•  ๊ฐ€๋Šฅ์„ฑ์ด ์žˆ๋‹ค. ์šฐ์„ ์ˆœ์œ„๋ฅผ 0์œผ๋กœ ๊ณ ์ •์‹œํ‚ค๋Š”๊ฒŒ ๋” ํ™•์‹คํ•˜์ง€๋งŒ, ์šฐ์„ ์ˆœ์œ„๊ฐ€ 0์ด๋ฉด์„œ๋„ MAC์ฃผ์†Œ๊ฐ€ ๋‚ฎ์•„ ๊ฒฐ๊ตญ Bridge ID๊ฐ€ ๋” ๋‚ฎ์€ Switch๊ฐ€ ์กด์žฌํ•  ์ˆ˜ ์žˆ๊ธฐ ๋•Œ๋ฌธ์— 100% ๋ณด์žฅํ•˜์ง„ ์•Š๋Š”๋‹ค.

diameter ์˜ต์…˜์€ Root Switch๋ฅผ ํฌํ•จํ•ด ๊ฐ€์žฅ ๋ฉ€๋ฆฌ ๋–จ์–ด์ง„ Switch ์ˆ˜๋Ÿ‰์„ ์˜๋ฏธํ•œ๋‹ค. SW1-SW3 ๋งํฌ๊ฐ€ ๋Š๊ฒผ์„ ๋•Œ, SW1๋ถ€ํ„ฐ SW3๊นŒ์ง€ ์ด 4๊ฐœ์˜ Switch๋ฅผ ๊ฑฐ์น˜๊ธฐ ๋•Œ๋ฌธ์— 4๋ฅผ ์ž…๋ ฅํ–ˆ๋‹ค. ์ฐธ๊ณ ๋กœ ์ด diameter๋ฅผ ํ†ตํ•ด ์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์„ ๋‹จ์ถ•์‹œํ‚ฌ ์ˆ˜ ์žˆ๋‹ค.

2. ์ง€์—ญ VLAN

Local VLAN

์ง€์—ญ VLAN์ด๋ž€, ํ•˜๋‚˜์˜ VLAN์ด ์ผ๋ถ€ ๋„คํŠธ์›Œํฌ์—๋งŒ ์กด์žฌํ•˜๋Š” ๊ฒƒ์„ ๋งํ•œ๋‹ค. ์ข…๋‹จ VLAN์— ๋น„ํ•ด ์„ค์ •์ด ํŽธ๋ฆฌํ•˜๊ณ , ์œ ์ง€๋ณด์ˆ˜๋‚˜ ์žฅ์• ์ฒ˜๋ฆฌ๋„ ๊ฐ„๋‹จํ•˜๋‹ค๊ณ  ํ•œ๋‹ค.

์œ„ ํ† ํด๋กœ์ง€๋ฅผ ๋ณด์ž. PC1๊ณผ PC2๋Š” R1๊นŒ์ง€ ๊ฐ€์ง€ ์•Š์•„๋„ SW2๋‚˜ SW3์—์„œ ๋ผ์šฐํŒ…๋˜์–ด ํ†ต์‹ ํ•  ์ˆ˜์žˆ๋‹ค. ๊ทธ๋ ‡๊ฒŒ ๋˜๋ฉด VLAN 10๊ณผ VLAN 20์€ ์ผ๋ถ€ ๋„คํŠธ์›Œํฌ์—๋งŒ ๊ฑธ์ณ์žˆ๋‹ค๊ณ  ๋ณผ ์ˆ˜์žˆ๋‹ค. VLAN 30๋„ ๋งˆ์ฐฌ๊ฐ€์ง€๋‹ค.

์ง€์—ญ VLAN์—์„œ๋Š” Root Switch๋ฅผ ์กฐ์ •ํ•  ํ•„์š”๊ฐ€ ์—†๋‹ค. ์–ด์ฐจํ”ผ ๋™์ผํ•œ VLAN์— ์˜ํ•ด ๊ตฌ์„ฑ๋˜๋Š” Loop๊ฐ€ ์—†๊ธฐ ๋•Œ๋ฌธ์— STP์— ์˜ํ•ด ์ฐจ๋‹จ๋œ ํฌํŠธ๊ฐ€ ์—†์œผ๋‹ˆ ๋ง์ด๋‹ค.

์ง€์—ญ VLAN ์‚ฌ์šฉ ์ค‘ ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ•˜๋ฉด, ๋ผ์šฐํŒ… ํ”„๋กœํ† ์ฝœ์— ์˜ํ•ด ์ปจ๋ฒ„์ „์Šค๊ฐ€ ์ผ์–ด๋‚จ์œผ๋กœ ์žฅ์• ๋ณต๊ตฌ๊ฐ€ ๋น ๋ฅด๋‹ค. ๋ถ€ํ•˜๋ถ„์‚ฐ(Load Balancing)๋„ ๋ผ์šฐํŒ… ํ…Œ์ด๋ธ”์— ์˜ํ•ด ๋ฐœ์ƒ๋˜๋ฏ€๋กœ ์ •๊ตํ•˜๋‹ค. ๋„คํŠธ์›Œํฌ ํ† ํด๋กœ์ง€๋„ ์ง๊ด€์ ์ด๋ผ์„œ ์œ ์ง€๋ณด์ˆ˜์—๋„ ํŽธ๋ฆฌํ•˜๋‹ค.

2-1) ์ง€์—ญ VLAN ์„ค์ •
  1. ๊ฐ Switch์—์„œ L3 ์ธํ„ฐํŽ˜์ด์Šค์™€ SVI๋ฅผ ๋งŒ๋“  ํ›„ IP๋ฅผ ํ• ๋‹นํ•œ๋‹ค.
  2. ๊ทธ๋ฆฌ๊ณ  ๋ผ์šฐํŒ… ์„ค์ •๋งŒ ํ•˜๋ฉด ๋.

[Switch] Spanning Tree Protocol

Switch ๋„คํŠธ์›Œํฌ์—์„œ Switch ๊ฐ„์˜ ๋งํฌ๋ฅผ ๋Œ€๋ถ€๋ถ„ ์ด์ค‘์œผ๋กœ ๊ตฌ์„ฑํ•œ๋‹ค. ํŠน์ • Switch๋‚˜ ๋งํฌ๊ฐ€ ๋‹ค์šด๋ผ๋„ ๋„คํŠธ์›Œํฌ๊ฐ€ ์ค‘๋‹จ๋˜์ง€ ์•Š๋„๋ก ํ•˜๊ณ , ํŠธ๋ž˜ํ”ฝ์„ ๋ถ„์‚ฐ์‹œ์ผœ ๋„คํŠธ์›Œํฌ ์„ฑ๋Šฅ์„ ํ–ฅ์ƒ ์‹œํ‚ฌ ์ˆ˜ ์žˆ๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค.

๊ทธ๋Ÿฌ๋‚˜ Ethernet ํ”„๋ ˆ์ž„ ๋ฃจํ”„(Bridging Loop)๊ฐ€ ๋ฐœ์ƒํ•˜์—ฌ ์Šค์œ„์นญ์ด ์ œ๋Œ€๋กœ ์•ˆ๋  ์ˆ˜ ์žˆ๊ณ , Switch์˜ MAC ํ…Œ์ด๋ธ”์ด ๋ถˆ์•ˆ์ •ํ•ด์งˆ ์ˆ˜ ์žˆ๋‹ค.

์ด๋Ÿฌํ•œ ๋ฌธ์ œ์ ์„ STP๋กœ ํ•ด๊ฒฐํ•  ์ˆ˜ ์žˆ๋‹ค.

  1. BPDU
  2. STP ๋™์ž‘๋ฐฉ์‹
  3. STP ํฌํŠธ ์ƒํƒœ

1. BPDU

[Bridge Protocol Data Unit]
STP๋Š” BPDU ํ”„๋ ˆ์ž„์„ ์ด์šฉํ•ด ๋ฃจํ”„๊ฐ€ ์—†๋Š” ๊ฒฝ๋กœ๋ฅผ ๊ตฌ์„ฑํ•œ๋‹ค.

BPDU์—๋Š” Configuration BPDU์™€ TCN BPDU ๋‘ ์ข…๋ฅ˜๊ฐ€ ์žˆ๋‹ค.

1-1) Configuration BPDU
์ถœ์ €: STP protocol frames, https://techhub.hpe.com/eginfolib/networking/docs/switches/5980/5200-3921_l2-lan_cg/content/499036672.htm

– Protocol ID: ํ•ญ์ƒ 0
– Version: BPDU ๋ฒ„์ „ ํ‘œ์‹œ(0:STP, 2:RSTP, 3:MSTP)
– BPDU Type: BPDU ์ข…๋ฅ˜ ํ‘œ์‹œ(0x00:Configuration BPDU)
– Flag: ํ† ํด๋กœ์ง€ ๋ณ€ํ™” ํ‘œ์‹œ(0x01:TC, 0x80:TCA)
– Root Bridge ID: ๋ฃจํŠธ ์Šค์œ„์น˜์˜ ID
– Path cost: ๋ฃจํŠธ ์Šค์œ„์น˜๊นŒ์ง€์˜ ๊ฒฝ๋กœ ๊ฐ’
– Bridge ID: ๋ฃจํŠธ ์Šค์œ„์น˜ ๊ฐ€๋Š” ๊ฒฝ๋กœ์ƒ ,์ง์ „ ์Šค์œ„์น˜ ID
– Port ID: ํฌํŠธ ID
– Message age: ๋ฃจํŠธ ์Šค์œ„์น˜๊นŒ์ง€์˜ ์Šค์œ„์น˜ ์ˆ˜
– Max age: BPDU ์ •๋ณด ์ €์žฅํ•˜๋Š” ์‹œ๊ฐ„
– Hello Time: BPDU ์ „์†ก ์ฃผ๊ธฐ
– Forward Delay: Listening/Learning ์ƒํƒœ์—์„œ ๋Œ€๊ธฐํ•˜๋Š” ์‹œ๊ฐ„

์œ„ Configuration BPDU๋ฅผ ํ†ตํ•ด Root Switch๋ฅผ ์„ ์ถœํ•˜๊ณ , Switch Port์˜ ์—ญํ• ์„ ์ง€์ •ํ•œ๋‹ค. ์˜ค์ง Root Switch๋งŒ Configuration BPDU๋ฅผ ์ƒ์„ฑํ•  ์ˆ˜ ์žˆ๊ณ , ๋‹ค๋ฅธ Switch๋“ค์€ ์ค‘๊ณ„๋งŒ ํ•œ๋‹ค.

1-2) TCN BPDU

[Topology Change Notification BPDU]

์ถœ์ €: STP protocol frames, https://techhub.hpe.com/eginfolib/networking/docs/switches/5980/5200-3921_l2-lan_cg/content/499036672.htm

– Protocol ID: ํ•ญ์ƒ 0
– Version: BPDU ๋ฒ„์ „ ํ‘œ์‹œ(0:STP, 2:RSTP, 3:MSTP)
– BPDU Type: BPDU ์ข…๋ฅ˜ ํ‘œ์‹œ(0x80: TCN BPDU)

์œ„ TCN BPDU๋ฅผ ํ†ตํ•ด ๋„คํŠธ์›Œํฌ์— ๋ณ€๊ฒฝ์ด ์žˆ์„ ๊ฒฝ์šฐ Root Switch๋กœ ๋ณด๊ณ ํ•œ๋‹ค. (ex. Switch ํŠน์ • ๋งํฌ ๋น„ํ™œ์„ฑํ™” ๋“ฑ)

1-3) Bridge ID, Path cost, Port ID

[Bridge ID]
Bridge ID๋Š” Priority(2 Bytes)์™€ MAC์ฃผ์†Œ(6 Bytes)๋กœ ๊ตฌ์„ฑ๋œ๋‹ค.
Priority์˜ ๊ธฐ๋ณธ๊ฐ’์€ 32768์ด๊ณ , 0~65535 ๋ฒ”์œ„ ๋‚ด ์ˆซ์ž๋กœ ๋ฐ”๊ฟ€ ์ˆ˜ ์žˆ๋‹ค.

[Path cost]
ํฌํŠธ์˜ ์†๋„ ๋ณ„๋กœ ๋ฏธ๋ฆฌ ์ •ํ•ด๋†“์€ ๊ฐ’์ด๋‹ค. IEEE์—์„œ ๊ถŒ๊ณ ํ•œ๋‹ค.
10Mbps – 100 , 100Mbps – 19 , 1Gbps – 4 , 10Gbps – 2

[Port ID]
BPDU๋ฅผ ์ „์†กํ•˜๋Š” Switch์˜ port priority์™€ ํฌํŠธ๋ฒˆํ˜ธ๋กœ ๊ตฌ์„ฑ๋œ๋‹ค.
Port Priority์˜ ๊ธฐ๋ณธ๊ฐ’์€ 128์ด๋‹ค.

2. STP ๋™์ž‘๋ฐฉ์‹

3. STP ํฌํŠธ ์ƒํƒœ

Disabled

ํฌํŠธ๊ฐ€ ๋™์ž‘ํ•˜์ง€ ์•Š๋Š” ์ƒํƒœ๋‹ค.
๊ณ ์žฅ์ด ๋‚ฌ๊ฑฐ๋‚˜ ๊ณ ์˜์ ์œผ๋กœ Shutdownํ•œ ์ƒํƒœ๋‹ค.

Blocking

๋ธŒ๋ฆฌ์ง• ๋ฃจํ”„ ๋ฐฉ์ง€๋ฅผ ์œ„ํ•ด Alternate Port(AP)๋กœ ์„ ์ •ํ•œ ์ƒํƒœ๋‹ค.
์˜ค์ง Root Switch๋กœ๋ถ€ํ„ฐ BPDU๋งŒ ์ˆ˜์‹ ํ•  ์ˆ˜ ์žˆ๋‹ค. ๋งŒ์•ฝ, Max-Age ํƒ€์ด๋จธ ์•ˆ์— BPDU๋ฅผ ์ˆ˜์‹ ํ•˜์ง€ ๋ชปํ•˜๊ฑฐ๋‚˜ ํ›„์ˆœ์œ„ BPDU๋ฅผ ์ˆ˜์‹ ํ•˜๋ฉด Listening ์ƒํƒœ๋กœ ๋ณ€๊ฒฝ๋œ๋‹ค.
์—ฌ๊ธฐ์„œ ํ›„์ˆœ์œ„ BPDU๋ž€, ๊ธฐ์กด Root ID๋ณด๋‹ค ๊ฐ’์ด ๋†’์€ Root ID๊ฐ€ ์„ค์ •๋œ BPDU๋ฅผ ์˜๋ฏธํ•œ๋‹ค.

Listening

Blocking ๋‹ค์Œ ๋‹จ๊ณ„๋กœ ์‹œ์ž‘๋˜๊ฑฐ๋‚˜ Switch ํฌํŠธ์— ๋…ธ๋“œ๊ฐ€ ์—ฐ๊ฒฐ๋  ๊ฒฝ์šฐ ํ•ด๋‹น ๋‹จ๊ณ„๋กœ ๋ณ€๊ฒฝ๋œ๋‹ค. Forwarding ๋‹จ๊ณ„๋กœ ๋ณ€๊ฒฝํ•˜๊ธฐ ์œ„ํ•œ ์ค€๋น„ ๋‹จ๊ณ„์ด๋‹ค.
Designated Port(DP)๋Š” BPDU๋ฅผ ์ „์†กํ•˜๊ณ , Root Port(RP)๋Š” BPDU๋ฅผ ์ˆ˜์‹ ํ•œ๋‹ค.(๋ฐ์ดํ„ฐ ์†ก์ˆ˜์‹  X)
Foward Delay 15์ดˆ๋™์•ˆ ์ถ”๊ฐ€์ ์ธ ํ† ํด๋กœ์ง€ ๋ณ€ํ™”๊ฐ€ ์—†์œผ๋ฉด Learning๋‹จ๊ณ„๋กœ ๋„˜์–ด๊ฐ„๋‹ค.

Learning

Forwarding ๋‹จ๊ณ„๋กœ ๋ณ€๊ฒฝํ•˜๊ธฐ ์œ„ํ•œ ์ง์ „ ๋‹จ๊ณ„์ด๋‹ค.
ํ”„๋ ˆ์ž„์„ ์†ก์ˆ˜์‹ ํ•˜๊ธฐ ์•ž์„œ ๋จผ์ € MACํ…Œ์ด๋ธ”์„ ํ•™์Šตํ•œ๋‹ค. Listening๊ณผ ๋งˆ์ฐฌ๊ฐ€์ง€๋กœ Foward Delay 15์ดˆ๊ฐ€ ์ง„ํ–‰๋˜๋ฉฐ, ๋ณ„๋„ ํ† ํด๋กœ์ง€ ๋ณ€๊ฒฝ์ด ์—†์œผ๋ฉด Forwarding ๋‹จ๊ณ„๋กœ ๋„˜์–ด๊ฐ„๋‹ค.

Forwarding

๋“œ๋””์–ด ํ”„๋ ˆ์ž„์„ ์†ก์ˆ˜์‹ ํ•  ์ˆ˜ ์žˆ๋Š” ์ƒํƒœ๋‹ค.
RP, DP ๋ชจ๋‘ Forwarding ๋‹จ๊ณ„๊ฐ€ ๋  ์ˆ˜ ์žˆ์ง€๋งŒ, AP๋Š” ๋  ์ˆ˜ ์—†๋‹ค.

** ๊ธฐ๋ณธ์ ์œผ๋กœ Switch ํฌํŠธ๊ฐ€ ํ™œ์„ฑํ™”๋˜๋ฉด, Listening ๋‹จ๊ณ„๋ถ€ํ„ฐ ์‹œ์ž‘ํ•œ๋‹ค.

** ๋Œ€์ฒด ๊ฒฝ๋กœ๊ฐ€ ์กด์žฌํ•˜๋Š” ๋„คํŠธ์›Œํฌ์—์„œ ์žฅ์• ๊ฐ€ ๋ฐœ์ƒํ•˜๋ฉด, ๋Œ€์ฒด ๊ฒฝ๋กœ๊ฐ€ ๋™์ž‘ํ•  ๋•Œ๊นŒ์ง€ Max-Age 20์ดˆ / AP๊ฐ€ ์ „์†ก์ƒํƒœ ๊ฑธ๋ฆฌ๋Š” ์‹œ๊ฐ„ 30์ดˆ(Listening โ†’ Learning โ†’ Forwarding 30์ดˆ), ์ด 50์ดˆ๋ฅผ ๊ธฐ๋‹ค๋ ค์•ผ ํ†ต์‹ ์ด ์ •์ƒ์ ์œผ๋กœ ๋ณต๊ตฌ๋˜๊ธฐ ๋•Œ๋ฌธ์— ๋ณ„๋„ ์ปจ๋ฒ„์ „์Šค ์‹œ๊ฐ„์„ ๋‹จ์ถ•์‹œ์ผœ์•ผ ํ•œ๋‹ค.

STP ์˜ˆ์‹œ

[Switch] ์‚ฌ์„ค VLAN

Switch์— ๋งŽ์€ ๊ณ ๊ฐ๋“ค์ด ์—ฐ๊ฒฐ๋˜์—ˆ๋‹ค๊ณ  ๊ฐ€์ •ํ•ด๋ณด์ž. ๊ฐ ํฌํŠธ ๋‹น VLAN์„ ํ• ๋‹น ํ•˜๊ฑฐ๋‚˜ ๋ชจ๋“  ๊ณ ๊ฐ์—๊ฒŒ ๋™์ผํ•œ VLAN์„ ํ• ๋‹นํ•ด์•ผ๋  ๊ฒƒ์ด๋‹ค.

ํ•˜์ง€๋งŒ ๋‘ ๊ฐ€์ง€ ๋ชจ๋‘ ๋ฌธ์ œ๊ฐ€ ๋ฐœ์ƒํ•œ๋‹ค.
๊ฐ ํฌํŠธ๋‹น VLAN์„ ๋ถ€์—ฌํ•˜๋ฉด, VLAN ๋ถ€์กฑ ํ˜„์ƒ์ด ๋ฐœ์ƒํ•  ์ˆ˜ ์žˆ์œผ๋ฉฐ, ๊ฐ VLAN๋งˆ๋‹ค ๋ณ„๋„์˜ IP๋ฅผ ํ• ๋‹นํ•ด์•ผ๋˜๊ธฐ ๋•Œ๋ฌธ์— IP ๋‚ญ๋น„๊ฐ€ ์‹ฌ๊ฐํ•ด์งˆ ์ˆ˜ ์žˆ๋‹ค.
๊ทธ๋ ‡๋‹ค๊ณ  ๋ชจ๋“  ๊ณ ๊ฐ์—๊ฒŒ ๋™์ผํ•œ VLAN์„ ๋ถ€์—ฌํ•ด๋„ ํŠธ๋ž˜ํ”ฝ ์ฐจ๋‹จ์„ ํ•  ์ˆ˜ ์—†์–ด ๋Œ€์—ญํญ์ด ๋‚ญ๋น„๋  ์ˆ˜ ์žˆ๊ณ , ๋ณด์•ˆ์—๋„ ์ทจ์•ฝํ•ด์ง„๋‹ค.

์ด๋Ÿฐ ๋ฌธ์ œ๋ฅผ ํ•ด๊ฒฐํ•ด์ฃผ๋Š” ๊ฒƒ์ด ์‚ฌ์„ค VLAN์ด๋‹ค.

์‚ฌ์„ค VLAN ํฌํŠธ์˜ ์ข…๋ฅ˜

  • Promiscuous Port (ํ”„๋กœ๋ฏธ์Šคํ์–ด์Šค ํฌํŠธ)
    Isolated Port ์™€ Community Port์— ์ ‘์†๋œ ์žฅ๋น„๋“ค๊ณผ ์™ธ๋ถ€์˜ ์—ฐ๊ฒฐ์„ ์œ„ํ•œ ํฌํŠธ์ด๋‹ค. ์—ฌ๊ธฐ์— ํ• ๋‹น๋˜๋Š” VLAN์ด Primary VLAN์ด ๋œ๋‹ค.
  • Isolated Port (๋…๋ฆฝ ํฌํŠธ)
    ๋™์ผํ•œ VLAN์— ์†Œ์†๋˜์ง€๋งŒ ๋…๋ฆฝ ํฌํŠธ๋ผ๋ฆฌ ์„œ๋กœ ํ†ต์‹ ํ•  ์ˆ˜ ์—†๋‹ค.
    ๋™์ผํ•œ GW, ๋™์ผํ•œ Subnet์„ ์‚ฌ์šฉํ•œ๋‹ค. ์™ธ๋ถ€์™€ ํ†ต์‹ ํ•  ์ˆ˜ ์žˆ๋‹ค.
    ์‚ฌ์„ค VLAN ํ•˜๋‚˜์— ๋ฌด์กฐ๊ฑด ํ•˜๋‚˜์˜ Isolated VLAN๋งŒ ๊ฐ€์งˆ ์ˆ˜ ์žˆ์œผ๋ฉฐ, ํ•˜๋‚˜์˜ Isolated VLAN์—๋Š” ์—ฌ๋Ÿฌ ๋ฌผ๋ฆฌ ํฌํŠธ๋ฅผ ํ• ๋‹นํ•  ์ˆ˜ ์žˆ๋‹ค.
  • Community Port (์ปค๋ฎค๋‹ˆํ‹ฐ ํฌํŠธ)
    ๋™์ผ VLAN์— ์†Œ์†๋œ ์ปค๋ฎค๋‹ˆํ‹ฐ ํฌํŠธ ๊ฐ„ ํ†ต์‹ ํ•  ์ˆ˜ ์žˆ๋‹ค.
    ๋…๋ฆฝ ํฌํŠธ์™€ ๋‹ฌ๋ฆฌ ์‚ฌ์„ค VLAN ํ•˜๋‚˜์— ์—ฌ๋Ÿฌ Community VLAN์„ ๊ฐ€์งˆ ์ˆ˜ ์žˆ๋‹ค. ๋‹ค๋ฅธ VLAN์˜ Communtiy VLAN๊ณผ ํ†ต์‹ ํ•  ์ˆ˜ ์—†๋‹ค.

๊ทธ๋Ÿผ, Isolated ํฌํŠธ์™€ Community ํฌํŠธ๋Š” ์„œ๋กœ ํ†ต์‹  ํ•  ์ˆ˜ ์žˆ์„๊นŒ?
L3 ๋ผ์šฐํŒ…์„ ํ•˜๋ฉด ํ†ต์‹ ํ•  ์ˆ˜ ์žˆ๋‹ค๊ณ  ํ•œ๋‹ค.
(์ฐธ๊ณ : Juniper – Private VLANs)

VLAN 10์€ Primary VLAN์ด ๋˜๊ณ , VLAN200-202๋Š” Secondary VLAN์ด ๋œ๋‹ค.

์‚ฌ์„ค VLAN์˜ ํŠน์ง•

  • ์‚ฌ์„ค VLAN Port๋“ค์€ Access Port ์ด๋‹ค.
  • Trunk Port๋Š” ์ผ๋ฐ˜/์‚ฌ์„ค VLAN ํŠธ๋ž˜ํ”ฝ ๋ชจ๋‘ ์ „์†กํ•œ๋‹ค.
  • ์‚ฌ์„ค VLAN์˜ Primary VLAN(Promiscuous VLAN)์€ ์˜ค์ง ํ•˜๋‚˜์ด๋‹ค. ๋ฌผ๋ก , ํฌํŠธ๋Š” ์—ฌ๋Ÿฌ๊ฐœ ํ• ๋‹นํ•  ์ˆ˜ ์žˆ๊ณ , ์‚ฌ์„ค VLAN ๋‚ด ๋ชจ๋“  ํฌํŠธ๋Š” Primary VLAN์˜ ๋ฉค๋ฒ„์ด๋‹ค.
  • L3 ๊ฒŒ์ดํŠธ์›จ์ด๋Š” Promiscuous Port๋ฅผ ํ†ตํ•ด ์—ฐ๊ฒฐํ•œ๋‹ค.
  • Primary VLAN SVI์— IP๋ฅผ ๋ถ€์—ฌํ•˜๋ฉด, ์ „์ฒด ์‚ฌ์„ค VLAN์˜ Subnet์ด ๋œ๋‹ค.

์‚ฌ์„ค VLAN ์„ค์ • ์‹œ ์ฃผ์˜์‚ฌํ•ญ

  • ์‚ฌ์„ค VLAN์€ VTP Transparent Mode์—์„œ๋งŒ ๊ฐ€๋Šฅํ•˜๋‹ค. ์‚ฌ์„ค VLAN์„ ์„ค์ •ํ•œ ํ›„์—๋Š” VTP Mode๋ฅผ ๋ณ€๊ฒฝํ•  ์ˆ˜ ์—†๋‹ค.
  • ์‚ฌ์„ค VLAN์— ๋Œ€ํ•œ ์ •๋ณด๋Š” vlan.dat๊ฐ€ ์•„๋‹Œ running-config์— ์ €์žฅ๋œ๋‹ค.
  • ์ „์ฒด ์‚ฌ์„ค VLAN์—์„œ ํ•˜๋‚˜์˜ STP๋งŒ ๋™์ž‘ํ•œ๋‹ค.
  • Ether-channel Port๋ฅผ ์‚ฌ์„ค VLAN Port๋กœ ์„ค์ •ํ•˜๋ฉด Ether-channel์ด ๋น„ํ™œ์„ฑํ™”๋œ๋‹ค.

[Switch] Virtual LAN

  1. Virtual LAN
  2. Trunking
  3. VTP
  4. Switch Port ํƒ€์ž…

1. Virtual LAN

๋…ผ๋ฆฌ์ ์œผ๋กœ ๋ถ„ํ• ๋œ Switch Network์ด๋‹ค. VLAN์ด ๋‹ค๋ฅด๋ฉด ์„œ๋กœ ํ†ต์‹ ํ•  ์ˆ˜ ์—†๋‹ค.

VLAN์˜ ์—ญํ• 

(1) Broadcast Domain ๋ถ„ํ• 
Broadcast๋ฅผ ์ˆ˜์‹ ํ•˜๋ฉด ์žฅ๋น„๋“ค์€ ๋ณธ์ธ์˜ ๊ฒƒ์ธ์ง€ ํ™•์ธํ•˜๊ณ  ์ฒ˜๋ฆฌํ•ด์•ผ ํ•˜๊ธฐ ๋•Œ๋ฌธ์— ๋งŽ์€ Broadcast ํŒจํ‚ท์€ ์žฅ๋น„ ์„ฑ๋Šฅ์— ๋ณ€ํ™”๋ฅผ ์ฃผ๊ณ , ๋„คํŠธ์›Œํฌ ๋Œ€์—ญํญ๋„ ์ฐจ์ง€ํ•˜๊ธฐ ๋•Œ๋ฌธ์— ์ข‹์ง€ ์•Š๋‹ค. VLAN์€ ์ ์ ˆํ•˜๊ฒŒ ๊ตฌ์—ญ์„ ๋‚˜๋ˆ”์œผ๋กœ์จ ์ด๋Ÿฌํ•œ Broadcast ํŒจํ‚ท์„ ์ค„์—ฌ์ค€๋‹ค.

(2) ๋ณด์•ˆ์„ฑ ๊ฐ•ํ™”
์„œ๋กœ ๋‹ค๋ฅธ VLAN์€ L3 ์žฅ๋น„๋ฅผ ํ†ตํ•ด์„œ๋งŒ ํ†ต์‹ ํ•  ์ˆ˜ ์žˆ๋‹ค.

(3) ๋ถ€ํ•˜ ๋ถ„์‚ฐ
Switch๊ฐ€ STP๋ฅผ ๊ตฌ์„ฑํ•˜๋ฉด ๋งํฌ ํ•œ ์ชฝ์ด ๊บผ์ง€๋ฉด์„œ ํŠน์ • ๋งํฌ๋กœ๋งŒ ํŠธ๋ž˜ํ”ฝ์„ ์ง‘์ค‘์‹œํ‚ค๊ฒŒ ๋œ๋‹ค. ํ•˜์ง€๋งŒ ๊ฐ Switch์—์„œ VLAN์„ ๋‹ค๋ฅด๊ฒŒ ์„ค์ •ํ•˜๋ฉด, VLAN๋งˆ๋‹ค ํŠธ๋ž˜ํ”ฝ ๊ฒฝ๋กœ๊ฐ€ ๋‹ฌ๋ผ์ง€๋ฏ€๋กœ L2 Load Balancing์„ ๊ธฐ๋Œ€ํ•  ์ˆ˜ ์žˆ๋‹ค.

VLAN์˜ ํŠน์ง•

์‚ฌ์šฉ๊ฐ€๋Šฅํ•œ VLAN ๊ฐœ์ˆ˜๋Š” Switch ๋ชจ๋ธ๋งˆ๋‹ค ๋‹ค๋ฅด๋‹ค.

VLAN ํ•˜๋‚˜ ๋‹น STP๊ฐ€ ์ง€์›๋˜๋Š” Switch ์ˆ˜๋Š” 128๊ฐœ์ด๋‹ค. ๋ฌผ๋ก , ์ˆ˜๋Ÿ‰์ด ๋งŽ์•„์ ธ๋„ MSTP๋‚˜ ๋ฃจํ”„ ์—†๋Š” ๋„คํŠธ์›Œํฌ๋ฅผ ๊ตฌ์„ฑํ•˜์—ฌ ํฐ ์ œ์•ฝ์ด ๋˜์ง„ ์•Š๋Š”๋‹ค.


2. Trunking

Trunk๋ž€, ์—ฌ๋Ÿฌ ๊ฐœ์˜ VLAN ํ”„๋ ˆ์ž„์„ ์ „์†กํ•  ์ˆ˜ ์žˆ๋Š” ๋งํฌ๋ฅผ ์˜๋ฏธํ•œ๋‹ค. ์ฆ‰, Trunk ํฌํŠธ๋กœ ๋™์ž‘์‹œํ‚ค๋Š” ๊ฒƒ์„ Trunking์ด๋ผ๊ณ  ํ•œ๋‹ค. Tagged ํฌํŠธ๋ผ๊ณ  ํ•˜๊ธฐ๋„ ํ•œ๋‹ค.

Trunking Protocol

Trunk ํฌํŠธ๋ฅผ ํ†ตํ•ด ํ”„๋ ˆ์ž„์„ ์ „์†กํ•œ๋‹ค๋ฉด, ๋ฐ˜๋“œ์‹œ VLAN ๋ฒˆํ˜ธ๋ฅผ ํ‘œ์‹œํ•ด์•ผํ•œ๋‹ค. ๊ทธ๋ž˜์•ผ ํ•ด๋‹น VLAN์— ์†ํ•œ ํฌํŠธ๋กœ Flooding์„ ํ•  ์ˆ˜ ์žˆ๊ธฐ ๋•Œ๋ฌธ์ด๋‹ค. ‘Trunk Encapsulation’์ด๋ผ๊ณ ๋„ ํ•œ๋‹ค. Cisco ๊ธฐ์ค€์œผ๋กœ ISL๊ณผ 802.1Q๊ฐ€ ์žˆ๋‹ค.

2-1) 802.1Q Trunking

IEEE 802.1Q์—์„œ ์ •์˜๋œ ํ‘œ์ค€ ํ”„๋กœํ† ์ฝœ์ด๋‹ค. Ethernet ํ”„๋ ˆ์ž„์—์„œ Source MAC ๋’ค์— 4 Byte์˜ ‘802.1Q Field’๋ฅผ ์ถ”๊ฐ€ํ•œ๋‹ค.

[Field ์„ค๋ช…]
Ethertype | ๊ฐ’: 0x8100
– ์ด ํ”„๋ ˆ์ž„์ด 802.1Q๋ผ๋Š” ๊ฒƒ์„ ํ‘œ์‹œํ•œ๋‹ค. TPID(Tag Protocol Identifier)๋ผ๊ณ ๋„ ํ•œ๋‹ค.

Priority | ๊ฐ’: 0~7
– ํ”„๋ ˆ์ž„์˜ ์šฐ์„ ์ˆœ์œ„๋ฅผ ํ‘œ์‹œํ•œ๋‹ค. ๋†’์„์ˆ˜๋ก ๋นจ๋ฆฌ ์ „์†ก๋œ๋‹ค. CoS(Class of Service)๋ผ๋„๊ณ  ํ•œ๋‹ค.

CFI; Canonical Format Identifier | ๊ฐ’: 0 or 1
– ๊ฐ’์ด 1์ผ ๋•Œ, ํ† ํฐ๋ง ํ”„๋ ˆ์ž„์ด Encapsulation๋œ ๊ฒƒ์œผ๋กœ ๊ฐ„์ฃผํ•œ๋‹ค.

VLAN Number | ๊ฐ’: 1~4094
– ํ”„๋ ˆ์ž„์˜ VLAN์„ ํ‘œ์‹œํ•œ๋‹ค.

[Native VLAN]
VLAN ๋ฒˆํ˜ธ๋ฅผ ํ‘œ์‹œํ•˜๋Š” VLAN์ด๋‹ค.
802.1Q Trunking์—์„œ๋งŒ ์‚ฌ์šฉ๋˜๋ฉฐ, ์–‘์ชฝ Switch์—์„œ ์„ค์ •๋œ Native VLAN์ด ๋™์ผํ•ด์•ผ ํ•œ๋‹ค.
์˜ˆ๋ฅผ ๋“ค์–ด, Native VLAN์ด 2์ผ ๋•Œ, VLAN 2์— ์†ํ•œ ํ”„๋ ˆ์ž„์€ ๋ณ„๋„์˜ Encapsulation ์—†์ด Trunk๋กœ ์ „์†กํ•œ๋‹ค. ์ƒ๋Œ€์ธก์—์„œ๋„ Encapsulation ๋˜์ง€ ์•Š์€ ํ”„๋ ˆ์ž„์„ ๋ฐ›๋Š”๋‹ค๋ฉด, ๋‹น์—ฐํžˆ Native VLAN์ด๋ผ ๊ฐ„์ฃผํ•œ๋‹ค.

2-2) ISL

Cisco์—์„œ ๊ฐœ๋ฐœํ•œ Trunking Encapsulation์ด๋‹ค. ํ™•์žฅ VLAN์„ ์ง€์›ํ•˜์ง€ ์•Š์•„ ์ ์ฐจ ์‚ฌ์šฉํ•˜์ง€ ์•Š๋Š”๋‹ค๊ณ  ํ•œ๋‹ค. Ethernet ํ”„๋ ˆ์ž„ ์•ž์— ‘ISL Header(26 Bytes)’์™€ ๋’ค์— ‘ISL FCS(4 Bytes)’๋ฅผ ์ถ”๊ฐ€ํ•œ๋‹ค.

2-3) Switch ํฌํŠธ์˜ DTP Mode

[Dynamic Trunking Protocol]
DTP๋ž€, Cisco Switch์—์„œ ์ƒํ˜ธ Switch๊ฐ„ Trunk ๊ด€๋ จ ์‚ฌํ•ญ์„ ํ˜‘์ƒํ•  ๋•Œ ์‚ฌ์šฉํ•˜๋Š” ํ”„๋กœํ† ์ฝœ์ด๋‹ค. ํ˜‘์ƒ ๋‚ด์šฉ์€ โ’งEncapsulation ๋ฐฉ์‹, โ‘ตTrunk ํฌํŠธ๋กœ ์ „ํ™˜์—ฌ๋ถ€์ด๋‹ค.

โ‘ด Encapsulation ๋ฐฉ์‹
Switch ๋ชจ๋ธ๋งˆ๋‹ค ์กฐ๊ธˆ์”ฉ ๋‹ค๋ฅด๋‚˜ ๋ณดํ†ต dot1q / ISL / Negotiate ์ด๋‹ค.

โ‘ต Trunk ํฌํŠธ ์ „ํ™˜ ์—ฌ๋ถ€ = ํฌํŠธMode ์„ค์ •
Access Mode
์ƒ๋Œ€์™€ ์ƒ๊ด€์—†์ด ํ•ญ์ƒ Access port๋กœ ๋™์ž‘ํ•œ๋‹ค.
Trunk Mode
์ƒ๋Œ€์™€ ์ƒ๊ด€์—†์ด ํ•ญ์ƒ Trunk port๋กœ ๋™์ž‘ํ•œ๋‹ค. Trunk port๋กœ ์„ค์ • ์ „ Encapsulation ๋ฐฉ์‹์„ ์ง€์ •ํ•ด์•ผ ํ•œ๋‹ค.
Dynamic Desirable Mode
์ƒ๋Œ€๊ฐ€ Trunk / Desirable / Auto โ†’ Trunk๋กœ ๋™์ž‘
์ƒ๋Œ€๊ฐ€ Access โ†’ Access๋กœ ๋™์ž‘
Dynamic Auto Mode
์ƒ๋Œ€๊ฐ€ Trunk / Desirable โ†’ Trunk๋กœ ๋™์ž‘
์ƒ๋Œ€๊ฐ€ Access / Auto โ†’ Access๋กœ ๋™์ž‘
Nonegotiate Mode
๋ณธ์ธ์ด Trunk๋กœ ๋™์ž‘ํ•  ๋•Œ, ์ƒ๋Œ€์—๊ฒŒ DTP ํŒจํ‚ท์„ ์ „์†กํ•˜์ง€ ์•Š๋Š” ์˜ต์…˜(Mode ์•„๋‹˜). Dynamic Mode์—์„  ์‚ฌ์šฉํ• ์ˆ˜ ์—†๋‹ค. ์ƒ๋Œ€๊ฐ€ Dynamic Desirable ์ƒํƒœ์—์„œ Nonegotiate๋กœ ์„ค์ •ํ•˜๋ฉด, ์ƒ๋Œ€์˜ DTP๋ฅผ ๋ฌด์‹œํ•˜๋ฏ€๋กœ ๋ณธ์ธ์€ Trunk, ์ƒ๋Œ€๋Š” Access๊ฐ€ ๋˜๋Š” ์ƒํ™ฉ์ด ๋ฒŒ์–ด์ง„๋‹ค. ๋ณดํ†ต ์„œ๋กœ Trunk์ผ ๋•Œ, ํŠธ๋ž˜ํ”ฝ ๊ฐ์†Œ์šฉ์œผ๋กœ ์‚ฌ์šฉํ•œ๋‹ค.

ํ‘œ1. Mode ๋ณ„ Trunk ๋™์ž‘ ์—ฌ๋ถ€

3. VTP

[VLAN Trunking Protocol]
์—ฌ๋Ÿฌ Switch๋“ค์ด VLAN ์„ค์ • ์ •๋ณด๋ฅผ ๊ตํ™˜ํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค.
๋™์ผ VLAN๋ผ๋ฆฌ ํ†ต์‹ ํ•  ๋•Œ, ์ค‘๊ฐ„ ์Šค์œ„์น˜์— ํ•ด๋‹นํ•˜๋Š” VLAN์ด ์—†์œผ๋ฉด ํ•ด๋‹น VLAN์€ ํ†ต์‹ ํ•  ์ˆ˜ ์—†๋‹ค. ์ด๋Ÿฌํ•œ ์ƒํ™ฉ์„ ๋ฐฉ์ง€ํ•˜๊ณ ์ž Switch ํ•˜๋‚˜์—์„œ VLAN ์ •๋ณด๊ฐ€ ๋ณ€๊ฒฝ๋˜์—ˆ์„ ๋•Œ ๋‚˜๋จธ์ง€ Switch๋“ค๋„ ๋ณ€๊ฒฝ๋œ ์ •๋ณด๋ฅผ ์ž๋™์œผ๋กœ ์ „๋‹ฌํ•ด์ฃผ๋Š” ๊ฒƒ์ด๋‹ค.

3-1) VTP ๋™์ž‘ ๊ณผ์ •

– ์ƒˆ๋กœ์šด Switch๋ฅผ ์—ฐ๊ฒฐํ•  ๋•Œ์—๋Š” VTP ๋ฒˆํ˜ธ๋ฅผ ํ™•์ธํ•˜๊ธฐ ์–ด๋ ต๊ธฐ ๋•Œ๋ฌธ์— ๋ฐ˜๋“œ์‹œ VTP ์„ค์ •๋ฒˆํ˜ธ๋ฅผ ์ดˆ๊ธฐํ™”ํ•˜๊ณ  ์—ฐ๊ฒฐํ•ด์•ผ ํ•œ๋‹ค.

3-2) VTP Domain

Switch ๊ฐ„ VTP Domain ์ด๋ฆ„์ด ๋™์ผํ•ด์•ผ๋งŒ VTP ์ •๋ณด๋ฅผ ์ฃผ๊ณ  ๋ฐ›๋Š”๋‹ค.
VTP ๋™์ž‘์„ ์œ„ํ•œ ์ตœ์†Œ ์กฐ๊ฑด์€ โ‘ดVTP Domain ์ด๋ฆ„ ๋™์ผ, โ‘ตTrunk ํฌํŠธ๋กœ ์—ฐ๊ฒฐ์ด๋‹ค.

๋‹จ, Trunk๋กœ ์—ฐ๊ฒฐ๋˜์–ด๋„ VTP ์ด๋ฆ„์„ ์„ค์ •ํ•˜์ง€ ์•Š์•˜๋‹ค๋ฉด VTP๊ฐ€ ๋™์ž‘ํ•˜์ง€ ์•Š๋Š”๋‹ค. VTP Domain ์ด๋ฆ„์ด ๋‹ค๋ฅด๋‹ค๋ฉด ์„œ๋กœ์˜ VTP ์ •๋ณด๋ฅผ ๋ฌด์‹œํ•œ๋‹ค.
ํ•˜๋‚˜์˜ Switch์—์„œ VTP Domain ์ด๋ฆ„์„ ์ง€์ •ํ•˜๋ฉด Trunk๋กœ ์—ฐ๊ฒฐ๋œ Switch์˜ VTP Domain ์ด๋ฆ„๋„ ๊ฐ™์ด ๋ฐ”๋€๋‹ค.

VTP ์ •๋ณด๋Š” Router๋ฅผ ๋„˜๊ธธ ์ˆ˜ ์—†๋‹ค.

3-3) VTP Mode

Server, Client, Transparent 3๊ฐ€์ง€๋กœ ๋‚˜๋‰œ๋‹ค.

VTP Server Mode
๊ธฐ๋ณธ VTP ๋ชจ๋“œ.
VLAN ์ •๋ณด๋ฅผ ์ƒ์„ฑ/์‚ญ์ œ/๋ณ€๊ฒฝํ•  ์ˆ˜ ์žˆ๋‹ค.
ํƒ€ Switch๋กœ ์ž์‹ ์˜ VTP ์ •๋ณด๋ฅผ ์ „์†กํ•œ๋‹ค.
ํƒ€ Switch๋กœ๋ถ€ํ„ฐ ๋ฐ›์€ ์ •๋ณด์™€ ์ž์‹ ์˜ ์ •๋ณด๋ฅผ ๋™๊ธฐํ™”ํ•œ๋‹ค.
ํƒ€ Switch๋กœ๋ถ€ํ„ฐ ๋ฐ›์€ ์ •๋ณด๋ฅผ ํƒ€ Switch์—๊ฒŒ ์ค‘๊ณ„ํ•œ๋‹ค.

VTP Client Mode
VLAN ์ •๋ณด๋ฅผ ์ƒ์„ฑ/์‚ญ์ œ/๋ณ€๊ฒฝํ•  ์ˆ˜ ์—†๋‹ค.
ํƒ€ Switch๋กœ ์ž์‹ ์˜ VTP ์ •๋ณด๋ฅผ ์ „์†กํ•œ๋‹ค.
ํƒ€ Switch๋กœ๋ถ€ํ„ฐ ๋ฐ›์€ ์ •๋ณด์™€ ์ž์‹ ์˜ ์ •๋ณด๋ฅผ ๋™๊ธฐํ™”ํ•œ๋‹ค.
ํƒ€ Switch๋กœ๋ถ€ํ„ฐ ๋ฐ›์€ ์ •๋ณด๋ฅผ ํƒ€ Switch์—๊ฒŒ ์ค‘๊ณ„ํ•œ๋‹ค.

VTP Transparent Mode
VTP ์„ค์ •๋ฒˆํ˜ธ๋Š” 0์œผ๋กœ ๊ณ ์ •๋œ๋‹ค.,
์ž์‹ ๋งŒ์˜ VLAN ์ •๋ณด๋ฅผ ์ƒ์„ฑ/์‚ญ์ œ/๋ณ€๊ฒฝํ•  ์ˆ˜ ์žˆ๋‹ค.
ํƒ€ Switch๋กœ ์ž์‹ ์˜ VTP ์ •๋ณด๋ฅผ ์ „์†กํ•˜์ง€ ์•Š๋Š”๋‹ค.
ํƒ€ Switch๋กœ๋ถ€ํ„ฐ ๋ฐ›์€ ์ •๋ณด์™€ ์ž์‹ ์˜ ์ •๋ณด๋ฅผ ๋™๊ธฐํ™”ํ•˜์ง€ ์•Š๋Š”๋‹ค.
ํƒ€ Switch๋กœ๋ถ€ํ„ฐ ๋ฐ›์€ ์ •๋ณด๋ฅผ ํƒ€ Switch์—๊ฒŒ ์ค‘๊ณ„ํ•œ๋‹ค.

3-4) VTP Version

VTPv2๋Š” v1๊ณผ ๋‹ฌ๋ฆฌ Transparent Mode์—์„œ VTP Domain ์ด๋ฆ„๊ณผ ๋ฒ„์ „์„ ํ™•์ธํ•˜์ง€ ์•Š๋Š”๋‹ค. VTPv2๋Š” ํ† ํฐ๋ง VLAN์„ ์ง€์›ํ•œ๋‹ค.

VTPv3๋Š” ํ™•์žฅ VLAN ์ •๋ณด, ์‚ฌ์„ค VLAN ์ •๋ณด, MST ์ •๋ณด๋ฅผ ์ „์†กํ•œ๋‹ค. VLAN ์ •๋ณด๋ฅผ ๋ฐ›์•„๋“ค์ผ ์ธ์ ‘ ์žฅ๋น„ ์ง€์ •์— ๋Œ€ํ•œ ์ œ์–ด ๊ธฐ๋Šฅ์ด ํ–ฅ์ƒ๋˜๋ฉด์„œ ์ž˜๋ชป๋œ VLAN ์ •๋ณด๋ฅผ ๋ฐ›์•„๋“ค์ž„์œผ๋กœ ์ธํ•ด ๋ฐœ์ƒํ•˜๋Š” ๋„คํŠธ์›Œํฌ ์žฅ์•  ๊ฐ€๋Šฅ์„ฑ์„ ์ค„์˜€๋‹ค.

3-5) VTP Pruning

์ž์‹ ์˜ VLAN์ด ์ธ์ ‘ํ•œ Switch์—์„œ ํ•„์š”์—†๋Š” VLAN์ผ ๊ฒฝ์šฐ ํ•ด๋‹น VLAN ํŠธ๋ž˜ํ”ฝ์„ ์ „์†กํ•˜์ง€ ์•Š๋Š” ๊ธฐ๋Šฅ์ด๋‹ค. ๋‹ค์‹œ ๋งํ•ด, ํ•„์š”์—†๋Š” VLAN์˜ Broadcast ํŠธ๋ž˜ํ”ฝ์„ Trunk ํฌํŠธ๋ฅผ ํ†ตํ•ด ์ „์†กํ•˜์ง€ ์•Š๋Š” ๊ฒƒ์ด๋‹ค.


4. Switch Port ํƒ€์ž…

[Tunnel Port]

์ฃผ๋กœ ๋„คํŠธ์›Œํฌ ์‚ฌ์—…์ž ์ธก์—์„œ ์ œํ•œ๋œ VLAN ๋ฒˆํ˜ธ๋ฅผ ์ด์šฉํ•ด ๋งŽ์€ ๊ณ ๊ฐ์„ ์ˆ˜์šฉํ•˜๊ธฐ ์œ„ํ•ด ์‚ฌ์šฉํ•œ๋‹ค. ์•„๋ž˜ ๊ทธ๋ฆผ์„ ๋ณด์ž.

๊ณ ๊ฐA ์™€ B๋Š” ๊ฐ™์€ VLAN ๋ฒˆํ˜ธ๋ฅผ ์‚ฌ์šฉํ•˜์ง€๋งŒ, ์„œ๋กœ ๋‹ค๋ฅธ ๋ง์ด์–ด์•ผ ํ•œ๋‹ค.
์ด๋Ÿด ๋•Œ, IEEE 802.1Q ํ„ฐ๋„๋ง์„ ํ†ตํ•ด ๊ณ ๊ฐ์„ ๊ตฌ๋ณ„ํ•  ์ˆ˜ ์žˆ๋‹ค. ๊ฐ ๊ณ ๊ฐ๋งˆ๋‹ค VLAN tag๋ฅผ ๋ถ€์ฐฉํ•ด ์ „์†กํ•˜๋Š” ๊ฒƒ์ด๋‹ค. ์ด๊ฒƒ์„ Metro tag๋ผ๊ณ ๋„ ํ•œ๋‹ค.

๊ณ ๊ฐ A์˜ SW11์—์„œ SW12๋กœ ํ†ต์‹ ์„ ํ•ด์•ผํ•œ๋‹ค๊ณ  ๊ฐ€์ •ํ•ด๋ณด์ž.

โ‘  SW11 โ†’SW1 โ†’ SW2
SW1์—์„œ ๋ฐ์ดํ„ฐ๋ฅผ ๋ฐ›๋Š”๋‹ค. ์ด ๋•Œ, Metro tag 10 ๋ถ€์ฐฉํ•˜์—ฌ SW2๋กœ ๋ณด๋‚ธ๋‹ค.
โ‘ก SW2 โ†’ SW12
SW2๋Š” Metro tag 10์„ ๋ณด๊ณ , ํ•ด๋‹น tag์— ์†Œ์†๋œ SW12๋กœ ์ „์†กํ•œ๋‹ค. ์ด ๋•Œ, Metro tag๋Š” ์ œ๊ฑฐํ•˜๊ณ  ์ „์†กํ•œ๋‹ค.

์ฆ‰, ์‚ฌ์—…์ž ๋‚ด๋ถ€๋ง์—์„œ ๊ณ ๊ฐ ๋ณ„๋กœ ํ•˜๋‚˜์˜ VLAN๋งŒ ๋ถ€์—ฌํ•˜๊ณ , ๋‚ด๋ถ€๋ง์—์„œ๋งŒ ์ฐธ์กฐํ•˜๋Š” ๊ฒƒ์ด๋‹ค.

[Switch] Transparent Bridging

OSI Layer 2์—์„œ ํ•ต์‹ฌ์€ Transparent Bridging๊ณผ RSTP ์ด๋‹ค.
์ด๋ฒˆ์—๋Š” Transparent Bridging์— ๋Œ€ํ•ด ์•Œ์•„๋ณด๊ณ ์ž ํ•œ๋‹ค.
(RSTP๋Š” ์ถ”ํ›„์— ์•Œ์•„๋ณธ๋‹ค.)

  1. Transparent Bridgind ์ด๋ž€?
  2. Transparent Bridging ์ ˆ์ฐจ
  3. ์˜ˆ์‹œ (๋‹จ์ผ/๋‹ค์ˆ˜ Switch์—์„œ)
  4. ์˜ˆ์‹œ (MAC ํ…Œ์ด๋ธ”์— ์—†๋Š” Unicast Frame)
  5. MAC ์ฃผ์†Œ์™€ IP ์ฃผ์†Œ์˜ ๊ด€๊ณ„

1. Transparent Bridging ์ด๋ž€?

‘Transparent’๋Š” ํˆฌ๋ช…ํ•˜๋‹ค๋ผ๋Š” ์˜๋ฏธ๋ฅผ ๋‹ด๊ณ  ์žˆ๋‹ค. ์šฐ๋ฆฌ๊ฐ€ ์ผ๋ฐ˜์ ์œผ๋กœ ํˆฌ๋ช…ํ•œ ๋ฌผ์ฒด๋ฅผ ์ธ์‹ํ•˜์ง€ ๋ชปํ•˜๋Š” ๊ฒƒ๊ณผ ๊ฐ™์€ ์˜๋ฏธ๋กœ ์šฐ๋ฆฌ๊ฐ€ ์˜์‹ํ•˜์ง€ ๋ชปํ•˜๋„๋ก ์•Œ์•„์„œ ๋™์ž‘ํ•œ๋‹ค๋Š” ์˜๋ฏธ๋กœ ํ•ด์„ํ•˜๋ฉด ๋œ๋‹ค.

Transparent Bridging์—์„œ๋Š” ์ด๋”๋„ท ์Šค์œ„์น˜๊ฐ€ ํ”„๋ ˆ์ž„์„ ์ˆ˜์‹ ํ•˜๊ณ , ๋ชฉ์ ์ง€๋กœ ์†ก์‹ ํ•˜๋Š” ๋ฐฉ์‹๊ณผ ์ ˆ์ฐจ๋ฅผ ์ •์˜ํ•œ๋‹ค. ๋˜ํ•œ, ์Šค์œ„์น˜๊ฐ€ ์ˆ˜์‹ ํ•œ ์ด๋”๋„ท ํ”„๋ ˆ์ž„์„ ์ฐธ์กฐํ•˜์—ฌ MAC ํ…Œ์ด๋ธ”์„ ๊ด€๋ฆฌํ•˜๊ณ , ๋ชฉ์ ์ง€๋กœ ์ „์†กํ•  ๋•Œ ์‚ฌ์šฉํ•˜๋Š” ํ”„๋กœํ† ์ฝœ์ด ๋˜๊ฒ ๋‹ค.

2. Transparent Bridging ์ ˆ์ฐจ

์ž ๊ทธ๋Ÿผ, Transparent Bridging์ด ๋ญ”์ง€ ์•Œ์•˜์œผ๋‹ˆ ์–ด๋–ป๊ฒŒ ๋™์ž‘ํ•˜๋Š”์ง€ ๋ณด์ž.

3. ์˜ˆ์‹œ (๋‹จ์ผ/๋‹ค์ˆ˜ Switch)

๋‹จ์ผ Switch์—์„œ ์–ด๋–ป๊ฒŒ Transparent Bridging์ด ๋™์ž‘ํ•˜๋Š”์ง€ ์•Œ์•„๋ณด์•˜๋‹ค. ๊ทธ๋Ÿฌ๋‚˜ ์‚ฌ์‹ค ๋‹ค์ˆ˜ Switch๊ฐ€ ์—ฐ๊ฒฐ๋œ๋‹ค๊ณ  ํ•ด์„œ ๋™์ž‘๋ฐฉ์‹์ด ํฌ๊ฒŒ ๋ฐ”๋€Œ์ง€ ์•Š๋Š”๋‹ค. ๋™์ผํ•˜๋‹ค๊ณ  ์ƒ๊ฐํ•ด๋„ ๋ฌด๋ฐฉํ•˜๋‹ค. ๋ณต์žกํ•ด๋ณด์ผ๋ฟ.

4. ์˜ˆ์‹œ (MAC ํ…Œ์ด๋ธ”์— ์—†๋Š” Unicast Frame)

Switch์˜ Aging-Timer์™€ PC/Router ๊ฐ„ ARP ์ง€์† ์‹œ๊ฐ„์ด ๋‹ฌ๋ผ ์ด๋Ÿฐ ์ƒํ™ฉ์ด ๋ฐœ์ƒํ•œ๋‹ค.

์˜ˆ๋ฅผ ๋“ค์–ด, PC1์ด PC2๋กœ PING ํ…Œ์ŠคํŠธ๋ฅผ ํ•œ๋‹ค๊ณ  ๊ฐ€์ •ํ•˜์ž.
โ‘  PC1์—๋Š” PC2์— ๋Œ€ํ•œ MAC์ด ์žˆ์–ด ARP ์—†์ด ๋ฐ”๋กœ ์š”์ฒญ์„ ๋ณด๋‚ธ๋‹ค.
โ‘ก ํ•˜์ง€๋งŒ Switch์—๋Š” Aging-Timer๊ฐ€ ๋งŒ๋ฃŒ๋˜์–ด ์ด๋ฏธ PC2์— ๋Œ€ํ•œ MAC์ด ์‚ฌ๋ผ์ง„์ง€ ์˜ค๋ž˜๋‹ค.
โ‘ข ๊ทธ๋ž˜์„œ Transparent Bridging ๊ทœ์น™์— ์˜๊ฑฐํ•˜์—ฌ ์ˆ˜์‹  ํฌํŠธ๋ฅผ ์ œ์™ธํ•œ ๋‚˜๋จธ์ง€ ํฌํŠธ๋กœ Flooding ํ•œ๋‹ค.

5. MAC ์ฃผ์†Œ์™€ IP ์ฃผ์†Œ์˜ ๊ด€๊ณ„

Ethernet ๊ธฐ์ค€์œผ๋กœ IP ํŒจํ‚ท์„ ํŠน์ • ๋ชฉ์ ์ง€๋กœ ๋ณด๋‚ด๊ธฐ ์œ„ํ•ด ๋‹ค์Œ ํ™‰์— ์žˆ๋Š” ์žฅ๋น„์˜ MAC์„ ์•Œ์•„์•ผ๋งŒ ํ•œ๋‹ค. ํ•˜์ง€๋งŒ ๋‹ค์Œ ํ™‰ ์žฅ๋น„์˜ MAC์„ ๋ชจ๋ฅธ๋‹ค๋ฉด, Destination MAC์„ ์–ด๋–ป๊ฒŒ ํ•ด์•ผํ• ๊นŒ? Broadcast, Multicast, Unicast ๋ณ„๋กœ ์•Œ์•„๋ณด๋„๋ก ํ•˜์ž.

Broadcast์ผ ๊ฒฝ์šฐ,

IP๊ฐ€ 255.255.255.255์ด๊ฑฐ๋‚˜ ๊ฐ ๋„คํŠธ์›Œํฌ์˜ Broadcast IP์ผ ๋•Œ, ๋ชจ๋“  ์žฅ๋น„๊ฐ€ ์ด ํŒจํ‚ท์„ ์ˆ˜์‹ ํ•˜๊ณ  ์ฒ˜๋ฆฌํ•ด์•ผํ•œ๋‹ค.
MAC์€ FFFF.FFFF.FFFF๋กœ ๋งคํ•‘๋œ๋‹ค.

Multicast์ผ ๊ฒฝ์šฐ,

๋ผ์šฐํŒ… ์ •๋ณด ์†ก์‹ ์šฉ IP, ๋ฐฉ์†ก ์ค‘๊ณ„ ๋“ฑ๊ณผ ๊ฐ™์€ ํŠน์ •๊ทธ๋ฃน์œผ๋กœ ์ „์†กํ•  ๋•Œ ์‚ฌ์šฉํ•œ๋‹ค.
MAC์€ 0100.5Exx.xxxx๋กœ ๋งคํ•‘๋œ๋‹ค. ๋ฌผ๋ก , ์ผ๋ถ€ ํ”„๋กœํ† ์ฝœ์€ ๋‹ค๋ฅธ MAC์œผ๋กœ ๋งคํ•‘๋˜๋Š” ๊ฒฝ์šฐ๋„ ์žˆ๋‹ค. (CDP, STP ๋“ฑ)

Unicast์ผ ๊ฒฝ์šฐ,

๋™์ผ ๋„คํŠธ์›Œํฌ๋ผ๋ฉด, ARP๋ฅผ ํ†ตํ•ด MAC์„ ๋งคํ•‘ํ•œ๋‹ค.
์™ธ๋ถ€ ๋„คํŠธ์›Œํฌ๋ผ๋ฉด, Gateway๋‚˜ Proxy๋ฅผ ์‚ฌ์šฉํ•˜์—ฌ MAC์„ ๋งคํ•‘ํ•œ๋‹ค.

  • (์™ธ๋ถ€ ๋„คํŠธ์›Œํฌ) Gateway๋ฅผ ํ†ตํ•œ MAC ๋งคํ•‘
    Switch์— Default-Gateway๊ฐ€ ์„ค์ •๋˜์–ด์žˆ๋‹ค๋ฉด, ๋ชฉ์ ์ง€ IP ๋Œ€์‹  GW IP์— ๋Œ€ํ•ด ARP ํ”„๋ ˆ์ž„์„ ์ „์†กํ•œ๋‹ค.

โ‘  SW1์ด ์™ธ๋ถ€ 200.200.200.1๋กœ PINGํ•˜๋ ค๋ฉด, ๋„คํŠธ์›Œํฌ๊ฐ€ ๋‹ค๋ฅด๊ธฐ ๋•Œ๋ฌธ์— GW๋กœ ์ „์†กํ•ด์•ผํ•œ๋‹ค.
โ‘ก ๊ทธ๋ž˜์„œ GW์˜ MAC์ฃผ์†Œ๋ฅผ ์ฐพ๋Š” ARP๋ฅผ ์š”์ฒญํ•œ๋‹ค.
โ‘ข ARP ์š”์ฒญ ํŒจํ‚ท์„ ์ˆ˜์‹ ํ•œ R1์€ ๋ณธ์ธ์˜ MAC์„ ์ „์†กํ•œ๋‹ค.
(์ด ๋•Œ, ์ถœ๋ฐœ์ง€ IP์™€ ์ถœ๋ฐœ์ง€ MAC์€ ๋ชจ๋‘ R1์ด๋‹ค.)

  • (์™ธ๋ถ€ ๋„คํŠธ์›Œํฌ) Proxy๋ฅผ ํ†ตํ•œ MAC ๋งคํ•‘
    Switch์— Default-Gateway๊ฐ€ ์„ค์ •๋˜์ง€ ์•Š์•˜์„๋•Œ, Switch๋Š” ์–ด๋–ป๊ฒŒ ํ•ด์•ผํ• ๊นŒ.

โ‘  Switch๊ฐ€ 200.200.200.1๋กœ PING์„ ํ•˜๊ธฐ ์œ„ํ•ด GW๋กœ ์ „์†กํ•ด์•ผํ•˜๋Š”๋ฐ ๋ชจ๋ฅด๋Š” ์ƒํ™ฉ์ด๋‹ค.
โ‘ก GW IP ๋Œ€์‹  ์ง์ ‘ ๋ชฉ์ ์ง€(200.200.200.1)์˜ MAC์„ ์ฐพ๋Š” ARP ํŒจํ‚ท์„ ์ „์†กํ•œ๋‹ค.
โ‘ข ARP ํŒจํ‚ท์„ ์ˆ˜์‹ ํ•œ R1์—์„œ โ‘ดARP ํŒจํ‚ท์˜ ๋ชฉ์ ์ง€ ์ฃผ์†Œ๋กœ ๋ผ์šฐํŒ…์ด ๊ฐ€๋Šฅํ•˜๊ณ  โ‘ตProxy ARP๊ฐ€ ํ™œ์„ฑํ™” ๋˜์–ด์žˆ๋‹ค๋ฉด, R1 ๋ณธ์ธ์˜ MAC์„ SW๋กœ ์‘๋‹ตํ•œ๋‹ค. (์ด ๋•Œ, ์ถœ๋ฐœ์ง€ IP๋Š” 200.200.200.1, ์ถœ๋ฐœ์ง€ MAC์€ R1์˜ MAC์ด๋‹ค.)
๋งŒ์ผ, ์œ„ ๋‘ ๊ฐ€์ง€๊ฐ€ ์ถฉ์กฑ๋˜์ง€ ์•Š๋‹ค๋ฉด, ARP ์‘๋‹ต์„ ํ•˜์ง€ ์•Š๋Š”๋‹ค.